automatic version update by autodist [release s20121221-1mamba;Thu Jan 10 2013]
This commit is contained in:
parent
27da534a60
commit
f4f169bf51
@ -1,2 +1,5 @@
|
||||
# iputils
|
||||
|
||||
The iputils package contains ping, a basic networking tool.
|
||||
The ping command sends a series of ICMP protocol ECHO_REQUEST packets to a specified network host and can tell you if that machine is alive and receiving network traffic.
|
||||
|
||||
|
12
iputils-notftpd.patch
Normal file
12
iputils-notftpd.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ur iputils.orig/Makefile iputils/Makefile
|
||||
--- iputils.orig/Makefile 2003-06-09 10:27:35.000000000 +0200
|
||||
+++ iputils/Makefile 2003-06-09 10:27:44.000000000 +0200
|
||||
@@ -27,7 +27,7 @@
|
||||
CCOPT=-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g
|
||||
CFLAGS=$(CCOPT) $(GLIBCFIX) -I$(KERNEL_INCLUDE) -I../include $(DEFINES)
|
||||
|
||||
-IPV4_TARGETS=tracepath ping clockdiff rdisc arping tftpd rarpd
|
||||
+IPV4_TARGETS=tracepath ping clockdiff rdisc arping rarpd
|
||||
IPV6_TARGETS=tracepath6 traceroute6 ping6
|
||||
TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
||||
|
28
iputils-s20071127-rdisc_open_max.patch
Normal file
28
iputils-s20071127-rdisc_open_max.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- iputils-s20071127/rdisc.c 2007-11-27 01:57:27.000000000 +0100
|
||||
+++ iputils-s20071127/rdisc.c.fix 2009-04-30 23:57:12.000000000 +0200
|
||||
@@ -240,14 +240,24 @@
|
||||
{
|
||||
int t;
|
||||
pid_t pid;
|
||||
+ long open_max;
|
||||
|
||||
if (trace)
|
||||
return;
|
||||
+ if ((open_max = sysconf(_SC_OPEN_MAX)) == -1) {
|
||||
+ if (errno == 0) {
|
||||
+ (void) fprintf(stderr, "OPEN_MAX is not supported\n");
|
||||
+ }
|
||||
+ else {
|
||||
+ (void) fprintf(stderr, "sysconf() error\n");
|
||||
+ }
|
||||
+ exit(1);
|
||||
+ }
|
||||
|
||||
if ((pid=fork()) != 0)
|
||||
exit(0);
|
||||
|
||||
- for (t = 0; t < OPEN_MAX; t++)
|
||||
+ for (t = 0; t < open_max; t++)
|
||||
if (t != s)
|
||||
close(t);
|
||||
|
134
iputils.spec
Normal file
134
iputils.spec
Normal file
@ -0,0 +1,134 @@
|
||||
Name: iputils
|
||||
Epoch: 1
|
||||
Version: s20121221
|
||||
Release: 1mamba
|
||||
Summary: Network monitoring tools including ping
|
||||
Group: Network/Monitoring
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: ftp://ftp.inr.ac.ru/ip-routing/
|
||||
Source: http://www.skbuff.net/iputils/iputils-%{version}.tar.bz2
|
||||
Patch0: %{name}-notftpd.patch
|
||||
Patch1: %{name}-s20071127-rdisc_open_max.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: OpenSP
|
||||
BuildRequires: libsysfs-devel
|
||||
BuildRequires: perl-SGMLSpm
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The iputils package contains ping, a basic networking tool.
|
||||
The ping command sends a series of ICMP protocol ECHO_REQUEST packets to a specified network host and can tell you if that machine is alive and receiving network traffic.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
%ifarch x86_64
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fpic -Werror"
|
||||
%else
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fpie -Werror"
|
||||
export LDFLAGS="-pie"
|
||||
%endif
|
||||
%make CC=%{_host}-gcc arping clockdiff ping ping6 rdisc tracepath tracepath6 \
|
||||
%if "%{_host}" != "%{_build}"
|
||||
.LIBPATTERNS=%{_prefix}/%{_host}/lib/lib%.so
|
||||
%endif
|
||||
|
||||
make man
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
mkdir -p %{buildroot}/{bin,sbin,%{_bindir},%{_sbindir},%{_mandir}/man8}
|
||||
install -m 755 ping %{buildroot}/bin
|
||||
install -m 755 ping6 %{buildroot}/bin
|
||||
install -m 755 tracepath %{buildroot}/bin
|
||||
install -m 755 tracepath6 %{buildroot}/bin
|
||||
install -m 755 arping %{buildroot}/sbin
|
||||
install -m 755 clockdiff %{buildroot}%{_sbindir}
|
||||
install -m 755 rdisc %{buildroot}%{_sbindir}
|
||||
|
||||
ln -sf /bin/ping6 %{buildroot}%{_sbindir}
|
||||
ln -sf /bin/tracepath %{buildroot}%{_sbindir}
|
||||
ln -sf /bin/tracepath6 %{buildroot}%{_sbindir}
|
||||
ln -sf /sbin/arping %{buildroot}%{_sbindir}/arping
|
||||
|
||||
install -m 644 doc/arping.8 %{buildroot}%{_mandir}/man8
|
||||
install -m 644 doc/clockdiff.8 %{buildroot}%{_mandir}/man8
|
||||
#install -m 644 doc/pg3.8 %{buildroot}%{_mandir}/man8
|
||||
install -m 644 doc/ping.8 %{buildroot}%{_mandir}/man8
|
||||
install -m 644 doc/rdisc.8 %{buildroot}%{_mandir}/man8
|
||||
install -m 644 doc/tracepath.8 %{buildroot}%{_mandir}/man8
|
||||
|
||||
ln -s ping.8.gz %{buildroot}%{_mandir}/man8/ping6.8.gz
|
||||
ln -s tracepath.8.gz %{buildroot}%{_mandir}/man8/tracepath6.8.gz
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%attr(4755,root,root) /bin/ping
|
||||
%attr(4755,root,root) /bin/ping6
|
||||
/bin/tracepath
|
||||
/bin/tracepath6
|
||||
/sbin/arping
|
||||
%{_sbindir}/*
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%changelog
|
||||
* Thu Jan 10 2013 Automatic Build System <autodist@mambasoft.it> s20121221-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Nov 18 2012 Automatic Build System <autodist@mambasoft.it> s20121114-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Nov 13 2012 Automatic Build System <autodist@mambasoft.it> s20121106-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 24 2012 Automatic Build System <autodist@mambasoft.it> s20121011-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Nov 09 2010 Automatic Build System <autodist@mambasoft.it> s20101006-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Jul 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> s20100418-3mamba
|
||||
- restore ping and ping6 to replace commands from inetutils due to missing required options in GNU implementation
|
||||
|
||||
* Mon Jul 12 2010 Silvan Calarco <silvan.calarco@mambasoft.it> s20100418-2mamba
|
||||
- don't install ping and ping6 provided by inetutils
|
||||
|
||||
* Sun Jun 27 2010 Automatic Build System <autodist@mambasoft.it> s20100418-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Apr 30 2009 Davide Madrisan <davide.madrisan@gmail.com> s20071127-2mamba
|
||||
- do not package the traceroute6 tool
|
||||
- ping6, tracepath, tracepath6 moved to /bin
|
||||
- fixed a building error
|
||||
- force "Position Independent Executables" (-pie) building to increase security
|
||||
- remove unneeded build requirements
|
||||
|
||||
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> s20071127-1mamba
|
||||
- update to s20071127
|
||||
|
||||
* Fri Oct 07 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> ss020927-5qilnx
|
||||
- spec file cleaned
|
||||
|
||||
* Thu Jul 10 2003 Silvan Calarco <silvan.calarco@qinet.it> ss020927-4qilnx
|
||||
- ping is now suid root so normal users can ping
|
||||
|
||||
* Mon May 09 2003 Silvan Calarco <silvan.calarco@qinet.it> ss020927-3qilnx
|
||||
- removed tftp server
|
||||
|
||||
* Mon Apr 22 2003 Silvan Calarco <silvan.calarco@qinet.it>
|
||||
- removed prefix variable definition
|
||||
- added make parameter KERNEL_INCLUDE
|
||||
|
||||
* Mon Apr 08 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it>
|
||||
- creation of iputils package
|
Loading…
Reference in New Issue
Block a user