automatic version update by autodist [release 6.7.0-1mamba;Tue Jan 09 2024]

This commit is contained in:
Automatic Build System 2024-01-10 13:59:57 +01:00
parent 64957fc054
commit 06fa7e9fa3
6 changed files with 8 additions and 110 deletions

View File

@ -1,11 +0,0 @@
--- iproute2-2.6.16-060323/lib/utils.c.crash 2005-09-01 21:21:50.000000000 +0200
+++ iproute2-2.6.16-060323/lib/utils.c 2006-09-19 13:47:26.000000000 +0200
@@ -439,7 +439,7 @@
len = 4;
}
- hash = addr[len-1] ^ addr[len-2] ^ addr[len-3] ^ addr[len-4];
+ hash = (addr[len-1] ^ addr[len-2] ^ addr[len-3] ^ addr[len-4]) & 0xff;
for (n = nht[hash]; n; n = n->next) {
if (n->addr.family == af &&

View File

@ -1,19 +0,0 @@
--- iproute-2.6.20-070313/Makefile.orig 2007-03-30 18:27:27.000000000 +0200
+++ iproute-2.6.20-070313/Makefile 2007-03-30 18:28:40.000000000 +0200
@@ -3,6 +3,7 @@
CONFDIR=/etc/iproute2
DOCDIR=/usr/share/doc/iproute2
MANDIR=/usr/share/man
+KERNEL_INCLUDE=/usr/include
# Path to db_185.h include
DBM_INCLUDE:=/usr/include
@@ -21,7 +22,7 @@
CC = gcc
HOSTCC = gcc
-CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall
+CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall $(RPM_OPT_FLAGS)
CFLAGS = $(CCOPTS) -I../include $(DEFINES)
YACCFLAGS = -d -t -v

View File

@ -1,23 +0,0 @@
--- iproute2-2.6.16-060323/man/man8/ip.8.old 2006-01-03 20:25:29.000000000 +0100
+++ iproute2-2.6.16-060323/man/man8/ip.8 2006-10-02 15:13:05.000000000 +0200
@@ -176,6 +176,8 @@ replace " | " monitor " } "
.IR NUMBER " ] [ "
.B cwnd
.IR NUMBER " ] [ "
+.B initcwnd
+.IR NUMBER " ] [ "
.B ssthresh
.IR REALM " ] [ "
.B realms
@@ -1080,6 +1079,11 @@ the clamp for congestion window. It is
flag is not used.
.TP
+.BI initcwnd " NUMBER "
+The maximum initial congestion window (cwnd) size in MSS of a
+TCP connection.
+
+.TP
.BI advmss " NUMBER " "(2.3.15+ only)"
the MSS ('Maximal Segment Size') to advertise to these
destinations when establishing TCP connections. If it is not given,

View File

@ -1,11 +0,0 @@
diff -Nru iproute2-2.6.29.orig/include/linux/if_tunnel.h iproute2-2.6.29/include/linux/if_tunnel.h
--- iproute2-2.6.29.orig/include/linux/if_tunnel.h 2009-03-24 23:15:14.000000000 +0100
+++ iproute2-2.6.29/include/linux/if_tunnel.h 2009-10-11 13:43:05.000000000 +0200
@@ -3,6 +3,7 @@
#include <linux/types.h>
+#include <linux/ip.h>
#define SIOCGETTUNNEL (SIOCDEVPRIVATE + 0)
#define SIOCADDTUNNEL (SIOCDEVPRIVATE + 1)

View File

@ -1,25 +0,0 @@
From 1f3ea01fe2ff61cbbca6474f7d9903a0756a4f44 Mon Sep 17 00:00:00 2001
From: Kamil Rytarowski <n54@gmx.com>
Date: Fri, 3 May 2013 18:43:38 +0200
Subject: [PATCH] Feed GCC 4.8.0 against new warning that is shipped with
-Wall: -Wsizeof-pointer-memaccess.
---
misc/lnstat.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/misc/lnstat.c b/misc/lnstat.c
index bd19cc1..90198b7 100644
--- a/misc/lnstat.c
+++ b/misc/lnstat.c
@@ -166,7 +166,7 @@ static struct table_hdr *build_hdr_string(struct lnstat_file *lnstat_files,
for (i = 0; i < HDR_LINES; i++) {
th.hdr[i] = malloc(HDR_LINE_LENGTH);
- memset(th.hdr[i], 0, sizeof(th.hdr[i]));
+ memset(th.hdr[i], 0, HDR_LINE_LENGTH);
}
for (i = 0; i < fps->num; i++) {
--
1.8.1.5

View File

@ -3,7 +3,7 @@
%define pckdocdir %{_datadir}/doc/iproute-%{version}
Name: iproute
Version: 6.6.0
Version: 6.7.0
Release: 1mamba
Summary: Advanced routing tools including ipv6 routing
Group: Network/Routing
@ -14,12 +14,7 @@ URL: https://wiki.linuxfoundation.org/networking/iproute2
Source0: http://kernel.org/pub/linux/utils/net/iproute2/iproute2-%{version}.tar.xz
Source1: iproute2-tc.initscript
Source2: iproute2-traffic_control-sysconfig
Patch1: %{name}-2.6.20-makefile.patch
Patch2: %{name}-2.6.16-ip_resolve_crash.patch
Patch3: %{name}-2.6.20-tc_pfifo_man.patch
Patch4: %{name}-2.6.29-if_tunnel.patch
Patch5: %{name}-2.6.29-cross_fix.patch
Patch6: iproute-3.8.0-gcc-4.8.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -56,8 +51,8 @@ This package contain the iproute2 documentation in dvi and html formats.
%debug_package
%prep
%setup -q -n iproute2-%{version}%{?extraver!="-"}
%patch 5 -p1
%setup -q -n iproute2-%{version}
#%patch 5 -p1
%build
%make \
@ -98,17 +93,15 @@ rm -f %{buildroot}%{pckdocdir}/*.sgml
%files
%defattr(-,root,root)
%{_bindir}/*
%dir %{_libdir}/iproute2
%{_libdir}/iproute2/*
%dir %{_libdir}/tc
%{_libdir}/tc/m_ipt.so
%{_libdir}/tc/m_xt.so
#%{_libdir}/tc/q_atm.so
%{_libdir}/tc/experimental.dist
%{_libdir}/tc/normal.dist
%{_libdir}/tc/pareto.dist
%{_libdir}/tc/paretonormal.dist
#%{_libdir}/tc/q_atm.so
%dir %{_datadir}/iproute2
%{_datadir}/iproute2/*
%{_includedir}/iproute2/bpf_elf.h
%{_datadir}/bash-completion/completions/*
%{_mandir}/man3/libnetlink.*
@ -116,16 +109,10 @@ rm -f %{buildroot}%{pckdocdir}/*.sgml
%{_mandir}/man8/*
%doc COPYING
#%if "%{stage1}" != "1"
#%files doc
#%defattr(-,root,root)
#%doc doc/*.dvi
#%doc doc/*.html
#%doc README
#%doc examples/
#%endif
%changelog
* Tue Jan 09 2024 Automatic Build System <autodist@openmamba.org> 6.7.0-1mamba
- automatic version update by autodist
* Mon Nov 06 2023 Automatic Build System <autodist@mambasoft.it> 6.6.0-1mamba
- automatic version update by autodist