diff --git a/inkscape-0.43-desktop_file.patch b/inkscape-0.43-desktop_file.patch
deleted file mode 100644
index 0801fec..0000000
--- a/inkscape-0.43-desktop_file.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- inkscape-0.43/inkscape.desktop.in.orig 2005-11-21 17:12:50.000000000 +0100
-+++ inkscape-0.43/inkscape.desktop.in 2005-11-21 17:15:30.000000000 +0100
-@@ -2,6 +2,9 @@
- _Name=Inkscape SVG Vector Illustrator
- _Comment=Create and edit Scalable Vector Graphics images
-
-+Name[it]=Inkscape
-+GenericName[it]=Illustratore Vettoriale SVG
-+
- Encoding=UTF-8
- Version=1.0
-
diff --git a/inkscape-0.47-gcc45.patch b/inkscape-0.47-gcc45.patch
deleted file mode 100644
index 7156b94..0000000
--- a/inkscape-0.47-gcc45.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff -Naur inkscape-0.47-orig/src/eraser-context.cpp inkscape-0.47/src/eraser-context.cpp
---- inkscape-0.47-orig/src/eraser-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/eraser-context.cpp 2010-02-18 08:46:26.000000000 -0500
-@@ -749,7 +749,7 @@
- if ( eraserMode ) {
- toWorkOn = sp_document_partial_items_in_box(sp_desktop_document(desktop), desktop->dkey, bounds);
- } else {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- toWorkOn = sp_document_items_at_points(sp_desktop_document(desktop), desktop->dkey, r->getPoints());
- }
- toWorkOn = g_slist_remove( toWorkOn, acid );
-diff -Naur inkscape-0.47-orig/src/extension/internal/filter/filter-file.cpp inkscape-0.47/src/extension/internal/filter/filter-file.cpp
---- inkscape-0.47-orig/src/extension/internal/filter/filter-file.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/extension/internal/filter/filter-file.cpp 2010-02-18 09:07:54.000000000 -0500
-@@ -161,7 +161,7 @@
- mywriter writer;
- sp_repr_write_stream(node, writer, 0, FALSE, g_quark_from_static_string("svg"), 0, 0);
-
-- Inkscape::Extension::build_from_mem(xml_str, new Filter::Filter(g_strdup(writer.c_str())));
-+ Inkscape::Extension::build_from_mem(xml_str, new Filter(g_strdup(writer.c_str())));
- g_free(xml_str);
- return;
- }
-diff -Naur inkscape-0.47-orig/src/extension/internal/filter/filter.cpp inkscape-0.47/src/extension/internal/filter/filter.cpp
---- inkscape-0.47-orig/src/extension/internal/filter/filter.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/extension/internal/filter/filter.cpp 2010-02-18 09:21:06.000000000 -0500
-@@ -217,7 +217,7 @@
- "%s\n"
- "\n"
- "\n", name, id, submenu, tip);
-- Inkscape::Extension::build_from_mem(xml_str, new Filter::Filter(filter));
-+ Inkscape::Extension::build_from_mem(xml_str, new Filter(filter));
- g_free(xml_str);
- return;
- }
-diff -Naur inkscape-0.47-orig/src/flood-context.cpp inkscape-0.47/src/flood-context.cpp
---- inkscape-0.47-orig/src/flood-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/flood-context.cpp 2010-02-18 08:48:16.000000000 -0500
-@@ -900,7 +900,7 @@
- if (is_point_fill) {
- fill_points.push_back(Geom::Point(event->button.x, event->button.y));
- } else {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- fill_points = r->getPoints();
- }
-
-@@ -1206,7 +1206,7 @@
-
- case GDK_BUTTON_RELEASE:
- if (event->button.button == 1 && !event_context->space_panning) {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- if (r->is_started()) {
- // set "busy" cursor
- desktop->setWaitingCursor();
-diff -Naur inkscape-0.47-orig/src/gradient-context.cpp inkscape-0.47/src/gradient-context.cpp
---- inkscape-0.47-orig/src/gradient-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/gradient-context.cpp 2010-02-18 08:47:33.000000000 -0500
-@@ -641,7 +641,7 @@
- if (!event_context->within_tolerance) {
- // we've been dragging, either do nothing (grdrag handles that),
- // or rubberband-select if we have rubberband
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- if (r->is_started() && !event_context->within_tolerance) {
- // this was a rubberband drag
- if (r->getMode() == RUBBERBAND_MODE_RECT) {
-diff -Naur inkscape-0.47-orig/src/select-context.cpp inkscape-0.47/src/select-context.cpp
---- inkscape-0.47-orig/src/select-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/select-context.cpp 2010-02-18 08:50:11.000000000 -0500
-@@ -602,7 +602,7 @@
- }
- sc->item = NULL;
- } else {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- if (r->is_started() && !within_tolerance) {
- // this was a rubberband drag
- GSList *items = NULL;
diff --git a/inkscape-0.47-poppler-0.12.2.patch b/inkscape-0.47-poppler-0.12.2.patch
deleted file mode 100644
index 3c1f2a2..0000000
--- a/inkscape-0.47-poppler-0.12.2.patch
+++ /dev/null
@@ -1,89 +0,0 @@
---- inkscape-0.47/src/extension/internal/pdfinput/pdf-parser.cpp~ 2009-11-16 18:29:17.000000000 +0100
-+++ inkscape-0.47/src/extension/internal/pdfinput/pdf-parser.cpp 2009-11-24 19:09:47.000000000 +0100
-@@ -809,7 +809,7 @@
- blendingColorSpace = NULL;
- isolated = knockout = gFalse;
- if (!obj4.dictLookup(const_cast("CS"), &obj5)->isNull()) {
-- blendingColorSpace = GfxColorSpace::parse(&obj5);
-+ blendingColorSpace = GfxColorSpace::parse(&obj5,(Gfx*)this);
- }
- obj5.free();
- if (obj4.dictLookup(const_cast("I"), &obj5)->isBool()) {
-@@ -1009,9 +1009,9 @@
- state->setFillPattern(NULL);
- res->lookupColorSpace(args[0].getName(), &obj);
- if (obj.isNull()) {
-- colorSpace = GfxColorSpace::parse(&args[0]);
-+ colorSpace = GfxColorSpace::parse(&args[0],(Gfx*)this);
- } else {
-- colorSpace = GfxColorSpace::parse(&obj);
-+ colorSpace = GfxColorSpace::parse(&obj,(Gfx*)this);
- }
- obj.free();
- if (colorSpace) {
-@@ -1032,9 +1032,9 @@
- state->setStrokePattern(NULL);
- res->lookupColorSpace(args[0].getName(), &obj);
- if (obj.isNull()) {
-- colorSpace = GfxColorSpace::parse(&args[0]);
-+ colorSpace = GfxColorSpace::parse(&args[0],(Gfx*)this);
- } else {
-- colorSpace = GfxColorSpace::parse(&obj);
-+ colorSpace = GfxColorSpace::parse(&obj,(Gfx*)this);
- }
- obj.free();
- if (colorSpace) {
-@@ -1101,7 +1101,7 @@
- builder->updateStyle(state);
- }
- if (args[numArgs-1].isName() &&
-- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
-+ (pattern = res->lookupPattern(args[numArgs-1].getName(),(Gfx*)this))) {
- state->setFillPattern(pattern);
- builder->updateStyle(state);
- }
-@@ -1145,7 +1145,7 @@
- builder->updateStyle(state);
- }
- if (args[numArgs-1].isName() &&
-- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
-+ (pattern = res->lookupPattern(args[numArgs-1].getName(),(Gfx*)this))) {
- state->setStrokePattern(pattern);
- builder->updateStyle(state);
- }
-@@ -1543,7 +1543,7 @@
- double *matrix = NULL;
- GBool savedState = gFalse;
-
-- if (!(shading = res->lookupShading(args[0].getName()))) {
-+ if (!(shading = res->lookupShading(args[0].getName(),(Gfx*)this))) {
- return;
- }
-
-@@ -2507,7 +2507,7 @@
- }
- }
- if (!obj1.isNull()) {
-- colorSpace = GfxColorSpace::parse(&obj1);
-+ colorSpace = GfxColorSpace::parse(&obj1,(Gfx*)this);
- } else if (csMode == streamCSDeviceGray) {
- colorSpace = new GfxDeviceGrayColorSpace();
- } else if (csMode == streamCSDeviceRGB) {
-@@ -2592,7 +2592,7 @@
- obj2.free();
- }
- }
-- maskColorSpace = GfxColorSpace::parse(&obj1);
-+ maskColorSpace = GfxColorSpace::parse(&obj1,(Gfx*)this);
- obj1.free();
- if (!maskColorSpace || maskColorSpace->getMode() != csDeviceGray) {
- goto err1;
-@@ -2767,7 +2767,7 @@
- if (obj1.dictLookup(const_cast("S"), &obj2)->isName(const_cast("Transparency"))) {
- transpGroup = gTrue;
- if (!obj1.dictLookup(const_cast("CS"), &obj3)->isNull()) {
-- blendingColorSpace = GfxColorSpace::parse(&obj3);
-+ blendingColorSpace = GfxColorSpace::parse(&obj3,(Gfx*)this);
- }
- obj3.free();
- if (obj1.dictLookup(const_cast("I"), &obj3)->isBool()) {
diff --git a/inkscape-0.48.5-libgc-7.4.2.patch b/inkscape-0.48.5-libgc-7.4.2.patch
deleted file mode 100644
index 8307859..0000000
--- a/inkscape-0.48.5-libgc-7.4.2.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Submitted By: Armin K. , rediffed by Fernando de Oliveira
-Date: 2014-06-23
-Initial Package Version: 0.48.5
-Upstream Status: Unknown
-Origin: Armin K.
-URL:
-Description: Fixes build with gc-7.4.2
-
-
---- inkscape-0.48.5.orig/configure 2014-06-20 19:05:43.525382393 -0300
-+++ inkscape-0.48.5/configure 2014-06-23 15:24:38.730084988 -0300
-@@ -9044,8 +9044,8 @@
- # include
- #endif
- #include
-- extern unsigned GC_version;
- int main(void){
-+ unsigned GC_version = GC_get_version();
- unsigned min = ((6 << 16) | (4 << 8) | 0);
- printf("%d.%d.%d ",GC_version >> 16, (GC_version >> 8) & 0xFF, GC_version & 0xFF);
- if (GC_version>=min) return 0;
---- inkscape-0.48.5.orig/configure.ac 2014-06-20 17:29:03.717600589 -0300
-+++ inkscape-0.48.5/configure.ac 2014-06-23 15:24:19.592598799 -0300
-@@ -241,8 +241,8 @@
- # include
- #endif
- #include
-- extern unsigned GC_version;
- int main(void){
-+ unsigned GC_version = GC_get_version();
- unsigned min = ((6 << 16) | (4 << 8) | 0);
- printf("%d.%d.%d ",GC_version >> 16, (GC_version >> 8) & 0xFF, GC_version & 0xFF);
- if (GC_version>=min) return 0;
diff --git a/inkscape-0.91-libgtk-3.22.patch b/inkscape-0.91-libgtk-3.22.patch
deleted file mode 100644
index 57387bd..0000000
--- a/inkscape-0.91-libgtk-3.22.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-=== modified file 'src/ui/clipboard.cpp'
---- src/ui/clipboard.cpp 2016-04-08 17:38:40 +0000
-+++ src/ui/clipboard.cpp 2016-04-08 18:21:11 +0000
-@@ -1300,7 +1300,11 @@
- */
- Glib::ustring ClipboardManagerImpl::_getBestTarget()
- {
-+#if WITH_GTKMM_3_0
-+ std::vector targets = _clipboard->wait_for_targets();
-+#else
- std::list targets = _clipboard->wait_for_targets();
-+#endif
-
- // clipboard target debugging snippet
- /*
-
diff --git a/inkscape-0.91-libgtkmm-3.18.patch b/inkscape-0.91-libgtkmm-3.18.patch
deleted file mode 100644
index aefa0fd..0000000
--- a/inkscape-0.91-libgtkmm-3.18.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-=== modified file 'src/ui/clipboard.cpp'
---- src/ui/clipboard.cpp 2016-04-02 15:15:43 +0000
-+++ src/ui/clipboard.cpp 2016-04-07 16:30:32 +0000
-@@ -146,8 +146,6 @@
- void _setClipboardColor(guint32);
- void _userWarn(SPDesktop *, char const *);
-
-- void _inkscape_wait_for_targets(std::list &);
--
- // private properites
- SPDocument *_clipboardSPDoc; ///< Document that stores the clipboard until someone requests it
- Inkscape::XML::Node *_defs; ///< Reference to the clipboard document's defs node
-@@ -1302,9 +1300,7 @@
- */
- Glib::ustring ClipboardManagerImpl::_getBestTarget()
- {
-- // GTKmm's wait_for_targets() is broken, see the comment in _inkscape_wait_for_targets()
-- std::list targets; // = _clipboard->wait_for_targets();
-- _inkscape_wait_for_targets(targets);
-+ std::list targets = _clipboard->wait_for_targets();
-
- // clipboard target debugging snippet
- /*
-@@ -1456,39 +1452,6 @@
- desktop->messageStack()->flash(Inkscape::WARNING_MESSAGE, msg);
- }
-
--
--// GTKMM's clipboard::wait_for_targets is buggy and might return bogus, see
--//
--// https://bugs.launchpad.net/inkscape/+bug/296778
--// http://mail.gnome.org/archives/gtk-devel-list/2009-June/msg00062.html
--//
--// for details. Until this has been fixed upstream we will use our own implementation
--// of this method, as copied from /gtkmm-2.16.0/gtk/gtkmm/clipboard.cc.
--void ClipboardManagerImpl::_inkscape_wait_for_targets(std::list &listTargets)
--{
-- //Get a newly-allocated array of atoms:
-- GdkAtom* targets = NULL;
-- gint n_targets = 0;
-- gboolean test = gtk_clipboard_wait_for_targets( gtk_clipboard_get(GDK_SELECTION_CLIPBOARD), &targets, &n_targets );
-- if (!test || (targets == NULL)) {
-- return;
-- }
--
-- //Add the targets to the C++ container:
-- for (int i = 0; i < n_targets; i++)
-- {
-- //Convert the atom to a string:
-- gchar* const atom_name = gdk_atom_name(targets[i]);
--
-- Glib::ustring target;
-- if (atom_name) {
-- target = Glib::ScopedPtr(atom_name).get(); //This frees the gchar*.
-- }
--
-- listTargets.push_back(target);
-- }
--}
--
- /* #######################################
- ClipboardManager class
- ####################################### */
-
diff --git a/inkscape-0.92.5-ImageMagick-7.0.10.7.patch b/inkscape-0.92.5-ImageMagick-7.0.10.7.patch
deleted file mode 100644
index 0572cd5..0000000
--- a/inkscape-0.92.5-ImageMagick-7.0.10.7.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-diff -Naur orig/src/extension/CMakeLists.txt patched/src/extension/CMakeLists.txt
---- orig/src/extension/CMakeLists.txt 2017-03-24 00:51:36.134741323 +0100
-+++ patched/src/extension/CMakeLists.txt 2017-03-24 04:14:34.510756391 +0100
-@@ -218,8 +218,8 @@
- internal/bitmap/normalize.h
- internal/bitmap/oilPaint.cpp
- internal/bitmap/oilPaint.h
-- internal/bitmap/opacity.cpp
-- internal/bitmap/opacity.h
-+# internal/bitmap/opacity.cpp
-+# internal/bitmap/opacity.h
- internal/bitmap/raise.cpp
- internal/bitmap/raise.h
- internal/bitmap/reduceNoise.cpp
-diff -Naur orig/src/extension/init.cpp patched/src/extension/init.cpp
---- orig/src/extension/init.cpp 2017-03-24 00:51:36.134741323 +0100
-+++ patched/src/extension/init.cpp 2017-03-24 13:12:39.709882011 +0100
-@@ -88,7 +88,7 @@
- #include "internal/bitmap/negate.h"
- #include "internal/bitmap/normalize.h"
- #include "internal/bitmap/oilPaint.h"
--#include "internal/bitmap/opacity.h"
-+//#include "internal/bitmap/opacity.h"
- #include "internal/bitmap/raise.h"
- #include "internal/bitmap/reduceNoise.h"
- #include "internal/bitmap/sample.h"
-@@ -224,7 +224,7 @@
- Internal::Bitmap::Negate::init();
- Internal::Bitmap::Normalize::init();
- Internal::Bitmap::OilPaint::init();
-- Internal::Bitmap::Opacity::init();
-+// Internal::Bitmap::Opacity::init();
- Internal::Bitmap::Raise::init();
- Internal::Bitmap::ReduceNoise::init();
- Internal::Bitmap::Sample::init();
-diff -Naur orig/src/extension/internal/bitmap/channel.cpp patched/src/extension/internal/bitmap/channel.cpp
---- orig/src/extension/internal/bitmap/channel.cpp 2017-03-24 00:51:36.134741323 +0100
-+++ patched/src/extension/internal/bitmap/channel.cpp 2017-03-24 03:06:36.164250664 +0100
-@@ -28,7 +28,7 @@
- else if (!strcmp(_layerName, "Yellow Channel")) layer = Magick::YellowChannel;
- else if (!strcmp(_layerName, "Black Channel")) layer = Magick::BlackChannel;
- else if (!strcmp(_layerName, "Opacity Channel")) layer = Magick::OpacityChannel;
-- else if (!strcmp(_layerName, "Matte Channel")) layer = Magick::MatteChannel;
-+ else if (!strcmp(_layerName, "Alpha Channel")) layer = Magick::AlphaChannel;
-
- image->channel(layer);
- }
-@@ -56,7 +56,7 @@
- "<_item value='Yellow Channel'>" N_("Yellow Channel") "\n"
- "<_item value='Black Channel'>" N_("Black Channel") "\n"
- "<_item value='Opacity Channel'>" N_("Opacity Channel") "\n"
-- "<_item value='Matte Channel'>" N_("Matte Channel") "\n"
-+ "<_item value='Alpha Channel'>" N_("Alpha Channel") "\n"
- "\n"
- "\n"
- "all\n"
-diff -Naur orig/src/extension/internal/bitmap/crop.cpp patched/src/extension/internal/bitmap/crop.cpp
---- orig/src/extension/internal/bitmap/crop.cpp 2017-03-24 00:51:36.134741323 +0100
-+++ patched/src/extension/internal/bitmap/crop.cpp 2017-03-24 02:31:09.915343848 +0100
-@@ -24,7 +24,7 @@
- int width = image->baseColumns() - (_left + _right);
- int height = image->baseRows() - (_top + _bottom);
- if (width > 0 and height > 0) {
-- image->crop(Magick::Geometry(width, height, _left, _top, false, false));
-+ image->crop(Magick::Geometry(width, height, _left, _top));
- image->page("+0+0");
- }
- }
-diff -Naur orig/src/extension/internal/bitmap/levelChannel.cpp patched/src/extension/internal/bitmap/levelChannel.cpp
---- orig/src/extension/internal/bitmap/levelChannel.cpp 2017-03-24 00:51:36.134741323 +0100
-+++ patched/src/extension/internal/bitmap/levelChannel.cpp 2017-03-24 03:45:35.902823802 +0100
-@@ -28,9 +28,9 @@
- else if (!strcmp(_channelName, "Yellow Channel")) channel = Magick::YellowChannel;
- else if (!strcmp(_channelName, "Black Channel")) channel = Magick::BlackChannel;
- else if (!strcmp(_channelName, "Opacity Channel")) channel = Magick::OpacityChannel;
-- else if (!strcmp(_channelName, "Matte Channel")) channel = Magick::MatteChannel;
-- Magick::Quantum black_point = Magick::Color::scaleDoubleToQuantum(_black_point / 100.0);
-- Magick::Quantum white_point = Magick::Color::scaleDoubleToQuantum(_white_point / 100.0);
-+ else if (!strcmp(_channelName, "Alpha Channel")) channel = Magick::AlphaChannel;
-+ Magick::Quantum black_point = static_cast(_black_point / 100.0);
-+ Magick::Quantum white_point = static_cast(_white_point / 100.0);
- image->levelChannel(channel, black_point, white_point, _mid_point);
- }
-
-@@ -60,7 +60,7 @@
- "<_item value='Yellow Channel'>" N_("Yellow Channel") "\n"
- "<_item value='Black Channel'>" N_("Black Channel") "\n"
- "<_item value='Opacity Channel'>" N_("Opacity Channel") "\n"
-- "<_item value='Matte Channel'>" N_("Matte Channel") "\n"
-+ "<_item value='Alpha Channel'>" N_("Alpha Channel") "\n"
- "\n"
- "0.0\n"
- "100.0\n"
-diff -Naur orig/src/extension/internal/bitmap/level.cpp patched/src/extension/internal/bitmap/level.cpp
---- orig/src/extension/internal/bitmap/level.cpp 2017-03-24 00:51:36.134741323 +0100
-+++ patched/src/extension/internal/bitmap/level.cpp 2017-03-24 03:45:33.306793000 +0100
-@@ -19,8 +19,8 @@
-
- void
- Level::applyEffect(Magick::Image* image) {
-- Magick::Quantum black_point = Magick::Color::scaleDoubleToQuantum(_black_point / 100.0);
-- Magick::Quantum white_point = Magick::Color::scaleDoubleToQuantum(_white_point / 100.0);
-+ Magick::Quantum black_point = static_cast(_black_point / 100.0);
-+ Magick::Quantum white_point = static_cast(_white_point / 100.0);
- image->level(black_point, white_point, _mid_point);
- }
diff --git a/inkscape-1.3.2-libxml2-2.12.5.patch b/inkscape-1.3.2-libxml2-2.12.5.patch
new file mode 100644
index 0000000..dc5b0f5
--- /dev/null
+++ b/inkscape-1.3.2-libxml2-2.12.5.patch
@@ -0,0 +1,33 @@
+From 694d8ae43d06efff21adebf377ce614d660b24cd Mon Sep 17 00:00:00 2001
+From: Christian Hesse
+Date: Fri, 17 Nov 2023 22:30:42 +0100
+Subject: [PATCH] include missing header file
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This fixes build error:
+```
+/build/inkscape/src/inkscape/src/object/uri.cpp: In constructor ‘Inkscape::URI::URI(const gchar*, const char*)’:
+/build/inkscape/src/inkscape/src/object/uri.cpp:86:9: error: ‘xmlFree’ was not declared in this scope; did you mean ‘xmlFreeURI’?
+ 86 | xmlFree(full);
+```
+---
+ src/object/uri.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/object/uri.h b/src/object/uri.h
+index 381adec58cf..d5b211fe2b2 100644
+--- a/src/object/uri.h
++++ b/src/object/uri.h
+@@ -13,6 +13,7 @@
+ #define INKSCAPE_URI_H
+
+ #include
++#include
+ #include
+ #include
+
+--
+GitLab
+
diff --git a/inkscape.spec b/inkscape.spec
index 5587304..b3f27dc 100644
--- a/inkscape.spec
+++ b/inkscape.spec
@@ -1,6 +1,6 @@
%define gittag INKSCAPE_%(echo %version | tr . _)
Name: inkscape
-Version: 1.3
+Version: 1.3.2
Release: 1mamba
Summary: A SVG based generic vector-drawing application
Group: Applications/Multimedia
@@ -9,13 +9,7 @@ Distribution: openmamba
Packager: Silvan Calarco
URL: https://inkscape.org/
Source: https://gitlab.com/inkscape/inkscape.git/%{gittag}/inkscape-%{version}.tar.bz2
-Patch: %{name}-0.43-desktop_file.patch
-Patch1: %{name}-0.47-poppler-0.12.2.patch
-Patch2: %{name}-0.47-gcc45.patch
-Patch3: inkscape-0.48.5-libgc-7.4.2.patch
-Patch4: inkscape-0.91-libgtkmm-3.18.patch
-Patch5: inkscape-0.91-libgtk-3.22.patch
-Patch6: inkscape-0.92.5-ImageMagick-7.0.10.7.patch
+Patch0: inkscape-1.3.2-libxml2-2.12.5.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@@ -88,6 +82,7 @@ Additional planned work includes conversion of the codebase from C/Gtk to C++/Gt
%setup -q
#-D -T
#:<< _EOF
+%patch 0 -p1 -b .libxml2-2.12.5
%build
%cmake -d build \
@@ -126,6 +121,9 @@ Additional planned work includes conversion of the codebase from C/Gtk to C++/Gt
#%doc ChaangeLog NEWS README
%changelog
+* Sun Feb 11 2024 Automatic Build System 1.3.2-1mamba
+- automatic version update by autodist
+
* Wed Jul 26 2023 Automatic Build System 1.3-1mamba
- automatic version update by autodist