automatic version update by autodist [release 0.48.5-1mamba;Thu Sep 18 2014]

This commit is contained in:
Automatic Build System 2024-01-05 23:55:11 +01:00
parent 379bdb220c
commit 5b9b405c6b
2 changed files with 40 additions and 2 deletions

View File

@ -0,0 +1,33 @@
Submitted By: Armin K. <krejzi at email dot com>, rediffed by Fernando de Oliveira <famobr at yahoo dot com dot br>
Date: 2014-06-23
Initial Package Version: 0.48.5
Upstream Status: Unknown
Origin: Armin K. <krejzi at email dot com>
URL:
Description: Fixes build with gc-7.4.2
--- inkscape-0.48.5.orig/configure 2014-06-20 19:05:43.525382393 -0300
+++ inkscape-0.48.5/configure 2014-06-23 15:24:38.730084988 -0300
@@ -9044,8 +9044,8 @@
# include <gc.h>
#endif
#include <stdio.h>
- extern unsigned GC_version;
int main(void){
+ unsigned GC_version = GC_get_version();
unsigned min = ((6 << 16) | (4 << 8) | 0);
printf("%d.%d.%d ",GC_version >> 16, (GC_version >> 8) & 0xFF, GC_version & 0xFF);
if (GC_version>=min) return 0;
--- inkscape-0.48.5.orig/configure.ac 2014-06-20 17:29:03.717600589 -0300
+++ inkscape-0.48.5/configure.ac 2014-06-23 15:24:19.592598799 -0300
@@ -241,8 +241,8 @@
# include <gc.h>
#endif
#include <stdio.h>
- extern unsigned GC_version;
int main(void){
+ unsigned GC_version = GC_get_version();
unsigned min = ((6 << 16) | (4 << 8) | 0);
printf("%d.%d.%d ",GC_version >> 16, (GC_version >> 8) & 0xFF, GC_version & 0xFF);
if (GC_version>=min) return 0;

View File

@ -1,6 +1,6 @@
Name: inkscape
Version: 0.48.4
Release: 2mamba
Version: 0.48.5
Release: 1mamba
Summary: A SVG based generic vector-drawing application
Group: Applications/Multimedia
Vendor: openmamba
@ -11,6 +11,7 @@ Source: http://downloads.sourceforge.net/sourceforge/inkscape/inkscape-%{
Patch: %{name}-0.43-desktop_file.patch
Patch1: %{name}-0.47-poppler-0.12.2.patch
Patch2: %{name}-0.47-gcc45.patch
Patch3: inkscape-0.48.5-libgc-7.4.2.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: aspell-devel
@ -75,6 +76,7 @@ Additional planned work includes conversion of the codebase from C/Gtk to C++/Gt
%setup -q
#%patch1 -p1
#%patch2 -p1
%patch3 -p1
# Fixes build with gcc 4.8
sed -e "s@commands_toolbox,@commands_toolbox@" -i src/widgets/desktop-widget.h
@ -118,6 +120,9 @@ LDFLAGS="-ldl" \
%doc AUTHORS ChangeLog COPYING* NEWS README
%changelog
* Thu Sep 18 2014 Automatic Build System <autodist@mambasoft.it> 0.48.5-1mamba
- automatic version update by autodist
* Sat Sep 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.48.4-2mamba
- rebuilt