update to 2.6 [release 2.6-1mamba;Wed Nov 27 2024]
This commit is contained in:
parent
076be47fe0
commit
3768b7799a
@ -1,9 +0,0 @@
|
||||
--- initscripts-1.3.33/src/initlog.c.orig 2007-04-11 09:57:34.000000000 +0200
|
||||
+++ initscripts-1.3.33/src/initlog.c 2007-04-11 09:57:49.000000000 +0200
|
||||
@@ -442,6 +442,5 @@
|
||||
setlocale(LC_ALL,"");
|
||||
bindtextdomain("initlog","/etc/locale");
|
||||
textdomain("initlog");
|
||||
- fprintf(stderr, _("WARNING: initlog is deprecated and will be removed in a future release\n"));
|
||||
exit(processArgs(argc,argv,0));
|
||||
}
|
@ -1,24 +0,0 @@
|
||||
diff -Nru initscripts-1.6.11/src.orig/Makefile initscripts-1.6.11/src/Makefile
|
||||
--- initscripts-1.6.11/src.orig/Makefile 2012-02-16 17:24:22.000000000 +0100
|
||||
+++ initscripts-1.6.11/src/Makefile 2013-03-19 17:39:49.126982264 +0100
|
||||
@@ -25,16 +25,16 @@
|
||||
all: $(PROGS)
|
||||
|
||||
getkey: getkey.o
|
||||
- $(CC) $(LDFLAGS) -o $@ $< -Wl,-Bstatic -lpopt -Wl,-Bdynamic
|
||||
+ $(CC) $(LDFLAGS) -o $@ $< -Wl,-Bstatic -Wl,-Bdynamic -lpopt
|
||||
|
||||
initlog: $(INITLOG_OBJS)
|
||||
- $(CC) $(LDFLAGS) -o $@ $(INITLOG_OBJS) -Wl,-Bstatic -lpopt -Wl,-Bdynamic
|
||||
+ $(CC) $(LDFLAGS) -o $@ $(INITLOG_OBJS) -Wl,-Bstatic -Wl,-Bdynamic -lpopt
|
||||
|
||||
ipcalc: ipcalc.o
|
||||
- $(CC) $(LDFLAGS) -o $@ $< -Wl,-Bstatic -lpopt -Wl,-Bdynamic
|
||||
+ $(CC) $(LDFLAGS) -o $@ $< -Wl,-Bstatic -Wl,-Bdynamic -lpopt
|
||||
|
||||
usleep: $(USLEEP_OBJS)
|
||||
- $(CC) $(LDFLAGS) -o $@ $(USLEEP_OBJS) -Wl,-Bstatic -lpopt -Wl,-Bdynamic
|
||||
+ $(CC) $(LDFLAGS) -o $@ $(USLEEP_OBJS) -Wl,-Bstatic -Wl,-Bdynamic -lpopt
|
||||
|
||||
usernetctl.o: usernetctl.c
|
||||
$(CC) $(CFLAGS) -fPIE -c usernetctl.c -o usernetctl.o
|
@ -1,8 +1,8 @@
|
||||
%define utmp_groupid 17
|
||||
|
||||
Name: initscripts
|
||||
Version: 2.5
|
||||
Release: 2mamba
|
||||
Version: 2.6
|
||||
Release: 1mamba
|
||||
Summary: Common tools used by initscripts-sysv5 and systemd in sysv5 mode
|
||||
Group: System/Configuration
|
||||
Vendor: openmamba
|
||||
@ -10,8 +10,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://src.openmamba.org/openmamba/initscripts
|
||||
Source: https://src.openmamba.org/openmamba/initscripts.git/v%{version}/initscripts-%{version}.tar.bz2
|
||||
Patch0: %{name}-1.3.33-initlog_deprecated_warning.patch
|
||||
Patch1: initscripts-1.6.11-gcc-4.7.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -29,14 +27,13 @@ Requires: gzip
|
||||
Requires: findutils
|
||||
Requires: psmisc
|
||||
Requires: hwdata
|
||||
Provides: /etc/init.d
|
||||
Provides: group(utmp)
|
||||
Obsoletes: initscripts-sysv5 < 2.4
|
||||
Obsoletes: initscripts-tools < 2.6
|
||||
|
||||
%description
|
||||
The initscripts package contains the basic system scripts used to boot your openmamba system, change runlevels, manage system services and network interfaces, and shut the system down cleanly.
|
||||
|
||||
%debug_package
|
||||
|
||||
%package tools
|
||||
Summary: Obsolete tools formerly used by SysV5 initscripts
|
||||
Group: System/Tools
|
||||
@ -46,14 +43,13 @@ Obsolete tools formerly used by SysV5 initscripts.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%make CC=%{_target_platform}-gcc tools
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall install-tools
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
@ -139,18 +135,17 @@ _EOF
|
||||
fi
|
||||
:
|
||||
|
||||
%posttrans
|
||||
if [ $1 -ge 1 ]; then
|
||||
# Apply updated sysctl settings
|
||||
sysctl -q --system
|
||||
fi
|
||||
:
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{_initrddir}
|
||||
%{_sysconfdir}/init.d
|
||||
%attr(0755,root,root) %config(noreplace) %{_initrddir}/rc.local
|
||||
%dir %{_sysconfdir}/rc.d
|
||||
%{_sysconfdir}/rc?.d
|
||||
%dir %{_sysconfdir}/rc.d/rc?.d
|
||||
%dir %{_sysconfdir}/modules.d
|
||||
%{_sysconfdir}/sysconfig/functions
|
||||
%{_sysconfdir}/sysconfig/rc
|
||||
%{_sbindir}/service
|
||||
%{_bindir}/service
|
||||
%{_prefix}/lib/modprobe.d/lp.conf
|
||||
%{_prefix}/lib/modprobe.d/rtl8192ce.conf
|
||||
%{_prefix}/lib/modprobe.d/blacklist-net.conf
|
||||
@ -159,30 +154,12 @@ fi
|
||||
%ghost %attr(0664,root,utmp) %{_var}/log/lastlog
|
||||
%ghost %attr(0644,root,root) %{_var}/log/wtmp
|
||||
#%ghost %attr(0664,root,utmp) %{_var}/run/utmp
|
||||
#%dir %{_var}/run/netreport
|
||||
%doc COPYING
|
||||
|
||||
%files tools
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/doexec
|
||||
%{_bindir}/ipcalc
|
||||
%{_bindir}/usleep
|
||||
%{_sbindir}/consoletype
|
||||
%{_sbindir}/genhostid
|
||||
%{_sbindir}/getkey
|
||||
%{_sbindir}/minilogd
|
||||
%attr(4755,root,root) %{_sbindir}/usernetctl
|
||||
%{_mandir}/man1/consoletype.*
|
||||
%{_mandir}/man1/doexec.*
|
||||
%{_mandir}/man1/genhostid.*
|
||||
%{_mandir}/man1/getkey.*
|
||||
%{_mandir}/man1/ipcalc.*
|
||||
%{_mandir}/man1/netreport.*
|
||||
%{_mandir}/man1/usleep.*
|
||||
%{_mandir}/man8/usernetctl.*
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Wed Nov 27 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6-1mamba
|
||||
- update to 2.6
|
||||
|
||||
* Wed Mar 20 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5-2mamba
|
||||
- post: fix typo in /etc/rpm/macros.lang introduced in past livedvd installations
|
||||
|
||||
|
Reference in New Issue
Block a user