85 lines
2.6 KiB
RPMSpec
85 lines
2.6 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: info2man
|
|
Version: 1.1.1
|
|
Release: 4mamba
|
|
Summary: Tool to convert GNU info documents into manual pages
|
|
Group: Development/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cskk.ezoshosting.com/cs/css/info2pod.html
|
|
# Manually renamed from http://www.cskk.ezoshosting.com/cs/css/info2man.tar.gz
|
|
Source: http://www.cskk.ezoshosting.com/cs/css/info2man-%{version}.tar.gz
|
|
Patch0: %{name}-1.1.1-mktemp.patch
|
|
Patch1: %{name}-1.1.1-makefile.patch
|
|
Patch2: %{name}-1.1.1-manpages.patch
|
|
License: OSI Approved
|
|
Requires: perl >= %perl_major_ver
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
BuildArch: noarch
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
info2man converts a GNU info file to a man page.
|
|
It first generates a POD (Plain Old Documentation) file using info2pod, then converts this to a man page using pod2man.
|
|
|
|
%prep
|
|
%setup -q -c
|
|
%patch0 -p1
|
|
%patch1 -p1
|
|
%patch2 -p1
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
install -D -m 755 info2man %{buildroot}%{_bindir}/info2man
|
|
install -m 755 info2pod %{buildroot}%{_bindir}/info2pod
|
|
|
|
install -D -m 644 info2man.1 %{buildroot}%{_mandir}/man1/info2man.1
|
|
install -m 644 info2pod.1 %{buildroot}%{_mandir}/man1/info2pod.1
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%{_bindir}/info2man
|
|
%{_bindir}/info2pod
|
|
%{_mandir}/man1/info2man.*
|
|
%{_mandir}/man1/info2pod.*
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Sat Feb 06 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-4mamba
|
|
- versioned source to prevent fake automatic updates
|
|
|
|
* Sat Jul 13 2013 Automatic Build System <autodist@mambasoft.it> 1.1.1-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed May 20 2009 Davide Madrisan <davide.madrisan@gmail.com> 1.1.1-2mamba
|
|
- updated specfile
|
|
|
|
* Thu May 18 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.1.1-1qilnx
|
|
- package created by autospec
|