automatic rebuild by autodist [release 1.1.1-3mamba;Sat Jul 13 2013]

This commit is contained in:
Automatic Build System 2024-01-05 23:54:50 +01:00
parent f0b4080d15
commit 7742133f92
5 changed files with 197 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# info2man
info2man converts a GNU info file to a man page.
It first generates a POD (Plain Old Documentation) file using info2pod, then converts this to a man page using pod2man.

View File

@ -0,0 +1,7 @@
--- info2man-1.1.1/Makefile.PL
+++ info2man-1.1.1/Makefile.PL
@@ -0,0 +1,4 @@
+#!/usr/bin/perl
+
+use ExtUtils::MakeMaker;
+WriteMakefile(NAME => 'cs');

View File

@ -0,0 +1,80 @@
--- info2man-1.1.1/info2man.1
+++ info2man-1.1.1/info2man.1
@@ -0,0 +1,40 @@
+.TH INFO2MAN 1
+.SH NAME
+info2man \- generate man pages from info documents
+.SH SYNOPSIS
+.B info2man
+.I info-file
+.SH DESCRIPTION
+.B info2man
+converts a GNU info file to a man page.
+It first generates a POD (Plain Old Documentation) file using
+.BR info2pod (1),
+then converts this to a man page using
+.BR pod2man (1).
+.PP
+.I info-file
+should be the full path to the info file (probably in
+.I /usr/share/info
+or similar).
+.SH OPTIONS
+None.
+.SH NOTES
+The style of info documentation and man pages differs considerably.
+Info documentation is generally written as a book, making full use of
+chapters, hyperlinks, footnotes, and the like.
+By contrast, man pages are often intended as something closer to a
+reference card.
+.PP
+That said, many people prefer the interface used to view man pages (a
+normal pager) to the available info browsers.
+This program will convert the form, but not the content; don't expect it
+to possess the artificial intelligence necessary to turn a lengthy
+interconnected info file into a man page that is a model of conciseness!
+.SH AUTHOR
+Cameron Simpson <cs@zip.com.au> wrote
+.BR info2man .
+.PP
+Colin Watson <cjwatson@debian.org> wrote this manual page.
+.SH "SEE ALSO"
+.BR info2pod (1),
+.BR pod2man (1).
--- info2man-1.1.1/info2pod.1
+++ info2man-1.1.1/info2pod.1
@@ -0,0 +1,24 @@
+.TH INFO2POD 1
+.SH NAME
+info2pod \- generate POD files from info documents
+.SH SYNOPSIS
+.B info2pod
+.I info-file
+.SH DESCRIPTION
+.B info2pod
+converts a GNU info file to Perl's POD (Plain Old Documentation) format.
+.PP
+.I info-file
+should be the full path to the info file (probably in
+.I /usr/share/info
+or similar).
+.SH OPTIONS
+None.
+.SH AUTHOR
+Cameron Simpson <cs@zip.com.au> wrote
+.BR info2man .
+.PP
+Colin Watson <cjwatson@debian.org> wrote this manual page.
+.SH "SEE ALSO"
+.BR info2man (1),
+.BR perlpod (1).
--- info2man-1.1.1/LICENSE
+++ info2man-1.1.1/LICENSE
@@ -0,0 +1,7 @@
+You're free to use, modify and redistribute these scripts provided that:
+
+ - you leave my code marked as mine and your modifications (if any)
+ marked as yours
+
+ - you make recipients aware that the scripts can be obtained for
+ free from my own web page

View File

@ -0,0 +1,29 @@
--- info2man-1.1.1/info2man 2004-07-17 10:15:54.000000000 +0200
+++ info2man-1.1.1/info2man 2006-05-18 15:34:52.000000000 +0200
@@ -4,12 +4,21 @@
# - Cameron Simpson <cs@zip.com.au> 01nov2000
#
-: ${TMPDIR:=/tmp}
+if [ $# -eq 0 ]
+then
+ echo "Usage: info2man info-file"
+ exit 1
+fi
+
+tmpdir=`mktemp -d /tmp/info2man.XXXXXX` ||
+ { echo "Cannot create directory \`$tmpdir'. Aborting." >&2; exit 1; }
+trap 'ret=$?; rm -rf $tmpdir && exit $ret' 0
+trap '(exit 0); exit' 1 2 13 15
+tmpfile=`env TMPDIR="" mktemp -p $tmpdir tmpfile.XXXXXX` ||
+ { echo "Cannot create temporary file \`$tmpfile'. Aborting." >&2; exit 1; }
xit=0
-tmp=$TMPDIR/i2m$$
-info2pod ${1+"$@"} >$tmp || xit=1
+info2pod ${1+"$@"} >$tmpfile || xit=1
# stderr tossed because of overzealous warnings
-pod2man --lax --center='GNU Info' $tmp 2>/dev/null || xit=1
-rm -f $tmp
+pod2man --lax --center='GNU Info' $tmpfile 2>/dev/null || xit=1
exit $xit

78
info2man.spec Normal file
View File

@ -0,0 +1,78 @@
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: info2man
Version: 1.1.1
Release: 3mamba
Summary: Tool to convert GNU info documents into manual pages
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@qilinux.it>
URL: http://www.cskk.ezoshosting.com/cs/css/info2pod.html
Source: http://www.cskk.ezoshosting.com/cs/css/info2man.tar.gz
Patch0: %{name}-1.1.1-mktemp.patch
Patch1: %{name}-1.1.1-makefile.patch
Patch2: %{name}-1.1.1-manpages.patch
License: OSI Approved
Requires: perl >= %perl_major_ver
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
BuildRequires: perl-devel >= %perl_major_ver
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
info2man converts a GNU info file to a man page.
It first generates a POD (Plain Old Documentation) file using info2pod, then converts this to a man page using pod2man.
%prep
%setup -q -c %{name}-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%build
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall_perl
packlist=`find %{buildroot} -name .packlist`
[ -z "$packlist" ] && exit 1 || cat $packlist | \
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
sort -u > .packlist && rm $packlist
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
for dir in `find %{buildroot} -type d | grep $strid`; do
echo "%dir ${dir#%buildroot}" >> .packlist
done
install -D -m 755 info2man %{buildroot}%{_bindir}/info2man
install -m 755 info2pod %{buildroot}%{_bindir}/info2pod
install -D -m 644 info2man.1 %{buildroot}%{_mandir}/man1/info2man.1
install -m 644 info2pod.1 %{buildroot}%{_mandir}/man1/info2pod.1
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
rm -f .packlist
%files -f .packlist
%defattr(-,root,root)
%{_bindir}/info2man
%{_bindir}/info2pod
%{_mandir}/man1/info2man.*
%{_mandir}/man1/info2pod.*
%doc LICENSE
%changelog
* Sat Jul 13 2013 Automatic Build System <autodist@mambasoft.it> 1.1.1-3mamba
- automatic rebuild by autodist
* Wed May 20 2009 Davide Madrisan <davide.madrisan@gmail.com> 1.1.1-2mamba
- updated specfile
* Thu May 18 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.1.1-1qilnx
- package created by autospec