remove info/dir [release 2.2.13-2mamba;Fri Apr 19 2024]
This commit is contained in:
parent
aab70168fd
commit
10cfbe1f98
@ -1,42 +0,0 @@
|
||||
diff -Nru indent-2.2.11/doc.orig/Makefile.am indent-2.2.11/doc/Makefile.am
|
||||
--- indent-2.2.11/doc.orig/Makefile.am 2008-04-14 20:31:19.000000000 +0200
|
||||
+++ indent-2.2.11/doc/Makefile.am 2014-12-28 12:57:09.337750595 +0100
|
||||
@@ -34,14 +34,14 @@
|
||||
html-split: @PACKAGE@_toc.html
|
||||
|
||||
@PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
|
||||
- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
|
||||
+ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
|
||||
|
||||
@PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
|
||||
case "$(TEXI2HTML)" in \
|
||||
*"/missing texi2html") \
|
||||
- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
|
||||
+ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
|
||||
*) $(RM) @PACKAGE@_*.html ; \
|
||||
- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
|
||||
+ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
|
||||
esac
|
||||
|
||||
install-html-monolithic: @PACKAGE@.html
|
||||
diff -Nru indent-2.2.11/doc.orig/Makefile.in indent-2.2.11/doc/Makefile.in
|
||||
--- indent-2.2.11/doc.orig/Makefile.in 2010-01-31 17:25:21.000000000 +0100
|
||||
+++ indent-2.2.11/doc/Makefile.in 2014-12-28 12:56:49.929854993 +0100
|
||||
@@ -663,14 +663,14 @@
|
||||
html-split: @PACKAGE@_toc.html
|
||||
|
||||
@PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
|
||||
- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
|
||||
+ $(TEXI2HTML) -expandinfo -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
|
||||
|
||||
@PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
|
||||
case "$(TEXI2HTML)" in \
|
||||
*"/missing texi2html") \
|
||||
- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
|
||||
+ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
|
||||
*) $(RM) @PACKAGE@_*.html ; \
|
||||
- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
|
||||
+ $(TEXI2HTML) -expand info -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
|
||||
esac
|
||||
|
||||
install-html-monolithic: @PACKAGE@.html
|
@ -1,10 +0,0 @@
|
||||
--- indent-2.2.9/src/output.c
|
||||
+++ indent-2.2.9/src/output.c
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
RCSTAG_CC ("$Id: output.c,v 1.5 2002/12/12 17:36:49 david Exp $");
|
||||
|
||||
-static FILE * output = NULL;
|
||||
+FILE* output = NULL;
|
||||
static BOOLEAN inhibited = 0;
|
||||
static buf_break_st_ty * buf_break_list = NULL;
|
17
indent.spec
17
indent.spec
@ -1,16 +1,13 @@
|
||||
Name: indent
|
||||
Version: 2.2.13
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A flexible tool to indent C programs
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://directory.fsf.org/wiki/GNU/indent
|
||||
URL: https://www.gnu.org/software/indent/
|
||||
Source: https://ftp.gnu.org/gnu/indent/indent-%{version}.tar.xz
|
||||
#Source: http://ftp.de.debian.org/debian/pool/main/i/indent/indent_%{version}.orig.tar.xz
|
||||
Patch: %{name}-2.2.9-gcc4fix.patch
|
||||
Patch1: indent-2.2.11-texinfo-5.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -27,8 +24,6 @@ It also has options for controlling the alignment of braces and declarations, pr
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -40,6 +35,8 @@ It also has options for controlling the alignment of braces and declarations, pr
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
rm -f %{buildroot}%{_datadir}/info/dir
|
||||
|
||||
%post
|
||||
%install_info %{name}.info
|
||||
:
|
||||
@ -54,14 +51,16 @@ It also has options for controlling the alignment of braces and declarations, pr
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/indent
|
||||
%{_datadir}/info/*
|
||||
%{_datadir}/info/%{name}.info*
|
||||
%dir %{_docdir}/indent
|
||||
%{_docdir}/indent/indent.html
|
||||
%{_datadir}/man/man1/*
|
||||
%doc AUTHORS COPYING
|
||||
#ChangeLog* NEWS README
|
||||
|
||||
%changelog
|
||||
* Fri Apr 19 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.13-2mamba
|
||||
- remove info/dir
|
||||
|
||||
* Thu Mar 30 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.13-1mamba
|
||||
- update to 2.2.13
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user