rebuilt as legacy package [release 51.2-2mamba;Sun Mar 02 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 23:50:32 +01:00
parent 7c82b9ab3c
commit 471e96db58
4 changed files with 211 additions and 0 deletions

View File

@ -1,2 +1,7 @@
# icu51 # icu51
ICU is a set of C/C++ and Java libraries that provides robust and full-featured Unicode and locale support.
The library provides calendar support, conversions for many character sets, language sensitive collation, date and time formatting, support for many locales, message catalogs and resources, message formatting, normalization, number and currency formatting, time zones support, transliteration, word, line and sentence breaking, etc.
This package contains the Unicode character database and derived properties, along with converters and time zones data.

View File

@ -0,0 +1,31 @@
--- icu/source/tools/ctestfw/Makefile.in
+++ icu/source/tools/ctestfw/Makefile.in
@@ -79,6 +79,28 @@
install-local: install-library
install-library: all-local
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
+ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+endif
+ifneq ($(ENABLE_SHARED),)
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
+ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+endif
+endif
+ifneq ($(IMPORT_LIB_EXT),)
+ $(INSTALL-L) $(FINAL_IMPORT_LIB) $(DESTDIR)$(libdir)
+ifneq ($(IMPORT_LIB),$(FINAL_IMPORT_LIB))
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(IMPORT_LIB))
+endif
+ifneq ($(MIDDLE_IMPORT_LIB),$(FINAL_IMPORT_LIB))
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(MIDDLE_IMPORT_LIB))
+endif
+endif
+endif
dist-local:

View File

@ -0,0 +1,16 @@
diff -Nru icu.orig//source/tools/toolutil/pkg_genc.c icu/source/tools/toolutil/pkg_genc.c
--- icu.orig//source/tools/toolutil/pkg_genc.c 2010-04-28 15:27:46.000000000 +0000
+++ icu/source/tools/toolutil/pkg_genc.c 2010-07-13 11:57:46.000000000 +0000
@@ -118,10 +118,10 @@
} assemblyHeader[] = {
{"gcc",
".globl %s\n"
- "\t.section .note.GNU-stack,\"\",@progbits\n"
+ "\t.section .note.GNU-stack,\"\",%%progbits\n"
"\t.section .rodata\n"
"\t.align 8\n" /* Either align 8 bytes or 2^8 (256) bytes. 8 bytes is needed. */
- "\t.type %s,@object\n"
+ "\t.type %s,%%object\n"
"%s:\n\n",
".long ","",HEX_0X

159
icu51.spec Normal file
View File

@ -0,0 +1,159 @@
%define libname libicu51
%define pkgver %(echo %version | tr '.' '_')
Name: icu51
Version: 51.2
Release: 2mamba
Summary: Set of C/C++ and Java libraries for Unicode support
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.icu-project.org
Source: http://download.icu-project.org/files/icu4c/%{version}/icu4c-%{pkgver}-src.tgz
Patch0: icu-4.4-ctestfw-makefilein.patch
Patch1: icu-4.4.1-arm_assembly.patch
License: MIT
Requires: %{libname} = %{version}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
ICU is a set of C/C++ and Java libraries that provides robust and full-featured Unicode and locale support.
The library provides calendar support, conversions for many character sets, language sensitive collation, date and time formatting, support for many locales, message catalogs and resources, message formatting, normalization, number and currency formatting, time zones support, transliteration, word, line and sentence breaking, etc.
This package contains the Unicode character database and derived properties, along with converters and time zones data.
%package -n %{libname}
Group: System/Libraries
Summary: Set of C/C++ and Java libraries for Unicode support
%description -n %{libname}
ICU is a set of C/C++ and Java libraries that provides robust and full-featured Unicode support, software internationalization and globalization (i18n/g11n).
ICU is widely portable and gives applications the same results on all platforms and between C/C++ and Java software.
This package contains the runtime libraries for ICU.
%package -n %{libname}-devel
Group: Development/Libraries
Summary: Static libraries and headers for ICU
Requires: %{libname} = %{version}
%description -n %{libname}-devel
ICU is a set of C/C++ and Java libraries that provides robust and full-featured Unicode support, software internationalization and globalization (i18n/g11n).
ICU is widely portable and gives applications the same results on all platforms and between C/C++ and Java software.
This package contains static libraries and header files need for development.
%prep
%setup -q -n icu
#%patch0 -p1
#%patch1 -p1
%build
cd source
%configure \
--enable-shared \
--enable-static \
--disable-samples
%make \
%ifarch arm
-j1
%endif
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C source
# fix wrong libraries permissions
chmod +x %{buildroot}%{_libdir}/*.so.*
rm -f %{buildroot}%{_datadir}/icu/%{version}/license.html
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/derb
%{_bindir}/gen*
%{_bindir}/icuinfo
%{_bindir}/makeconv
%{_bindir}/pkgdata
%{_bindir}/uconv
%{_sbindir}/gen*
%{_sbindir}/icupkg
%{_mandir}/man?/*
%doc license.html readme.html
%files -n %{libname}
%defattr(-,root,root)
%{_libdir}/*.so.*
%files -n %{libname}-devel
%defattr(-,root,root)
%{_bindir}/icu-config
%dir %{_datadir}/icu
%dir %{_datadir}/icu/%{version}
%dir %{_datadir}/icu/%{version}/config
%{_datadir}/icu/%{version}/mkinstalldirs
%{_datadir}/icu/%{version}/config/mh-linux
%{_datadir}/icu/%{version}/install-sh
%dir %{_includedir}/layout
%dir %{_includedir}/unicode
%{_includedir}/layout/*.h
%{_includedir}/unicode/*.h
%{_libdir}/*.a
%{_libdir}/*.so
%dir %{_libdir}/icu
%dir %{_libdir}/icu/%{version}
%{_libdir}/icu/current
%{_libdir}/icu/%{version}/Makefile.inc
%{_libdir}/icu/Makefile.inc
%{_libdir}/icu/%{version}/pkgdata.inc
%{_libdir}/icu/pkgdata.inc
%{_libdir}/pkgconfig/icu-*.pc
%changelog
* Sun Mar 02 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 51.2-2mamba
- rebuilt as legacy package
* Sat May 25 2013 Automatic Build System <autodist@mambasoft.it> 51.2-1mamba
- automatic version update by autodist
* Tue Mar 26 2013 Automatic Build System <autodist@mambasoft.it> 51.1-1mamba
- automatic version update by autodist
* Wed Jan 23 2013 Automatic Build System <autodist@mambasoft.it> 50.1.2-1mamba
- automatic version update by autodist
* Tue Dec 18 2012 Automatic Build System <autodist@mambasoft.it> 50.1.1-1mamba
- automatic version update by autodist
* Sun Dec 02 2012 Automatic Build System <autodist@mambasoft.it> 50.1-1mamba
- automatic version update by autodist
* Mon Jul 12 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.1-1mamba
- update to 4.4.1
* Tue Jun 29 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4-2mamba
- added patch to fix install of libtestfw library required by icutest tool
* Tue Mar 23 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4-1mamba
- update to 4.4
* Tue Dec 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0-1mamba
- update to 4.0
* Thu Oct 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8-1mamba
- update to 3.8
* Thu Jan 12 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 3.2-2qilnx
- fixed license
* Tue May 31 2005 Davide Madrisan <davide.madrisan@qilinux.it> 3.2-1qilnx
- package created by autospec