added upstream patch to fix problems seen with thunderbird >= 115 (see https://bugzilla.mozilla.org/show_bug.cgi?id=1843007 ) [release 73.2-2mamba;Fri Sep 29 2023]
This commit is contained in:
parent
8503fea664
commit
e4acbad2ec
25
icu-73.2-ICU-22132.patch
Normal file
25
icu-73.2-ICU-22132.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -u a/i18n/vtzone.cpp a/i18n/vtzone.cpp
|
||||
--- a/i18n/vtzone.cpp 2023-07-14 09:05:38.000000000 +0100
|
||||
+++ b/i18n/vtzone.cpp 2023-07-14 09:05:38.000000000 +0100
|
||||
@@ -1735,14 +1735,14 @@
|
||||
}
|
||||
}
|
||||
} else {
|
||||
- UnicodeString icutzprop;
|
||||
- UVector customProps(nullptr, uhash_compareUnicodeString, status);
|
||||
+ UVector customProps(uprv_deleteUObject, uhash_compareUnicodeString, status);
|
||||
if (olsonzid.length() > 0 && icutzver.length() > 0) {
|
||||
- icutzprop.append(olsonzid);
|
||||
- icutzprop.append(u'[');
|
||||
- icutzprop.append(icutzver);
|
||||
- icutzprop.append(u']');
|
||||
- customProps.addElement(&icutzprop, status);
|
||||
+ LocalPointer<UnicodeString> icutzprop(new UnicodeString(ICU_TZINFO_PROP), status);
|
||||
+ icutzprop->append(olsonzid);
|
||||
+ icutzprop->append(u'[');
|
||||
+ icutzprop->append(icutzver);
|
||||
+ icutzprop->append(u']');
|
||||
+ customProps.adoptElement(icutzprop.orphan(), status);
|
||||
}
|
||||
writeZone(writer, *tz, &customProps, status);
|
||||
}
|
10
icu.spec
10
icu.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: icu
|
||||
Version: 73.2
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Set of C/C++ and Java libraries for Unicode support
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -12,7 +12,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.icu-project.org
|
||||
Source: https://github.com/unicode-org/icu.git/release-%{gitver}/icu-%{version}.tar.bz2
|
||||
#Source: http://download.icu-project.org/files/icu4c/%{version}/icu4c-%{pkgver}-src.tgz
|
||||
Patch0: icu-73.2-ICU-22132.patch
|
||||
License: MIT
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -52,6 +52,9 @@ This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
cd icu4c/source
|
||||
%patch 0 -p1 -b .ICU-22132
|
||||
cd ../..
|
||||
|
||||
%build
|
||||
cd icu4c/source
|
||||
@ -123,6 +126,9 @@ rm -f %{buildroot}%{_datadir}/icu/%{version}/license.html
|
||||
%{_libdir}/pkgconfig/icu-*.pc
|
||||
|
||||
%changelog
|
||||
* Fri Sep 29 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 73.2-2mamba
|
||||
- added upstream patch to fix problems seen with thunderbird >= 115 (see https://bugzilla.mozilla.org/show_bug.cgi?id=1843007 )
|
||||
|
||||
* Wed Jun 14 2023 Automatic Build System <autodist@mambasoft.it> 73.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user