automatic version update by autodist [release 63.1-1mamba;Tue Oct 30 2018]
This commit is contained in:
parent
09f4e3652c
commit
9f25d2edb2
@ -1,31 +0,0 @@
|
|||||||
--- icu/source/tools/ctestfw/Makefile.in
|
|
||||||
+++ icu/source/tools/ctestfw/Makefile.in
|
|
||||||
@@ -79,6 +79,28 @@
|
|
||||||
install-local: install-library
|
|
||||||
|
|
||||||
install-library: all-local
|
|
||||||
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
|
|
||||||
+ifneq ($(ENABLE_STATIC),)
|
|
||||||
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
|
|
||||||
+endif
|
|
||||||
+ifneq ($(ENABLE_SHARED),)
|
|
||||||
+ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
|
|
||||||
+ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
|
|
||||||
+ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
|
|
||||||
+endif
|
|
||||||
+endif
|
|
||||||
+ifneq ($(IMPORT_LIB_EXT),)
|
|
||||||
+ $(INSTALL-L) $(FINAL_IMPORT_LIB) $(DESTDIR)$(libdir)
|
|
||||||
+ifneq ($(IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(IMPORT_LIB))
|
|
||||||
+endif
|
|
||||||
+ifneq ($(MIDDLE_IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
|
||||||
+ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(MIDDLE_IMPORT_LIB))
|
|
||||||
+endif
|
|
||||||
+endif
|
|
||||||
+endif
|
|
||||||
|
|
||||||
dist-local:
|
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
diff -Nru icu.orig//source/tools/toolutil/pkg_genc.c icu/source/tools/toolutil/pkg_genc.c
|
|
||||||
--- icu.orig//source/tools/toolutil/pkg_genc.c 2010-04-28 15:27:46.000000000 +0000
|
|
||||||
+++ icu/source/tools/toolutil/pkg_genc.c 2010-07-13 11:57:46.000000000 +0000
|
|
||||||
@@ -118,10 +118,10 @@
|
|
||||||
} assemblyHeader[] = {
|
|
||||||
{"gcc",
|
|
||||||
".globl %s\n"
|
|
||||||
- "\t.section .note.GNU-stack,\"\",@progbits\n"
|
|
||||||
+ "\t.section .note.GNU-stack,\"\",%%progbits\n"
|
|
||||||
"\t.section .rodata\n"
|
|
||||||
"\t.align 8\n" /* Either align 8 bytes or 2^8 (256) bytes. 8 bytes is needed. */
|
|
||||||
- "\t.type %s,@object\n"
|
|
||||||
+ "\t.type %s,%%object\n"
|
|
||||||
"%s:\n\n",
|
|
||||||
|
|
||||||
".long ","",HEX_0X
|
|
11
icu.spec
11
icu.spec
@ -2,7 +2,7 @@
|
|||||||
%define pkgver %(echo %version | tr '.' '_')
|
%define pkgver %(echo %version | tr '.' '_')
|
||||||
|
|
||||||
Name: icu
|
Name: icu
|
||||||
Version: 62.1
|
Version: 63.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Set of C/C++ and Java libraries for Unicode support
|
Summary: Set of C/C++ and Java libraries for Unicode support
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -11,8 +11,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.icu-project.org
|
URL: http://www.icu-project.org
|
||||||
Source: http://download.icu-project.org/files/icu4c/%{version}/icu4c-%{pkgver}-src.tgz
|
Source: http://download.icu-project.org/files/icu4c/%{version}/icu4c-%{pkgver}-src.tgz
|
||||||
Patch0: %{name}-4.4-ctestfw-makefilein.patch
|
|
||||||
Patch1: %{name}-4.4.1-arm_assembly.patch
|
|
||||||
License: MIT
|
License: MIT
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -50,9 +48,7 @@ ICU is widely portable and gives applications the same results on all platforms
|
|||||||
This package contains static libraries and header files need for development.
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}
|
%setup -q -n icu
|
||||||
#%patch0 -p1
|
|
||||||
#%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd source
|
cd source
|
||||||
@ -123,6 +119,9 @@ rm -f %{buildroot}%{_datadir}/icu/%{version}/license.html
|
|||||||
%{_libdir}/pkgconfig/icu-*.pc
|
%{_libdir}/pkgconfig/icu-*.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 30 2018 Automatic Build System <autodist@mambasoft.it> 63.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Thu Aug 09 2018 Automatic Build System <autodist@mambasoft.it> 62.1-1mamba
|
* Thu Aug 09 2018 Automatic Build System <autodist@mambasoft.it> 62.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user