automatic version update by autodist [release 1.3.8-1mamba;Tue Nov 19 2013]

This commit is contained in:
Automatic Build System 2024-01-05 23:49:15 +01:00
parent 5f0679ebc8
commit be85f84aa3
4 changed files with 98 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# icewm
IceWM is a window manager for the X Window System.

View File

@ -0,0 +1,14 @@
--- icewm-1.3.7.orig/src/base.h
+++ icewm-1.3.7/src/base.h
@@ -2,9 +2,9 @@
#define __BASE_H
#if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
-#define deprecated __attribute__((deprecated))
+#define _ICEWM_deprecated __attribute__((deprecated))
#else
-#define deprecated
+#define _ICEWM_deprecated
#endif
/*** Atomar Data Types ********************************************************/

10
icewm-1.3.7-gcc-4.7.patch Normal file
View File

@ -0,0 +1,10 @@
--- icewm-1.3.7.orig/src/yarray.h 2010-10-31 14:09:36.000000000 +0000
+++ icewm-1.3.7/src/yarray.h 2012-05-21 01:46:52.970218411 +0000
@@ -152,7 +152,7 @@
}
virtual void remove(const typename YArray<DataType *>::SizeType index) {
- if (index < YArray<DataType *>::getCount()) delete getItem(index);
+ if (index < YArray<DataType *>::getCount()) delete this->getItem(index);
YArray<DataType *>::remove(index);
}

72
icewm.spec Normal file
View File

@ -0,0 +1,72 @@
%define majver %(echo %version | cut -d. -f1-2)
Name: icewm
Version: 1.3.8
Release: 1mamba
Summary: A window manager for the X Window System
Group: System/X11
Vendor: openmamba
Distribution: openmamba
Packager: Filippo Bedendo Bordon <michiamophil@libero.it>
URL: http://www.icewm.org/
Source: http://downloads.sourceforge.net/project/icewm/icewm-%{majver}/%{version}/%{name}-%{version}.tar.gz
Patch0: icewm-1.3.7-buildfix-deprecated.patch
Patch1: icewm-1.3.7-gcc-4.7.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libstdc++6-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXft-devel
BuildRequires: libXinerama-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
IceWM is a window manager for the X Window System.
%prep
%setup -q
#%patch0 -p1
#%patch1 -p1
%build
%configure
%make \
LFLAGS="-lfontconfig"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/*
%{_datadir}/%{name}/*
%doc AUTHORS COPYING
#BUGS CHANGES COPYING README README.wm-session TODO
%changelog
* Tue Nov 19 2013 Automatic Build System <autodist@mambasoft.it> 1.3.8-1mamba
- automatic version update by autodist
* Mon Mar 04 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.7-2mamba
- specfile fixes
- added gcc 4.7 plus another ftbfs patches
* Wed Nov 16 2011 Filippo Bedendo Bordon <michiamophil@libero.it> 1.3.7-1mamba
- package created by autospec