scheduler: patch to increase MAX_BUSY_INSTALLING time from 2 minutes to 20 [release 1.0.1-6mamba;Wed Jun 18 2014]
This commit is contained in:
parent
5299bf69be
commit
c282aa5c49
20
icecc-1.0.1-dont_map_x86_to_x86_64.patch
Normal file
20
icecc-1.0.1-dont_map_x86_to_x86_64.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -Nru icecc-1.0.1.orig/services/scheduler.cpp icecc-1.0.1/services/scheduler.cpp
|
||||||
|
--- icecc-1.0.1.orig/services/scheduler.cpp 2014-06-18 18:40:13.627459699 +0200
|
||||||
|
+++ icecc-1.0.1/services/scheduler.cpp 2014-06-18 18:51:34.366733667 +0200
|
||||||
|
@@ -602,16 +602,11 @@
|
||||||
|
platform_map.insert( make_pair( string( "i386" ), string( "i486" ) ) );
|
||||||
|
platform_map.insert( make_pair( string( "i386" ), string( "i586" ) ) );
|
||||||
|
platform_map.insert( make_pair( string( "i386" ), string( "i686" ) ) );
|
||||||
|
- platform_map.insert( make_pair( string( "i386" ), string( "x86_64" ) ) );
|
||||||
|
|
||||||
|
platform_map.insert( make_pair( string( "i486" ), string( "i586" ) ) );
|
||||||
|
platform_map.insert( make_pair( string( "i486" ), string( "i686" ) ) );
|
||||||
|
- platform_map.insert( make_pair( string( "i486" ), string( "x86_64" ) ) );
|
||||||
|
|
||||||
|
platform_map.insert( make_pair( string( "i586" ), string( "i686" ) ) );
|
||||||
|
- platform_map.insert( make_pair( string( "i586" ), string( "x86_64" ) ) );
|
||||||
|
-
|
||||||
|
- platform_map.insert( make_pair( string( "i686" ), string( "x86_64" ) ) );
|
||||||
|
|
||||||
|
platform_map.insert( make_pair( string( "ppc" ), string( "ppc64" ) ) );
|
||||||
|
platform_map.insert( make_pair( string( "s390" ), string( "s390x" ) ) );
|
12
icecc-1.0.1-increase_MAX_BUSY_INSTALLING.patch
Normal file
12
icecc-1.0.1-increase_MAX_BUSY_INSTALLING.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru icecc-1.0.1.orig/services/comm.h icecc-1.0.1/services/comm.h
|
||||||
|
--- icecc-1.0.1.orig/services/comm.h 2013-07-11 15:41:17.000000000 +0200
|
||||||
|
+++ icecc-1.0.1/services/comm.h 2014-06-18 18:41:09.720490740 +0200
|
||||||
|
@@ -43,7 +43,7 @@
|
||||||
|
// MAX_SCHEDULER_PING must be multiple of MAX_SCHEDULER_PONG
|
||||||
|
#define MAX_SCHEDULER_PING 12 * MAX_SCHEDULER_PONG
|
||||||
|
// maximum amount of time in seconds a daemon can be busy installing
|
||||||
|
-#define MAX_BUSY_INSTALLING 120
|
||||||
|
+#define MAX_BUSY_INSTALLING 1200
|
||||||
|
|
||||||
|
#define IS_PROTOCOL_22( c ) ( (c)->protocol >= 22 )
|
||||||
|
#define IS_PROTOCOL_23( c ) ( (c)->protocol >= 23 )
|
11
icecc.spec
11
icecc.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: icecc
|
Name: icecc
|
||||||
Version: 1.0.1
|
Version: 1.0.1
|
||||||
Release: 5mamba
|
Release: 6mamba
|
||||||
Summary: A distributed build system based on distcc
|
Summary: A distributed build system based on distcc
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -22,6 +22,8 @@ Source6: icecream-monitor
|
|||||||
Patch0: %{name}-0.9.7-arm_platform_map.patch
|
Patch0: %{name}-0.9.7-arm_platform_map.patch
|
||||||
Patch1: %{name}-0.9.7-x86_64-map-to-i686-for-now.patch
|
Patch1: %{name}-0.9.7-x86_64-map-to-i686-for-now.patch
|
||||||
Patch2: icecc-0.9.98.1-sysconfig-openmamba.patch
|
Patch2: icecc-0.9.98.1-sysconfig-openmamba.patch
|
||||||
|
Patch3: icecc-1.0.1-increase_MAX_BUSY_INSTALLING.patch
|
||||||
|
Patch4: icecc-1.0.1-dont_map_x86_to_x86_64.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -29,7 +31,7 @@ BuildRequires: libcap-ng-devel
|
|||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: llvm-clang-devel
|
BuildRequires: libclang-devel
|
||||||
BuildRequires: pkg-config
|
BuildRequires: pkg-config
|
||||||
Requires: gcc
|
Requires: gcc
|
||||||
Requires: gcc-c++
|
Requires: gcc-c++
|
||||||
@ -45,6 +47,8 @@ Icecream was created by SUSE based on distcc. Like distcc, Icecream takes compil
|
|||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
#%patch4 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -148,6 +152,9 @@ fi
|
|||||||
%doc COPYING
|
%doc COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-6mamba
|
||||||
|
- scheduler: patch to increase MAX_BUSY_INSTALLING time from 2 minutes to 20
|
||||||
|
|
||||||
* Mon Jun 02 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-5mamba
|
* Mon Jun 02 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-5mamba
|
||||||
- remove x86_64-map-to-i686 patch no longer needed now
|
- remove x86_64-map-to-i686 patch no longer needed now
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user