automatic version update by autodist [release 2.3.3-1mamba;Fri Jul 06 2012]

This commit is contained in:
Automatic Build System 2024-01-05 23:48:40 +01:00
parent fd4a765111
commit 931d58c646
5 changed files with 174 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# icecast
Icecast is an Internet based broadcasting system based on the Mpeg Layer III streaming technology. It was originally inspired by Nullsoft's Shoutcast and also mp3serv by Scott Manley. The icecast project was started for several reasons: a) all broadcasting systems were pretty much closed source, non-free software implementations, b) Shoutcast doesn't allow you to run your own directory servers, or support them, and c) we thought it would be a lot of fun.

10
icecast-curl.patch Normal file
View File

@ -0,0 +1,10 @@
--- icecast-2.3.1/src/auth_url.c.curl 2005-11-30 13:16:17.000000000 -0500
+++ icecast-2.3.1/src/auth_url.c 2006-11-06 07:21:06.000000000 -0500
@@ -518,7 +518,6 @@
curl_easy_setopt (url_info->handle, CURLOPT_WRITEDATA, url_info->handle);
curl_easy_setopt (url_info->handle, CURLOPT_NOSIGNAL, 1L);
curl_easy_setopt (url_info->handle, CURLOPT_TIMEOUT, 15L);
- curl_easy_setopt (url_info->handle, CURLOPT_PASSWDFUNCTION, my_getpass);
curl_easy_setopt (url_info->handle, CURLOPT_ERRORBUFFER, &url_info->errormsg[0]);
if (url_info->username && url_info->password)

38
icecast.conf.patch Normal file
View File

@ -0,0 +1,38 @@
--- conf/icecast.xml.in
+++ conf/icecast.xml.in 2005-05-21 02:24:39.211077978 +0200
@@ -94,7 +94,7 @@
<hidden>1</hidden>
<no-yp>1</no-yp>
<authentication type="htpasswd">
- <option name="filename" value="myauth"/>
+ <option name="filename" value="/usr/share/icecast/myauth"/>
<option name="allow_duplicate_users" value="0"/>
</authentication>
</mount>
@@ -114,10 +114,10 @@
<!-- Note that if <chroot> is turned on below, these paths must both
be relative to the new root, not the original root -->
- <logdir>@localstatedir@/log/@PACKAGE@</logdir>
+ <logdir>/var/log/icecast</logdir>
<webroot>@pkgdatadir@/web</webroot>
<adminroot>@pkgdatadir@/admin</adminroot>
- <!-- <pidfile>@pkgdatadir@/icecast.pid</pidfile> -->
+ <pidfile>/var/run/icecast/icecast.pid</pidfile>
<!-- Aliases: treat requests for 'source' path as being for 'dest' path
May be made specific to a port or bound address using the "port"
@@ -142,10 +142,10 @@
<security>
<chroot>0</chroot>
- <!--
+ <!-- Changing user will break logrotate support ( cannot create pid file )
<changeowner>
- <user>nobody</user>
- <group>nogroup</group>
+ <user>icecast</user>
+ <group>icecast</group>
</changeowner>
-->
</security>

8
icecast.logrotate Normal file
View File

@ -0,0 +1,8 @@
/var/log/icecast/*.log {
weekly
notifempty
missingok
postrotate
/bin/kill -HUP `/bin/cat /var/run/icecast/icecast.pid`
endscript
}

116
icecast.spec Normal file
View File

@ -0,0 +1,116 @@
Name: icecast
Version: 2.3.3
Release: 1mamba
Summary: Xiph Streaming media server that supports multiple audio formats.
Group: System/Servers
Vendor: openmamba
Distribution: openmamba
Packager: Automatic Build System <autodist@mambasoft.it>
URL: http://www.icecast.org/
Source0: http://downloads.xiph.org/releases/icecast/icecast-%{version}.tar.gz
Source1: %{name}.init.tar.bz2
Source2: %{name}.logrotate
Patch0: %{name}.conf.patch
Patch1: %{name}-curl.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libcares-devel
BuildRequires: libcurl-devel
BuildRequires: libe2fs-devel
BuildRequires: libgcrypt-devel
BuildRequires: libgpg-error-devel
BuildRequires: libidn-devel
BuildRequires: libkrb5-devel
BuildRequires: libogg-devel
BuildRequires: libopenldap-devel
BuildRequires: libopenssl-devel
BuildRequires: libsasl-devel
BuildRequires: libspeex-devel
BuildRequires: libssh2-devel
BuildRequires: libtheora-devel
BuildRequires: libvorbis-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Icecast is an Internet based broadcasting system based on the Mpeg Layer III streaming technology. It was originally inspired by Nullsoft's Shoutcast and also mp3serv by Scott Manley. The icecast project was started for several reasons: a) all broadcasting systems were pretty much closed source, non-free software implementations, b) Shoutcast doesn't allow you to run your own directory servers, or support them, and c) we thought it would be a lot of fun.
%prep
%setup -q
%patch0
#%patch1 -p1
tar jxvf %{S:1} > %{name}
%build
./autogen.sh || :
%configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir}/icecast2
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
rm -rf %{buildroot}%{_docdir}/%{name}
install -d -m 755 %{buildroot}%{_var}/log/%{name}
install -d -m 755 %{buildroot}%{_initrddir}
install -m 755 %{name} %{buildroot}%{_initrddir}
#
# logrotate
install -d %{buildroot}%{_sysconfdir}/logrotate.d/
install -m 0644 %{S:2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
# to hold pid file ( need to be writable by icecast )
mkdir -p %{buildroot}%{_var}/run/%{name}/
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%dir %{_sysconfdir}/icecast2
%{_bindir}/icecast
%dir %{_datadir}/icecast
%dir %{_datadir}/icecast/admin
%{_datadir}/icecast/admin/listclients.xsl
%{_datadir}/icecast/admin/listmounts.xsl
%{_datadir}/icecast/admin/manageauth.xsl
%{_datadir}/icecast/admin/moveclients.xsl
%{_datadir}/icecast/admin/response.xsl
%{_datadir}/icecast/admin/stats.xsl
%{_datadir}/icecast/admin/updatemetadata.xsl
%{_datadir}/icecast/admin/vclt.xsl
%{_datadir}/icecast/admin/xspf.xsl
%dir %{_datadir}/icecast/web
%{_datadir}/icecast/web/auth.xsl
%{_datadir}/icecast/web/*.jpg
%{_datadir}/icecast/web/*.gif
%{_datadir}/icecast/web/server_version.xsl
%{_datadir}/icecast/web/status.xsl
%{_datadir}/icecast/web/status2.xsl
%{_datadir}/icecast/web/*.css
%{_datadir}/icecast/web/*.png
%dir %{_datadir}/icecast/doc
%{_datadir}/icecast/doc/icecast.xml.dist
%{_datadir}/icecast/doc/icecast_minimal.xml.dist
%{_datadir}/icecast/doc/icecast_shoutcast_compat.xml.dist
%{_datadir}/icecast/doc/icecast_urlauth.xml.dist
%attr(-,icecast,icecast) %{_var}/log/%{name}
%attr(-,icecast,icecast) %dir %{_var}/run/%{name}/
%config(noreplace) %{_sysconfdir}/icecast2/icecast.xml
%config(noreplace) %{_initrddir}/%{name}
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
%doc AUTHORS COPYING ChangeLog NEWS README TODO
%changelog
* Fri Jul 06 2012 Automatic Build System <autodist@mambasoft.it> 2.3.3-1mamba
- automatic version update by autodist
* Mon Apr 11 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.2-2mamba
- rebuilt with current libcares
* Sun Jul 27 2008 gil <puntogil@libero.it> 2.3.2-1mamba
- package created by autospec