fixed url and other specfile fixes and cleanups [release 2.4.4-3mamba;Wed Apr 03 2024]
This commit is contained in:
parent
db995d4111
commit
4d7dc3f86d
@ -1,10 +0,0 @@
|
|||||||
--- icecast-2.3.1/src/auth_url.c.curl 2005-11-30 13:16:17.000000000 -0500
|
|
||||||
+++ icecast-2.3.1/src/auth_url.c 2006-11-06 07:21:06.000000000 -0500
|
|
||||||
@@ -518,7 +518,6 @@
|
|
||||||
curl_easy_setopt (url_info->handle, CURLOPT_WRITEDATA, url_info->handle);
|
|
||||||
curl_easy_setopt (url_info->handle, CURLOPT_NOSIGNAL, 1L);
|
|
||||||
curl_easy_setopt (url_info->handle, CURLOPT_TIMEOUT, 15L);
|
|
||||||
- curl_easy_setopt (url_info->handle, CURLOPT_PASSWDFUNCTION, my_getpass);
|
|
||||||
curl_easy_setopt (url_info->handle, CURLOPT_ERRORBUFFER, &url_info->errormsg[0]);
|
|
||||||
|
|
||||||
if (url_info->username && url_info->password)
|
|
@ -1,38 +0,0 @@
|
|||||||
--- conf/icecast.xml.in
|
|
||||||
+++ conf/icecast.xml.in 2005-05-21 02:24:39.211077978 +0200
|
|
||||||
@@ -94,7 +94,7 @@
|
|
||||||
<hidden>1</hidden>
|
|
||||||
<no-yp>1</no-yp>
|
|
||||||
<authentication type="htpasswd">
|
|
||||||
- <option name="filename" value="myauth"/>
|
|
||||||
+ <option name="filename" value="/usr/share/icecast/myauth"/>
|
|
||||||
<option name="allow_duplicate_users" value="0"/>
|
|
||||||
</authentication>
|
|
||||||
</mount>
|
|
||||||
@@ -114,10 +114,10 @@
|
|
||||||
|
|
||||||
<!-- Note that if <chroot> is turned on below, these paths must both
|
|
||||||
be relative to the new root, not the original root -->
|
|
||||||
- <logdir>@localstatedir@/log/@PACKAGE@</logdir>
|
|
||||||
+ <logdir>/var/log/icecast</logdir>
|
|
||||||
<webroot>@pkgdatadir@/web</webroot>
|
|
||||||
<adminroot>@pkgdatadir@/admin</adminroot>
|
|
||||||
- <!-- <pidfile>@pkgdatadir@/icecast.pid</pidfile> -->
|
|
||||||
+ <pidfile>/var/run/icecast/icecast.pid</pidfile>
|
|
||||||
|
|
||||||
<!-- Aliases: treat requests for 'source' path as being for 'dest' path
|
|
||||||
May be made specific to a port or bound address using the "port"
|
|
||||||
@@ -142,10 +142,10 @@
|
|
||||||
|
|
||||||
<security>
|
|
||||||
<chroot>0</chroot>
|
|
||||||
- <!--
|
|
||||||
+ <!-- Changing user will break logrotate support ( cannot create pid file )
|
|
||||||
<changeowner>
|
|
||||||
- <user>nobody</user>
|
|
||||||
- <group>nogroup</group>
|
|
||||||
+ <user>icecast</user>
|
|
||||||
+ <group>icecast</group>
|
|
||||||
</changeowner>
|
|
||||||
-->
|
|
||||||
</security>
|
|
35
icecast.spec
35
icecast.spec
@ -1,43 +1,30 @@
|
|||||||
Name: icecast
|
Name: icecast
|
||||||
Version: 2.4.4
|
Version: 2.4.4
|
||||||
Release: 2mamba
|
Release: 3mamba
|
||||||
Summary: Xiph Streaming media server that supports multiple audio formats.
|
Summary: Xiph Streaming media server that supports multiple audio formats
|
||||||
Group: System/Servers
|
Group: System/Servers
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Automatic Build System <autodist@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.icecast.org/
|
URL: https://www.icecast.org/
|
||||||
Source0: http://downloads.xiph.org/releases/icecast/icecast-%{version}.tar.gz
|
Source0: https://ftp.osuosl.org/pub/xiph/releases/icecast/icecast-%{version}.tar.gz
|
||||||
Source1: %{name}.init.tar.bz2
|
Source2: icecast.logrotate
|
||||||
Source2: %{name}.logrotate
|
|
||||||
Source3: icecast.service
|
Source3: icecast.service
|
||||||
Source4: icecast.sysusers
|
Source4: icecast.sysusers
|
||||||
Source5: icecast.tmpfiles
|
Source5: icecast.tmpfiles
|
||||||
Patch0: %{name}.conf.patch
|
|
||||||
Patch1: %{name}-curl.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libcares-devel
|
|
||||||
BuildRequires: libcurl-devel
|
BuildRequires: libcurl-devel
|
||||||
BuildRequires: libe2fs-devel
|
BuildRequires: libkate-devel
|
||||||
BuildRequires: libgcrypt-devel
|
|
||||||
BuildRequires: libgpg-error-devel
|
|
||||||
BuildRequires: libidn-devel
|
|
||||||
BuildRequires: libkrb5-devel
|
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
BuildRequires: libopenldap-devel
|
|
||||||
BuildRequires: libopenssl-devel
|
BuildRequires: libopenssl-devel
|
||||||
BuildRequires: libsasl-devel
|
|
||||||
BuildRequires: libspeex-devel
|
BuildRequires: libspeex-devel
|
||||||
BuildRequires: libssh2-devel
|
|
||||||
BuildRequires: libtheora-devel
|
BuildRequires: libtheora-devel
|
||||||
BuildRequires: libvorbis-devel
|
BuildRequires: libvorbis-devel
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libxslt-devel
|
BuildRequires: libxslt-devel
|
||||||
BuildRequires: libz-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Icecast is an Internet based broadcasting system based on the Mpeg Layer III streaming technology. It was originally inspired by Nullsoft's Shoutcast and also mp3serv by Scott Manley. The icecast project was started for several reasons: a) all broadcasting systems were pretty much closed source, non-free software implementations, b) Shoutcast doesn't allow you to run your own directory servers, or support them, and c) we thought it would be a lot of fun.
|
Icecast is an Internet based broadcasting system based on the Mpeg Layer III streaming technology. It was originally inspired by Nullsoft's Shoutcast and also mp3serv by Scott Manley. The icecast project was started for several reasons: a) all broadcasting systems were pretty much closed source, non-free software implementations, b) Shoutcast doesn't allow you to run your own directory servers, or support them, and c) we thought it would be a lot of fun.
|
||||||
@ -46,11 +33,6 @@ Icecast is an Internet based broadcasting system based on the Mpeg Layer III str
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0
|
|
||||||
#%patch1 -p1
|
|
||||||
#tar jxvf %{S:1} > %{name}
|
|
||||||
|
|
||||||
#./autogen.sh -fi
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -115,6 +97,9 @@ install -D -m0644 %{SOURCE5} %{buildroot}%{_tmpfilesdir}/icecast.conf
|
|||||||
#ChangeLog NEWS README TODO
|
#ChangeLog NEWS README TODO
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 03 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.4-3mamba
|
||||||
|
- fixed url and other specfile fixes and cleanups
|
||||||
|
|
||||||
* Sun Feb 28 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.4-2mamba
|
* Sun Feb 28 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.4-2mamba
|
||||||
- fixed path of icecash.xml in service file
|
- fixed path of icecash.xml in service file
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user