automatic version update by autodist [release 1.5.30-1mamba;Sun May 26 2024]
This commit is contained in:
parent
1da19e633c
commit
a191c8e526
@ -1,104 +0,0 @@
|
||||
From dd4cc5b028c35f9bb8fa9d3bdc8f26bcdfc43d40 Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Wed, 30 Sep 2020 20:35:23 +0900
|
||||
Subject: [PATCH] ui/gtk3: Fix arguments in GLib.DBusSignalCallback for Vala
|
||||
0.50
|
||||
|
||||
BUG=https://github.com/ibus/ibus/issues/2265
|
||||
---
|
||||
ui/gtk3/application.vala | 22 +++++++++++-----------
|
||||
ui/gtk3/extension.vala | 22 +++++++++++-----------
|
||||
2 files changed, 22 insertions(+), 22 deletions(-)
|
||||
|
||||
diff --git a/ui/gtk3/application.vala b/ui/gtk3/application.vala
|
||||
index cc9ee54c9..da65301b4 100644
|
||||
--- a/ui/gtk3/application.vala
|
||||
+++ b/ui/gtk3/application.vala
|
||||
@@ -3,7 +3,7 @@
|
||||
* ibus - The Input Bus
|
||||
*
|
||||
* Copyright(c) 2011 Peng Huang <shawn.p.huang@gmail.com>
|
||||
- * Copyright(c) 2017 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
+ * Copyright(c) 2017-2020 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU Lesser General Public
|
||||
@@ -69,22 +69,22 @@ class Application {
|
||||
}
|
||||
|
||||
private void bus_name_acquired_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
debug("signal_name = %s", signal_name);
|
||||
m_panel = new Panel(m_bus);
|
||||
m_panel.load_settings();
|
||||
}
|
||||
|
||||
private void bus_name_lost_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
// "Destroy" dbus method was called before this callback is called.
|
||||
// "Destroy" dbus method -> ibus_service_destroy()
|
||||
// -> g_dbus_connection_unregister_object()
|
||||
diff --git a/ui/gtk3/extension.vala b/ui/gtk3/extension.vala
|
||||
index ea3cd4647..a6f2e8e6a 100644
|
||||
--- a/ui/gtk3/extension.vala
|
||||
+++ b/ui/gtk3/extension.vala
|
||||
@@ -3,7 +3,7 @@
|
||||
* ibus - The Input Bus
|
||||
*
|
||||
* Copyright(c) 2018 Peng Huang <shawn.p.huang@gmail.com>
|
||||
- * Copyright(c) 2018 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
+ * Copyright(c) 2018-2020 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU Lesser General Public
|
||||
@@ -67,22 +67,22 @@ class ExtensionGtk : Gtk.Application {
|
||||
|
||||
|
||||
private void bus_name_acquired_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
debug("signal_name = %s", signal_name);
|
||||
m_panel = new PanelBinding(m_bus, this);
|
||||
m_panel.load_settings();
|
||||
}
|
||||
|
||||
private void bus_name_lost_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
// "Destroy" dbus method was called before this callback is called.
|
||||
// "Destroy" dbus method -> ibus_service_destroy()
|
||||
// -> g_dbus_connection_unregister_object()
|
52
ibus.spec
52
ibus.spec
@ -1,5 +1,5 @@
|
||||
Name: ibus
|
||||
Version: 1.5.29
|
||||
Version: 1.5.30
|
||||
Release: 1mamba
|
||||
Summary: Intelligent Input Bus for Linux / Unix OS
|
||||
Group: System/Servers
|
||||
@ -8,7 +8,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://code.google.com/archive/p/ibus
|
||||
Source: https://github.com/ibus/ibus.git/%{version}/ibus-%{version}.tar.bz2
|
||||
Patch0: ibus-1.5.23-vala-0.50.2.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -26,15 +25,16 @@ BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphene-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libnotify-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpython27-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: libvulkan-devel
|
||||
BuildRequires: libwayland-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libz-devel
|
||||
@ -80,12 +80,20 @@ Gtk2 bindings for %{name}.
|
||||
|
||||
%package gtk3
|
||||
Group: System/Libraries
|
||||
Summary: Gtk2 bindings for %{name}
|
||||
Summary: Gtk3 bindings for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description gtk3
|
||||
Gtk3 bindings for %{name}.
|
||||
|
||||
%package gtk4
|
||||
Group: System/Libraries
|
||||
Summary: Gtk4 bindings for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description gtk4
|
||||
Gtk4 bindings for %{name}.
|
||||
|
||||
%package wayland
|
||||
Group: System/Libraries
|
||||
Summary: Wayland bindings for %{name}
|
||||
@ -94,20 +102,13 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description wayland
|
||||
Wayland bindings for %{name}.
|
||||
|
||||
%package -n python-ibus
|
||||
Group: System/Libraries
|
||||
Summary: Python bindings for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: python-dbus
|
||||
|
||||
%description -n python-ibus
|
||||
Python bindings for %{name}.
|
||||
|
||||
%package -n python-ibus-py3
|
||||
Group: System/Libraries
|
||||
Summary: Python 3 bindings for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: python-dbus-py3
|
||||
Provides: python-ibus
|
||||
Obsoletes: python-ibus < 1.5.30
|
||||
|
||||
%description -n python-ibus-py3
|
||||
Python 3 bindings for %{name}.
|
||||
@ -136,7 +137,6 @@ This package includes the %{name} API documentation.
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
./autogen.sh
|
||||
|
||||
sed -i "s|/usr/bin/python$|%{__python3}|" engine/gensimple.py
|
||||
@ -154,9 +154,8 @@ sed -i "s|umount|: #umount|" data/dconf/make-dconf-override-db.sh
|
||||
--enable-wayland \
|
||||
--disable-memconf \
|
||||
--enable-ui \
|
||||
--with-python=%{__python3}
|
||||
|
||||
# --enable-python-library \
|
||||
--with-python=%{__python3} \
|
||||
--disable-python2
|
||||
|
||||
%make -j1
|
||||
|
||||
@ -226,12 +225,6 @@ fi
|
||||
%{_mandir}/man5/ibus.5*
|
||||
%{_mandir}/man7/ibus-emoji.7*
|
||||
|
||||
%ifnarch aarch64
|
||||
%files -n python-%{name}
|
||||
%defattr(-,root,root)
|
||||
%{python27_sitearch}/gi/overrides/*
|
||||
%endif
|
||||
|
||||
%files -n python-%{name}-py3
|
||||
%defattr(-,root,root)
|
||||
%{python3_sitearch}/gi/overrides/*
|
||||
@ -253,7 +246,11 @@ fi
|
||||
%files gtk3
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.so
|
||||
|
||||
|
||||
%files gtk4
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/gtk-4.0/4.0.0/immodules/libim-ibus.so
|
||||
|
||||
%files wayland
|
||||
%defattr(-,root,root)
|
||||
%{_libexecdir}/ibus-wayland
|
||||
@ -267,7 +264,7 @@ fi
|
||||
%{_datadir}/vala/vapi/ibus-1.0.deps
|
||||
%{_datadir}/vala/vapi/ibus-1.0.vapi
|
||||
%{_libdir}/pkgconfig/ibus-1.0.pc
|
||||
%doc ChangeLog README
|
||||
#%doc ChangeLog README
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
@ -275,6 +272,9 @@ fi
|
||||
%{_datadir}/gtk-doc/html/ibus/*
|
||||
|
||||
%changelog
|
||||
* Sun May 26 2024 Automatic Build System <autodist@openmamba.org> 1.5.30-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 17 2023 Automatic Build System <autodist@mambasoft.it> 1.5.29-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user