update to 1.5.23 [release 1.5.23-1mamba;Sun Dec 06 2020]
This commit is contained in:
parent
eec2e80074
commit
0d141b748f
104
ibus-1.5.23-vala-0.50.2.patch
Normal file
104
ibus-1.5.23-vala-0.50.2.patch
Normal file
@ -0,0 +1,104 @@
|
||||
From dd4cc5b028c35f9bb8fa9d3bdc8f26bcdfc43d40 Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Wed, 30 Sep 2020 20:35:23 +0900
|
||||
Subject: [PATCH] ui/gtk3: Fix arguments in GLib.DBusSignalCallback for Vala
|
||||
0.50
|
||||
|
||||
BUG=https://github.com/ibus/ibus/issues/2265
|
||||
---
|
||||
ui/gtk3/application.vala | 22 +++++++++++-----------
|
||||
ui/gtk3/extension.vala | 22 +++++++++++-----------
|
||||
2 files changed, 22 insertions(+), 22 deletions(-)
|
||||
|
||||
diff --git a/ui/gtk3/application.vala b/ui/gtk3/application.vala
|
||||
index cc9ee54c9..da65301b4 100644
|
||||
--- a/ui/gtk3/application.vala
|
||||
+++ b/ui/gtk3/application.vala
|
||||
@@ -3,7 +3,7 @@
|
||||
* ibus - The Input Bus
|
||||
*
|
||||
* Copyright(c) 2011 Peng Huang <shawn.p.huang@gmail.com>
|
||||
- * Copyright(c) 2017 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
+ * Copyright(c) 2017-2020 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU Lesser General Public
|
||||
@@ -69,22 +69,22 @@ class Application {
|
||||
}
|
||||
|
||||
private void bus_name_acquired_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
debug("signal_name = %s", signal_name);
|
||||
m_panel = new Panel(m_bus);
|
||||
m_panel.load_settings();
|
||||
}
|
||||
|
||||
private void bus_name_lost_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
// "Destroy" dbus method was called before this callback is called.
|
||||
// "Destroy" dbus method -> ibus_service_destroy()
|
||||
// -> g_dbus_connection_unregister_object()
|
||||
diff --git a/ui/gtk3/extension.vala b/ui/gtk3/extension.vala
|
||||
index ea3cd4647..a6f2e8e6a 100644
|
||||
--- a/ui/gtk3/extension.vala
|
||||
+++ b/ui/gtk3/extension.vala
|
||||
@@ -3,7 +3,7 @@
|
||||
* ibus - The Input Bus
|
||||
*
|
||||
* Copyright(c) 2018 Peng Huang <shawn.p.huang@gmail.com>
|
||||
- * Copyright(c) 2018 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
+ * Copyright(c) 2018-2020 Takao Fujiwara <takao.fujiwara1@gmail.com>
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU Lesser General Public
|
||||
@@ -67,22 +67,22 @@ class ExtensionGtk : Gtk.Application {
|
||||
|
||||
|
||||
private void bus_name_acquired_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
debug("signal_name = %s", signal_name);
|
||||
m_panel = new PanelBinding(m_bus, this);
|
||||
m_panel.load_settings();
|
||||
}
|
||||
|
||||
private void bus_name_lost_cb(DBusConnection connection,
|
||||
- string sender_name,
|
||||
- string object_path,
|
||||
- string interface_name,
|
||||
- string signal_name,
|
||||
- Variant parameters) {
|
||||
+ string? sender_name,
|
||||
+ string object_path,
|
||||
+ string interface_name,
|
||||
+ string signal_name,
|
||||
+ Variant parameters) {
|
||||
// "Destroy" dbus method was called before this callback is called.
|
||||
// "Destroy" dbus method -> ibus_service_destroy()
|
||||
// -> g_dbus_connection_unregister_object()
|
81
ibus.spec
81
ibus.spec
@ -1,5 +1,5 @@
|
||||
Name: ibus
|
||||
Version: 1.5.22
|
||||
Version: 1.5.23
|
||||
Release: 1mamba
|
||||
Summary: Intelligent Input Bus for Linux / Unix OS
|
||||
Group: System/Servers
|
||||
@ -8,7 +8,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://code.google.com/p/ibus/
|
||||
Source: https://github.com/ibus/ibus.git/%{version}/ibus-%{version}.tar.bz2
|
||||
#Source: http://ibus.googlecode.com/files/ibus-%{version}.tar.gz
|
||||
Patch0: ibus-1.5.23-vala-0.50.2.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -19,7 +19,7 @@ BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
@ -35,16 +35,14 @@ BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libmount-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsepol-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libwayland-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: perl-XML-Parser
|
||||
@ -52,6 +50,8 @@ BuildRequires: gnome-common
|
||||
BuildRequires: unicode-emoji
|
||||
BuildRequires: unicode-ucd
|
||||
BuildRequires: cldr-emoji-annotation
|
||||
BuildRequires: python
|
||||
BuildRequires: python3
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -66,6 +66,24 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description -n lib%{name}
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n python-ibus
|
||||
Group: System/Libraries
|
||||
Summary: Python bindings for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: python-dbus
|
||||
|
||||
%description -n python-ibus
|
||||
Python bindings for %{name}.
|
||||
|
||||
%package -n python-ibus-py3
|
||||
Group: System/Libraries
|
||||
Summary: Python 3 bindings for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: python-dbus-py3
|
||||
|
||||
%description -n python-ibus-py3
|
||||
Python 3 bindings for %{name}.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
@ -88,10 +106,23 @@ This package includes the %{name} API documentation.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
./autogen.sh
|
||||
|
||||
sed -i "s|/usr/bin/python$|%{__python3}|" engine/gensimple.py
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure --enable-gtk-doc
|
||||
%configure \
|
||||
--enable-dconf \
|
||||
--enable-gtk-doc \
|
||||
--enable-wayland \
|
||||
--disable-memconf \
|
||||
--enable-ui \
|
||||
--with-python=%{__python3}
|
||||
|
||||
# --enable-python-library \
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -103,6 +134,18 @@ This package includes the %{name} API documentation.
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
if [ $1 -ge 1 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
fi
|
||||
:
|
||||
|
||||
%postun
|
||||
if [ $1 -eq 0 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
fi
|
||||
:
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
@ -114,9 +157,6 @@ This package includes the %{name} API documentation.
|
||||
%{_bindir}/ibus
|
||||
%{_bindir}/ibus-daemon
|
||||
%{_bindir}/ibus-setup
|
||||
%{python_sitearch}/gi/overrides/IBus.py
|
||||
%{python_sitearch}/gi/overrides/IBus.pyc
|
||||
%{python_sitearch}/gi/overrides/IBus.pyo
|
||||
%{_datadir}/bash-completion/completions/ibus.bash
|
||||
%{_datadir}/gir-1.0/IBus-1.0.gir
|
||||
%dir %{_datadir}/ibus
|
||||
@ -143,6 +183,20 @@ This package includes the %{name} API documentation.
|
||||
%{_mandir}/man5/ibus.5*
|
||||
%{_mandir}/man7/ibus-emoji.7*
|
||||
|
||||
%ifnarch aarch64
|
||||
%files -n python-%{name}
|
||||
%defattr(-,root,root)
|
||||
%ifarch x86_64
|
||||
%dir %{python_sitelib}/ibus
|
||||
%{python_sitelib}/ibus/*
|
||||
%endif
|
||||
%{python_sitearch}/gi/overrides/*
|
||||
%endif
|
||||
|
||||
%files -n python-%{name}-py3
|
||||
%defattr(-,root,root)
|
||||
%{python3_sitearch}/gi/overrides/*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/gtk-2.0/2.10.0/immodules/im-ibus.la
|
||||
@ -171,6 +225,9 @@ This package includes the %{name} API documentation.
|
||||
%{_datadir}/gtk-doc/html/ibus/*
|
||||
|
||||
%changelog
|
||||
* Sun Dec 06 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.23-1mamba
|
||||
- update to 1.5.23
|
||||
|
||||
* Fri Feb 21 2020 Automatic Build System <autodist@mambasoft.it> 1.5.22-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user