package created using the webbuild interface [release 4.3-1mamba;Sat May 25 2024]
This commit is contained in:
parent
6034dc3f7c
commit
08cbb3781a
33
hypnotix-4.3-mpv-0.38.0.patch
Normal file
33
hypnotix-4.3-mpv-0.38.0.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 37187015ad0ea8966113bdbf10a9dc2d677c3539 Mon Sep 17 00:00:00 2001
|
||||
From: Ame-chan-angel <amechanangel@proton.me>
|
||||
Date: Sun, 21 Apr 2024 23:06:49 +0000
|
||||
Subject: [PATCH] Fix loadfile for mpv v0.38.0
|
||||
|
||||
---
|
||||
usr/lib/hypnotix/mpv.py | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/usr/lib/hypnotix/mpv.py b/usr/lib/hypnotix/mpv.py
|
||||
index 465b3f2..4817a13 100644
|
||||
--- a/usr/lib/hypnotix/mpv.py
|
||||
+++ b/usr/lib/hypnotix/mpv.py
|
||||
@@ -526,6 +526,7 @@ def _mpv_client_api_version():
|
||||
_mpv_create = backend.mpv_create
|
||||
|
||||
_API_VER = _mpv_client_api_version()[0]
|
||||
+_USE_LOADFILE_INDEX = _mpv_client_api_version() >= (2, 3) # libmpv 0.38.0
|
||||
|
||||
_handle_func('mpv_destroy' if _API_VER > 1 else 'mpv_detach_destroy', [], None, errcheck=None)
|
||||
_handle_func('mpv_create_client', [c_char_p], MpvHandle, notnull_errcheck)
|
||||
@@ -1148,7 +1149,10 @@ def _encode_options(options):
|
||||
|
||||
def loadfile(self, filename, mode='replace', **options):
|
||||
"""Mapped mpv loadfile command, see man mpv(1)."""
|
||||
- self.command('loadfile', filename.encode(fs_enc), mode, MPV._encode_options(options))
|
||||
+ if _USE_LOADFILE_INDEX:
|
||||
+ self.command('loadfile', filename.encode(fs_enc), mode, -1, MPV._encode_options(options))
|
||||
+ else:
|
||||
+ self.command('loadfile', filename.encode(fs_enc), mode, MPV._encode_options(options))
|
||||
|
||||
def loadlist(self, playlist, mode='replace'):
|
||||
"""Mapped mpv loadlist command, see man mpv(1)."""
|
72
hypnotix.spec
Normal file
72
hypnotix.spec
Normal file
@ -0,0 +1,72 @@
|
||||
Name: hypnotix
|
||||
Version: 4.3
|
||||
Release: 1mamba
|
||||
Summary: An M3U IPTV Player
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/linuxmint/hypnotix
|
||||
Source: https://github.com/linuxmint/hypnotix.git/%{version}/hypnotix-%{version}.tar.bz2
|
||||
Patch0: hypnotix-4.3-mpv-0.38.0.patch
|
||||
License: GPL-3.0-only
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: circle-flags
|
||||
Requires: dconf
|
||||
Requires: hicolor-icon-theme
|
||||
Requires: mpv
|
||||
Requires: pycairo-py3
|
||||
Requires: pygobject-py3
|
||||
Requires: python-cinemagoer-py3
|
||||
Requires: python-requests-py3
|
||||
Requires: python-setproctitle-py3
|
||||
Requires: python-unidecode-py3
|
||||
Requires: xapp
|
||||
|
||||
%description
|
||||
An M3U IPTV Player.
|
||||
|
||||
#% debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .mpv-0.38.0
|
||||
|
||||
# Set version in About dialog
|
||||
sed -i "s/__DEB_VERSION__/%{version}/g" usr/lib/hypnotix/hypnotix.py
|
||||
|
||||
# Fix license path
|
||||
sed -i 's|common-licenses/GPL|licenses/common/GPL/license.txt|g' \
|
||||
usr/lib/hypnotix/hypnotix.py
|
||||
|
||||
%build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
install -d -m0755 %{buildroot}
|
||||
cp -a usr %{buildroot}
|
||||
|
||||
%find_lang %{name} || touch %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/hypnotix
|
||||
%dir %{_prefix}/lib/hypnotix
|
||||
%{_prefix}/lib/hypnotix/*.py
|
||||
%{_prefix}/lib/hypnotix/mpv.py.mpv-*
|
||||
%{_datadir}/applications/hypnotix.desktop
|
||||
%{_datadir}/glib-2.0/schemas/org.x.hypnotix.gschema.xml
|
||||
%dir %{_datadir}/hypnotix
|
||||
%{_datadir}/hypnotix/*
|
||||
%{_datadir}/icons/hicolor/scalable/apps/hypnotix.svg
|
||||
%doc debian/copyright
|
||||
|
||||
%changelog
|
||||
* Sat May 25 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user