update to 2020.0.0 [release 2020.0.0-1mamba;Sun Jun 27 2021]
This commit is contained in:
parent
fe00596aef
commit
3f8598234e
28
hugin-2020.0.0-openexr-3.0.4.patch
Normal file
28
hugin-2020.0.0-openexr-3.0.4.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -ru hugin-2020.0.0.orig/CMakeModules/FindOpenEXR.cmake hugin-2020.0.0/CMakeModules/FindOpenEXR.cmake
|
||||
--- hugin-2020.0.0.orig/CMakeModules/FindOpenEXR.cmake 2021-04-24 13:32:14.405277312 +0200
|
||||
+++ hugin-2020.0.0/CMakeModules/FindOpenEXR.cmake 2021-04-24 19:14:40.144215012 +0200
|
||||
@@ -10,6 +10,12 @@
|
||||
# Redistribution and use is allowed according to the terms of the BSD license.
|
||||
# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
|
||||
|
||||
+FIND_PACKAGE(OpenEXR CONFIG REQUIRED)
|
||||
+IF (TARGET OpenEXR::OpenEXR)
|
||||
+ SET(OPENEXR_FOUND TRUE)
|
||||
+ SET(OPENEXR_INCLUDE_DIR OpenEXR::OpenEXR)
|
||||
+ SET(OPENEXR_LIBRARIES OpenEXR::OpenEXR)
|
||||
+ENDIF()
|
||||
|
||||
if (OPENEXR_INCLUDE_DIR AND OPENEXR_LIBRARIES)
|
||||
# in cache already
|
||||
diff -ru hugin-2020.0.0.orig/CMakeModules/FindVIGRA.cmake hugin-2020.0.0/CMakeModules/FindVIGRA.cmake
|
||||
--- hugin-2020.0.0.orig/CMakeModules/FindVIGRA.cmake 2021-04-24 13:32:14.405277312 +0200
|
||||
+++ hugin-2020.0.0/CMakeModules/FindVIGRA.cmake 2021-04-24 18:54:50.461698528 +0200
|
||||
@@ -74,7 +74,7 @@
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE
|
||||
)
|
||||
STRING(TOLOWER "${OUTPUT_LDD_VIGRA}" OUTPUT_LDD_VIGRA_LOWER)
|
||||
- IF(NOT "${OUTPUT_LDD_VIGRA_LOWER}" MATCHES "libilmimf")
|
||||
+ IF(NOT "${OUTPUT_LDD_VIGRA_LOWER}" MATCHES "libopenexr")
|
||||
MESSAGE(FATAL_ERROR "Libvigraimpex found. But vigraimpex seems to compiled without OpenEXR support. OpenEXR support is required for Hugin.")
|
||||
ENDIF()
|
||||
ELSE()
|
101
hugin.spec
101
hugin.spec
@ -1,66 +1,66 @@
|
||||
%define majorver %(echo "%{version}" | sed "s,\..$,,")
|
||||
|
||||
Name: hugin
|
||||
Version: 2018.0.0
|
||||
Version: 2020.0.0
|
||||
Release: 1mamba
|
||||
Summary: A panoramic photo stitcher
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://hugin.sourceforge.net
|
||||
Source: http://downloads.sourceforge.net/project/hugin/hugin/hugin-%{majorver}/hugin-%{version}.tar.bz2
|
||||
Source: https://sourceforge.net/projects/hugin/files/hugin/hugin-%{majorver}/hugin-%{version}.tar.bz2
|
||||
Patch0: %{name}-2010.0.0-libpng14.patch
|
||||
Patch1: hugin-2011.4.0-gcc-4.7.patch
|
||||
Patch2: hugin-2014.0.0-liblensfun-0.3.0.patch
|
||||
Patch3: hugin-2014.0.0-libboost-1.57.patch
|
||||
Patch4: hugin-2014.0.0-libboost-1.57-2.patch
|
||||
Patch5: hugin-2020.0.0-openexr-3.0.4.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libexiv2-devel
|
||||
BuildRequires: libfreeglut-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglew-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libilmbase-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libgomp-devel
|
||||
BuildRequires: libimath-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblcms2-devel
|
||||
BuildRequires: libopenexr-devel
|
||||
BuildRequires: libpano13-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libwxBase-unicode-devel
|
||||
BuildRequires: libwxGTK-unicode-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libvigra-devel
|
||||
BuildRequires: libwx_baseu30-devel
|
||||
BuildRequires: libwx_gtk3u30-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libvigra-devel >= 1.11.1-2mamba
|
||||
BuildRequires: liblensfun-devel >= 0.3.2-1mamba
|
||||
BuildRequires: libpano13-devel >= 2.9.19-1mamba
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libtclap-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
# FIXME:
|
||||
# 3. DEPENDENCIES
|
||||
# The following external programs are highly recommended:
|
||||
# 1. autopano-sift-C, panomatic, autopano or autopano-sift
|
||||
|
||||
%description
|
||||
A powerful software package for creation and processing of panoramic images.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
rm CMakeModules/FindZLIB.cmake # Doesn't define the ZLIB::ZLIB target needed by OpenEXR 3
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
@ -79,7 +79,7 @@ A powerful software package for creation and processing of panoramic images.
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
update-desktop-database &>/dev/null
|
||||
update-mime-database %{_datadir}/mime &>/dev/null
|
||||
update-mime-database -n %{_datadir}/mime &>/dev/null
|
||||
touch --no-create %{_datadir}/icons/gnome
|
||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/gnome
|
||||
exit 0
|
||||
@ -87,7 +87,7 @@ exit 0
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
update-desktop-database &>/dev/null
|
||||
update-mime-database %{_datadir}/mime &>/dev/null
|
||||
update-mime-database -n %{_datadir}/mime &>/dev/null
|
||||
touch --no-create %{_datadir}/icons/gnome
|
||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/gnome
|
||||
exit 0
|
||||
@ -96,7 +96,6 @@ exit 0
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/align_image_stack
|
||||
%{_bindir}/autooptimiser
|
||||
#%{_bindir}/autopano-noop.sh
|
||||
%{_bindir}/calibrate_lens_gui
|
||||
%{_bindir}/celeste_standalone
|
||||
%{_bindir}/checkpto
|
||||
@ -108,23 +107,10 @@ exit 0
|
||||
%{_bindir}/deghosting_mask
|
||||
%{_bindir}/fulla
|
||||
%{_bindir}/hugin
|
||||
%{_bindir}/hugin_hdrmerge
|
||||
%{_bindir}/hugin_stacker
|
||||
%{_bindir}/hugin_stitch_project
|
||||
#%{_bindir}/matchpoint
|
||||
%{_bindir}/hugin_*
|
||||
%{_bindir}/nona
|
||||
#%{_bindir}/nona_gui
|
||||
%{_bindir}/pano_modify
|
||||
%{_bindir}/pano_trafo
|
||||
%{_bindir}/pto_gen
|
||||
%{_bindir}/pto_mask
|
||||
%{_bindir}/pto_merge
|
||||
%{_bindir}/pto_move
|
||||
%{_bindir}/pto_template
|
||||
#%{_bindir}/pto2mk
|
||||
%{_bindir}/pto_lensstack
|
||||
%{_bindir}/pto_var
|
||||
#%{_bindir}/PTBatcher
|
||||
%{_bindir}/pano_*
|
||||
%{_bindir}/pto_*
|
||||
%{_bindir}/PTBatcherGUI
|
||||
%{_bindir}/tca_correct
|
||||
%{_bindir}/vig_optimize
|
||||
@ -133,30 +119,25 @@ exit 0
|
||||
%{_bindir}/verdandi
|
||||
%dir %{_libdir}/hugin
|
||||
%{_libdir}/hugin/libceleste*
|
||||
#%{_libdir}/hugin/libflann_cpp.so.0.0
|
||||
%{_libdir}/hugin/libhugin*
|
||||
%{_libdir}/hugin/libicpfindlib.so.*
|
||||
%{_libdir}/hugin/liblocalfeatures.so.*
|
||||
#%{_libdir}/hugin/libmakefilelib.so.0.0
|
||||
%dir %{_datadir}/%{name}
|
||||
#%{_datadir}/%{name}/Makefile.*.mk
|
||||
#%{_datadir}/%{name}/data/celeste.model
|
||||
%{_datadir}/%{name}/xrc
|
||||
%dir %{_datadir}/hugin/data
|
||||
%{_datadir}/hugin/data/*
|
||||
%{_datadir}/appdata/*.xml
|
||||
%{_datadir}/metainfo/*.xml
|
||||
%{_datadir}/applications/pto_gen.desktop
|
||||
%{_datadir}/applications/PTBatcherGUI.desktop
|
||||
%{_datadir}/applications/calibrate_lens_gui.desktop
|
||||
%{_datadir}/applications/hugin.desktop
|
||||
%{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
|
||||
%{_datadir}/mime/packages/hugin.xml
|
||||
%{_datadir}/pixmaps/hugin.png
|
||||
%{_datadir}/pixmaps/ptbatcher.png
|
||||
%{_datadir}/icons/hicolor/*/apps/*.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/*.svg
|
||||
%{_datadir}/icons/gnome/48x48/mimetypes/application-x-ptoptimizer-script.png
|
||||
#%{python_sitearch}/_hsi.so
|
||||
#%{python_sitearch}/hpi.py
|
||||
#%{python_sitearch}/hsi.py
|
||||
#%{_mandir}/man1/autopano-noop.sh.1*
|
||||
%{_mandir}/man1/calibrate_lens_gui.1*
|
||||
%{_mandir}/man1/checkpto.1*
|
||||
%{_mandir}/man1/cpfind.1*
|
||||
@ -168,34 +149,24 @@ exit 0
|
||||
%{_mandir}/man1/deghosting_mask.1*
|
||||
%{_mandir}/man1/fulla.1*
|
||||
%{_mandir}/man1/hugin.1*
|
||||
%{_mandir}/man1/hugin_hdrmerge.1*
|
||||
%{_mandir}/man1/hugin_stitch_project.1*
|
||||
%{_mandir}/man1/hugin_*.1*
|
||||
%{_mandir}/man1/icpfind.1*
|
||||
%{_mandir}/man1/linefind.1*
|
||||
#%{_mandir}/man1/matchpoint.1*
|
||||
%{_mandir}/man1/pto_gen.1*
|
||||
%{_mandir}/man1/pto_lensstack.1*
|
||||
%{_mandir}/man1/pto_mask.1*
|
||||
%{_mandir}/man1/pto_move.1*
|
||||
%{_mandir}/man1/pto_template.1*
|
||||
%{_mandir}/man1/pto_var.1*
|
||||
#%{_mandir}/man1/PTBatcher.1*
|
||||
%{_mandir}/man1/pto_*.1*
|
||||
%{_mandir}/man1/PTBatcherGUI.1*
|
||||
%{_mandir}/man1/nona.1*
|
||||
#%{_mandir}/man1/nona_gui.1*
|
||||
%{_mandir}/man1/pano_modify.1*
|
||||
%{_mandir}/man1/pano_trafo.1*
|
||||
%{_mandir}/man1/pto_merge.1*
|
||||
#%{_mandir}/man1/pto2mk.1*
|
||||
%{_mandir}/man1/tca_correct.1*
|
||||
%{_mandir}/man1/vig_optimize.1*
|
||||
%{_mandir}/man1/hugin_executor.1.gz
|
||||
%{_mandir}/man1/hugin_lensdb.1.gz
|
||||
%{_mandir}/man1/verdandi.1.gz
|
||||
%{_mandir}/man1/verdandi.1*
|
||||
%doc AUTHORS
|
||||
#ChangeLog README README_JP TODO
|
||||
|
||||
%changelog
|
||||
* Sun Jun 27 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2020.0.0-1mamba
|
||||
- update to 2020.0.0
|
||||
|
||||
* Mon Feb 12 2018 Automatic Build System <autodist@mambasoft.it> 2018.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user