update to 2014.0.0 [release 2014.0.0-1mamba;Thu Feb 05 2015]
This commit is contained in:
parent
5be3e8ef6a
commit
2a4287912d
10
hugin-2014.0.0-libboost-1.57-2.patch
Normal file
10
hugin-2014.0.0-libboost-1.57-2.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- hugin-2014.0.0/src/hugin1/hugin/TextureManager.h.orig 2015-02-05 16:50:30.315039553 +0100
|
||||
+++ hugin-2014.0.0/src/hugin1/hugin/TextureManager.h 2015-02-05 16:52:15.609915821 +0100
|
||||
@@ -42,6 +42,7 @@
|
||||
#include <map>
|
||||
#include <boost/version.hpp>
|
||||
#if BOOST_VERSION>=105400
|
||||
+#include <boost/weak_ptr.hpp>
|
||||
#include <boost/signals2/trackable.hpp>
|
||||
namespace boostSignal=boost::signals2;
|
||||
#else
|
81
hugin-2014.0.0-libboost-1.57.patch
Normal file
81
hugin-2014.0.0-libboost-1.57.patch
Normal file
@ -0,0 +1,81 @@
|
||||
--- hugin-2013.0.0.old/src/tools/ParseExp.cpp 2013-10-27 10:19:02.000000000 +0100
|
||||
+++ hugin-2013.0.0/src/tools/ParseExp.cpp 2014-09-12 01:41:15.468973470 +0200
|
||||
@@ -50,37 +50,45 @@
|
||||
//power function
|
||||
struct lazy_pow_
|
||||
{
|
||||
- template <typename X, typename Y>
|
||||
- struct result { typedef X type; };
|
||||
+ template<class> struct result;
|
||||
+
|
||||
+ template <typename F, typename X, typename Y>
|
||||
+ struct result<F(X,Y)> { typedef X& type; };
|
||||
|
||||
template <typename X, typename Y>
|
||||
- X operator()(X x, Y y) const
|
||||
+ X& operator()(X& x, Y y) const
|
||||
{
|
||||
- return std::pow(x, y);
|
||||
+ x= std::pow(x, y);
|
||||
+ return x;
|
||||
}
|
||||
};
|
||||
|
||||
// modulus for double values
|
||||
struct lazy_mod_
|
||||
{
|
||||
- template <typename X, typename Y>
|
||||
- struct result { typedef X type; };
|
||||
+ template<class> struct result;
|
||||
+
|
||||
+ template <typename F, typename X, typename Y>
|
||||
+ struct result<F(X,Y)> { typedef X& type; };
|
||||
|
||||
template <typename X, typename Y>
|
||||
- X operator()(X x, Y y) const
|
||||
+ X& operator()(X& x, Y y) const
|
||||
{
|
||||
- return std::fmod(x,y);
|
||||
+ x= std::fmod(x,y);
|
||||
+ return x;
|
||||
}
|
||||
};
|
||||
|
||||
// if statement
|
||||
struct lazy_if_
|
||||
{
|
||||
- template <typename X, typename Y, typename Z>
|
||||
- struct result { typedef Y type; };
|
||||
+ template<class> struct result;
|
||||
|
||||
- template <typename X, typename Y, typename Z>
|
||||
- X operator()(X x, Y y, Z z) const
|
||||
+ template <typename F, typename X, typename Y>
|
||||
+ struct result<F(X,Y,Y)> { typedef Y& type; };
|
||||
+
|
||||
+ template <typename X, typename Y>
|
||||
+ Y& operator()(X x, Y& y, Y& z) const
|
||||
{
|
||||
return x ? y : z;
|
||||
}
|
||||
@@ -89,13 +97,16 @@
|
||||
// wrapper for unary function
|
||||
struct lazy_ufunc_
|
||||
{
|
||||
- template <typename F, typename A1>
|
||||
- struct result { typedef A1 type; };
|
||||
+ template<class> struct result;
|
||||
+
|
||||
+ template<typename F, typename F1, typename A1>
|
||||
+ struct result<F(F1,A1)> { typedef A1& type; };
|
||||
|
||||
template <typename F, typename A1>
|
||||
- A1 operator()(F f, A1 a1) const
|
||||
+ A1& operator()(F f, A1& a1) const
|
||||
{
|
||||
- return f(a1);
|
||||
+ a1= f(a1);
|
||||
+ return a1;
|
||||
}
|
||||
};
|
||||
|
19
hugin-2014.0.0-liblensfun-0.3.0.patch
Normal file
19
hugin-2014.0.0-liblensfun-0.3.0.patch
Normal file
@ -0,0 +1,19 @@
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=524700
|
||||
|
||||
diff -Naur hugin-2014.0.0.orig/src/hugin_base/lensdb/LensDB.cpp
|
||||
hugin-2014.0.0/src/hugin_base/lensdb/LensDB.cpp
|
||||
--- hugin-2014.0.0.orig/src/hugin_base/lensdb/LensDB.cpp 2014-04-27
|
||||
08:26:57.000000000 +0200
|
||||
+++ hugin-2014.0.0/src/hugin_base/lensdb/LensDB.cpp 2014-10-08
|
||||
10:44:29.445076647 +0200
|
||||
@@ -620,7 +620,9 @@
|
||||
break;
|
||||
case LF_DIST_MODEL_NONE:
|
||||
case LF_DIST_MODEL_POLY5:
|
||||
+#ifdef LF_DIST_MODEL_FOV1
|
||||
case LF_DIST_MODEL_FOV1:
|
||||
+#endif
|
||||
default:
|
||||
return false;
|
||||
break;
|
||||
|
44
hugin.spec
44
hugin.spec
@ -1,8 +1,8 @@
|
||||
%define majorver %(echo "%{version}" | sed "s,\..$,,")
|
||||
|
||||
Name: hugin
|
||||
Version: 2013.0.0
|
||||
Release: 2mamba
|
||||
Version: 2014.0.0
|
||||
Release: 1mamba
|
||||
Summary: A panoramic photo stitcher
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -12,6 +12,9 @@ URL: http://hugin.sourceforge.net
|
||||
Source: http://downloads.sourceforge.net/project/hugin/hugin/hugin-%{majorver}/hugin-%{version}.tar.bz2
|
||||
Patch0: %{name}-2010.0.0-libpng14.patch
|
||||
Patch1: hugin-2011.4.0-gcc-4.7.patch
|
||||
Patch2: hugin-2014.0.0-liblensfun-0.3.0.patch
|
||||
Patch3: hugin-2014.0.0-libboost-1.57.patch
|
||||
Patch4: hugin-2014.0.0-libboost-1.57-2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -39,8 +42,8 @@ BuildRequires: libXi-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libpano13-devel >= 2.9.19-1mamba
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libpano13-devel >= 2.9.18
|
||||
BuildRequires: libtclap-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -54,10 +57,13 @@ A powerful software package for creation and processing of panoramic images.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -89,7 +95,7 @@ exit 0
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/align_image_stack
|
||||
%{_bindir}/autooptimiser
|
||||
%{_bindir}/autopano-noop.sh
|
||||
#%{_bindir}/autopano-noop.sh
|
||||
%{_bindir}/calibrate_lens_gui
|
||||
%{_bindir}/celeste_standalone
|
||||
%{_bindir}/checkpto
|
||||
@ -103,17 +109,20 @@ exit 0
|
||||
%{_bindir}/hugin
|
||||
%{_bindir}/hugin_hdrmerge
|
||||
%{_bindir}/hugin_stitch_project
|
||||
%{_bindir}/matchpoint
|
||||
#%{_bindir}/matchpoint
|
||||
%{_bindir}/nona
|
||||
%{_bindir}/nona_gui
|
||||
#%{_bindir}/nona_gui
|
||||
%{_bindir}/pano_modify
|
||||
%{_bindir}/pano_trafo
|
||||
%{_bindir}/pto_gen
|
||||
%{_bindir}/pto_mask
|
||||
%{_bindir}/pto_merge
|
||||
%{_bindir}/pto_move
|
||||
%{_bindir}/pto_template
|
||||
%{_bindir}/pto2mk
|
||||
%{_bindir}/pto_lensstack
|
||||
%{_bindir}/pto_var
|
||||
%{_bindir}/PTBatcher
|
||||
#%{_bindir}/PTBatcher
|
||||
%{_bindir}/PTBatcherGUI
|
||||
%{_bindir}/tca_correct
|
||||
%{_bindir}/vig_optimize
|
||||
@ -130,6 +139,8 @@ exit 0
|
||||
%{_datadir}/%{name}/xrc
|
||||
%dir %{_datadir}/hugin/data
|
||||
%{_datadir}/hugin/data/*
|
||||
%{_datadir}/appdata/*.xml
|
||||
%{_datadir}/appdata/hugin.appdata.xml
|
||||
%{_datadir}/applications/pto_gen.desktop
|
||||
%{_datadir}/applications/PTBatcherGUI.desktop
|
||||
%{_datadir}/applications/calibrate_lens_gui.desktop
|
||||
@ -141,7 +152,7 @@ exit 0
|
||||
%{python_sitearch}/_hsi.so
|
||||
%{python_sitearch}/hpi.py
|
||||
%{python_sitearch}/hsi.py
|
||||
%{_mandir}/man1/autopano-noop.sh.1*
|
||||
#%{_mandir}/man1/autopano-noop.sh.1*
|
||||
%{_mandir}/man1/calibrate_lens_gui.1*
|
||||
%{_mandir}/man1/checkpto.1*
|
||||
%{_mandir}/man1/cpfind.1*
|
||||
@ -157,14 +168,17 @@ exit 0
|
||||
%{_mandir}/man1/hugin_stitch_project.1*
|
||||
%{_mandir}/man1/icpfind.1*
|
||||
%{_mandir}/man1/linefind.1*
|
||||
%{_mandir}/man1/matchpoint.1*
|
||||
#%{_mandir}/man1/matchpoint.1*
|
||||
%{_mandir}/man1/pto_gen.1*
|
||||
%{_mandir}/man1/pto_lensstack.1*
|
||||
%{_mandir}/man1/pto_mask.1*
|
||||
%{_mandir}/man1/pto_move.1*
|
||||
%{_mandir}/man1/pto_template.1*
|
||||
%{_mandir}/man1/pto_var.1*
|
||||
%{_mandir}/man1/PTBatcher.1*
|
||||
#%{_mandir}/man1/PTBatcher.1*
|
||||
%{_mandir}/man1/PTBatcherGUI.1*
|
||||
%{_mandir}/man1/nona.1*
|
||||
%{_mandir}/man1/nona_gui.1*
|
||||
#%{_mandir}/man1/nona_gui.1*
|
||||
%{_mandir}/man1/pano_modify.1*
|
||||
%{_mandir}/man1/pano_trafo.1*
|
||||
%{_mandir}/man1/pto_merge.1*
|
||||
@ -175,6 +189,12 @@ exit 0
|
||||
#ChangeLog README README_JP TODO
|
||||
|
||||
%changelog
|
||||
* Thu Feb 05 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2014.0.0-1mamba
|
||||
- update to 2014.0.0
|
||||
|
||||
* Thu Feb 05 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2013.0.0-3mamba
|
||||
- rebuilt by autoport with build requirements: libpano13-devel>=2.9.19-1mamba--buildreqlibpano13-devel>=2.9.19-1mamba
|
||||
|
||||
* Mon Mar 31 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2013.0.0-2mamba
|
||||
- rebuilt with openexr 2.1.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user