added a patch to remove closed source libImageProcessor and fix build on arm [release 3.19.6-3mamba;Sun Jul 21 2019]
This commit is contained in:
parent
c7bcc4e0f9
commit
bab4361a69
10
hplip-3.18.12-openmamba-AUTH_TYPES-warning.patch
Normal file
10
hplip-3.18.12-openmamba-AUTH_TYPES-warning.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- hplip-3.18.12/base/password.py.orig 2018-12-03 08:07:04.000000000 +0100
|
||||
+++ hplip-3.18.12/base/password.py 2019-01-28 06:15:36.455652572 +0100
|
||||
@@ -52,6 +52,7 @@
|
||||
'centos': 'su',
|
||||
'igos': 'su',
|
||||
'linuxmint': 'sudo',
|
||||
+ 'openmamba': 'sudo',
|
||||
'linpus': 'sudo',
|
||||
'gos': 'sudo',
|
||||
'boss': 'su',
|
@ -1,18 +0,0 @@
|
||||
--- hplip-3.18.3/base/password.py.orig 2018-03-21 19:04:43.925064585 +0100
|
||||
+++ hplip-3.18.3/base/password.py 2018-03-21 20:26:10.309174831 +0100
|
||||
@@ -37,6 +37,7 @@
|
||||
'suse': 'su',
|
||||
'mandriva': 'su',
|
||||
'fedora': 'su',
|
||||
+ 'openmamba': 'su',
|
||||
'redhat': 'su',
|
||||
'rhel': 'su',
|
||||
'slackware': 'su',
|
||||
@@ -51,6 +52,7 @@
|
||||
'centos': 'su',
|
||||
'igos': 'su',
|
||||
'linuxmint': 'sudo',
|
||||
+ 'openmamba': 'sudo',
|
||||
'linpus': 'sudo',
|
||||
'gos': 'sudo',
|
||||
'boss': 'su',
|
93
hplip-3.19.3-Makefile-missing-DESTDIR.patch
Normal file
93
hplip-3.19.3-Makefile-missing-DESTDIR.patch
Normal file
@ -0,0 +1,93 @@
|
||||
--- hplip-3.19.3/Makefile.am.orig 2019-05-05 15:19:04.022430433 +0200
|
||||
+++ hplip-3.19.3/Makefile.am 2019-05-05 15:20:06.893397649 +0200
|
||||
@@ -684,15 +684,15 @@
|
||||
|
||||
install-data-hook:
|
||||
if HPLIP_BUILD
|
||||
- if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
|
||||
- cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
|
||||
- chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
|
||||
- ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
|
||||
+ if [ \( "$(UNAME)" = "x86_64" -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
|
||||
+ cp prnt/hpcups/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/ ; \
|
||||
+ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_64.so ; \
|
||||
+ ln -sf $(libdir)/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
|
||||
fi; \
|
||||
- if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
|
||||
- cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
|
||||
- chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
|
||||
- ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
|
||||
+ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
|
||||
+ cp prnt/hpcups/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/ ; \
|
||||
+ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_32.so ; \
|
||||
+ ln -sf $(libdir)/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
|
||||
fi
|
||||
if !HPLIP_CLASS_DRIVER
|
||||
# If scanner build, add hpaio entry to sane dll.conf.
|
||||
@@ -709,11 +709,11 @@
|
||||
ln -sf $(libdir)/sane/libsane-hpaio.so $(libdir)/x86_64-linux-gnu/sane/ ; \
|
||||
ln -sf $(libdir)/sane/libsane-hpaio.so.1 $(libdir)/x86_64-linux-gnu/sane/ ; \
|
||||
fi; \
|
||||
- if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/i386-linux-gnu" \) ]; then \
|
||||
- ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so ; \
|
||||
- ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
|
||||
- ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
|
||||
- ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
|
||||
+ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/i386-linux-gnu" \) ]; then \
|
||||
+ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so ; \
|
||||
+ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
|
||||
+ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
|
||||
+ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
|
||||
fi \
|
||||
fi
|
||||
endif #HPLIP_CLASS_DRIVER
|
||||
--- hplip-3.19.3/Makefile.in.orig 2019-05-05 15:37:16.070374478 +0200
|
||||
+++ hplip-3.19.3/Makefile.in 2019-05-05 15:38:20.716763336 +0200
|
||||
@@ -9504,15 +9504,15 @@
|
||||
|
||||
|
||||
install-data-hook:
|
||||
-@HPLIP_BUILD_TRUE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
|
||||
-@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
|
||||
-@HPLIP_BUILD_TRUE@ chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
|
||||
-@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
|
||||
+@HPLIP_BUILD_TRUE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
|
||||
+@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/ ; \
|
||||
+@HPLIP_BUILD_TRUE@ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_64.so ; \
|
||||
+@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
|
||||
@HPLIP_BUILD_TRUE@ fi; \
|
||||
-@HPLIP_BUILD_TRUE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
|
||||
-@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
|
||||
-@HPLIP_BUILD_TRUE@ chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
|
||||
-@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
|
||||
+@HPLIP_BUILD_TRUE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
|
||||
+@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/ ; \
|
||||
+@HPLIP_BUILD_TRUE@ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_32.so ; \
|
||||
+@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
|
||||
@HPLIP_BUILD_TRUE@ fi
|
||||
# If scanner build, add hpaio entry to sane dll.conf.
|
||||
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ "$(scan_build)" = "yes" ]; then \
|
||||
@@ -9524,15 +9524,15 @@
|
||||
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ echo "Adding hpaio entry to /etc/sane.d/dll.conf." ; \
|
||||
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ echo hpaio >>$(DESTDIR)/etc/sane.d/dll.conf ; \
|
||||
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi; \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/x86_64-linux-gnu/sane" \) ]; then \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so $(libdir)/x86_64-linux-gnu/sane/ ; \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1 $(libdir)/x86_64-linux-gnu/sane/ ; \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(DESTDIR)$(libdir)/x86_64-linux-gnu/sane" \) ]; then \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so $(DESTDIR)$(libdir)/x86_64-linux-gnu/sane/ ; \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1 $(DESTDIR)$(libdir)/x86_64-linux-gnu/sane/ ; \
|
||||
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi; \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/i386-linux-gnu" \) ]; then \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so ; \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
|
||||
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/i386-linux-gnu" \) ]; then \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so ; \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
|
||||
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
|
||||
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi \
|
||||
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi
|
||||
# Create hp-xxx commands in bindir.
|
113
hplip-3.19.6-remove-libImageProcessor.patch
Normal file
113
hplip-3.19.6-remove-libImageProcessor.patch
Normal file
@ -0,0 +1,113 @@
|
||||
From fa9c0cf1a5db9bf8880b4796d5e3e0da46534e3d Mon Sep 17 00:00:00 2001
|
||||
From: Didier Raboud <odyx@debian.org>
|
||||
Date: Tue, 21 Aug 2018 18:18:10 +0200
|
||||
Subject: Remove all ImageProcessor functionality, which is closed-source
|
||||
|
||||
---
|
||||
Makefile.am | 14 ++------------
|
||||
prnt/hpcups/HPCupsFilter.cpp | 21 ---------------------
|
||||
2 files changed, 2 insertions(+), 33 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 1b097c4f9..8d5d78c9f 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -166,7 +166,7 @@ if !HPLIP_CLASS_DRIVER
|
||||
dist_hplip_SCRIPTS = hpssd.py __init__.py hpdio.py
|
||||
endif #HPLIP_CLASS_DRIVER
|
||||
|
||||
-dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template prnt/hpcups/libImageProcessor-x86_64.so prnt/hpcups/libImageProcessor-x86_32.so
|
||||
+dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template
|
||||
dist_noinst_SCRIPTS += dat2drv.py install.py hplip-install init-suse-firewall init-iptables-firewall class_rpm_build.sh hplipclassdriver.spec createPPD.sh Makefile_dat2drv hpijs-drv
|
||||
|
||||
if !HPLIP_CLASS_DRIVER
|
||||
@@ -594,7 +594,7 @@ hpcups_SOURCES = prnt/hpcups/HPCupsFilter.cpp prnt/hpcups/HPCupsFilter.h prnt/hp
|
||||
prnt/hpcups/ImageProcessor.h
|
||||
|
||||
hpcups_CXXFLAGS = $(APDK_ENDIAN_FLAG) $(DBUS_CFLAGS)
|
||||
-hpcups_LDADD = -L./prnt/hpcups/ -ljpeg -ldl -lImageProcessor -lcups -lcupsimage -lz $(DBUS_LIBS)
|
||||
+hpcups_LDADD = -L./prnt/hpcups/ -ljpeg -ldl -lcups -lcupsimage -lz $(DBUS_LIBS)
|
||||
#else
|
||||
#hpcupsdir = $(cupsfilterdir)
|
||||
#hpcups_PROGRAMS = hpcups
|
||||
@@ -686,16 +686,6 @@ endif #HPLIP_CLASS_DRIVER
|
||||
|
||||
install-data-hook:
|
||||
if HPLIP_BUILD
|
||||
- if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
|
||||
- cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
|
||||
- chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
|
||||
- ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
|
||||
- fi; \
|
||||
- if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
|
||||
- cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
|
||||
- chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
|
||||
- ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
|
||||
- fi
|
||||
if !HPLIP_CLASS_DRIVER
|
||||
# If scanner build, add hpaio entry to sane dll.conf.
|
||||
if [ "$(scan_build)" = "yes" ]; then \
|
||||
diff --git a/prnt/hpcups/HPCupsFilter.cpp b/prnt/hpcups/HPCupsFilter.cpp
|
||||
index 5b282d83f..0bacfafac 100644
|
||||
--- a/prnt/hpcups/HPCupsFilter.cpp
|
||||
+++ b/prnt/hpcups/HPCupsFilter.cpp
|
||||
@@ -31,7 +31,6 @@
|
||||
\*****************************************************************************/
|
||||
|
||||
#include "HPCupsFilter.h"
|
||||
-#include "ImageProcessor.h"
|
||||
|
||||
#include <signal.h>
|
||||
#include <sys/wait.h>
|
||||
@@ -637,16 +636,10 @@ int HPCupsFilter::processRasterData(cups_raster_t *cups_raster)
|
||||
|
||||
|
||||
sprintf(hpPreProcessedRasterFile, "%s/hp_%s_cups_SwapedPagesXXXXXX",CUPS_TMP_DIR, m_JA.user_name);
|
||||
- image_processor_t* imageProcessor = imageProcessorCreate();
|
||||
|
||||
while (cupsRasterReadHeader2(cups_raster, &cups_header))
|
||||
{
|
||||
|
||||
- IMAGE_PROCESSOR_ERROR result = imageProcessorStartPage(imageProcessor, &cups_header);
|
||||
- if (result != IPE_SUCCESS){
|
||||
- dbglog("DEBUG: imageProcessorStartPage failed result = %d\n", result);
|
||||
- }
|
||||
-
|
||||
current_page_number++;
|
||||
|
||||
if (current_page_number == 1) {
|
||||
@@ -745,12 +738,6 @@ int HPCupsFilter::processRasterData(cups_raster_t *cups_raster)
|
||||
color_raster = rgbRaster;
|
||||
black_raster = kRaster;
|
||||
|
||||
- result = imageProcessorProcessLine(imageProcessor, m_pPrinterBuffer, cups_header.cupsBytesPerLine);
|
||||
- if (result != IPE_SUCCESS){
|
||||
- dbglog("DEBUG: imageProcessorProcessLine failed result = %d\n", result);
|
||||
- }
|
||||
-
|
||||
-
|
||||
if ((y == 0) && !is_ljmono) {
|
||||
//For ljmono, make sure that first line is not a blankRaster line.Otherwise printer
|
||||
//may not skip blank lines before actual data
|
||||
@@ -780,12 +767,6 @@ int HPCupsFilter::processRasterData(cups_raster_t *cups_raster)
|
||||
}
|
||||
} // for() loop end
|
||||
|
||||
- result = imageProcessorEndPage(imageProcessor);
|
||||
- if (result != IPE_SUCCESS){
|
||||
- dbglog("DEBUG: imageProcessorEndPage failed result = %d\n", result);
|
||||
- }
|
||||
-
|
||||
-
|
||||
m_Job.NewPage();
|
||||
if (err != NO_ERROR) {
|
||||
break;
|
||||
@@ -800,8 +781,6 @@ int HPCupsFilter::processRasterData(cups_raster_t *cups_raster)
|
||||
rgbRaster = NULL;
|
||||
}
|
||||
|
||||
- imageProcessorDestroy(imageProcessor);
|
||||
-
|
||||
unlink(hpPreProcessedRasterFile);
|
||||
return ret_status;
|
||||
}
|
65
hplip.spec
65
hplip.spec
@ -2,8 +2,8 @@
|
||||
%define lp_gid 9
|
||||
%define cups_ver %(cups-config --api-version)
|
||||
Name: hplip
|
||||
Version: 3.18.6
|
||||
Release: 1mamba
|
||||
Version: 3.19.6
|
||||
Release: 3mamba
|
||||
Summary: A printer driver for HP inkjet devices
|
||||
Group: System/Spooling
|
||||
Vendor: openmamba
|
||||
@ -14,8 +14,10 @@ Source: http://downloads.sourceforge.net/sourceforge/hplip/hplip-%{versio
|
||||
Source1: http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-%{version}-plugin.run
|
||||
Patch0: %{name}-3.11.7-cups-1.5.patch
|
||||
Patch1: %{name}-3.12.9-cups-1.6.patch
|
||||
Patch2: hplip-3.18.3-openmamba-AUTH_TYPES-warning.patch
|
||||
Patch2: hplip-3.18.12-openmamba-AUTH_TYPES-warning.patch
|
||||
Patch3: hplip-3.16.5-systray-hide-when-inactive.patch
|
||||
Patch4: hplip-3.19.3-Makefile-missing-DESTDIR.patch
|
||||
Patch5: hplip-3.19.6-remove-libImageProcessor.patch
|
||||
License: BSD, LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -40,9 +42,17 @@ BuildRequires: libssp-devel
|
||||
BuildRequires: libudev-devel
|
||||
Obsoletes: hpijs
|
||||
Requires: cups
|
||||
Requires: python-Imaging
|
||||
Requires: PyQt5-py36
|
||||
Requires: python-Pillow-py36
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires(pre): libsane-backends >= 1.0.16
|
||||
%ifarch x86_64
|
||||
Provides: libImageProcessor.so()(64bit)
|
||||
Provides: libImageProcessor.so(VERS_1.0)(64bit)
|
||||
%else
|
||||
Provides: libImageProcessor.so
|
||||
Provides: libImageProcessor.so(VERS_1.0)
|
||||
%endif
|
||||
Provides: hpijs = %{version}
|
||||
|
||||
%description
|
||||
@ -73,6 +83,8 @@ This package contains the proprietary plugins needed by some printers.
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
#%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
#sed -i "s|SYSFS{|ATTRS{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules
|
||||
#sed -i "s|sysfs{|ATTR{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules
|
||||
@ -82,6 +94,9 @@ sed -i "s|chmod 774|/bin/true 774|" Makefile.in
|
||||
|
||||
sh %{SOURCE1} --target hplip-%{version}-plugin --noexec
|
||||
|
||||
export AUTOMAKE='automake --foreign'
|
||||
autoreconf -f -i
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-qt5 \
|
||||
@ -94,7 +109,7 @@ sh %{SOURCE1} --target hplip-%{version}-plugin --noexec
|
||||
--enable-cups-drv-install \
|
||||
--enable-cups-ppd-install \
|
||||
--with-hpppddir=%{_datadir}/cups/model/HP \
|
||||
PYTHON=%{__python}
|
||||
PYTHON=%{__python36}
|
||||
|
||||
# \
|
||||
# --disable-foomatic_install
|
||||
@ -102,7 +117,15 @@ sh %{SOURCE1} --target hplip-%{version}-plugin --noexec
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall rulessystemdir=%{_unitdir}
|
||||
%makeinstall rulessystemdir=%{_unitdir} libdir=%{_libdir}
|
||||
|
||||
#%ifarch x86_64
|
||||
#cp prnt/hpcups/libImageProcessor-x86_64.so %{buildroot}%{_libdir}
|
||||
#ln -sf %{_libdir}/libImageProcessor-x86_64.so %{buildroot}%{_libdir}/libImageProcessor.so
|
||||
#%else
|
||||
#cp prnt/hpcups/libImageProcessor-x86_32.so %{buildroot}%{_libdir}
|
||||
#ln -sf %{_libdir}/libImageProcessor-x86_32.so %{buildroot}%{_libdir}/libImageProcessor.so
|
||||
#%endif
|
||||
|
||||
# remove conflict with libsane-backends
|
||||
rm -f %{buildroot}%{_sysconfdir}/sane.d/dll.conf
|
||||
@ -219,14 +242,15 @@ fi
|
||||
%{_libdir}/libhpip.so.*
|
||||
%{_libdir}/libhpipp.so.*
|
||||
%{_libdir}/libhpmud.so.*
|
||||
#%{_libdir}/libImageProcessor*.so
|
||||
%{_libdir}/sane/libsane-hpaio.so.*
|
||||
%{_libdir}/sane/libsane-hpaio.so
|
||||
#%{_libdir}/menu/hplip
|
||||
%{python_sitearch}/*.so
|
||||
%{python_sitearch}/cupsext.la
|
||||
%{python_sitearch}/hpmudext.la
|
||||
%{python_sitearch}/scanext.la
|
||||
%{python_sitearch}/pcardext.la
|
||||
%{python36_sitearch}/*.so
|
||||
%{python36_sitearch}/cupsext.la
|
||||
%{python36_sitearch}/hpmudext.la
|
||||
%{python36_sitearch}/scanext.la
|
||||
%{python36_sitearch}/pcardext.la
|
||||
%{_datadir}/applications/hplip.desktop
|
||||
%{_datadir}/cups/drv/hp/hpijs.drv
|
||||
%{_datadir}/cups/drv/hp/hpcups.drv
|
||||
@ -235,6 +259,7 @@ fi
|
||||
%else
|
||||
%{_datadir}/cups/mime/pstotiff.*
|
||||
%endif
|
||||
%{_datadir}/applications/hp-uiscan.desktop
|
||||
%dir %{_datadir}/hplip
|
||||
%{_datadir}/hplip/*
|
||||
%{_datadir}/cups/model/HP/*
|
||||
@ -274,6 +299,24 @@ fi
|
||||
%{_localstatedir}/lib/hp/hplip.state
|
||||
|
||||
%changelog
|
||||
* Sun Jul 21 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.19.6-3mamba
|
||||
- added a patch to remove closed source libImageProcessor and fix build on arm
|
||||
|
||||
* Sat Jul 20 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.19.6-2mamba
|
||||
- rebuilt with python 3.6
|
||||
|
||||
* Sat Jun 29 2019 Automatic Build System <autodist@mambasoft.it> 3.19.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri May 17 2019 Automatic Build System <autodist@mambasoft.it> 3.19.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri May 03 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.19.3-1mamba
|
||||
- update to 3.19.3
|
||||
|
||||
* Sat Feb 02 2019 Automatic Build System <autodist@mambasoft.it> 3.19.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jun 26 2018 Automatic Build System <autodist@mambasoft.it> 3.18.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user