automatic version update by autodist [release 3.22.4-1mamba;Sat May 21 2022]

This commit is contained in:
Automatic Build System 2024-01-05 23:42:58 +01:00
parent 9ec5343d72
commit 868c8224ba
9 changed files with 243 additions and 144 deletions

View File

@ -1,20 +0,0 @@
--- hplip-3.16.5/ui4/ui_utils.py.orig 2016-05-04 07:23:05.000000000 +0200
+++ hplip-3.16.5/ui4/ui_utils.py 2016-07-04 20:36:14.571475245 +0200
@@ -156,7 +156,7 @@
else:
QSettings.__init__(self, os.path.join(prop.user_dir, 'hplip.conf'), QSettings.IniFormat)
- self.systray_visible = SYSTRAY_VISIBLE_SHOW_ALWAYS
+ self.systray_visible = SYSTRAY_VISIBLE_HIDE_WHEN_INACTIVE
self.systray_messages = SYSTRAY_MESSAGES_SHOW_ALL
self.last_used_device_uri = ''
self.last_used_printer = ''
@@ -197,7 +197,7 @@
self.sync()
self.beginGroup("settings")
- self.systray_visible = value_int(self.value("systray_visible"))[0]
+ self.systray_visible = value_int(self.value("systray_visible", self.systray_visible))[0]
self.systray_messages = value_int(self.value("systray_messages"))[0]

View File

@ -1,93 +0,0 @@
--- hplip-3.19.3/Makefile.am.orig 2019-05-05 15:19:04.022430433 +0200
+++ hplip-3.19.3/Makefile.am 2019-05-05 15:20:06.893397649 +0200
@@ -684,15 +684,15 @@
install-data-hook:
if HPLIP_BUILD
- if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
- cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
- chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
- ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
+ if [ \( "$(UNAME)" = "x86_64" -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
+ cp prnt/hpcups/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/ ; \
+ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_64.so ; \
+ ln -sf $(libdir)/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
fi; \
- if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
- cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
- chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
- ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
+ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
+ cp prnt/hpcups/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/ ; \
+ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_32.so ; \
+ ln -sf $(libdir)/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
fi
if !HPLIP_CLASS_DRIVER
# If scanner build, add hpaio entry to sane dll.conf.
@@ -709,11 +709,11 @@
ln -sf $(libdir)/sane/libsane-hpaio.so $(libdir)/x86_64-linux-gnu/sane/ ; \
ln -sf $(libdir)/sane/libsane-hpaio.so.1 $(libdir)/x86_64-linux-gnu/sane/ ; \
fi; \
- if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/i386-linux-gnu" \) ]; then \
- ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so ; \
- ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
- ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
- ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
+ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/i386-linux-gnu" \) ]; then \
+ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so ; \
+ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
+ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
+ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
fi \
fi
endif #HPLIP_CLASS_DRIVER
--- hplip-3.19.3/Makefile.in.orig 2019-05-05 15:37:16.070374478 +0200
+++ hplip-3.19.3/Makefile.in 2019-05-05 15:38:20.716763336 +0200
@@ -9504,15 +9504,15 @@
install-data-hook:
-@HPLIP_BUILD_TRUE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
-@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
-@HPLIP_BUILD_TRUE@ chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
-@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
+@HPLIP_BUILD_TRUE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
+@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/ ; \
+@HPLIP_BUILD_TRUE@ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_64.so ; \
+@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
@HPLIP_BUILD_TRUE@ fi; \
-@HPLIP_BUILD_TRUE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
-@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
-@HPLIP_BUILD_TRUE@ chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
-@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
+@HPLIP_BUILD_TRUE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/" \) ]; then \
+@HPLIP_BUILD_TRUE@ cp prnt/hpcups/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/ ; \
+@HPLIP_BUILD_TRUE@ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_32.so ; \
+@HPLIP_BUILD_TRUE@ ln -sf $(libdir)/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
@HPLIP_BUILD_TRUE@ fi
# If scanner build, add hpaio entry to sane dll.conf.
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ "$(scan_build)" = "yes" ]; then \
@@ -9524,15 +9524,15 @@
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ echo "Adding hpaio entry to /etc/sane.d/dll.conf." ; \
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ echo hpaio >>$(DESTDIR)/etc/sane.d/dll.conf ; \
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi; \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/x86_64-linux-gnu/sane" \) ]; then \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so $(libdir)/x86_64-linux-gnu/sane/ ; \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1 $(libdir)/x86_64-linux-gnu/sane/ ; \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( "$(UNAME)" = "x86_64" -a -d "$(DESTDIR)$(libdir)/x86_64-linux-gnu/sane" \) ]; then \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so $(DESTDIR)$(libdir)/x86_64-linux-gnu/sane/ ; \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1 $(DESTDIR)$(libdir)/x86_64-linux-gnu/sane/ ; \
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi; \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/i386-linux-gnu" \) ]; then \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so ; \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
-@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(DESTDIR)$(libdir)/i386-linux-gnu" \) ]; then \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so ; \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/libhpmud.so.0.0.6 $(DESTDIR)$(libdir)/i386-linux-gnu/libhpmud.so.0 ; \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so.1 ; \
+@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ ln -sf $(libdir)/sane/libsane-hpaio.so.1.0.0 $(DESTDIR)$(libdir)/i386-linux-gnu/sane/libsane-hpaio.so ; \
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi \
@HPLIP_BUILD_TRUE@@HPLIP_CLASS_DRIVER_FALSE@ fi
# Create hp-xxx commands in bindir.

View File

@ -1,16 +1,17 @@
diff -Nru hplip-3.21.4.orig/Makefile.am hplip-3.21.4/Makefile.am diff --git a/Makefile.am b/Makefile.am
--- hplip-3.21.4.orig/Makefile.am 2021-05-06 10:39:14.000000000 +0200 index f65afea..12317dc 100644
+++ hplip-3.21.4/Makefile.am 2021-06-21 21:33:11.109559334 +0200 --- a/Makefile.am
@@ -167,7 +167,7 @@ +++ b/Makefile.am
@@ -167,7 +167,7 @@ if !HPLIP_CLASS_DRIVER
dist_hplip_SCRIPTS = hpssd.py __init__.py hpdio.py dist_hplip_SCRIPTS = hpssd.py __init__.py hpdio.py
endif #HPLIP_CLASS_DRIVER endif #HPLIP_CLASS_DRIVER
-dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template prnt/hpcups/libImageProcessor-x86_64.so prnt/hpcups/libImageProcessor-x86_32.so -dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template prnt/hpcups/libImageProcessor-x86_64.so prnt/hpcups/libImageProcessor-x86_32.so
+dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template +dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template
dist_noinst_SCRIPTS += dat2drv.py install.py hplip-install init-suse-firewall init-iptables-firewall class_rpm_build.sh hplipclassdriver.spec createPPD.sh Makefile_dat2drv hpijs-drv
if !HPLIP_CLASS_DRIVER dist_noinst_DATA += prnt/ipp-usb/HPLIP.conf
@@ -595,7 +595,7 @@ dist_noinst_SCRIPTS += dat2drv.py install.py hplip-install init-suse-firewall init-iptables-firewall class_rpm_build.sh hplipclassdriver.spec createPPD.sh Makefile_dat2drv hpijs-drv
@@ -597,7 +597,7 @@ hpcups_SOURCES = prnt/hpcups/HPCupsFilter.cpp prnt/hpcups/HPCupsFilter.h prnt/hp
prnt/hpcups/ImageProcessor.h prnt/hpcups/ImageProcessor.h
hpcups_CXXFLAGS = $(APDK_ENDIAN_FLAG) $(DBUS_CFLAGS) hpcups_CXXFLAGS = $(APDK_ENDIAN_FLAG) $(DBUS_CFLAGS)
@ -19,7 +20,7 @@ diff -Nru hplip-3.21.4.orig/Makefile.am hplip-3.21.4/Makefile.am
#else #else
#hpcupsdir = $(cupsfilterdir) #hpcupsdir = $(cupsfilterdir)
#hpcups_PROGRAMS = hpcups #hpcups_PROGRAMS = hpcups
@@ -685,16 +685,6 @@ @@ -687,16 +687,6 @@ endif #HPLIP_CLASS_DRIVER
install-data-hook: install-data-hook:
if HPLIP_BUILD if HPLIP_BUILD
@ -33,6 +34,6 @@ diff -Nru hplip-3.21.4.orig/Makefile.am hplip-3.21.4/Makefile.am
- chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \ - chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
- ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \ - ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
- fi - fi
if !HPLIP_CLASS_DRIVER if [ -d "/usr/share/ipp-usb/quirks/" ]; then \
# If scanner build, add hpaio entry to sane dll.conf. echo "ipp-usb directory exists"; \
if [ "$(scan_build)" = "yes" ]; then \ cp prnt/ipp-usb/HPLIP.conf /usr/share/ipp-usb/quirks/ ; \

View File

@ -0,0 +1,52 @@
diff -up hplip-3.20.9/configure.in.configure-python hplip-3.20.9/configure.in
--- hplip-3.20.9/configure.in.configure-python 2020-09-23 07:24:27.000000000 +0200
+++ hplip-3.20.9/configure.in 2020-10-02 07:27:09.082331431 +0200
@@ -604,17 +604,29 @@ if test "$class_driver" = "no" && test "
fi
fi
-SAVE_CPPFLAGS="$CPPFLAGS"
-CFLAGS=`python-config --includes`
-if [ $? -eq 0 ]
-then
- echo $FLAGS
-else
-CFLAGS=`python3-config --includes`
- if [ $? -eq 0 ]
- then
- echo $FLAGS
- fi
+AC_PATH_PROG(python3_config_path, python3-config, [AC_MSG_ERROR([python3-config not installed], 6)])
+
+PYTHON_INCLUDES=`$python3_config_path --includes`
+if test "X$PYTHON_INCLUDES" = "X" ; then
+ AC_MSG_ERROR([Cannot get Python includes via python3-config], 6)
+fi
+
+PYTHON_LIBS=`$python3_config_path --libs`
+if test "X$PYTHON_LIBS" = "X" ; then
+ AC_MSG_ERROR([Cannot get Python libs via python3-config], 6)
+fi
+
+SAVE_CFLAGS=$CFLAGS
+SAVE_LIBS=$LIBS
+
+CFLAGS="$CFLAGS $PYTHON_INCLUDES"
+LIBS="$LIBS $PYTHON_LIBS"
+
+AC_TRY_LINK(,[ ], AC_MSG_RESULT(yes); python_includes="ok", AC_MSG_ERROR([no: PYTHON DISABLED], 6))
+
+if test "X$python_includes" != "Xok" ; then
+ CFLAGS="$SAVE_CFLAGS"
+ LIBS="$SAVE_LIBS"
fi
#CFLAGS=`(python-config --includes)`
@@ -631,7 +643,6 @@ if test "$class_driver" = "no" && test "
AS_IF([test "x$FOUND_HEADER" != "xyes"],
[AC_MSG_ERROR([cannot find python-devel support], 6)])
fi
-CFLAGS="$save_CFLAGS"
if test "$hpijs_only_build" = "no" && test "$scan_build" = "yes" && test "$hpcups_only_build" = "no"; then
AC_CHECK_LIB([sane], [sane_open], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find sane-backends-devel support (or --disable-scan-build)], 12)])

View File

@ -0,0 +1,14 @@
--- upgrade.py.orig 2013-10-31 12:46:54.000000000 +0100
+++ upgrade.py 2013-12-04 14:58:03.000000000 +0100
@@ -134,6 +134,11 @@ except getopt.GetoptError, e:
if os.getenv("HPLIP_DEBUG"):
log.set_level('debug')
+
+log.error("HPLIP upgrade is disabled. Please use your distribution software manager to upgrade the package.")
+clean_exit(1)
+
+
for o, a in opts:
if o in ('-h', '--help'):
usage()

View File

@ -0,0 +1,11 @@
--- hplip-3.22.2/scan/sane/bb_ledm.c 2022-02-23 08:41:05.000000000 +0100
+++ hplip-3.22.2/scan/sane/bb_ledm.c.new 2022-03-12 21:10:05.818054984 +0100
@@ -1015,7 +1015,7 @@
c +=11;
char BinaryURL[30];
i = 0;
- while(*c != '<')
+ while(*c != '<' && i < 29)
{
BinaryURL[i++] = *c ;
c++;

134
hplip-3.22.4-python3.patch Normal file
View File

@ -0,0 +1,134 @@
From: Till Kamppeter <till.kamppeter@gmail.com>
Date: Fri, 22 Jul 2016 09:33:04 +0200
Subject: Workaround patch for missing Python3 transition of the old
(pre-USB-storage) photo memory card support (pcardext) as this part builds
in Python3 environments but with pointer-related warnings which are fatal
errors for Ubuntu's build servers. The patch silences the warnings but the
memory card support is dropped in Python3 environments. This patch is
supplied by the HPLIP upstream developers and will be replaced by a more
proper solution in the next upstream release of HPLIP (see LP: #1275353)
---
pcard/pcardext/pcardext.c | 59 +++++++++++++++++++++++++++++++++++++----------
pcard/photocard.py | 2 +-
unload.py | 5 ++++
3 files changed, 53 insertions(+), 13 deletions(-)
diff --git a/pcard/pcardext/pcardext.c b/pcard/pcardext/pcardext.c
index c1a8273..37d979b 100644
--- a/pcard/pcardext/pcardext.c
+++ b/pcard/pcardext/pcardext.c
@@ -20,7 +20,7 @@ pcardext - Python extension for HP photocard services
Requires:
Python 2.2+
-Author: Don Welch
+Author: Don Welch
\*****************************************************************************/
@@ -38,9 +38,37 @@ typedef int Py_ssize_t;
int verbose=0;
+#if PY_MAJOR_VERSION >= 3
+ #define MOD_ERROR_VAL NULL
+ #define MOD_SUCCESS_VAL(val) val
+ #define MOD_INIT(name) PyMODINIT_FUNC PyInit_##name(void)
+ #define PyInt_AS_LONG PyLong_AS_LONG
+ #define MOD_DEF(ob, name, doc, methods) \
+ static struct PyModuleDef moduledef = { \
+ PyModuleDef_HEAD_INIT, name, doc, -1, methods, }; \
+ ob = PyModule_Create(&moduledef);
+
+
+ #define PY_String_Bytes PyBytes_FromStringAndSize
+ #define PY_AsString_Bytes PyBytes_AsStringAndSize
+
+#else
+ #define MOD_ERROR_VAL
+ #define MOD_SUCCESS_VAL(val)
+ #define MOD_INIT(name) void init##name(void)
+ #define MOD_DEF(ob, name, doc, methods) \
+ ob = Py_InitModule3(name, methods, doc);
+
+ #define PY_String_Bytes PyString_FromStringAndSize
+ #define PY_AsString_Bytes PyString_AsStringAndSize
+
+#endif
+
PyObject * readsectorFunc = NULL;
PyObject * writesectorFunc = NULL;
+
+
int ReadSector(int sector, int nsector, void *buf, int size)
{
PyObject * result;
@@ -56,9 +84,13 @@ int ReadSector(int sector, int nsector, void *buf, int size)
if( result )
{
Py_ssize_t len = 0;
- PyString_AsStringAndSize( result, &result_str, &len );
+
+ //PyString_AsStringAndSize( result, &result_str, &len );
+ //PyBytes_AsStringAndSize( result, &result_str, &len );
+ PY_AsString_Bytes( result, &result_str, &len );
- if( len < nsector*FAT_HARDSECT )
+
+ if( len < nsector*FAT_HARDSECT )
{
goto abort;
}
@@ -205,7 +237,9 @@ PyObject * pcardext_read( PyObject * self, PyObject * args )
if( FatReadFileExt( name, offset, len, buffer ) == len )
{
- return PyString_FromStringAndSize( (char *)buffer, len );
+ // return PyString_FromStringAndSize( (char *)buffer, len );
+ return PY_String_Bytes( (char *)buffer, len );
+ // return PyBytes_FromStringAndSize( (char *)buffer, len );
}
else
{
@@ -233,14 +267,15 @@ static PyMethodDef pcardext_methods[] =
static char pcardext_documentation[] = "Python extension for HP photocard services";
-void initpcardext( void )
-{
- PyObject * mod = Py_InitModule4( "pcardext", pcardext_methods,
- pcardext_documentation, (PyObject*)NULL,
- PYTHON_API_VERSION );
-
- if (mod == NULL)
- return;
+MOD_INIT(pcardext) {
+
+ PyObject* mod ;
+ MOD_DEF(mod, "pcardext", pcardext_documentation, pcardext_methods);
+ if (mod == NULL)
+ return MOD_ERROR_VAL;
+
+ return MOD_SUCCESS_VAL(mod);
+
}
diff --git a/unload.py b/unload.py
index 3fdd5a3..ce8b069 100755
--- a/unload.py
+++ b/unload.py
@@ -44,6 +44,11 @@ except ImportError:
# Local
from base.g import *
+from base.sixext import PY3
+if PY3:
+ log.error("This functionality is not spported in python3 environment.")
+ sys.exit(1)
+
from base import device, utils, tui, module
from prnt import cups

View File

@ -9,12 +9,3 @@
self.systray_messages = SYSTRAY_MESSAGES_SHOW_ALL self.systray_messages = SYSTRAY_MESSAGES_SHOW_ALL
self.last_used_device_uri = '' self.last_used_device_uri = ''
self.last_used_printer = '' self.last_used_printer = ''
@@ -214,7 +214,7 @@
self.sync()
self.beginGroup("settings")
- self.systray_visible = value_int(self.value("systray_visible"))[0]
+ self.systray_visible = value_int(self.value("systray_visible"), self.systray_visible)[0]
self.systray_messages = value_int(self.value("systray_messages"))[0]

View File

@ -2,7 +2,7 @@
%define lp_gid 9 %define lp_gid 9
%define cups_ver %(cups-config --api-version) %define cups_ver %(cups-config --api-version)
Name: hplip Name: hplip
Version: 3.21.8 Version: 3.22.4
Release: 1mamba Release: 1mamba
Summary: A printer driver for HP inkjet devices Summary: A printer driver for HP inkjet devices
Group: System/Spooling Group: System/Spooling
@ -15,25 +15,31 @@ Source1: http://www.openprinting.org/download/printdriver/auxfiles/HP/plug
Patch0: %{name}-3.11.7-cups-1.5.patch Patch0: %{name}-3.11.7-cups-1.5.patch
Patch1: %{name}-3.12.9-cups-1.6.patch Patch1: %{name}-3.12.9-cups-1.6.patch
Patch2: hplip-3.18.12-openmamba-AUTH_TYPES-warning.patch Patch2: hplip-3.18.12-openmamba-AUTH_TYPES-warning.patch
Patch3: hplip-3.16.5-systray-hide-when-inactive.patch Patch6: hplip-3.22.4-ui5-systray-hide-when-inactive.patch
Patch4: hplip-3.19.3-Makefile-missing-DESTDIR.patch Patch7: hplip-3.22.4-python3.patch
Patch5: hplip-3.21.4-remove-libImageProcessor.patch Patch8: hplip-3.22.4-configure-python.patch
Patch6: hplip-3.20.11-ui5-systray-hide-when-inactive.patch Patch9: hplip-3.22.4-disable_upgrade.patch
Patch10: hplip-3.22.4-fix-possible-stack-buffer.overflows.patch
Patch11: hplip-3.22.4-Remove-all-ImageProcessor-functionality.patch
License: BSD, LGPL License: BSD, LGPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: libatomic-devel
BuildRequires: libavahi-devel BuildRequires: libavahi-devel
BuildRequires: libcups-devel BuildRequires: libcups-devel
BuildRequires: libdbus-devel BuildRequires: libdbus-devel
BuildRequires: libgcc BuildRequires: libgcc
BuildRequires: libjpeg-devel BuildRequires: libjpeg-devel
BuildRequires: libnetsnmp-devel BuildRequires: libnetsnmp-devel
BuildRequires: libnsl-devel
BuildRequires: libopenssl-devel BuildRequires: libopenssl-devel
BuildRequires: libpython3-devel
BuildRequires: libsane-backends-devel BuildRequires: libsane-backends-devel
BuildRequires: libssp-devel BuildRequires: libssp-devel
BuildRequires: libstdc++6-devel BuildRequires: libstdc++6-devel
BuildRequires: libsystemd-devel BuildRequires: libsystemd-devel
BuildRequires: libudev-devel BuildRequires: libudev-devel
BuildRequires: libusb-compat-devel
BuildRequires: libusb-devel BuildRequires: libusb-devel
BuildRequires: libz-devel BuildRequires: libz-devel
## AUTOBUILDREQ-END ## AUTOBUILDREQ-END
@ -74,13 +80,13 @@ This package contains the proprietary plugins needed by some printers.
%prep %prep
%setup -q %setup -q
#%patch0 -p1
#%patch1 -p1
%patch2 -p1 %patch2 -p1
%patch3 -p1 %patch6 -p1 -b .ui5-systray-hide-when-inactive
#%patch4 -p1 %patch7 -p1 -b .python3
%patch5 -p1 %patch8 -p1 -b .configure-python
%patch6 -p1 %patch9 -p0 -b .disable_upgrade
%patch10 -p1 -b .fix-possible-stack-buffer.overflows
%patch11 -p1 -b .Remove-all-ImageProcessor-functionality
#sed -i "s|SYSFS{|ATTRS{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules #sed -i "s|SYSFS{|ATTRS{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules
#sed -i "s|sysfs{|ATTR{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules #sed -i "s|sysfs{|ATTR{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules
@ -280,6 +286,9 @@ fi
%{_localstatedir}/lib/hp/hplip.state %{_localstatedir}/lib/hp/hplip.state
%changelog %changelog
* Sat May 21 2022 Automatic Build System <autodist@mambasoft.it> 3.22.4-1mamba
- automatic version update by autodist
* Wed Sep 08 2021 Automatic Build System <autodist@mambasoft.it> 3.21.8-1mamba * Wed Sep 08 2021 Automatic Build System <autodist@mambasoft.it> 3.21.8-1mamba
- automatic version update by autodist - automatic version update by autodist