rebuilt by autoport with build requirements: libnetsnmp-devel>=5.9-1mamba [release 3.20.11-2mamba;Tue Dec 08 2020]
This commit is contained in:
parent
4748e46f9e
commit
07e71062ff
20
hplip-3.20.11-ui5-systray-hide-when-inactive.patch
Normal file
20
hplip-3.20.11-ui5-systray-hide-when-inactive.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- hplip-3.20.11/ui5/ui_utils.py.orig 2020-12-13 11:57:56.371789774 +0100
|
||||
+++ hplip-3.20.11/ui5/ui_utils.py 2020-12-13 11:58:44.127640113 +0100
|
||||
@@ -173,7 +173,7 @@
|
||||
else:
|
||||
QSettings.__init__(self, os.path.join(prop.user_dir, 'hplip.conf'), QSettings.IniFormat)
|
||||
|
||||
- self.systray_visible = SYSTRAY_VISIBLE_SHOW_ALWAYS
|
||||
+ self.systray_visible = SYSTRAY_VISIBLE_HIDE_WHEN_INACTIVE
|
||||
self.systray_messages = SYSTRAY_MESSAGES_SHOW_ALL
|
||||
self.last_used_device_uri = ''
|
||||
self.last_used_printer = ''
|
||||
@@ -214,7 +214,7 @@
|
||||
self.sync()
|
||||
|
||||
self.beginGroup("settings")
|
||||
- self.systray_visible = value_int(self.value("systray_visible"))[0]
|
||||
+ self.systray_visible = value_int(self.value("systray_visible"), self.systray_visible)[0]
|
||||
|
||||
self.systray_messages = value_int(self.value("systray_messages"))[0]
|
||||
|
37
hplip.spec
37
hplip.spec
@ -3,7 +3,7 @@
|
||||
%define cups_ver %(cups-config --api-version)
|
||||
Name: hplip
|
||||
Version: 3.20.11
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A printer driver for HP inkjet devices
|
||||
Group: System/Spooling
|
||||
Vendor: openmamba
|
||||
@ -18,6 +18,7 @@ Patch2: hplip-3.18.12-openmamba-AUTH_TYPES-warning.patch
|
||||
Patch3: hplip-3.16.5-systray-hide-when-inactive.patch
|
||||
Patch4: hplip-3.19.3-Makefile-missing-DESTDIR.patch
|
||||
Patch5: hplip-3.19.6-remove-libImageProcessor.patch
|
||||
Patch6: hplip-3.20.11-ui5-systray-hide-when-inactive.patch
|
||||
License: BSD, LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -44,6 +45,7 @@ BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libnetsnmp-devel >= 5.9-1mamba
|
||||
BuildRequires: gcc-fortran >= 4.0.1
|
||||
BuildRequires: libieee1284-devel
|
||||
BuildRequires: libgphoto-devel
|
||||
@ -94,7 +96,7 @@ This package contains the proprietary plugins needed by some printers.
|
||||
%patch3 -p1
|
||||
#%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%patch6 -p1
|
||||
#sed -i "s|SYSFS{|ATTRS{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules
|
||||
#sed -i "s|sysfs{|ATTR{|g" data/rules/55-hpmud.rules data/rules/56-hpmud_support.rules
|
||||
|
||||
@ -120,19 +122,22 @@ autoreconf -f -i
|
||||
%configure \
|
||||
--enable-qt5 \
|
||||
--disable-qt4 \
|
||||
--enable-foomatic-drv-install \
|
||||
--enable-foomatic-ppd-install \
|
||||
--enable-foomatic-rip-hplip-install \
|
||||
--enable-hpijs-install \
|
||||
--enable-hpcups-install \
|
||||
--enable-cups-drv-install \
|
||||
--enable-cups-ppd-install \
|
||||
--enable-pp-build \
|
||||
--with-hpppddir=%{_datadir}/cups/model/HP \
|
||||
PYTHON=%{__python3}
|
||||
|
||||
# --enable-cups-ppd-install \
|
||||
# \
|
||||
# --disable-foomatic_install
|
||||
%make -j1 rulessystemdir=%{_unitdir}
|
||||
# --enable-foomatic-rip-hplip-install \
|
||||
# --enable-foomatic-drv-install \
|
||||
# --enable-foomatic-ppd-install \
|
||||
# --enable-hpijs-install \
|
||||
|
||||
%make -j1 rulessystemdir=%{_unitdir} \
|
||||
SNMPLIB="netsnmp -DNETSNMP_ATTRIBUTE_DEPRECATED="
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -245,15 +250,12 @@ fi
|
||||
%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%dir %{_sysconfdir}/hp
|
||||
%{_sysconfdir}/hp/hplip.conf
|
||||
#%{_sysconfdir}/cron.daily/hplip_cron
|
||||
%{_bindir}/hp-*
|
||||
%{_bindir}/hpijs
|
||||
#%{_bindir}/hpijs
|
||||
%{_prefix}/lib/cups/backend/hp*
|
||||
%{_prefix}/lib/cups/filter/foomatic-rip-hplip
|
||||
#%{_prefix}/lib/cups/filter/hpcac
|
||||
#%{_prefix}/lib/cups/filter/foomatic-rip-hplip
|
||||
%{_prefix}/lib/cups/filter/hpcups
|
||||
%{_prefix}/lib/cups/filter/hpcupsfax
|
||||
#%{_prefix}/lib/cups/filter/hplipjs
|
||||
%{_prefix}/lib/cups/filter/hpps
|
||||
%{_prefix}/lib/cups/filter/pstotiff
|
||||
%{_unitdir}/hplip-printer@.service
|
||||
@ -261,17 +263,15 @@ fi
|
||||
%{_libdir}/libhpip.so.*
|
||||
%{_libdir}/libhpipp.so.*
|
||||
%{_libdir}/libhpmud.so.*
|
||||
#%{_libdir}/libImageProcessor*.so
|
||||
%{_libdir}/sane/libsane-hpaio.so.*
|
||||
%{_libdir}/sane/libsane-hpaio.so
|
||||
#%{_libdir}/menu/hplip
|
||||
%{python3_sitearch}/*.so
|
||||
%{python3_sitearch}/cupsext.la
|
||||
%{python3_sitearch}/hpmudext.la
|
||||
%{python3_sitearch}/scanext.la
|
||||
%{python3_sitearch}/pcardext.la
|
||||
%{_datadir}/applications/hplip.desktop
|
||||
%{_datadir}/cups/drv/hp/hpijs.drv
|
||||
#%{_datadir}/cups/drv/hp/hpijs.drv
|
||||
%{_datadir}/cups/drv/hp/hpcups.drv
|
||||
%if "%{cups_ver}" == "1.4"
|
||||
%{_sysconfdir}/cups/pstotiff.*
|
||||
@ -284,8 +284,6 @@ fi
|
||||
%{_datadir}/cups/model/HP/*
|
||||
%{_datadir}/hal/fdi/preprobe/10osvendor/20-hplip-devices.fdi
|
||||
%dir %attr(0755,root,lp) /var/lib/hp
|
||||
#%config(noreplace) /var/lib/hp/hplip.state
|
||||
#%dir %attr(0774,root,lp) /var/log/hp
|
||||
%exclude %{_datadir}/hplip/plugin.spec
|
||||
%exclude %{_datadir}/hplip/data/firmware/hp_laserjet_*.fw.gz
|
||||
%exclude %{_datadir}/hplip/fax/plugins/fax_marvell*.so
|
||||
@ -318,6 +316,9 @@ fi
|
||||
%{_localstatedir}/lib/hp/hplip.state
|
||||
|
||||
%changelog
|
||||
* Tue Dec 08 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.20.11-2mamba
|
||||
- rebuilt by autoport with build requirements: libnetsnmp-devel>=5.9-1mamba
|
||||
|
||||
* Sun Dec 06 2020 Automatic Build System <autodist@mambasoft.it> 3.20.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user