automatic version update by autodist [release 1.7.2-1mamba;Sun Feb 11 2024]
This commit is contained in:
parent
5f01852c3c
commit
b0f162af4a
@ -1,10 +0,0 @@
|
||||
--- HandBrake-0.10.1/contrib/ffmpeg/module.defs.orig 2015-03-25 01:09:58.087598099 +0100
|
||||
+++ HandBrake-0.10.1/contrib/ffmpeg/module.defs 2015-03-25 01:10:17.880596870 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
--disable-avdevice \
|
||||
--disable-avfilter \
|
||||
--disable-avserver \
|
||||
+ --disable-inline-asm \
|
||||
--disable-muxers \
|
||||
--disable-network \
|
||||
--disable-hwaccels \
|
@ -1,12 +0,0 @@
|
||||
diff -Nur HandBrake-0.9.5.orig/gtk/configure.ac HandBrake-0.9.5/gtk/configure.ac
|
||||
--- HandBrake-0.9.5.orig/gtk/configure.ac 2011-03-07 13:06:20.333338164 -0800
|
||||
+++ HandBrake-0.9.5/gtk/configure.ac 2011-03-07 13:07:46.346670456 -0800
|
||||
@@ -94,7 +94,7 @@
|
||||
mingw_flag=yes
|
||||
;;
|
||||
*)
|
||||
- GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 libnotify gudev-1.0"
|
||||
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 libnotify gudev-1.0 dbus-glib-1"
|
||||
mingw_flag=no
|
||||
;;
|
||||
esac
|
@ -1,31 +0,0 @@
|
||||
Index: gtk/src/callbacks.c
|
||||
===================================================================
|
||||
--- gtk/src/callbacks.c (revision 3830)
|
||||
+++ gtk/src/callbacks.c (working copy)
|
||||
@@ -39,6 +39,10 @@
|
||||
#endif
|
||||
|
||||
#include <libnotify/notify.h>
|
||||
+#ifndef NOTIFY_CHECK_VERSION
|
||||
+#define NOTIFY_CHECK_VERSION(x,y,z) 0
|
||||
+#endif
|
||||
+
|
||||
#include <gdk/gdkx.h>
|
||||
#else
|
||||
#define WINVER 0x0500
|
||||
@@ -4881,9 +4885,13 @@
|
||||
notification = notify_notification_new(
|
||||
"Encode Complete",
|
||||
"Put down that cocktail, Your HandBrake queue is done!",
|
||||
- "hb-icon",
|
||||
- NULL);
|
||||
+ "hb-icon"
|
||||
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
|
||||
+ );
|
||||
+#else
|
||||
+ ,NULL);
|
||||
notify_notification_attach_to_status_icon(notification, si);
|
||||
+#endif
|
||||
g_signal_connect(notification, "closed", (GCallback)notify_closed_cb, ud);
|
||||
notify_notification_show(notification, NULL);
|
||||
#endif
|
@ -1,61 +0,0 @@
|
||||
From 4d8f5fe1c4b29edfbcc77e4774378e05b38688db Mon Sep 17 00:00:00 2001
|
||||
From: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
Date: Wed, 28 Dec 2022 22:23:50 +0200
|
||||
Subject: [PATCH] LinGUI: fix build with -Werror=format-security
|
||||
|
||||
Add missing format strings where needed.
|
||||
|
||||
Fixes: f6c0971c0042 ("Added XDG color-scheme implementation")
|
||||
Fixes: 3c71841d7716 ("LinGUI: Add warning color to dialog buttons")
|
||||
Fixes: 23f067ef4186 ("LinGUI: Add subtitle and audio track names to queue")
|
||||
---
|
||||
gtk/src/callbacks.c | 2 +-
|
||||
gtk/src/color-scheme.c | 2 +-
|
||||
gtk/src/queuehandler.c | 4 ++--
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/gtk/src/callbacks.c b/gtk/src/callbacks.c
|
||||
index d815e10e2..eed9a4510 100644
|
||||
--- a/gtk/src/callbacks.c
|
||||
+++ b/gtk/src/callbacks.c
|
||||
@@ -3790,7 +3790,7 @@ ghb_title_message_dialog(GtkWindow *parent, GtkMessageType type, const gchar *ti
|
||||
type, GTK_BUTTONS_NONE,
|
||||
"%s", title);
|
||||
if (message)
|
||||
- gtk_message_dialog_format_secondary_text(GTK_MESSAGE_DIALOG(dialog), message);
|
||||
+ gtk_message_dialog_format_secondary_text(GTK_MESSAGE_DIALOG(dialog), "%s", message);
|
||||
|
||||
gtk_dialog_add_buttons(GTK_DIALOG(dialog),
|
||||
no, GTK_RESPONSE_NO,
|
||||
diff --git a/gtk/src/color-scheme.c b/gtk/src/color-scheme.c
|
||||
index 6fbf65e71..0816d6808 100644
|
||||
--- a/gtk/src/color-scheme.c
|
||||
+++ b/gtk/src/color-scheme.c
|
||||
@@ -173,7 +173,7 @@ DesktopColorScheme color_scheme_get_desktop_scheme (void)
|
||||
DBUS_TIMEOUT, NULL, &error);
|
||||
if (!result)
|
||||
{
|
||||
- g_debug(error->message);
|
||||
+ g_debug("%s", error->message);
|
||||
return DESKTOP_NO_PREFERENCE;
|
||||
}
|
||||
|
||||
diff --git a/gtk/src/queuehandler.c b/gtk/src/queuehandler.c
|
||||
index db186fbe3..a2b3e96aa 100644
|
||||
--- a/gtk/src/queuehandler.c
|
||||
+++ b/gtk/src/queuehandler.c
|
||||
@@ -682,12 +682,12 @@ queue_update_summary(GhbValue * queueDict, signal_user_data_t *ud)
|
||||
def = ghb_dict_get_bool(subsettings, "Default");
|
||||
name = ghb_dict_get_string(subsettings, "Name");
|
||||
|
||||
- g_string_append_printf(str, sep);
|
||||
+ g_string_append_printf(str, "%s", sep);
|
||||
if (name)
|
||||
{
|
||||
g_string_append_printf(str, "%s - ", name);
|
||||
}
|
||||
- g_string_append_printf(str, desc);
|
||||
+ g_string_append_printf(str, "%s", desc);
|
||||
free(desc);
|
||||
if (force)
|
||||
{
|
@ -1,33 +0,0 @@
|
||||
From eb0455d64690eed0068e5cb202f72ecdf899837c Mon Sep 17 00:00:00 2001
|
||||
From: Lynne <dev@lynne.ee>
|
||||
Date: Sun, 25 Dec 2022 01:03:30 +0100
|
||||
Subject: [PATCH] hwcontext_vulkan: remove optional encode/decode extensions
|
||||
from the list
|
||||
|
||||
They're not currently used, so they don't need to be there.
|
||||
Vulkan stabilized the decode extensions less than a week ago, and their
|
||||
name prefixes were changed from EXT to KHR. It's a bit too soon to be
|
||||
depending on it, so rather than bumping, just remove these for now.
|
||||
---
|
||||
libavutil/hwcontext_vulkan.c | 8 --------
|
||||
1 file changed, 8 deletions(-)
|
||||
|
||||
diff --git a/libavutil/hwcontext_vulkan.c b/libavutil/hwcontext_vulkan.c
|
||||
index f1db1c7291f1..2a9b5f4aac62 100644
|
||||
--- a/libavutil/hwcontext_vulkan.c
|
||||
+++ b/libavutil/hwcontext_vulkan.c
|
||||
@@ -358,14 +358,6 @@ static const VulkanOptExtension optional_device_exts[] = {
|
||||
{ VK_KHR_EXTERNAL_MEMORY_WIN32_EXTENSION_NAME, FF_VK_EXT_EXTERNAL_WIN32_MEMORY },
|
||||
{ VK_KHR_EXTERNAL_SEMAPHORE_WIN32_EXTENSION_NAME, FF_VK_EXT_EXTERNAL_WIN32_SEM },
|
||||
#endif
|
||||
-
|
||||
- /* Video encoding/decoding */
|
||||
- { VK_KHR_VIDEO_QUEUE_EXTENSION_NAME, FF_VK_EXT_NO_FLAG },
|
||||
- { VK_KHR_VIDEO_DECODE_QUEUE_EXTENSION_NAME, FF_VK_EXT_NO_FLAG },
|
||||
- { VK_KHR_VIDEO_ENCODE_QUEUE_EXTENSION_NAME, FF_VK_EXT_NO_FLAG },
|
||||
- { VK_EXT_VIDEO_ENCODE_H264_EXTENSION_NAME, FF_VK_EXT_NO_FLAG },
|
||||
- { VK_EXT_VIDEO_DECODE_H264_EXTENSION_NAME, FF_VK_EXT_NO_FLAG },
|
||||
- { VK_EXT_VIDEO_DECODE_H265_EXTENSION_NAME, FF_VK_EXT_NO_FLAG },
|
||||
};
|
||||
|
||||
/* Converts return values to strings */
|
@ -1,5 +1,5 @@
|
||||
Name: handbrake
|
||||
Version: 1.6.1
|
||||
Version: 1.7.2
|
||||
Release: 1mamba
|
||||
Summary: An open-source multithreaded video transcoder
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
@ -8,63 +8,40 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://handbrake.fr/
|
||||
Source: https://github.com/HandBrake/HandBrake/releases/download/%{version}/HandBrake-%{version}-source.tar.bz2
|
||||
Source1: handbrake-1.6.0-vulkan-headers-1.3.238.patch
|
||||
Patch0: %{name}-0.9.5-dbus-glib.patch
|
||||
Patch1: %{name}-0.9.5-libnotify-0.7.patch
|
||||
Patch2: handbrake-0.10.1-ffmpeg-disable-inline-asm.patch
|
||||
Patch3: handbrake-1.6.0-fix-build-with-Werror-format-security.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libass-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libenchant1-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libfribidi-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
BuildRequires: libgudev-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libjansson-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: liblame-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libnuma-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libopus-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsoup2-devel
|
||||
BuildRequires: libspeex-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libthai-devel
|
||||
BuildRequires: libtheora-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libvpx6-devel
|
||||
BuildRequires: libwebkit-gtk3-devel
|
||||
BuildRequires: libvpx-devel
|
||||
BuildRequires: libx264-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libvpx-devel >= 1.14.0
|
||||
BuildRequires: intel-gpu-tools
|
||||
|
||||
%description
|
||||
@ -74,12 +51,6 @@ HandBrake is an open-source, GPL-licensed, multithreaded video transcoder.
|
||||
|
||||
%prep
|
||||
%setup -q -n HandBrake-%{version}
|
||||
#%patch0 -p1
|
||||
#%patch1 -p0
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1 -b .fix-build-with-Werror-format-security
|
||||
|
||||
cp %{SOURCE1} contrib/ffmpeg/A31-vulkan-headers.patch
|
||||
|
||||
%build
|
||||
./configure \
|
||||
@ -93,9 +64,7 @@ cd build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
cd build
|
||||
%makeinstall PREFIX=%{_prefix}
|
||||
cd ..
|
||||
%makeinstall -C build PREFIX=%{_prefix}
|
||||
|
||||
%find_lang ghb
|
||||
|
||||
@ -112,6 +81,9 @@ cd ..
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Sun Feb 11 2024 Automatic Build System <autodist@openmamba.org> 1.7.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jan 25 2023 Automatic Build System <autodist@mambasoft.it> 1.6.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user