automatic version update by autodist [release 0.9.9-1mamba;Sun May 19 2013]

This commit is contained in:
Automatic Build System 2024-01-05 23:37:26 +01:00
parent 210a34a0a2
commit 19dd3d2433
4 changed files with 184 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# handbrake
HandBrake is an open-source, GPL-licensed, multithreaded video transcoder.

View File

@ -0,0 +1,12 @@
diff -Nur HandBrake-0.9.5.orig/gtk/configure.ac HandBrake-0.9.5/gtk/configure.ac
--- HandBrake-0.9.5.orig/gtk/configure.ac 2011-03-07 13:06:20.333338164 -0800
+++ HandBrake-0.9.5/gtk/configure.ac 2011-03-07 13:07:46.346670456 -0800
@@ -94,7 +94,7 @@
mingw_flag=yes
;;
*)
- GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 libnotify gudev-1.0"
+ GHB_PACKAGES="gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 libnotify gudev-1.0 dbus-glib-1"
mingw_flag=no
;;
esac

View File

@ -0,0 +1,31 @@
Index: gtk/src/callbacks.c
===================================================================
--- gtk/src/callbacks.c (revision 3830)
+++ gtk/src/callbacks.c (working copy)
@@ -39,6 +39,10 @@
#endif
#include <libnotify/notify.h>
+#ifndef NOTIFY_CHECK_VERSION
+#define NOTIFY_CHECK_VERSION(x,y,z) 0
+#endif
+
#include <gdk/gdkx.h>
#else
#define WINVER 0x0500
@@ -4881,9 +4885,13 @@
notification = notify_notification_new(
"Encode Complete",
"Put down that cocktail, Your HandBrake queue is done!",
- "hb-icon",
- NULL);
+ "hb-icon"
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
+ );
+#else
+ ,NULL);
notify_notification_attach_to_status_icon(notification, si);
+#endif
g_signal_connect(notification, "closed", (GCallback)notify_closed_cb, ud);
notify_notification_show(notification, NULL);
#endif

139
handbrake.spec Normal file
View File

@ -0,0 +1,139 @@
Name: handbrake
Version: 0.9.9
Release: 1mamba
Summary: An open-source multithreaded video transcoder
Group: Graphical Desktop/Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://handbrake.fr/
Source: http://downloads.sourceforge.net/project/handbrake/%{version}/HandBrake-%{version}.tar.bz2
Source1: a52dec-0.7.4.tar.gz
Source2: faac-1.28.tar.gz
Source3: faad2-2.7.tar.gz
Source4: ffmpeg-r25689.tar.bz2
Source5: lame-3.98.tar.gz
Source6: libmkv-0.6.4.1-0-ga80e593.tar.bz2
Source7: mp4v2-trunk-r355.tar.bz2
Source8: libass-0.9.9.tar.bz2
Source9: libogg-1.1.3.tar.gz
Source10: mpeg2dec-0.5.1.tar.gz
Source11: libbluray-0.0.1-pre-16-g1aab213.tar.gz
Source12: libsamplerate-0.1.4.tar.gz
Source13: x264-r1834-a51816a.tar.gz
Source14: libdca-r81-strapped.tar.gz
Source15: libtheora-1.1.0.tar.bz2
Source16: fontconfig-2.8.0.tar.gz
Source17: libdvdnav-svn1168.tar.gz
Source18: libvorbis-aotuv_b5.tar.gz
Source19: freetype-2.3.9.tar.gz
Source20: libdvdread-svn1168.tar.gz
Source21: libxml2-2.7.7.tar.gz
Patch0: %{name}-0.9.5-dbus-glib.patch
Patch1: %{name}-0.9.5-libnotify-0.7.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libenchant-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgcrypt-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libgeoclue-devel
BuildRequires: libGL-devel
BuildRequires: libglib-devel
BuildRequires: libglitz-devel
BuildRequires: libgnutls-devel
BuildRequires: libgpg-error-devel
BuildRequires: libgst-plugins-base-devel
BuildRequires: libgstreamer-devel
BuildRequires: libgtk2-devel
BuildRequires: libICE-devel
BuildRequires: libicu-devel
BuildRequires: libjpeg-devel
BuildRequires: libnotify-devel
BuildRequires: libpango-devel
BuildRequires: libpixman-devel
BuildRequires: libpng-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libselinux-devel
BuildRequires: libSM-devel
BuildRequires: libsoup-devel
BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libtasn1-devel
BuildRequires: libuuid-devel
BuildRequires: libwebkit-gtk-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libxcb-util-devel
BuildRequires: libXcomposite-devel
BuildRequires: libXcursor-devel
BuildRequires: libXdamage-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXinerama-devel
BuildRequires: libxml2-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
BuildRequires: libxslt-devel
BuildRequires: libXt-devel
BuildRequires: libz-devel
BuildRequires: udev-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
HandBrake is an open-source, GPL-licensed, multithreaded video transcoder.
%prep
%setup -q -n HandBrake-%{version}
#%patch0 -p1
#%patch1 -p0
mkdir download
ln -s \
%{S:1} %{S:2} %{S:3} %{S:4} %{S:5} \
%{S:6} %{S:7} %{S:8} %{S:9} %{S:10} \
%{S:11} %{S:12} %{S:13} %{S:14} %{S:15} \
%{S:16} %{S:17} %{S:18} %{S:19} %{S:20} \
%{S:21} \
download/
%build
./configure
cd build
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
cd build
%makeinstall PREFIX=%{_prefix} PREFIX/=%{_prefix}/
#%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/ghb
%{_bindir}/HandBrakeCLI
%{_datadir}/applications/ghb.desktop
%{_datadir}/icons/hicolor/*/apps/hb-icon.png
%doc AUTHORS COPYING CREDITS NEWS THANKS
%changelog
* Sun May 19 2013 Automatic Build System <autodist@mambasoft.it> 0.9.9-1mamba
- automatic version update by autodist
* Mon Aug 15 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.5-1mamba
- package created by autospec