replace wheel with sysadmin group in polkit rules file; added debug package [release 1.52.2-2mamba;Wed Jun 12 2024]

This commit is contained in:
Silvan Calarco 2024-06-13 10:33:27 +02:00
parent 228db8ffec
commit fffed809bc
5 changed files with 7 additions and 147 deletions

View File

@ -1,12 +0,0 @@
diff -Nru gvfs-1.12.2.orig/daemon/gvfsafpvolume.c gvfs-1.12.2/daemon/gvfsafpvolume.c
--- gvfs-1.12.2.orig/daemon/gvfsafpvolume.c 2012-05-15 12:52:00.168703467 +0200
+++ gvfs-1.12.2/daemon/gvfsafpvolume.c 2012-05-15 12:53:59.415382104 +0200
@@ -1082,7 +1082,7 @@
return;
error:
- g_clear_object (info);
+ g_clear_object (&info);
g_simple_async_result_take_error (simple, err);
g_simple_async_result_complete (simple);
g_object_unref (simple);

View File

@ -1,50 +0,0 @@
diff -up gvfs-1.3.2/Makefile.am.archive-integration gvfs-1.3.2/Makefile.am
--- gvfs-1.3.2/Makefile.am.archive-integration 2009-06-25 19:55:39.000000000 -0400
+++ gvfs-1.3.2/Makefile.am 2009-07-13 22:51:52.480693853 -0400
@@ -1,5 +1,19 @@
NULL =
+@INTLTOOL_DESKTOP_RULE@
+
+desktop_in_files = mount-archive.desktop.in
+
+mount-archive.desktop.in: mount-archive.desktop.in.in
+ sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+
+desktopdir = $(datadir)/applications
+if HAVE_ARCHIVE
+desktop_DATA = mount-archive.desktop
+else
+desktop_DATA =
+endif
+
SUBDIRS = \
common \
metadata \
@@ -19,6 +33,8 @@ EXTRA_DIST = \
gvfs.doap \
README.commits \
MAINTAINERS \
+ mount-archive.desktop.in.in \
+ $(desktop_in_files) \
$(NULL)
DISTCLEANFILES = \
diff -up /dev/null gvfs-1.3.2/mount-archive.desktop.in.in
--- /dev/null 2009-07-13 16:21:55.049012465 -0400
+++ gvfs-1.3.2/mount-archive.desktop.in.in 2009-07-13 22:39:14.844931097 -0400
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Encoding=UTF-8
+_Name=Archive Mounter
+Exec=@libexecdir@/gvfsd-archive file=%u
+X-Gnome-Vfs-System=gio
+MimeType=application/x-cd-image;application/x-bzip-compressed-tar;application/x-compressed-tar;application/x-tar;application/x-cpio;application/x-zip;application/zip;application/x-lzma-compressed-tar;application/x-xz-compressed-tar;
+Terminal=false
+StartupNotify=false
+Type=Application
+NoDisplay=true
+X-GNOME-Bugzilla-Bugzilla=GNOME
+X-GNOME-Bugzilla-Product=gvfs
+X-GNOME-Bugzilla-Component=archive-backend
+X-GNOME-Bugzilla-Version=@VERSION@

View File

@ -1,33 +0,0 @@
Not all gphoto drivers implement get storage info (drivers for proprietary
protocols often don't). This patch fixes the gphoto2volumemonitor to still
recognize cams which gphoto driver does not implement get storage info.
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
diff -up gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c~ gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c
--- gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c~ 2009-11-18 13:14:51.000000000 +0100
+++ gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c 2010-01-06 11:46:16.000000000 +0100
@@ -605,7 +605,7 @@ get_stores_for_camera (int bus_num, int
GPContext *context;
GPPortInfo info;
GPPortInfoList *il;
- int num_storage_info, n;
+ int num_storage_info, n, rc;
Camera *camera;
char *port;
guint i;
@@ -637,8 +637,14 @@ get_stores_for_camera (int bus_num, int
goto out;
/* Get information about the storage heads */
- if (gp_camera_get_storageinfo (camera, &storage_info, &num_storage_info, context) != 0)
+ rc = gp_camera_get_storageinfo (camera, &storage_info, &num_storage_info, context);
+ if (rc != 0) {
+ /* Not all gphoto drivers implement get storage info (drivers for proprietary
+ protocols often don't) */
+ if (rc == GP_ERROR_NOT_SUPPORTED)
+ l = g_list_prepend (l, g_strdup ("/"));
goto out;
+ }
/* Append the data to the list */
for (i = 0; i < num_storage_info; i++)

View File

@ -1,17 +0,0 @@
--- gconf/gapplookupgconf.h 2010-11-12 17:17:05.000000000 +0100
+++ gconf/gapplookupgconf.h-gil 2011-03-03 19:26:13.000000000 +0100
@@ -25,7 +25,14 @@
#include <glib-object.h>
#include <gio/gio.h>
+
+#ifdef G_DISABLE_DEPRECATED
+#undef G_DISABLE_DEPRECATED
+#include <gio/gdesktopappinfo.h>
+#define G_DISABLE_DEPRECATED
+#else
#include <gio/gdesktopappinfo.h>
+#endif
G_BEGIN_DECLS

View File

@ -2,7 +2,7 @@
Name: gvfs
Version: 1.52.2
Release: 1mamba
Release: 2mamba
Summary: Backends for the gio framework in GLib
Group: System/Libraries
Vendor: openmamba
@ -10,11 +10,6 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.gnome.org
Source: http://ftp.acc.umu.se/pub/GNOME/sources/gvfs/%{majver}/gvfs-%{version}.tar.xz
# http://bugzilla.gnome.org/show_bug.cgi?id=567235
Patch0: gvfs-1.3.2-archive-integration.patch
Patch1: gvfs-1.5.1-gphoto2-no-storageinfo-support.patch
Patch2: gvfs-1.6.6-glib.patch
Patch3: gvfs-1.12.2-glib-2.32.2.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -65,26 +60,6 @@ Requires(post):libglib
Requires(post):desktop-file-utils
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
# gvfs configuration summary:
# gio module directory : /usr/lib/gio/modules
# hotplug backend: gudev
# FTP/HTTP/WebDAV support yes
# ObexFTP support yes
# Samba support: yes
# FUSE support: yes
# CDDA support: yes
# Gphoto2 support: yes
# archive support: yes
# AFC support: yes
# GConf support: yes
# DNS-SD support: yes
# Build HAL volume monitor: no (with fast init path: no)
# Build GDU volume monitor: yes
# GNOME Keyring support: yes
# Bash-completion support: yes
%description
The gvfs package provides backend implementations for the gio framework in GLib. It includes ftp, sftp, cifs.
@ -106,27 +81,21 @@ Obsoletes: gvfs-devel
The gvfs package provides backend implementations for the gio framework in GLib. It includes ftp, sftp, cifs.
This package contains libraries and header files needed for development.
%debug_package
%prep
%setup -q
#%patch0 -p1 -b .archive-integration
#%patch3 -p1
%build
%meson
#./autogen.sh
#% configure \
# --enable-gdu \
# --enable-afc \
# --with-bash-completion-dir=%{_sysconfdir}/bash_completion.d/
%meson_build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%meson_install
#rm %{buildroot}%{_libdir}/*.la
sed -i "s|wheel|sysadmin|" %{buildroot}%{_datadir}/polkit-1/rules.d/org.gtk.vfs.file-operations.rules
%find_lang %{name}
@ -204,6 +173,9 @@ fi
#%doc ChangeLog ChangeLog.pre-1-2 NEWS README README.commits TODO
%changelog
* Wed Jun 12 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.52.2-2mamba
- replace wheel with sysadmin group in polkit rules file; added debug package
* Sat Jan 06 2024 Automatic Build System <autodist@openmamba.org> 1.52.2-1mamba
- automatic version update by autodist