automatic version update by autodist [release 1.18.3-1mamba;Fri Nov 08 2013]
This commit is contained in:
parent
8c295b3eae
commit
c491c7f063
@ -1,2 +1,4 @@
|
||||
# gvfs
|
||||
|
||||
The gvfs package provides backend implementations for the gio framework in GLib. It includes ftp, sftp, cifs.
|
||||
|
||||
|
12
gvfs-1.12.2-glib-2.32.2.patch
Normal file
12
gvfs-1.12.2-glib-2.32.2.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru gvfs-1.12.2.orig/daemon/gvfsafpvolume.c gvfs-1.12.2/daemon/gvfsafpvolume.c
|
||||
--- gvfs-1.12.2.orig/daemon/gvfsafpvolume.c 2012-05-15 12:52:00.168703467 +0200
|
||||
+++ gvfs-1.12.2/daemon/gvfsafpvolume.c 2012-05-15 12:53:59.415382104 +0200
|
||||
@@ -1082,7 +1082,7 @@
|
||||
return;
|
||||
|
||||
error:
|
||||
- g_clear_object (info);
|
||||
+ g_clear_object (&info);
|
||||
g_simple_async_result_take_error (simple, err);
|
||||
g_simple_async_result_complete (simple);
|
||||
g_object_unref (simple);
|
50
gvfs-1.3.2-archive-integration.patch
Normal file
50
gvfs-1.3.2-archive-integration.patch
Normal file
@ -0,0 +1,50 @@
|
||||
diff -up gvfs-1.3.2/Makefile.am.archive-integration gvfs-1.3.2/Makefile.am
|
||||
--- gvfs-1.3.2/Makefile.am.archive-integration 2009-06-25 19:55:39.000000000 -0400
|
||||
+++ gvfs-1.3.2/Makefile.am 2009-07-13 22:51:52.480693853 -0400
|
||||
@@ -1,5 +1,19 @@
|
||||
NULL =
|
||||
|
||||
+@INTLTOOL_DESKTOP_RULE@
|
||||
+
|
||||
+desktop_in_files = mount-archive.desktop.in
|
||||
+
|
||||
+mount-archive.desktop.in: mount-archive.desktop.in.in
|
||||
+ sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
|
||||
+
|
||||
+desktopdir = $(datadir)/applications
|
||||
+if HAVE_ARCHIVE
|
||||
+desktop_DATA = mount-archive.desktop
|
||||
+else
|
||||
+desktop_DATA =
|
||||
+endif
|
||||
+
|
||||
SUBDIRS = \
|
||||
common \
|
||||
metadata \
|
||||
@@ -19,6 +33,8 @@ EXTRA_DIST = \
|
||||
gvfs.doap \
|
||||
README.commits \
|
||||
MAINTAINERS \
|
||||
+ mount-archive.desktop.in.in \
|
||||
+ $(desktop_in_files) \
|
||||
$(NULL)
|
||||
|
||||
DISTCLEANFILES = \
|
||||
diff -up /dev/null gvfs-1.3.2/mount-archive.desktop.in.in
|
||||
--- /dev/null 2009-07-13 16:21:55.049012465 -0400
|
||||
+++ gvfs-1.3.2/mount-archive.desktop.in.in 2009-07-13 22:39:14.844931097 -0400
|
||||
@@ -0,0 +1,14 @@
|
||||
+[Desktop Entry]
|
||||
+Encoding=UTF-8
|
||||
+_Name=Archive Mounter
|
||||
+Exec=@libexecdir@/gvfsd-archive file=%u
|
||||
+X-Gnome-Vfs-System=gio
|
||||
+MimeType=application/x-cd-image;application/x-bzip-compressed-tar;application/x-compressed-tar;application/x-tar;application/x-cpio;application/x-zip;application/zip;application/x-lzma-compressed-tar;application/x-xz-compressed-tar;
|
||||
+Terminal=false
|
||||
+StartupNotify=false
|
||||
+Type=Application
|
||||
+NoDisplay=true
|
||||
+X-GNOME-Bugzilla-Bugzilla=GNOME
|
||||
+X-GNOME-Bugzilla-Product=gvfs
|
||||
+X-GNOME-Bugzilla-Component=archive-backend
|
||||
+X-GNOME-Bugzilla-Version=@VERSION@
|
33
gvfs-1.5.1-gphoto2-no-storageinfo-support.patch
Normal file
33
gvfs-1.5.1-gphoto2-no-storageinfo-support.patch
Normal file
@ -0,0 +1,33 @@
|
||||
Not all gphoto drivers implement get storage info (drivers for proprietary
|
||||
protocols often don't). This patch fixes the gphoto2volumemonitor to still
|
||||
recognize cams which gphoto driver does not implement get storage info.
|
||||
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
diff -up gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c~ gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c
|
||||
--- gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c~ 2009-11-18 13:14:51.000000000 +0100
|
||||
+++ gvfs-1.5.1/monitor/gphoto2/ggphoto2volumemonitor.c 2010-01-06 11:46:16.000000000 +0100
|
||||
@@ -605,7 +605,7 @@ get_stores_for_camera (int bus_num, int
|
||||
GPContext *context;
|
||||
GPPortInfo info;
|
||||
GPPortInfoList *il;
|
||||
- int num_storage_info, n;
|
||||
+ int num_storage_info, n, rc;
|
||||
Camera *camera;
|
||||
char *port;
|
||||
guint i;
|
||||
@@ -637,8 +637,14 @@ get_stores_for_camera (int bus_num, int
|
||||
goto out;
|
||||
|
||||
/* Get information about the storage heads */
|
||||
- if (gp_camera_get_storageinfo (camera, &storage_info, &num_storage_info, context) != 0)
|
||||
+ rc = gp_camera_get_storageinfo (camera, &storage_info, &num_storage_info, context);
|
||||
+ if (rc != 0) {
|
||||
+ /* Not all gphoto drivers implement get storage info (drivers for proprietary
|
||||
+ protocols often don't) */
|
||||
+ if (rc == GP_ERROR_NOT_SUPPORTED)
|
||||
+ l = g_list_prepend (l, g_strdup ("/"));
|
||||
goto out;
|
||||
+ }
|
||||
|
||||
/* Append the data to the list */
|
||||
for (i = 0; i < num_storage_info; i++)
|
17
gvfs-1.6.6-glib.patch
Normal file
17
gvfs-1.6.6-glib.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- gconf/gapplookupgconf.h 2010-11-12 17:17:05.000000000 +0100
|
||||
+++ gconf/gapplookupgconf.h-gil 2011-03-03 19:26:13.000000000 +0100
|
||||
@@ -25,7 +25,14 @@
|
||||
|
||||
#include <glib-object.h>
|
||||
#include <gio/gio.h>
|
||||
+
|
||||
+#ifdef G_DISABLE_DEPRECATED
|
||||
+#undef G_DISABLE_DEPRECATED
|
||||
+#include <gio/gdesktopappinfo.h>
|
||||
+#define G_DISABLE_DEPRECATED
|
||||
+#else
|
||||
#include <gio/gdesktopappinfo.h>
|
||||
+#endif
|
||||
|
||||
|
||||
G_BEGIN_DECLS
|
306
gvfs.spec
Normal file
306
gvfs.spec
Normal file
@ -0,0 +1,306 @@
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
|
||||
Name: gvfs
|
||||
Version: 1.18.3
|
||||
Release: 1mamba
|
||||
Summary: Backends for the gio framework in GLib
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.gnome.org
|
||||
Source: http://ftp.acc.umu.se/pub/GNOME/sources/gvfs/%{majver}/gvfs-%{version}.tar.xz
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=567235
|
||||
Patch0: gvfs-1.3.2-archive-integration.patch
|
||||
Patch1: gvfs-1.5.1-gphoto2-no-storageinfo-support.patch
|
||||
Patch2: gvfs-1.6.6-glib.patch
|
||||
Patch3: gvfs-1.12.2-glib-2.32.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libacl-devel
|
||||
BuildRequires: libarchive-devel
|
||||
BuildRequires: libattr-devel
|
||||
BuildRequires: libavahi-devel
|
||||
BuildRequires: libavahi-glib-devel
|
||||
BuildRequires: libbluetooth-devel
|
||||
BuildRequires: libbluray-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcdio-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libelf-devel
|
||||
BuildRequires: libexif-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfuse-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgphoto-devel
|
||||
BuildRequires: libimobiledevice-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libplist-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsmbclient-devel
|
||||
BuildRequires: libsoup-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libssp-devel
|
||||
BuildRequires: libusb0-devel
|
||||
BuildRequires: libusbmuxd-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: udev-devel
|
||||
BuildRequires: udisks2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: gettext-devel
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: intltool
|
||||
BuildRequires: libtalloc-devel
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: polkit-devel
|
||||
BuildRequires: libimobiledevice-devel >= 1.1.4
|
||||
BuildRequires: /usr/bin/ssh
|
||||
BuildRequires: udisks2-devel
|
||||
BuildRequires: libbluray-devel
|
||||
BuildRequires: gnome-online-accounts-devel
|
||||
BuildConflicts: hal-devel
|
||||
Requires(post):libglib
|
||||
Requires(post):desktop-file-utils
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
# gvfs configuration summary:
|
||||
|
||||
# gio module directory : /usr/lib/gio/modules
|
||||
|
||||
# hotplug backend: gudev
|
||||
# FTP/HTTP/WebDAV support yes
|
||||
# ObexFTP support yes
|
||||
# Samba support: yes
|
||||
# FUSE support: yes
|
||||
# CDDA support: yes
|
||||
# Gphoto2 support: yes
|
||||
# archive support: yes
|
||||
# AFC support: yes
|
||||
# GConf support: yes
|
||||
# DNS-SD support: yes
|
||||
# Build HAL volume monitor: no (with fast init path: no)
|
||||
# Build GDU volume monitor: yes
|
||||
# GNOME Keyring support: yes
|
||||
# Bash-completion support: yes
|
||||
|
||||
%description
|
||||
The gvfs package provides backend implementations for the gio framework in GLib. It includes ftp, sftp, cifs.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Libraries and headers for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The gvfs package provides backend implementations for the gio framework in GLib. It includes ftp, sftp, cifs.
|
||||
|
||||
This package contains libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1 -b .archive-integration
|
||||
#%patch3 -p1
|
||||
|
||||
%build
|
||||
sed -i "s|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|" configure.ac
|
||||
# for archive-integration.patch
|
||||
libtoolize --force
|
||||
autoreconf
|
||||
#libtoolize --force || :
|
||||
#aclocal || :
|
||||
#autoheader || :
|
||||
#automake || :
|
||||
#autoconf || :
|
||||
%configure \
|
||||
--enable-gdu \
|
||||
--enable-afc \
|
||||
--with-bash-completion-dir=%{_sysconfdir}/bash_completion.d/
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
rm %{buildroot}%{_libdir}/*.la
|
||||
rm %{buildroot}%{_libdir}/gio/modules/*.la
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
killall -USR1 gvfsd >&/dev/null || :
|
||||
if [ $1 -ge 1 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
update-desktop-database &> /dev/null || :
|
||||
# update-gio-modules "$host" &> /dev/null || :
|
||||
fi
|
||||
:
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
if [ $1 -eq 0 ]; then
|
||||
update-desktop-database &> /dev/null ||:
|
||||
# update-gio-modules "$host" &> /dev/null || :
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
|
||||
fi
|
||||
:
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/bash_completion.d/gvfs
|
||||
%{_bindir}/gvfs-cat
|
||||
%{_bindir}/gvfs-copy
|
||||
%{_bindir}/gvfs-info
|
||||
%{_bindir}/gvfs-less
|
||||
%{_bindir}/gvfs-ls
|
||||
%{_bindir}/gvfs-mime
|
||||
%{_bindir}/gvfs-mkdir
|
||||
%{_bindir}/gvfs-monitor-dir
|
||||
%{_bindir}/gvfs-monitor-file
|
||||
%{_bindir}/gvfs-mount
|
||||
%{_bindir}/gvfs-move
|
||||
%{_bindir}/gvfs-open
|
||||
%{_bindir}/gvfs-rename
|
||||
%{_bindir}/gvfs-rm
|
||||
%{_bindir}/gvfs-save
|
||||
%{_bindir}/gvfs-set-attribute
|
||||
%{_bindir}/gvfs-trash
|
||||
%{_bindir}/gvfs-tree
|
||||
#%{_libdir}/gio/modules/libgiogconf.so
|
||||
%{_libdir}/gio/modules/libgioremote-volume-monitor.so
|
||||
%{_libdir}/gio/modules/libgvfsdbus.so
|
||||
#%{_libdir}/libgvfscommon-dnssd.so.*
|
||||
%{_libdir}/libgvfscommon.so.*
|
||||
%{_libexecdir}/gvfs-afc-volume-monitor
|
||||
%{_prefix}/lib/tmpfiles.d/gvfsd-fuse-tmpfiles.conf
|
||||
#%{_libexecdir}/gvfs-fuse-daemon
|
||||
#%{_libexecdir}/gvfs-gdu-volume-monitor
|
||||
%ifarch x86_64
|
||||
%{_libexecdir}/gvfs-goa-volume-monitor
|
||||
%endif
|
||||
%{_libexecdir}/gvfs-gphoto2-volume-monitor
|
||||
%{_libexecdir}/gvfs-udisks2-volume-monitor
|
||||
%{_libexecdir}/gvfsd
|
||||
%{_libexecdir}/gvfsd-afc
|
||||
%{_libexecdir}/gvfsd-afp
|
||||
%{_libexecdir}/gvfsd-afp-browse
|
||||
%{_libexecdir}/gvfsd-archive
|
||||
%{_libexecdir}/gvfsd-burn
|
||||
%{_libexecdir}/gvfsd-cdda
|
||||
%{_libexecdir}/gvfsd-computer
|
||||
%{_libexecdir}/gvfsd-dav
|
||||
%{_libexecdir}/gvfsd-dnssd
|
||||
%{_libexecdir}/gvfsd-ftp
|
||||
%{_libexecdir}/gvfsd-fuse
|
||||
%ifnarch x86_64
|
||||
# FIXME
|
||||
%{_libexecdir}/gvfs-goa-volume-monitor
|
||||
%endif
|
||||
%{_libexecdir}/gvfsd-gphoto2
|
||||
%{_libexecdir}/gvfsd-http
|
||||
%{_libexecdir}/gvfsd-localtest
|
||||
%{_libexecdir}/gvfsd-metadata
|
||||
%{_libexecdir}/gvfs-mtp-volume-monitor
|
||||
%{_libexecdir}/gvfsd-mtp
|
||||
%{_libexecdir}/gvfsd-network
|
||||
%{_libexecdir}/gvfsd-obexftp
|
||||
%{_libexecdir}/gvfsd-recent
|
||||
%{_libexecdir}/gvfsd-sftp
|
||||
%{_libexecdir}/gvfsd-smb
|
||||
%{_libexecdir}/gvfsd-smb-browse
|
||||
%{_libexecdir}/gvfsd-trash
|
||||
#%{_datadir}/applications/mount-archive.desktop
|
||||
%{_datadir}/dbus-1/services/gvfs-*.service
|
||||
%{_datadir}/dbus-1/services/org.gtk.Private.*.service
|
||||
%{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
|
||||
%{_datadir}/GConf/gsettings/gvfs-smb.convert
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.system.*.xml
|
||||
%dir %{_datadir}/gvfs
|
||||
%dir %{_datadir}/gvfs/mounts
|
||||
%{_datadir}/gvfs/mounts/*.mount
|
||||
%dir %{_datadir}/gvfs/remote-volume-monitors
|
||||
%{_datadir}/gvfs/remote-volume-monitors/*.monitor
|
||||
%{_mandir}/man1/gvfs-*.1*
|
||||
%{_mandir}/man1/gvfsd-fuse.1.gz
|
||||
%{_mandir}/man1/gvfsd-metadata.1.gz
|
||||
%{_mandir}/man1/gvfsd.1.gz
|
||||
%{_mandir}/man7/gvfs.7.gz
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/gvfs-client/
|
||||
%dir %{_includedir}/gvfs-client/gvfs
|
||||
%{_includedir}/gvfs-client/gvfs/*.h
|
||||
#%{_libdir}/libgvfscommon-dnssd.so
|
||||
%{_libdir}/libgvfscommon.so
|
||||
#%doc ChangeLog ChangeLog.pre-1-2 NEWS README README.commits TODO
|
||||
|
||||
%changelog
|
||||
* Fri Nov 08 2013 Automatic Build System <autodist@mambasoft.it> 1.18.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Oct 20 2013 Automatic Build System <autodist@mambasoft.it> 1.18.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Jun 14 2013 Automatic Build System <autodist@mambasoft.it> 1.16.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 15 2013 Automatic Build System <autodist@mambasoft.it> 1.16.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 16 2013 Automatic Build System <autodist@mambasoft.it> 1.16.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Mar 31 2013 Automatic Build System <autodist@mambasoft.it> 1.16.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Nov 14 2012 Automatic Build System <autodist@mambasoft.it> 1.14.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 16 2012 Automatic Build System <autodist@mambasoft.it> 1.14.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Sep 28 2012 Automatic Build System <autodist@mambasoft.it> 1.14.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Sep 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.3-3mamba
|
||||
- rebuilt with gnome 3 (updates build requirements)
|
||||
|
||||
* Thu May 31 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.3-2mamba
|
||||
- rebuilt with gnome-disk-utility 2.32 (previously was built with wrong local gnome-disk-utility 3.0)
|
||||
|
||||
* Wed May 23 2012 Automatic Build System <autodist@mambasoft.it> 1.12.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon May 14 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.2-1mamba
|
||||
- update to 1.12.2
|
||||
|
||||
* Mon Oct 17 2011 Automatic Build System <autodist@mambasoft.it> 1.10.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 01 2011 Automatic Build System <autodist@mambasoft.it> 1.10.0-1mamba
|
||||
- update to 1.10.0
|
||||
|
||||
* Tue Sep 20 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.2-2mamba
|
||||
- run glib-compile-schemas in %post and %postun scripts
|
||||
|
||||
* Tue Aug 23 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.2-1mamba
|
||||
- update to 1.8.2
|
||||
|
||||
* Thu Mar 03 2011 gil <puntogil@libero.it> 1.6.6-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user