rebuilt without webkit-gtk3, added patches and specfile cleanups [release 2.1.5-2mamba;Mon Apr 01 2024]
This commit is contained in:
parent
ab03a5dda9
commit
893706fb8d
@ -1,64 +0,0 @@
|
|||||||
diff -ru gtkpod-2.0.2.orig/libgtkpod/file.c gtkpod-2.0.2/libgtkpod/file.c
|
|
||||||
--- gtkpod-2.0.2.orig/libgtkpod/file.c 2011-06-04 15:46:23.000000000 +0200
|
|
||||||
+++ gtkpod-2.0.2/libgtkpod/file.c 2012-05-15 12:10:15.955308873 +0200
|
|
||||||
@@ -395,7 +395,7 @@
|
|
||||||
GDir *dir = g_dir_open(name, 0, NULL);
|
|
||||||
block_widgets();
|
|
||||||
if (dir != NULL) {
|
|
||||||
- G_CONST_RETURN gchar *next;
|
|
||||||
+ const gchar *next;
|
|
||||||
do {
|
|
||||||
next = g_dir_read_name(dir);
|
|
||||||
if (next != NULL) {
|
|
||||||
diff -ru gtkpod-2.0.2.orig/libgtkpod/misc.c gtkpod-2.0.2/libgtkpod/misc.c
|
|
||||||
--- gtkpod-2.0.2.orig/libgtkpod/misc.c 2011-06-04 15:46:23.000000000 +0200
|
|
||||||
+++ gtkpod-2.0.2/libgtkpod/misc.c 2012-05-15 12:09:23.927623088 +0200
|
|
||||||
@@ -161,7 +161,7 @@
|
|
||||||
/* Concats @base_dir and @rel_dir if and only if @rel_dir is not
|
|
||||||
* absolute (does not start with '~' or '/'). Otherwise simply return
|
|
||||||
* a copy of @rel_dir. Must free return value after use */
|
|
||||||
-gchar *concat_dir_if_relative(G_CONST_RETURN gchar *base_dir, G_CONST_RETURN gchar *rel_dir) {
|
|
||||||
+gchar *concat_dir_if_relative(const gchar *base_dir, const gchar *rel_dir) {
|
|
||||||
/* sanity */
|
|
||||||
if (!rel_dir || !*rel_dir)
|
|
||||||
return g_build_filename(base_dir, rel_dir, NULL);
|
|
||||||
diff -ru gtkpod-2.0.2.orig/libgtkpod/misc.h gtkpod-2.0.2/libgtkpod/misc.h
|
|
||||||
--- gtkpod-2.0.2.orig/libgtkpod/misc.h 2012-05-15 12:02:57.580422139 +0200
|
|
||||||
+++ gtkpod-2.0.2/libgtkpod/misc.h 2012-05-15 12:10:03.242385651 +0200
|
|
||||||
@@ -81,9 +80,9 @@
|
|
||||||
void add_new_pl_or_spl_user_name (iTunesDB *itdb, gchar *dflt, gint32 pos);
|
|
||||||
void create_add_files_fileselector (void);
|
|
||||||
void create_add_playlists_fileselector (void);
|
|
||||||
-gchar *concat_dir (G_CONST_RETURN gchar *dir, G_CONST_RETURN gchar *file);
|
|
||||||
-gchar *concat_dir_if_relative (G_CONST_RETURN gchar *base_dir,
|
|
||||||
- G_CONST_RETURN gchar *rel_dir);
|
|
||||||
+gchar *concat_dir (const gchar *dir, const gchar *file);
|
|
||||||
+gchar *concat_dir_if_relative (const gchar *base_dir,
|
|
||||||
+ const gchar *rel_dir);
|
|
||||||
float get_ms_since (GTimeVal *old_time, gboolean update);
|
|
||||||
gint get_sort_tab_number (gchar *text);
|
|
||||||
gboolean parse_tracks_from_string (gchar **s, Track **track);
|
|
||||||
diff -ru gtkpod-2.0.2.orig/libgtkpod/syncdir.c gtkpod-2.0.2/libgtkpod/syncdir.c
|
|
||||||
--- gtkpod-2.0.2.orig/libgtkpod/syncdir.c 2011-06-04 15:46:23.000000000 +0200
|
|
||||||
+++ gtkpod-2.0.2/libgtkpod/syncdir.c 2012-05-15 12:09:03.910743978 +0200
|
|
||||||
@@ -319,7 +319,7 @@
|
|
||||||
if (g_file_test(dirname, G_FILE_TEST_IS_DIR)) {
|
|
||||||
GDir *dir = g_dir_open(dirname, 0, NULL);
|
|
||||||
if (dir != NULL) {
|
|
||||||
- G_CONST_RETURN gchar *next;
|
|
||||||
+ const gchar *next;
|
|
||||||
while ((next = g_dir_read_name(dir))) {
|
|
||||||
gchar *filename = g_build_filename(dirname, next, NULL);
|
|
||||||
FileType *filetype = determine_filetype(filename);
|
|
||||||
diff -ru gtkpod-2.0.2.orig/plugins/photo_editor/display_photo.c gtkpod-2.0.2/plugins/photo_editor/display_photo.c
|
|
||||||
--- gtkpod-2.0.2.orig/plugins/photo_editor/display_photo.c 2011-06-04 15:46:23.000000000 +0200
|
|
||||||
+++ gtkpod-2.0.2/plugins/photo_editor/display_photo.c 2012-05-15 12:10:26.908242724 +0200
|
|
||||||
@@ -1153,7 +1153,7 @@
|
|
||||||
/* Leaf through all the files inside the directory and check if they are image
|
|
||||||
* files. If they are then add them to the database.
|
|
||||||
*/
|
|
||||||
- G_CONST_RETURN gchar *filename;
|
|
||||||
+ const gchar *filename;
|
|
||||||
GPtrArray* filename_arr = g_ptr_array_new();
|
|
||||||
unsigned u;
|
|
||||||
|
|
@ -1,24 +0,0 @@
|
|||||||
Index: gtkpod-2.1.2/src/anjuta-app.c
|
|
||||||
===================================================================
|
|
||||||
--- gtkpod-2.1.2.orig/src/anjuta-app.c
|
|
||||||
+++ gtkpod-2.1.2/src/anjuta-app.c
|
|
||||||
@@ -38,6 +38,7 @@
|
|
||||||
#include <libanjuta/resources.h>
|
|
||||||
#include <libanjuta/anjuta-plugin-manager.h>
|
|
||||||
#include <libanjuta/anjuta-debug.h>
|
|
||||||
+#include <libanjuta/anjuta-version.h>
|
|
||||||
|
|
||||||
#include "anjuta-app.h"
|
|
||||||
#include "anjuta-actions.h"
|
|
||||||
@@ -501,7 +502,11 @@ static void anjuta_app_instance_init(Anj
|
|
||||||
g_list_free(plugins_dirs);
|
|
||||||
|
|
||||||
/* Preferences */
|
|
||||||
+#if ANJUTA_CHECK_VERSION(3,5,3)
|
|
||||||
+ app->preferences = anjuta_preferences_new(app->plugin_manager, PREF_SCHEMA);
|
|
||||||
+#else
|
|
||||||
app->preferences = anjuta_preferences_new(app->plugin_manager);
|
|
||||||
+#endif
|
|
||||||
g_object_add_weak_pointer(G_OBJECT (app->preferences), (gpointer) &app->preferences);
|
|
||||||
|
|
||||||
g_signal_connect(app->settings, "changed::" GDL_STYLE, G_CALLBACK(on_gdl_style_changed), app);
|
|
@ -1,44 +0,0 @@
|
|||||||
Index: gtkpod-2.1.2/src/anjuta-action-callbacks.c
|
|
||||||
===================================================================
|
|
||||||
--- gtkpod-2.1.2.orig/src/anjuta-action-callbacks.c
|
|
||||||
+++ gtkpod-2.1.2/src/anjuta-action-callbacks.c
|
|
||||||
@@ -65,7 +65,7 @@ void
|
|
||||||
on_layout_lock_toggle (GtkAction *action, AnjutaApp *app)
|
|
||||||
{
|
|
||||||
if (app->layout_manager)
|
|
||||||
- g_object_set (app->layout_manager->master, "locked",
|
|
||||||
+ g_object_set (gdl_dock_layout_get_master (app->layout_manager), "locked",
|
|
||||||
gtk_toggle_action_get_active (GTK_TOGGLE_ACTION (action)),
|
|
||||||
NULL);
|
|
||||||
}
|
|
||||||
Index: gtkpod-2.1.2/src/anjuta-app.c
|
|
||||||
===================================================================
|
|
||||||
--- gtkpod-2.1.2.orig/src/anjuta-app.c
|
|
||||||
+++ gtkpod-2.1.2/src/anjuta-app.c
|
|
||||||
@@ -252,7 +252,7 @@ static void on_gdl_style_changed(GSettin
|
|
||||||
else if (g_strcmp0(pr_style, "Tabs") == 0)
|
|
||||||
style = GDL_SWITCHER_STYLE_TABS;
|
|
||||||
|
|
||||||
- g_object_set(G_OBJECT(app->layout_manager->master), "switcher-style", style, NULL);
|
|
||||||
+ g_object_set(G_OBJECT(gdl_dock_layout_get_master (app->layout_manager)), "switcher-style", style, NULL);
|
|
||||||
g_free(pr_style);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -478,14 +478,14 @@ static void anjuta_app_instance_init(Anj
|
|
||||||
gtk_widget_show(app->dock);
|
|
||||||
gtk_box_pack_end(GTK_BOX (hbox), app->dock, TRUE, TRUE, 0);
|
|
||||||
|
|
||||||
- dockbar = gdl_dock_bar_new(GDL_DOCK(app->dock));
|
|
||||||
+ dockbar = gdl_dock_bar_new(G_OBJECT(app->dock));
|
|
||||||
gtk_widget_show(dockbar);
|
|
||||||
gtk_box_pack_start(GTK_BOX (hbox), dockbar, FALSE, FALSE, 0);
|
|
||||||
|
|
||||||
- app->layout_manager = gdl_dock_layout_new(GDL_DOCK (app->dock));
|
|
||||||
+ app->layout_manager = gdl_dock_layout_new(G_OBJECT (app->dock));
|
|
||||||
g_signal_connect (app->layout_manager, "notify::dirty",
|
|
||||||
G_CALLBACK (on_layout_dirty_notify), app);
|
|
||||||
- g_signal_connect (app->layout_manager->master, "notify::locked",
|
|
||||||
+ g_signal_connect (gdl_dock_layout_get_master (app->layout_manager), "notify::locked",
|
|
||||||
G_CALLBACK (on_layout_locked_notify), app);
|
|
||||||
|
|
||||||
/* UI engine */
|
|
185
gtkpod-2.1.5-ducttape.patch
Normal file
185
gtkpod-2.1.5-ducttape.patch
Normal file
@ -0,0 +1,185 @@
|
|||||||
|
diff -ur -x .git gtkpod-2.1.5/libgtkpod/gtkpod_app_iface.c gtkpod-aur/libgtkpod/gtkpod_app_iface.c
|
||||||
|
--- gtkpod-2.1.5/libgtkpod/gtkpod_app_iface.c 2015-06-02 12:14:21.000000000 -0600
|
||||||
|
+++ gtkpod-aur/libgtkpod/gtkpod_app_iface.c 2024-01-31 10:10:49.850838442 -0700
|
||||||
|
@@ -37,6 +37,9 @@
|
||||||
|
#include "context_menus.h"
|
||||||
|
#include "prefs.h"
|
||||||
|
|
||||||
|
+GtkPodApp *gtkpod_app;
|
||||||
|
+guint gtkpod_app_signals[LAST_SIGNAL];
|
||||||
|
+
|
||||||
|
static void gtkpod_app_base_init(GtkPodAppInterface* klass) {
|
||||||
|
static gboolean initialized = FALSE;
|
||||||
|
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/libgtkpod/gtkpod_app_iface.h gtkpod-aur/libgtkpod/gtkpod_app_iface.h
|
||||||
|
--- gtkpod-2.1.5/libgtkpod/gtkpod_app_iface.h 2015-06-02 12:14:21.000000000 -0600
|
||||||
|
+++ gtkpod-aur/libgtkpod/gtkpod_app_iface.h 2024-01-31 10:10:49.850838442 -0700
|
||||||
|
@@ -245,7 +245,7 @@
|
||||||
|
FileType* gtkpod_get_filetype(gchar *name);
|
||||||
|
GList *gtkpod_get_filetypes();
|
||||||
|
|
||||||
|
-GtkPodApp *gtkpod_app;
|
||||||
|
-guint gtkpod_app_signals[LAST_SIGNAL];
|
||||||
|
+extern GtkPodApp *gtkpod_app;
|
||||||
|
+extern guint gtkpod_app_signals[LAST_SIGNAL];
|
||||||
|
|
||||||
|
#endif /* GTKPOD_APP_IFACE_H_ */
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/libgtkpod/misc.c gtkpod-aur/libgtkpod/misc.c
|
||||||
|
--- gtkpod-2.1.5/libgtkpod/misc.c 2015-06-02 12:14:21.000000000 -0600
|
||||||
|
+++ gtkpod-aur/libgtkpod/misc.c 2024-01-31 10:36:40.131731667 -0700
|
||||||
|
@@ -39,6 +39,7 @@
|
||||||
|
#include <sys/wait.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
#include <glib/gi18n-lib.h>
|
||||||
|
+#include <libxml/parser.h>
|
||||||
|
#include "charset.h"
|
||||||
|
#include "clientserver.h"
|
||||||
|
#include "misc.h"
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/core_preferences/plugin.c gtkpod-aur/plugins/core_preferences/plugin.c
|
||||||
|
--- gtkpod-2.1.5/plugins/core_preferences/plugin.c 2015-06-02 12:14:21.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/core_preferences/plugin.c 2024-01-31 10:10:49.864171706 -0700
|
||||||
|
@@ -44,6 +44,8 @@
|
||||||
|
/* Parent class. Part of standard class definition */
|
||||||
|
static gpointer parent_class;
|
||||||
|
|
||||||
|
+CorePrefsPlugin *core_prefs_plugin;
|
||||||
|
+
|
||||||
|
static GtkActionEntry core_prefs_actions[] =
|
||||||
|
{
|
||||||
|
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/core_preferences/plugin.h gtkpod-aur/plugins/core_preferences/plugin.h
|
||||||
|
--- gtkpod-2.1.5/plugins/core_preferences/plugin.h 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/core_preferences/plugin.h 2024-01-31 10:10:49.864171706 -0700
|
||||||
|
@@ -61,6 +61,6 @@
|
||||||
|
AnjutaPluginClass parent_class;
|
||||||
|
};
|
||||||
|
|
||||||
|
-CorePrefsPlugin *core_prefs_plugin;
|
||||||
|
+extern CorePrefsPlugin *core_prefs_plugin;
|
||||||
|
|
||||||
|
#endif /* PLUGIN_H_ */
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/details_editor/plugin.c gtkpod-aur/plugins/details_editor/plugin.c
|
||||||
|
--- gtkpod-2.1.5/plugins/details_editor/plugin.c 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/details_editor/plugin.c 2024-01-31 10:10:49.870838337 -0700
|
||||||
|
@@ -40,6 +40,8 @@
|
||||||
|
/* Parent class. Part of standard class definition */
|
||||||
|
static gpointer parent_class;
|
||||||
|
|
||||||
|
+DetailsEditorPlugin *details_editor_plugin;
|
||||||
|
+
|
||||||
|
static GtkActionEntry details_editor_actions[] =
|
||||||
|
{
|
||||||
|
{
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/details_editor/plugin.h gtkpod-aur/plugins/details_editor/plugin.h
|
||||||
|
--- gtkpod-2.1.5/plugins/details_editor/plugin.h 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/details_editor/plugin.h 2024-01-31 10:10:49.870838337 -0700
|
||||||
|
@@ -52,6 +52,6 @@
|
||||||
|
AnjutaPluginClass parent_class;
|
||||||
|
};
|
||||||
|
|
||||||
|
-DetailsEditorPlugin *details_editor_plugin;
|
||||||
|
+extern DetailsEditorPlugin *details_editor_plugin;
|
||||||
|
|
||||||
|
#endif /* PLUGIN_H_ */
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/info_display/plugin.c gtkpod-aur/plugins/info_display/plugin.c
|
||||||
|
--- gtkpod-2.1.5/plugins/info_display/plugin.c 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/info_display/plugin.c 2024-01-31 10:10:49.874171653 -0700
|
||||||
|
@@ -40,6 +40,8 @@
|
||||||
|
/* Parent class. Part of standard class definition */
|
||||||
|
static gpointer parent_class;
|
||||||
|
|
||||||
|
+InfoDisplayPlugin *info_display_plugin;
|
||||||
|
+
|
||||||
|
static GtkActionEntry info_actions[] =
|
||||||
|
{
|
||||||
|
{
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/info_display/plugin.h gtkpod-aur/plugins/info_display/plugin.h
|
||||||
|
--- gtkpod-2.1.5/plugins/info_display/plugin.h 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/info_display/plugin.h 2024-01-31 10:10:49.874171653 -0700
|
||||||
|
@@ -50,6 +50,6 @@
|
||||||
|
AnjutaPluginClass parent_class;
|
||||||
|
};
|
||||||
|
|
||||||
|
-InfoDisplayPlugin *info_display_plugin;
|
||||||
|
+extern InfoDisplayPlugin *info_display_plugin;
|
||||||
|
|
||||||
|
#endif /* PLUGIN_H_ */
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/photo_editor/plugin.c gtkpod-aur/plugins/photo_editor/plugin.c
|
||||||
|
--- gtkpod-2.1.5/plugins/photo_editor/plugin.c 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/photo_editor/plugin.c 2024-01-31 10:10:49.877504969 -0700
|
||||||
|
@@ -41,6 +41,8 @@
|
||||||
|
/* Parent class. Part of standard class definition */
|
||||||
|
static gpointer parent_class;
|
||||||
|
|
||||||
|
+PhotoEditorPlugin *photo_editor_plugin;
|
||||||
|
+
|
||||||
|
static GtkActionEntry photo_editor_actions[] =
|
||||||
|
{
|
||||||
|
{
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/photo_editor/plugin.h gtkpod-aur/plugins/photo_editor/plugin.h
|
||||||
|
--- gtkpod-2.1.5/plugins/photo_editor/plugin.h 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/photo_editor/plugin.h 2024-01-31 10:10:49.877504969 -0700
|
||||||
|
@@ -59,6 +59,6 @@
|
||||||
|
AnjutaPluginClass parent_class;
|
||||||
|
};
|
||||||
|
|
||||||
|
-PhotoEditorPlugin *photo_editor_plugin;
|
||||||
|
+extern PhotoEditorPlugin *photo_editor_plugin;
|
||||||
|
|
||||||
|
#endif /* PLUGIN_H_ */
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/repository_editor/plugin.c gtkpod-aur/plugins/repository_editor/plugin.c
|
||||||
|
--- gtkpod-2.1.5/plugins/repository_editor/plugin.c 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/repository_editor/plugin.c 2024-01-31 10:10:49.884171601 -0700
|
||||||
|
@@ -40,6 +40,8 @@
|
||||||
|
/* Parent class. Part of standard class definition */
|
||||||
|
static gpointer parent_class;
|
||||||
|
|
||||||
|
+RepositoryEditorPlugin *repository_editor_plugin;
|
||||||
|
+
|
||||||
|
static GtkActionEntry repository_editor_actions[] =
|
||||||
|
{
|
||||||
|
{
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/repository_editor/plugin.h gtkpod-aur/plugins/repository_editor/plugin.h
|
||||||
|
--- gtkpod-2.1.5/plugins/repository_editor/plugin.h 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/repository_editor/plugin.h 2024-01-31 10:10:49.884171601 -0700
|
||||||
|
@@ -51,6 +51,6 @@
|
||||||
|
AnjutaPluginClass parent_class;
|
||||||
|
};
|
||||||
|
|
||||||
|
-RepositoryEditorPlugin *repository_editor_plugin;
|
||||||
|
+extern RepositoryEditorPlugin *repository_editor_plugin;
|
||||||
|
|
||||||
|
#endif /* PLUGIN_H_ */
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/sjcd/plugin.c gtkpod-aur/plugins/sjcd/plugin.c
|
||||||
|
--- gtkpod-2.1.5/plugins/sjcd/plugin.c 2015-06-02 12:14:21.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/sjcd/plugin.c 2024-01-31 12:10:20.581848356 -0700
|
||||||
|
@@ -43,6 +43,8 @@
|
||||||
|
#define PREFERENCE_ICON_STOCK_ID "sjcd-preference-icon"
|
||||||
|
#define TAB_NAME _("Sound Juicer")
|
||||||
|
|
||||||
|
+SJCDPlugin *sjcd_plugin;
|
||||||
|
+
|
||||||
|
/* Parent class. Part of standard class definition */
|
||||||
|
static gpointer parent_class;
|
||||||
|
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/plugins/sjcd/plugin.h gtkpod-aur/plugins/sjcd/plugin.h
|
||||||
|
--- gtkpod-2.1.5/plugins/sjcd/plugin.h 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/plugins/sjcd/plugin.h 2024-01-31 12:12:21.926064288 -0700
|
||||||
|
@@ -59,7 +59,7 @@
|
||||||
|
AnjutaPluginClass parent_class;
|
||||||
|
};
|
||||||
|
|
||||||
|
-SJCDPlugin *sjcd_plugin;
|
||||||
|
+extern SJCDPlugin *sjcd_plugin;
|
||||||
|
|
||||||
|
gchar* sjcd_plugin_get_builder_file();
|
||||||
|
|
||||||
|
diff -ur -x .git gtkpod-2.1.5/scripts/sync-palm-jppy.py gtkpod-aur/scripts/sync-palm-jppy.py
|
||||||
|
--- gtkpod-2.1.5/scripts/sync-palm-jppy.py 2014-08-29 13:58:58.000000000 -0600
|
||||||
|
+++ gtkpod-aur/scripts/sync-palm-jppy.py 2024-01-31 10:10:49.900838181 -0700
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python2
|
||||||
|
# Script for syncing Palm addressbook data with iPod via Jppy
|
||||||
|
# (c) 2005 Nick Piper <nick at nickpiper dot co dot uk>
|
||||||
|
#
|
148
gtkpod.spec
148
gtkpod.spec
@ -1,117 +1,75 @@
|
|||||||
Name: gtkpod
|
Name: gtkpod
|
||||||
Version: 2.1.5
|
Version: 2.1.5
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A platform independent GUI for Apple's iPod using GTK2
|
Summary: A platform independent GUI for Apple's iPod using GTK2
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.gtkpod.org
|
URL: https://www.prosite.de/
|
||||||
Source: http://downloads.sourceforge.net/sourceforge/gtkpod/%{name}-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/sourceforge/gtkpod/%{name}-%{version}.tar.gz
|
||||||
Source1: gtkpod.png
|
Source1: gtkpod.png
|
||||||
Patch0: %{name}-2.0.2-remove_deprecated_G_CONST_RETURN.patch
|
Patch0: gtkpod-2.1.5-ducttape.patch
|
||||||
Patch1: gtkpod-2.1.2-anjuta-3.6.patch
|
|
||||||
Patch2: gtkpod-2.1.3-libgdl-3.6.2.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: anjuta-devel
|
BuildRequires: anjuta-devel
|
||||||
BuildRequires: brasero-devel
|
BuildRequires: brasero-devel
|
||||||
BuildRequires: clutter-gtk-devel
|
BuildRequires: clutter-gtk-devel
|
||||||
BuildRequires: faad2
|
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libatk-devel
|
|
||||||
BuildRequires: libat-spi2-atk-devel
|
|
||||||
BuildRequires: libat-spi2-core-devel
|
|
||||||
BuildRequires: libbzip2-devel
|
|
||||||
BuildRequires: libcairo-devel
|
|
||||||
BuildRequires: libcares-devel
|
|
||||||
BuildRequires: libclutter-devel
|
|
||||||
BuildRequires: libcogl-devel
|
|
||||||
BuildRequires: libcurl-devel
|
|
||||||
BuildRequires: libdbus-devel
|
|
||||||
BuildRequires: libdbus-glib-devel
|
|
||||||
BuildRequires: libdrm-devel
|
|
||||||
BuildRequires: libenchant-devel
|
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libffi-devel
|
|
||||||
BuildRequires: libflac-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
|
||||||
BuildRequires: libfreetype-devel
|
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libgcrypt-devel
|
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
|
||||||
BuildRequires: libgdl-devel
|
|
||||||
BuildRequires: libgeoclue-devel
|
|
||||||
BuildRequires: libGL-devel
|
|
||||||
BuildRequires: libglib-devel
|
|
||||||
BuildRequires: libgpg-error-devel
|
|
||||||
BuildRequires: libgpod-devel
|
|
||||||
BuildRequires: libgraphite2-devel
|
|
||||||
BuildRequires: libgss-devel
|
|
||||||
BuildRequires: libgst-plugins-base010-devel
|
|
||||||
BuildRequires: libgstreamer010-devel
|
|
||||||
BuildRequires: libgtk-devel
|
|
||||||
BuildRequires: libharfbuzz-devel
|
|
||||||
BuildRequires: libICE-devel
|
|
||||||
BuildRequires: libicu-devel
|
|
||||||
BuildRequires: libid3tag-devel
|
|
||||||
BuildRequires: libidn-devel
|
|
||||||
BuildRequires: libimobiledevice-devel
|
|
||||||
BuildRequires: libjpeg-devel
|
|
||||||
BuildRequires: libjson-glib-devel
|
|
||||||
BuildRequires: liblzma-devel
|
|
||||||
BuildRequires: libmusicbrainz-devel
|
|
||||||
BuildRequires: libogg-devel
|
|
||||||
BuildRequires: libopenldap-devel
|
|
||||||
BuildRequires: libopenssl-devel
|
|
||||||
BuildRequires: libpango-devel
|
|
||||||
BuildRequires: libpixman-devel
|
|
||||||
BuildRequires: libplist-devel
|
|
||||||
BuildRequires: libpng-devel
|
|
||||||
BuildRequires: libpthread-stubs-devel
|
|
||||||
BuildRequires: librtmp-devel
|
|
||||||
BuildRequires: libsasl-devel
|
|
||||||
BuildRequires: libselinux-devel
|
|
||||||
BuildRequires: libSM-devel
|
|
||||||
BuildRequires: libsoup-devel
|
|
||||||
BuildRequires: libsqlite-devel
|
|
||||||
BuildRequires: libssh2-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
|
||||||
BuildRequires: libusbmuxd-devel
|
|
||||||
BuildRequires: libuuid-devel
|
|
||||||
BuildRequires: libvorbis-devel
|
|
||||||
BuildRequires: libwebkit-gtk3-devel
|
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXau-devel
|
|
||||||
BuildRequires: libxcb-devel
|
|
||||||
BuildRequires: libXcomposite-devel
|
BuildRequires: libXcomposite-devel
|
||||||
BuildRequires: libXcursor-devel
|
|
||||||
BuildRequires: libXdamage-devel
|
BuildRequires: libXdamage-devel
|
||||||
BuildRequires: libXdmcp-devel
|
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libXfixes-devel
|
BuildRequires: libXfixes-devel
|
||||||
BuildRequires: libXi-devel
|
BuildRequires: libXi-devel
|
||||||
BuildRequires: libXinerama-devel
|
|
||||||
BuildRequires: libxml2-devel
|
|
||||||
BuildRequires: libXrandr-devel
|
BuildRequires: libXrandr-devel
|
||||||
BuildRequires: libXrender-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
BuildRequires: libxslt-devel
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: libXt-devel
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libcap-devel
|
||||||
|
BuildRequires: libclutter-devel
|
||||||
|
BuildRequires: libcogl-devel
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
BuildRequires: libdiscid-devel
|
||||||
|
BuildRequires: libdrm-devel
|
||||||
|
BuildRequires: libdw-devel
|
||||||
|
BuildRequires: libflac-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libgdl-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
|
BuildRequires: libgpod-devel
|
||||||
|
BuildRequires: libgraphite2-devel
|
||||||
|
BuildRequires: libgst-plugins-base-devel
|
||||||
|
BuildRequires: libgstreamer-devel
|
||||||
|
BuildRequires: libgtk3-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
|
BuildRequires: libid3tag-devel
|
||||||
|
BuildRequires: libjson-glib-devel
|
||||||
|
BuildRequires: libmesa-devel
|
||||||
|
BuildRequires: libmtdev-devel
|
||||||
|
BuildRequires: libmusicbrainz-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpcre-devel
|
||||||
|
BuildRequires: libperl
|
||||||
|
BuildRequires: libselinux-devel
|
||||||
|
BuildRequires: libsepol-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libthai-devel
|
||||||
|
BuildRequires: libvorbis-devel
|
||||||
|
BuildRequires: libwayland-devel
|
||||||
|
BuildRequires: libwayland-egl-devel
|
||||||
|
BuildRequires: libxkbcommon-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: perl-devel
|
BuildRequires: perl-devel
|
||||||
BuildRequires: pkg-config
|
|
||||||
BuildRequires: udev-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libplist-devel >= 1.11-1mamba
|
BuildConflicts: libwebkit-gtk3-devel
|
||||||
BuildRequires: glib-gettextize >= 2.6.6
|
|
||||||
BuildRequires: libgdk-pixbuf-devel >= 0.22.0
|
|
||||||
BuildRequires: libglitz-devel >= 0.4.4
|
|
||||||
BuildRequires: faad2
|
BuildRequires: faad2
|
||||||
BuildRequires: libgeoclue-devel
|
BuildRequires: libgeoclue-devel
|
||||||
BuildRequires: libcogl-devel >= 1.18
|
|
||||||
BuildRequires: rhythmbox-devel
|
BuildRequires: rhythmbox-devel
|
||||||
Requires: faad2
|
Requires: faad2
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
gtkpod is a platform independent Graphical User Interface for Apple's iPod using GTK2. It supports the first to fourth Generation as well as the iPod mini, iPod Photo and the iPod shuffle.
|
gtkpod is a platform independent Graphical User Interface for Apple's iPod using GTK2. It supports the first to fourth Generation as well as the iPod mini, iPod Photo and the iPod shuffle.
|
||||||
@ -125,13 +83,13 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description devel
|
%description devel
|
||||||
gtkpod is a platform independent Graphical User Interface for Apple's iPod using GTK2. It supports the first to fourth Generation as well as the iPod mini, iPod Photo and the iPod shuffle.
|
gtkpod is a platform independent Graphical User Interface for Apple's iPod using GTK2. It supports the first to fourth Generation as well as the iPod mini, iPod Photo and the iPod shuffle.
|
||||||
The new iPod nano is supported as well, but you need to call 'File->Create iPod's Directories' once before syncing.
|
The new iPod nano is supported as well, but you need to call 'File->Create iPod's Directories' once before syncing.
|
||||||
|
This package contains libraries and header files needed for development.
|
||||||
|
|
||||||
This package contains libraries and header files need for development.
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch1 -p1
|
%patch 0 -p1 -b .ducttape
|
||||||
#%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -173,9 +131,8 @@ EOF
|
|||||||
%{_libdir}/libatomicparsley.so.*
|
%{_libdir}/libatomicparsley.so.*
|
||||||
%{_libdir}/gtkpod/*.plugin
|
%{_libdir}/gtkpod/*.plugin
|
||||||
%{_libdir}/gtkpod/lib*.a
|
%{_libdir}/gtkpod/lib*.a
|
||||||
%{_libdir}/gtkpod/lib*.la
|
|
||||||
%{_libdir}/gtkpod/lib*.so
|
%{_libdir}/gtkpod/lib*.so
|
||||||
%{_datadir}/gtkpod/data/*.png
|
%{_datadir}/gtkpod/data/*
|
||||||
%{_datadir}/icons/hicolor/*/apps/gtkpod.png
|
%{_datadir}/icons/hicolor/*/apps/gtkpod.png
|
||||||
%{_datadir}/icons/hicolor/scalable/apps/gtkpod.svg
|
%{_datadir}/icons/hicolor/scalable/apps/gtkpod.svg
|
||||||
%{_datadir}/pixmaps/gtkpod.png
|
%{_datadir}/pixmaps/gtkpod.png
|
||||||
@ -194,10 +151,8 @@ EOF
|
|||||||
%{_datadir}/gtkpod/data/dock-layout.xml
|
%{_datadir}/gtkpod/data/dock-layout.xml
|
||||||
%{_datadir}/gtkpod/data/glade/*.xml
|
%{_datadir}/gtkpod/data/glade/*.xml
|
||||||
%{_datadir}/gtkpod/data/ui/*.ui
|
%{_datadir}/gtkpod/data/ui/*.ui
|
||||||
#%{_datadir}/gtkpod/data/rhythmbox.gep
|
%{_datadir}/glib-2.0/schemas/org.gtkpod.*gschema.xml
|
||||||
%{_datadir}/glib-2.0/schemas/org.gtkpod.gschema.xml
|
%{_mandir}/man1/gtkpod.1*
|
||||||
#%{_datadir}/glib-2.0/schemas/org.gtkpod.sjcd.gschema.xml
|
|
||||||
%{_mandir}/man1/gtkpod.1.gz
|
|
||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
@ -206,10 +161,8 @@ EOF
|
|||||||
%dir %{_includedir}/gtkpod/gtkpod
|
%dir %{_includedir}/gtkpod/gtkpod
|
||||||
%{_includedir}/gtkpod/gtkpod/*.h
|
%{_includedir}/gtkpod/gtkpod/*.h
|
||||||
%{_libdir}/libgtkpod.a
|
%{_libdir}/libgtkpod.a
|
||||||
%{_libdir}/libgtkpod.la
|
|
||||||
%{_libdir}/libgtkpod.so
|
%{_libdir}/libgtkpod.so
|
||||||
%{_libdir}/libatomicparsley.a
|
%{_libdir}/libatomicparsley.a
|
||||||
%{_libdir}/libatomicparsley.la
|
|
||||||
%{_libdir}/libatomicparsley.so
|
%{_libdir}/libatomicparsley.so
|
||||||
%{_libdir}/pkgconfig/libgtkpod-1.1.0.pc
|
%{_libdir}/pkgconfig/libgtkpod-1.1.0.pc
|
||||||
%dir %{_datadir}/gtkpod/doc
|
%dir %{_datadir}/gtkpod/doc
|
||||||
@ -217,6 +170,9 @@ EOF
|
|||||||
%doc ChangeLog NEWS README
|
%doc ChangeLog NEWS README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 01 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.5-2mamba
|
||||||
|
- rebuilt without webkit-gtk3, added patches and specfile cleanups
|
||||||
|
|
||||||
* Sat Jun 06 2015 Automatic Build System <autodist@mambasoft.it> 2.1.5-1mamba
|
* Sat Jun 06 2015 Automatic Build System <autodist@mambasoft.it> 2.1.5-1mamba
|
||||||
- automatic update by autodist
|
- automatic update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user