gtk-vnc/gtk-vnc.spec

186 lines
5.7 KiB
RPMSpec

%define majver %(echo %version | cut -d. -f 1-2)
Name: gtk-vnc
Version: 1.3.1
Release: 1mamba
Summary: A VNC viewer widget for GTK
Group: Development/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://wiki.gnome.org/Projects/gtk-vnc
Source: https://download.gnome.org/sources/gtk-vnc/%{majver}/gtk-vnc-%{version}.tar.xz
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libX11-devel
BuildRequires: libcairo-devel
BuildRequires: libgcrypt-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgnutls-devel
BuildRequires: libgtk3-devel
BuildRequires: libpulseaudio-devel
BuildRequires: libsasl2-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libpulseaudio-devel >= 8.0-1mamba
Provides: python-gtk-vnc
Obsoletes: python-gtk-vnc < 1.3.0
%description
gtk-vnc is a VNC viewer widget for GTK.
It is built using coroutines allowing it to be completely asynchronous while remaining single threaded.
It provides a core C library, and bindings for Python (PyGTK).
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
gtk-vnc is a VNC viewer widget for GTK.
It is built using coroutines allowing it to be completely asynchronous while remaining single threaded.
It provides a core C library, and bindings for Python (PyGTK).
This package contains static libraries and header files needed for development.
%package -n python-gtk-vnc
Summary: Python bindings for the gtk-vnc library
Group: Development/Libraries/Python
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n python-gtk-vnc
gtk-vnc is a VNC viewer widget for GTK.
It is built using coroutines allowing it to be completely asynchronous while remaining single threaded.
It provides a core C library, and bindings for Python (PyGTK).
This package contains a module allowing use of the GTK-VNC widget from python.
%debug_package
%prep
%setup -q
%build
%meson
%meson_build
#tar xf %{S:0}
#mv %{name}-%{version} gtk2-build
#cd gtk2-build
#% configure --with-python --with-gtk=2.0 --disable-static
#cd ..
#
#% configure \
# --with-gtk=3.0 \
# --with-python
#
##--enable-plugin=yes
#% make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%meson_install
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/gvnccapture
%{_libdir}/libgtk-vnc*.so.*
%{_libdir}/libgvnc-1.0.so.*
%{_libdir}/libgvncpulse-1.0.so.*
%{_libdir}/girepository-1.0/GVnc-1.0.typelib
%{_libdir}/girepository-1.0/GVncPulse-1.0.typelib
%{_libdir}/girepository-1.0/GtkVnc-*.typelib
%{_mandir}/man1/gvnccapture.1*
%doc AUTHORS COPYING.LIB
%files devel
%defattr(-,root,root)
%dir %{_includedir}/gtk-vnc-*/
%{_includedir}/gtk-vnc-*/*.h
%dir %{_includedir}/gvnc-1.0
%{_includedir}/gvnc-1.0/*.h
%dir %{_includedir}/gvncpulse-1.0
%{_includedir}/gvncpulse-1.0/*.h
%{_libdir}/libgtk-vnc*.so
%{_libdir}/libgvnc-1.0.so
%{_libdir}/libgvncpulse-1.0.so
%{_datadir}/gir-1.0/GVnc-1.0.gir
%{_datadir}/gir-1.0/GVncPulse-1.0.gir
%{_datadir}/gir-1.0/GtkVnc-*.gir
%{_datadir}/vala/vapi/*.deps
%{_datadir}/vala/vapi/*.vapi
%{_libdir}/pkgconfig/gtk-vnc-*.pc
%{_libdir}/pkgconfig/gvnc-1.0.pc
%{_libdir}/pkgconfig/gvncpulse-1.0.pc
#%doc ChangeLog NEWS README
#%files -n python-gtk-vnc
#%defattr(-, root, root)
#%{python_sitearch}/gtkvnc.la
#%{python_sitearch}/gtkvnc.so
##%doc examples/gvncviewer.py
%changelog
* Sun Jul 31 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1-1mamba
- update to 1.3.1
* Thu Nov 18 2021 Automatic Build System <autodist@mambasoft.it> 1.3.0-1mamba
- automatic version update by autodist
* Wed Apr 14 2021 Automatic Build System <autodist@mambasoft.it> 1.2.0-1mamba
- automatic version update by autodist
* Sat Aug 17 2019 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
- automatic version update by autodist
* Fri Aug 17 2018 Automatic Build System <autodist@mambasoft.it> 0.9.0-1mamba
- automatic version update by autodist
* Sat Aug 04 2018 Automatic Build System <autodist@mambasoft.it> 0.8.0-1mamba
- automatic version update by autodist
* Fri Mar 23 2018 Automatic Build System <autodist@mambasoft.it> 0.7.2-1mamba
- automatic version update by autodist
* Sat May 20 2017 Automatic Build System <autodist@mambasoft.it> 0.7.1-1mamba
- automatic version update by autodist
* Sat Feb 11 2017 Automatic Build System <autodist@mambasoft.it> 0.7.0-1mamba
- automatic version update by autodist
* Tue Aug 23 2016 Automatic Build System <autodist@mambasoft.it> 0.6.0-1mamba
- automatic version update by autodist
* Sat Apr 02 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.4-3mamba
- rebuilt by autoport with build requirements: libpulseaudio-devel>=8.0-1mamba
* Mon Oct 05 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.4-2mamba
- rebuilt with gtk2 version for python binding
* Sun Apr 19 2015 Automatic Build System <autodist@mambasoft.it> 0.5.4-1mamba
- automatic version update by autodist
* Tue May 20 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-2mamba
- rebuilt with gtk 3.0
* Mon Oct 28 2013 Automatic Build System <autodist@mambasoft.it> 0.5.3-1mamba
- automatic version update by autodist
* Fri Mar 01 2013 Automatic Build System <autodist@mambasoft.it> 0.5.2-1mamba
- automatic version update by autodist
* Wed Oct 24 2012 Automatic Build System <autodist@mambasoft.it> 0.5.1-1mamba
- update to 0.5.1
* Thu Mar 25 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.3.10-1mamba
- package created by autospec