rebuilt with mono 2 [release 2.12.10-5mamba;Mon Sep 16 2013]
This commit is contained in:
parent
d03efbb1d1
commit
04c14cfdb4
@ -1,2 +1,10 @@
|
||||
# gtk-sharp2
|
||||
|
||||
Gtk#, a GUI Toolkit, is a set of .NET bindings for the gtk+ (http://www.gtk.org/) toolkit and assorted GNOME (http://www.gnome.org/) libraries.
|
||||
This library allows you to build fully native graphical Gnome application using Mono.
|
||||
GTK# is an event-driven system like any other modern windowing library.
|
||||
Every widget in an application has handler methods that get called when particular events happen.
|
||||
|
||||
Applications built using Gtk# will run on many platforms including Linux, Windows and MacOS X.
|
||||
Gtk is the native toolkit for the Linux desktop running GNOME, so applications will look and function best on here.
|
||||
|
||||
|
30
gtk-sharp-2.10.1-fix_doc.patch
Normal file
30
gtk-sharp-2.10.1-fix_doc.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- gtk-sharp-2.8.2/doc/en/index.xml.docfix 2006-02-28 19:15:21.000000000 +0100
|
||||
+++ gtk-sharp-2.8.2/doc/en/index.xml 2006-09-11 13:54:08.000000000 +0200
|
||||
@@ -1238,9 +1238,6 @@
|
||||
<Type Name="MimeEquivalence" />
|
||||
<Type Name="ModuleCallbackFullAuthenticationOutFlags" />
|
||||
</Namespace>
|
||||
- <Namespace Name="GtkSharp.GnomeVfsSharp">
|
||||
- <Type Name="ObjectManager" />
|
||||
- </Namespace>
|
||||
<Namespace Name="Art">
|
||||
<Type Name="Affine" />
|
||||
<Type Name="AlphaGamma" />
|
||||
@@ -1470,9 +1467,6 @@
|
||||
<Type Name="Authentication" />
|
||||
<Type Name="PrintSvg" />
|
||||
</Namespace>
|
||||
- <Namespace Name="GtkSharp.GnomeSharp">
|
||||
- <Type Name="ObjectManager" />
|
||||
- </Namespace>
|
||||
<Namespace Name="GConf">
|
||||
<Type Name="ClientBase" />
|
||||
<Type Name="Client" />
|
||||
--- gtk-sharp-2.8.2/doc/gtk-sharp-docs.source.docfix 2003-04-15 00:58:01.000000000 +0200
|
||||
+++ gtk-sharp-2.8.2/doc/gtk-sharp-docs.source 2006-09-11 13:53:35.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
<?xml version="1.0"?>
|
||||
<monodoc>
|
||||
- <source provider="ecma" basefile="gtk-sharp-docs" path="classlib-gnome"/>
|
||||
+ <source provider="ecma-uncompiled" basefile="gtk-sharp-docs" path="classlib-gnome"/>
|
||||
</monodoc>
|
161
gtk-sharp-2.12.10-glib-2.34.patch
Normal file
161
gtk-sharp-2.12.10-glib-2.34.patch
Normal file
@ -0,0 +1,161 @@
|
||||
diff -Naur glue.new/list.c glue/list.c
|
||||
--- glue.new/list.c 2009-01-08 02:54:06.000000000 +1000
|
||||
+++ glue/list.c 2012-12-10 16:57:37.901364140 +1000
|
||||
@@ -20,7 +20,7 @@
|
||||
*/
|
||||
|
||||
|
||||
-#include <glib/glist.h>
|
||||
+#include <glib.h>
|
||||
|
||||
/* Forward declarations */
|
||||
gpointer gtksharp_list_get_data (GList *l);
|
||||
diff -Naur glue.new/list.c~ glue/list.c~
|
||||
--- glue.new/list.c~ 1970-01-01 10:00:00.000000000 +1000
|
||||
+++ glue/list.c~ 2012-12-10 16:57:37.891364197 +1000
|
||||
@@ -0,0 +1,40 @@
|
||||
+/* list.c : Glue to access fields in GList.
|
||||
+ *
|
||||
+ * Author: Rachel Hestilow <hestilow@ximian.com>
|
||||
+ *
|
||||
+ * Copyright (c) 2002 Rachel Hestilow, Mike Kestner
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or
|
||||
+ * modify it under the terms of version 2 of the Lesser GNU General
|
||||
+ * Public License as published by the Free Software Foundation.
|
||||
+ *
|
||||
+ * This program is distributed in the hope that it will be useful,
|
||||
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ * Lesser General Public License for more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU Lesser General Public
|
||||
+ * License along with this program; if not, write to the
|
||||
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Boston, MA 02111-1307, USA.
|
||||
+ */
|
||||
+
|
||||
+
|
||||
+#include <glib/glist.h>
|
||||
+
|
||||
+/* Forward declarations */
|
||||
+gpointer gtksharp_list_get_data (GList *l);
|
||||
+GList *gtksharp_list_get_next (GList *l);
|
||||
+/* */
|
||||
+
|
||||
+gpointer
|
||||
+gtksharp_list_get_data (GList *l)
|
||||
+{
|
||||
+ return l->data;
|
||||
+}
|
||||
+
|
||||
+GList*
|
||||
+gtksharp_list_get_next (GList *l)
|
||||
+{
|
||||
+ return l->next;
|
||||
+}
|
||||
diff -Naur glue.new/slist.c glue/slist.c
|
||||
--- glue.new/slist.c 2009-01-08 02:54:06.000000000 +1000
|
||||
+++ glue/slist.c 2012-12-10 16:57:46.371342245 +1000
|
||||
@@ -20,7 +20,7 @@
|
||||
*/
|
||||
|
||||
|
||||
-#include <glib/gslist.h>
|
||||
+#include <glib.h>
|
||||
|
||||
/* Forward declarations */
|
||||
gpointer gtksharp_slist_get_data (GSList *l);
|
||||
diff -Naur glue.new/slist.c~ glue/slist.c~
|
||||
--- glue.new/slist.c~ 1970-01-01 10:00:00.000000000 +1000
|
||||
+++ glue/slist.c~ 2012-12-10 16:57:46.361342225 +1000
|
||||
@@ -0,0 +1,41 @@
|
||||
+/* slist.c : Glue to access fields in GSList.
|
||||
+ *
|
||||
+ * Author: Rachel Hestilow <hestilow@ximian.com>
|
||||
+ *
|
||||
+ * Copyright (c) 2002 Rachel Hestilow, Mike Kestner
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or
|
||||
+ * modify it under the terms of version 2 of the Lesser GNU General
|
||||
+ * Public License as published by the Free Software Foundation.
|
||||
+ *
|
||||
+ * This program is distributed in the hope that it will be useful,
|
||||
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ * Lesser General Public License for more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU Lesser General Public
|
||||
+ * License along with this program; if not, write to the
|
||||
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Boston, MA 02111-1307, USA.
|
||||
+ */
|
||||
+
|
||||
+
|
||||
+#include <glib/gslist.h>
|
||||
+
|
||||
+/* Forward declarations */
|
||||
+gpointer gtksharp_slist_get_data (GSList *l);
|
||||
+
|
||||
+GSList *gtksharp_slist_get_next (GSList *l);
|
||||
+/* */
|
||||
+
|
||||
+gpointer
|
||||
+gtksharp_slist_get_data (GSList *l)
|
||||
+{
|
||||
+ return l->data;
|
||||
+}
|
||||
+
|
||||
+GSList*
|
||||
+gtksharp_slist_get_next (GSList *l)
|
||||
+{
|
||||
+ return l->next;
|
||||
+}
|
||||
diff -Naur glue.new/thread.c glue/thread.c
|
||||
--- glue.new/thread.c 2009-01-08 02:54:06.000000000 +1000
|
||||
+++ glue/thread.c 2012-12-10 16:57:55.548026002 +1000
|
||||
@@ -20,7 +20,7 @@
|
||||
*/
|
||||
|
||||
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
|
||||
gboolean glibsharp_g_thread_supported (void);
|
||||
|
||||
diff -Naur glue.new/thread.c~ glue/thread.c~
|
||||
--- glue.new/thread.c~ 1970-01-01 10:00:00.000000000 +1000
|
||||
+++ glue/thread.c~ 2012-12-10 16:57:55.538025982 +1000
|
||||
@@ -0,0 +1,32 @@
|
||||
+/* thread.c : glue functions for GLib.Thread
|
||||
+ *
|
||||
+ * Author: Alp Toker <alp@atoker.com>
|
||||
+ *
|
||||
+ * Copyright (c) 2005 Alp Toker
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or
|
||||
+ * modify it under the terms of version 2 of the Lesser GNU General
|
||||
+ * Public License as published by the Free Software Foundation.
|
||||
+ *
|
||||
+ * This program is distributed in the hope that it will be useful,
|
||||
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
+ * Lesser General Public License for more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU Lesser General Public
|
||||
+ * License along with this program; if not, write to the
|
||||
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Boston, MA 02111-1307, USA.
|
||||
+ */
|
||||
+
|
||||
+
|
||||
+#include <glib/gthread.h>
|
||||
+
|
||||
+gboolean glibsharp_g_thread_supported (void);
|
||||
+
|
||||
+gboolean
|
||||
+glibsharp_g_thread_supported ()
|
||||
+{
|
||||
+ return g_thread_supported ();
|
||||
+}
|
||||
+
|
38
gtk-sharp-2.12.10-pkg-config-x86_64.patch
Normal file
38
gtk-sharp-2.12.10-pkg-config-x86_64.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -Nru gtk-sharp-2.12.10.orig/glade/glade-sharp-2.0.pc.in gtk-sharp-2.12.10/glade/glade-sharp-2.0.pc.in
|
||||
--- gtk-sharp-2.12.10.orig/glade/glade-sharp-2.0.pc.in 2013-08-10 16:36:47.525766853 +0000
|
||||
+++ gtk-sharp-2.12.10/glade/glade-sharp-2.0.pc.in 2013-08-10 16:38:44.105667280 +0000
|
||||
@@ -9,4 +9,4 @@
|
||||
Version: @VERSION@
|
||||
Requires: gtk-sharp-2.0
|
||||
Cflags: -I:${gapidir}/glade-api.xml
|
||||
-Libs: -r:${libdir}/mono/@PACKAGE_VERSION@/glade-sharp.dll
|
||||
+Libs: -r:${prefix}/lib/mono/@PACKAGE_VERSION@/glade-sharp.dll
|
||||
diff -Nru gtk-sharp-2.12.10.orig/glib/glib-sharp-2.0.pc.in gtk-sharp-2.12.10/glib/glib-sharp-2.0.pc.in
|
||||
--- gtk-sharp-2.12.10.orig/glib/glib-sharp-2.0.pc.in 2013-08-10 16:36:47.525766853 +0000
|
||||
+++ gtk-sharp-2.12.10/glib/glib-sharp-2.0.pc.in 2013-08-10 16:37:52.546153535 +0000
|
||||
@@ -8,5 +8,5 @@
|
||||
Description: GLib# - .NET Binding for the glib library.
|
||||
Version: @VERSION@
|
||||
Cflags: -I:${gapidir}/glib-api.xml
|
||||
-Libs: -r:${libdir}/mono/@PACKAGE_VERSION@/glib-sharp.dll
|
||||
+Libs: -r:${prefix}/lib/mono/@PACKAGE_VERSION@/glib-sharp.dll
|
||||
|
||||
diff -Nru gtk-sharp-2.12.10.orig/gtk/gtk-sharp-2.0.pc.in gtk-sharp-2.12.10/gtk/gtk-sharp-2.0.pc.in
|
||||
--- gtk-sharp-2.12.10.orig/gtk/gtk-sharp-2.0.pc.in 2013-08-10 16:36:47.525766853 +0000
|
||||
+++ gtk-sharp-2.12.10/gtk/gtk-sharp-2.0.pc.in 2013-08-10 16:38:25.257845023 +0000
|
||||
@@ -8,5 +8,5 @@
|
||||
Description: Gtk# - GNOME .NET Binding
|
||||
Version: @VERSION@
|
||||
Cflags: -I:${gapidir}/pango-api.xml -I:${gapidir}/atk-api.xml -I:${gapidir}/gdk-api.xml -I:${gapidir}/gtk-api.xml
|
||||
-Libs: -r:${libdir}/mono/@PACKAGE_VERSION@/pango-sharp.dll -r:${libdir}/mono/@PACKAGE_VERSION@/atk-sharp.dll -r:${libdir}/mono/@PACKAGE_VERSION@/gdk-sharp.dll -r:${libdir}/mono/@PACKAGE_VERSION@/gtk-sharp.dll
|
||||
+Libs: -r:${prefix}/lib/mono/@PACKAGE_VERSION@/pango-sharp.dll -r:${prefix}/lib/mono/@PACKAGE_VERSION@/atk-sharp.dll -r:${prefix}/lib/mono/@PACKAGE_VERSION@/gdk-sharp.dll -r:${prefix}/lib/mono/@PACKAGE_VERSION@/gtk-sharp.dll
|
||||
Requires: glib-sharp-2.0
|
||||
diff -Nru gtk-sharp-2.12.10.orig/gtkdotnet/gtk-dotnet-2.0.pc.in gtk-sharp-2.12.10/gtkdotnet/gtk-dotnet-2.0.pc.in
|
||||
--- gtk-sharp-2.12.10.orig/gtkdotnet/gtk-dotnet-2.0.pc.in 2013-08-10 16:36:47.526766844 +0000
|
||||
+++ gtk-sharp-2.12.10/gtkdotnet/gtk-dotnet-2.0.pc.in 2013-08-10 16:38:55.982555280 +0000
|
||||
@@ -7,4 +7,4 @@
|
||||
Description: .NET Extensions for Gtk
|
||||
Version: @VERSION@
|
||||
Requires:gtk-sharp-2.0
|
||||
-Libs: -r:${libdir}/mono/@PACKAGE_VERSION@/gtk-dotnet.dll
|
||||
+Libs: -r:${prefix}/lib/mono/@PACKAGE_VERSION@/gtk-dotnet.dll
|
72
gtk-sharp-2.12.2-libdir.patch
Normal file
72
gtk-sharp-2.12.2-libdir.patch
Normal file
@ -0,0 +1,72 @@
|
||||
diff -Nru gtk-sharp-2.12.2/generator/Makefile.am gtk-sharp-2.12.2-gil/generator/Makefile.am
|
||||
--- gtk-sharp-2.12.2/generator/Makefile.am 2008-08-21 00:09:49.000000000 +0200
|
||||
+++ gtk-sharp-2.12.2-gil/generator/Makefile.am 2008-09-09 23:48:15.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-assemblydir = $(prefix)/lib/gtk-sharp-2.0
|
||||
+assemblydir = $(libdir)/gtk-sharp-2.0
|
||||
assembly_DATA = gapi_codegen.exe
|
||||
bin_SCRIPTS = gapi2-codegen
|
||||
CLEANFILES = gapi_codegen.exe
|
||||
diff -Nru gtk-sharp-2.12.2/glade/glade-sharp-2.0.pc.in gtk-sharp-2.12.2-gil/glade/glade-sharp-2.0.pc.in
|
||||
--- gtk-sharp-2.12.2/glade/glade-sharp-2.0.pc.in 2008-08-21 00:10:49.000000000 +0200
|
||||
+++ gtk-sharp-2.12.2-gil/glade/glade-sharp-2.0.pc.in 2008-09-09 23:53:09.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
-prefix=${pcfiledir}/../..
|
||||
+prefix=@prefix@
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
-gapidir=${prefix}/share/gapi-2.0
|
||||
+libdir=@libdir@
|
||||
+gapidir=@datadir@/gapi-2.0
|
||||
|
||||
|
||||
Name: Glade#
|
||||
diff -Nru gtk-sharp-2.12.2/glib/glib-sharp-2.0.pc.in gtk-sharp-2.12.2-gil/glib/glib-sharp-2.0.pc.in
|
||||
--- gtk-sharp-2.12.2/glib/glib-sharp-2.0.pc.in 2008-08-21 00:10:51.000000000 +0200
|
||||
+++ gtk-sharp-2.12.2-gil/glib/glib-sharp-2.0.pc.in 2008-09-09 23:45:45.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
-prefix=${pcfiledir}/../..
|
||||
+prefix=@prefix@
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
-gapidir=${prefix}/share/gapi-2.0
|
||||
+libdir=@libdir@
|
||||
+gapidir=@datadir@/gapi-2.0
|
||||
|
||||
|
||||
Name: GLib#
|
||||
diff -Nru gtk-sharp-2.12.2/gtk/gtk-sharp-2.0.pc.in gtk-sharp-2.12.2-gil/gtk/gtk-sharp-2.0.pc.in
|
||||
--- gtk-sharp-2.12.2/gtk/gtk-sharp-2.0.pc.in 2008-08-21 00:09:48.000000000 +0200
|
||||
+++ gtk-sharp-2.12.2-gil/gtk/gtk-sharp-2.0.pc.in 2008-09-09 23:51:22.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
-prefix=${pcfiledir}/../..
|
||||
+prefix=@prefix@
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
-gapidir=${prefix}/share/gapi-2.0
|
||||
+libdir=@libdir@
|
||||
+gapidir=@datadir@/gapi-2.0
|
||||
|
||||
|
||||
Name: Gtk#
|
||||
diff -Nru gtk-sharp-2.12.2/gtkdotnet/gtk-dotnet-2.0.pc.in gtk-sharp-2.12.2-gil/gtkdotnet/gtk-dotnet-2.0.pc.in
|
||||
--- gtk-sharp-2.12.2/gtkdotnet/gtk-dotnet-2.0.pc.in 2008-08-21 00:09:51.000000000 +0200
|
||||
+++ gtk-sharp-2.12.2-gil/gtkdotnet/gtk-dotnet-2.0.pc.in 2008-09-09 23:49:32.000000000 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
-prefix=${pcfiledir}/../..
|
||||
+prefix=@prefix@
|
||||
exec_prefix=${prefix}
|
||||
-libdir=${exec_prefix}/lib
|
||||
+libdir=@libdir@
|
||||
|
||||
|
||||
Name: Gtk.DotNet
|
||||
diff -Nru gtk-sharp-2.12.2/parser/Makefile.am gtk-sharp-2.12.2-gil/parser/Makefile.am
|
||||
--- gtk-sharp-2.12.2/parser/Makefile.am 2008-08-21 00:09:51.000000000 +0200
|
||||
+++ gtk-sharp-2.12.2-gil/parser/Makefile.am 2008-09-09 23:46:48.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-assemblydir = $(prefix)/lib/gtk-sharp-2.0
|
||||
+assemblydir = $(libdir)/gtk-sharp-2.0
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
assembly_DATA = gapi-fixup.exe gapi-parser.exe
|
||||
pkgconfig_DATA = gapi-2.0.pc
|
12
gtk-sharp-2.12.8-DateTimeToTime_t.patch
Normal file
12
gtk-sharp-2.12.8-DateTimeToTime_t.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru gtk-sharp-2.12.8.orig/glib/Marshaller.cs gtk-sharp-2.12.8/glib/Marshaller.cs
|
||||
--- gtk-sharp-2.12.8.orig/glib/Marshaller.cs 2009-01-30 20:51:10.000000000 +0100
|
||||
+++ gtk-sharp-2.12.8/glib/Marshaller.cs 2009-03-25 17:01:55.000000000 +0100
|
||||
@@ -312,7 +312,7 @@
|
||||
|
||||
public static IntPtr DateTimeTotime_t (DateTime time)
|
||||
{
|
||||
- return new IntPtr (((long)time.Subtract (local_epoch).TotalSeconds) - utc_offset);
|
||||
+ return new IntPtr (((int)time.Subtract (local_epoch).TotalSeconds) - utc_offset);
|
||||
}
|
||||
|
||||
public static DateTime time_tToDateTime (IntPtr time_t)
|
208
gtk-sharp2.spec
Normal file
208
gtk-sharp2.spec
Normal file
@ -0,0 +1,208 @@
|
||||
%define majversion %(echo %version | cut -d. -f 1-2)
|
||||
|
||||
Name: gtk-sharp2
|
||||
Version: 2.12.10
|
||||
Release: 5mamba
|
||||
Summary: A set of .NET bindings for the GTK+ toolkit and assorted GNOME libraries
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||
URL: http://www.mono-project.com/GtkSharp
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/gtk-sharp/%{majversion}/gtk-sharp-%{version}.tar.bz2
|
||||
Patch1: gtk-sharp-2.12.2-libdir.patch
|
||||
Patch2: gtk-sharp-2.10.1-fix_doc.patch
|
||||
Patch3: gtk-sharp-2.12.8-DateTimeToTime_t.patch
|
||||
Patch4: gtk-sharp-2.12.10-glib-2.34.patch
|
||||
Patch5: gtk-sharp-2.12.10-pkg-config-x86_64.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libelf-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglade-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpng15-devel
|
||||
BuildRequires: libpthread-stubs-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: mono-core
|
||||
BuildRequires: perl-XML-LibXML
|
||||
BuildRequires: udev-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: mono-devel
|
||||
Requires: mono-core
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Gtk#, a GUI Toolkit, is a set of .NET bindings for the gtk+ (http://www.gtk.org/) toolkit and assorted GNOME (http://www.gnome.org/) libraries.
|
||||
This library allows you to build fully native graphical Gnome application using Mono.
|
||||
GTK# is an event-driven system like any other modern windowing library.
|
||||
Every widget in an application has handler methods that get called when particular events happen.
|
||||
|
||||
Applications built using Gtk# will run on many platforms including Linux, Windows and MacOS X.
|
||||
Gtk is the native toolkit for the Linux desktop running GNOME, so applications will look and function best on here.
|
||||
|
||||
%package devel
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: perl-XML-LibXML
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Gtk#, a GUI Toolkit, is a set of .NET bindings for the gtk+ (http://www.gtk.org/) toolkit and assorted GNOME (http://www.gnome.org/) libraries.
|
||||
This library allows you to build fully native graphical Gnome application using Mono.
|
||||
GTK# is an event-driven system like any other modern windowing library.
|
||||
Every widget in an application has handler methods that get called when particular events happen.
|
||||
|
||||
Applications built using Gtk# will run on many platforms including Linux, Windows and MacOS X.
|
||||
Gtk is the native toolkit for the Linux desktop running GNOME, so applications will look and function best on here.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package doc
|
||||
Summary: Documentation for %{name}
|
||||
Group: Documentation
|
||||
Requires: monodoc
|
||||
|
||||
%description doc
|
||||
Gtk-sharp, a GUI Toolkit, is a set of .NET bindings for the gtk+ (http://www.gtk.org/) toolkit and assorted GNOME (http://www.gnome.org/) libraries.
|
||||
This library allows you to build fully native graphical Gnome application using Mono.
|
||||
GTK-sharp is an event-driven system like any other modern windowing library.
|
||||
Every widget in an application has handler methods that get called when particular events happen.
|
||||
|
||||
Applications built using Gtk-sharp will run on many platforms including Linux, Windows and MacOS X.
|
||||
Gtk is the native toolkit for the Linux desktop running GNOME, so applications will look and function best on here.
|
||||
|
||||
This package contains the documentation for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n gtk-sharp-%{version}
|
||||
%patch1 -p1
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch5 -p1
|
||||
cd glib
|
||||
%patch4 -p0
|
||||
|
||||
%build
|
||||
#autoreconf -fi
|
||||
%configure
|
||||
%make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall \
|
||||
GACUTIL_FLAGS="/package gtk-sharp-2.0 /gacdir %{_prefix}/lib /root %{buildroot}%{_prefix}/lib"
|
||||
|
||||
# postplug one-shot update script to remove old package with wrong script
|
||||
install -d %{buildroot}%{_sysconfdir}/postplug/updates.d
|
||||
cat > %{buildroot}%{_sysconfdir}/postplug/updates.d/gtk-sharp-remove-broken-001.upd << _EOF
|
||||
rpm -e gtk-sharp-2.12.10-2mamba --noscripts
|
||||
exit 0
|
||||
_EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%post doc
|
||||
# FIXME: doc requires mono-tools
|
||||
[ -x %{_bindir}/monodoc ] &&
|
||||
%{_bindir}/monodoc --make-search-index &>/dev/null
|
||||
exit 0
|
||||
|
||||
%postun doc
|
||||
if [ "$1" = "0" ]; then
|
||||
[ -x %{_bindir}/monodoc ] &&
|
||||
%{_bindir}/monodoc --make-search-index &>/dev/null
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/postplug/updates.d/gtk-sharp-remove-broken-001.upd
|
||||
%{_libdir}/*.so
|
||||
%{_prefix}/lib/mono/*/*atk-sharp*
|
||||
%{_prefix}/lib/mono/*/*gdk-sharp*
|
||||
%{_prefix}/lib/mono/*/*glade-sharp*
|
||||
%{_prefix}/lib/mono/*/*glib-sharp*
|
||||
%{_prefix}/lib/mono/*/*gtk-dotnet*
|
||||
%{_prefix}/lib/mono/*/*gtk-sharp*
|
||||
%{_prefix}/lib/mono/*/*pango-sharp*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/gapi*
|
||||
%{_prefix}/lib/gtk-sharp-?.?/gapi*
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/*.la
|
||||
%{_datadir}/gapi-?.?
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
#%doc ChangeLog NEWS README README.generator
|
||||
|
||||
%files doc
|
||||
%defattr(-,root,root)
|
||||
%{_prefix}/lib/monodoc/sources/gtk-sharp*
|
||||
|
||||
%changelog
|
||||
* Mon Sep 16 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.10-5mamba
|
||||
- rebuilt with mono 2
|
||||
|
||||
* Wed Jul 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.10-4mamba
|
||||
- legacy package (rebuilt with mono 3)
|
||||
|
||||
* Tue Jan 11 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.10-3mamba
|
||||
- rebuilt to add mono dependencies
|
||||
|
||||
* Sun Aug 29 2010 Davide Madrisan <davide.madrisan@gmail.com> 2.12.10-2mamba
|
||||
- rebuilt to update the list of pkgconfig provides
|
||||
|
||||
* Sat May 29 2010 Automatic Build System <autodist@mambasoft.it> 2.12.10-1mamba
|
||||
- automatic update to 2.12.10 by autodist
|
||||
|
||||
* Fri May 29 2009 Automatic Build System <autodist@mambasoft.it> 2.12.9-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 2.12.8-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Mar 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.8-2mamba
|
||||
- added patch that fixes type in DateTimeTotime_t function (check with cdcollector)
|
||||
|
||||
* Mon Mar 23 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.8-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Jan 20 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.7-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Sep 09 2008 gil <puntogil@libero.it> 2.12.2-1mamba
|
||||
- update to 2.12.2
|
||||
|
||||
* Sun Jul 01 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.10.1-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user