libgstreamer: require gstreamer-tools; added debug package [release 1.16.2-2mamba;Fri Jul 10 2020]
This commit is contained in:
parent
41fbe8a14d
commit
e0bdfe795c
55
gstreamer-1.16.2-glib-2.64.2.patch
Normal file
55
gstreamer-1.16.2-glib-2.64.2.patch
Normal file
@ -0,0 +1,55 @@
|
||||
--- gstreamer-1.16.2/common/glib-gen.mak
|
||||
+++ gstreamer-1.16.2/common/glib-gen.mak
|
||||
@@ -1,11 +1,13 @@
|
||||
# these are the variables your Makefile.am should set
|
||||
# the example is based on the colorbalance interface
|
||||
|
||||
+H := \#
|
||||
+
|
||||
#glib_enum_headers=$(colorbalance_headers)
|
||||
#glib_enum_define=GST_COLOR_BALANCE
|
||||
#glib_enum_prefix=gst_color_balance
|
||||
|
||||
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
|
||||
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
|
||||
|
||||
# these are all the rules generating the relevant files
|
||||
%-marshal.h: %-marshal.list
|
||||
--- gstreamer-1.16.2/common/gst-glib-gen.mak
|
||||
+++ gstreamer-1.16.2/common/gst-glib-gen.mak
|
||||
@@ -1,14 +1,16 @@
|
||||
# these are the variables your Makefile.am should set
|
||||
# the example is based on the colorbalance interface
|
||||
|
||||
+H := \#
|
||||
+
|
||||
#glib_enum_headers=$(colorbalance_headers)
|
||||
#glib_enum_define=GST_COLOR_BALANCE
|
||||
#glib_gen_prefix=gst_color_balance
|
||||
#glib_gen_basename=colorbalance
|
||||
#glib_gen_decl_banner=GST_EXPORT
|
||||
-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
|
||||
+#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
|
||||
|
||||
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
|
||||
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
|
||||
|
||||
# these are all the rules generating the relevant files
|
||||
$(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
|
||||
--- gstreamer-1.16.2/libs/gst/controller/Makefile.am
|
||||
+++ gstreamer-1.16.2/libs/gst/controller/Makefile.am
|
||||
@@ -4,11 +4,13 @@
|
||||
gstinterpolationcontrolsource.h \
|
||||
gstlfocontrolsource.h
|
||||
|
||||
+H := \#
|
||||
+
|
||||
glib_enum_define = GST_CONTROLLER
|
||||
glib_gen_prefix = gst
|
||||
glib_gen_basename = controller
|
||||
glib_gen_decl_banner=GST_CONTROLLER_API
|
||||
-glib_gen_decl_include=\#include <gst/controller/controller-prelude.h>
|
||||
+glib_gen_decl_include=$(H)include <gst/controller/controller-prelude.h>
|
||||
|
||||
built_sources = controller-enumtypes.c
|
||||
built_headers = controller-enumtypes.h
|
@ -6,7 +6,7 @@
|
||||
|
||||
Name: gstreamer
|
||||
Version: 1.16.2
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Epoch: 2
|
||||
Summary: A framework for streaming media
|
||||
Group: System/Libraries
|
||||
@ -16,13 +16,18 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://gstreamer.freedesktop.org
|
||||
Source: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
|
||||
Patch0: gstreamer-1.1.3-bison-3.0.patch
|
||||
Patch1: gstreamer-1.16.2-glib-2.64.2.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: libdw-devel
|
||||
BuildRequires: libelf-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: pkg-config
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libunwind-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: bash
|
||||
BuildRequires: ldconfig
|
||||
@ -50,7 +55,7 @@ GStreamer is a streaming-media framework, based on graphs of filters which opera
|
||||
%package -n %{libname}
|
||||
Summary: Libraries for GStreamer streaming-media framework
|
||||
Group: System/Libraries
|
||||
#Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: %{name}-tools = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n %{libname}
|
||||
GStreamer is a library that allows the construction of graphs of media-handling components, ranging from simple Ogg/Vorbis playback to complex audio (mixing) and video (non-linear editing) processing. Applications can take advantage of advances in codec and filter technology transparently.
|
||||
@ -75,10 +80,13 @@ Requires: gtk-doc
|
||||
%description -n %{libname}-apidocs
|
||||
GStreamer library API documentation.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n gstreamer-%{version}
|
||||
#-D -T
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -160,6 +168,9 @@ install -d %{buildroot}%{gscachedir}
|
||||
%{_datadir}/gtk-doc/html/gstreamer-plugins-%{MAJversion}.0/
|
||||
|
||||
%changelog
|
||||
* Fri Jul 10 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.16.2-2mamba
|
||||
- libgstreamer: require gstreamer-tools; added debug package
|
||||
|
||||
* Wed Dec 04 2019 Automatic Build System <autodist@mambasoft.it> 1.16.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
@ -326,7 +337,7 @@ install -d %{buildroot}%{gscachedir}
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 03 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.0-2mamba
|
||||
- remove obsolete for *gstreamer0.10 to prevent a circoluar obsolete with gstreamer010 legacy package
|
||||
- remove obsolete for *gstreamer0.10 to prevent a circular obsolete with gstreamer010 legacy package
|
||||
|
||||
* Tue Sep 25 2012 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
|
||||
- update to 1.0.0
|
||||
|
Loading…
Reference in New Issue
Block a user