automatic version update by autodist [release 1.2.4-1mamba;Tue Apr 22 2014]

This commit is contained in:
Automatic Build System 2024-01-05 23:32:50 +01:00
parent d2ad12d82c
commit d4d55b03bc
4 changed files with 233 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# gst-plugins-ugly # gst-plugins-ugly
GStreamer Ugly Plug-ins is a set of plug-ins that we consider to have ugly quality code, correct functionality, our preferred license (LGPL for the plug-in code, LGPL or LGPL-compatible for the supporting library).

View File

@ -0,0 +1,11 @@
--- gst-plugins-ugly-0.10.10/common/m4/gst-feature.m4 2008-11-08 15:48:44.000000000 +0100
+++ gst-plugins-ugly-0.10.10/common/m4/gst-feature.m4-gil 2009-01-01 03:23:11.000000000 +0100
@@ -139,7 +139,7 @@
[$1]_CFLAGS=
HAVE_[$1]=no
else
- if [$2] --plugin-libs [$3] &> /dev/null; then
+ if [$2] --plugin-libs [$3] > /dev/null 2> /dev/null; then
[$1]_LIBS=`[$2] --plugin-libs [$3]`
else
[$1]_LIBS=`[$2] --libs [$3]`

View File

@ -0,0 +1,15 @@
diff -up gst-plugins-ugly-0.10.12/ext/x264/gstx264enc.c.x264 gst-plugins-ugly-0.10.12/ext/x264/gstx264enc.c
--- gst-plugins-ugly-0.10.12/ext/x264/gstx264enc.c.x264 2009-06-05 22:02:52.000000000 +0200
+++ gst-plugins-ugly-0.10.12/ext/x264/gstx264enc.c 2009-10-26 16:44:43.000000000 +0100
@@ -576,7 +576,11 @@ gst_x264_enc_init_encoder (GstX264Enc *
encoder->x264param.analyse.i_noise_reduction = encoder->noise_reduction;
encoder->x264param.i_frame_reference = encoder->ref;
encoder->x264param.i_bframe = encoder->bframes;
+#if X264_BUILD < 78
encoder->x264param.b_bframe_pyramid = encoder->b_pyramid;
+#else
+ encoder->x264param.i_bframe_pyramid = encoder->b_pyramid;
+#endif
#if X264_BUILD < 63
encoder->x264param.b_bframe_adaptive = encoder->b_adapt;
#else

205
gst-plugins-ugly.spec Normal file
View File

@ -0,0 +1,205 @@
%define majver %(echo %version | cut -d. -f 1).0
Name: gst-plugins-ugly
Version: 1.2.4
Release: 1mamba
Summary: A set of plug-ins for gstreamer considered to have ugly quality code
Group: System/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://gstreamer.freedesktop.org/modules/gst-plugins-ugly.html
Source: http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
Patch: gst-plugins-ugly-0.10.10-featurem4.patch
Patch1: gst-plugins-ugly-0.10.13-x264.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: liba52dec-devel
BuildRequires: libamrnb-devel
BuildRequires: libcdio-devel
BuildRequires: libdvdread-devel
BuildRequires: libgcc
BuildRequires: libglib-devel
BuildRequires: libgst-plugins-base-devel
BuildRequires: libgstreamer-devel
BuildRequires: libid3tag-devel
BuildRequires: liblame-devel
BuildRequires: libmad-devel
BuildRequires: liboil-devel
BuildRequires: libsidplay-devel
BuildRequires: libstdc++6-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
BuildRequires: mpeg2dec-devel
## AUTOBUILDREQ-END
BuildRequires: libopencore-amr-devel
BuildRequires: libdvdnav-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
#configure: *** Plug-ins without external dependencies that will be built:
# asfdemux
# dvdlpcmdec
# dvdsub
# iec958
# mpegaudioparse
# mpegstream
# realmedia
#configure: *** Plug-ins without external dependencies that will NOT be built:
# synaesthesia
#configure: *** Plug-ins with dependencies that will be built:
# a52dec
# amrnb
# cdio
# dvdreadsrc
# id3tag
# lame
# mad
# mpeg2dec
# sid
#configure: *** Plug-ins with dependencies that will NOT be built:
# dvdnav
#configure: *** checking feature: dvdnav library ***
#configure: *** for plug-ins: dvdnav ***
#configure: *** These plugins will not be built: dvdnav
#configure: dvdnavsrc not stable yet, not building
%description
GStreamer Ugly Plug-ins is a set of plug-ins that we consider to have ugly quality code, correct functionality, our preferred license (LGPL for the plug-in code, LGPL or LGPL-compatible for the supporting library).
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
GStreamer Ugly Plug-ins is a set of plug-ins that we consider to have good quality code, correct functionality, our preferred license (LGPL for the plug-in code, LGPL or LGPL-compatible for the supporting library).
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch -p1
#%patch1 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%find_lang %{name}-%{majver}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}-%{majver}.lang
%defattr(-,root,root)
%{_libdir}/gstreamer-%{majver}/libgst*.so
%{_datadir}/gstreamer-%{majver}/presets/GstX264Enc.prs
%{_datadir}/gstreamer-%{majver}/presets/GstAmrnbEnc.prs
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
#%{_libdir}/gstreamer-%{majver}/libgst*.a
%{_libdir}/gstreamer-%{majver}/libgst*.la
%doc ChangeLog NEWS README
%changelog
* Tue Apr 22 2014 Automatic Build System <autodist@mambasoft.it> 1.2.4-1mamba
- automatic version update by autodist
* Mon Feb 10 2014 Automatic Build System <autodist@mambasoft.it> 1.2.3-1mamba
- automatic version update by autodist
* Tue Jan 07 2014 Automatic Build System <autodist@mambasoft.it> 1.2.2-1mamba
- automatic version update by autodist
* Mon Nov 11 2013 Automatic Build System <autodist@mambasoft.it> 1.2.1-1mamba
- automatic version update by autodist
* Thu Oct 31 2013 Automatic Build System <autodist@mambasoft.it> 1.2.0-1mamba
- automatic version update by autodist
* Fri Jun 14 2013 Automatic Build System <autodist@mambasoft.it> 1.1.1-1mamba
- automatic version update by autodist
* Fri Apr 26 2013 Automatic Build System <autodist@mambasoft.it> 1.0.7-1mamba
- automatic version update by autodist
* Sun Mar 31 2013 Automatic Build System <autodist@mambasoft.it> 1.0.6-1mamba
- automatic version update by autodist
* Mon Jan 14 2013 Automatic Build System <autodist@mambasoft.it> 1.0.5-1mamba
- automatic version update by autodist
* Wed Dec 19 2012 Automatic Build System <autodist@mambasoft.it> 1.0.4-1mamba
- automatic version update by autodist
* Sun Nov 25 2012 Automatic Build System <autodist@mambasoft.it> 1.0.3-1mamba
- automatic version update by autodist
* Wed Oct 31 2012 Automatic Build System <autodist@mambasoft.it> 1.0.2-1mamba
- automatic version update by autodist
* Mon Oct 15 2012 Automatic Build System <autodist@mambasoft.it> 1.0.1-1mamba
- automatic version update by autodist
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 0.10.19-1mamba
- update to 0.10.19
* Thu Aug 04 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.18-2mamba
- rebuilt with libx264 116
* Sat Jun 25 2011 Automatic Build System <autodist@mambasoft.it> 0.10.18-1mamba
- automatic update by autodist
* Mon Jun 21 2010 Automatic Build System <autodist@mambasoft.it> 0.10.15-1mamba
- automatic update by autodist
* Mon Mar 15 2010 Automatic Build System <autodist@mambasoft.it> 0.10.14-2mamba
- automatic rebuild by autodist
* Wed Mar 10 2010 Automatic Build System <autodist@mambasoft.it> 0.10.14-1mamba
- automatic update by autodist
* Thu Jan 14 2010 Automatic Build System <autodist@mambasoft.it> 0.10.13-2mamba
- automatic rebuild by autodist
* Thu Nov 19 2009 Automatic Build System <autodist@mambasoft.it> 0.10.13-1mamba
- update to 0.10.13
* Thu Nov 19 2009 Automatic Build System <autodist@mambasoft.it> 0.10.12-6mamba
- automatic rebuild by autodist
* Thu Oct 15 2009 Automatic Build System <autodist@mambasoft.it> 0.10.12-5mamba
- automatic rebuild by autodist
* Wed Aug 19 2009 Automatic Build System <autodist@mambasoft.it> 0.10.12-4mamba
- automatic rebuild by autodist
* Wed Aug 12 2009 Automatic Build System <autodist@mambasoft.it> 0.10.12-3mamba
- automatic rebuild by autodist
* Fri Jul 10 2009 Automatic Build System <autodist@mambasoft.it> 0.10.12-2mamba
- automatic rebuild by autodist
* Mon Jul 06 2009 Automatic Build System <autodist@mambasoft.it> 0.10.12-1mamba
- automatic update by autodist
* Mon Mar 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.11-1mamba
- automatic update by autodist
* Wed Jan 07 2009 gil <puntogil@libero.it> 0.10.10-2mamba
- new libcdio
* Thu Jan 01 2009 gil <puntogil@libero.it> 0.10.10-1mamba
- update to 0.10.10
* Mon Jul 14 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.8-1mamba
- package created by autospec