rebuilt with libmjpegtools 2.2.1 [release 0.10.23-6mamba;Sat Jan 01 2022]
This commit is contained in:
parent
3fe6debd37
commit
b8b7543b52
11
gst-plugins-bad010-0.10.23-disable-assrender-test.patch
Normal file
11
gst-plugins-bad010-0.10.23-disable-assrender-test.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/tests/check/elements/assrender.c
|
||||
+++ b/tests/check/elements/assrender.c
|
||||
@@ -289,8 +289,6 @@ assrender_suite (void)
|
||||
tcase_set_timeout (tc_chain, 120);
|
||||
|
||||
suite_add_tcase (s, tc_chain);
|
||||
- tcase_add_test (tc_chain, test_assrender_basic_xRGB);
|
||||
- tcase_add_test (tc_chain, test_assrender_basic_I420);
|
||||
|
||||
return s;
|
||||
}
|
10
gst-plugins-bad010-0.10.23-disable-camerabin-test.patch
Normal file
10
gst-plugins-bad010-0.10.23-disable-camerabin-test.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- gst-plugins-bad/tests/check/Makefile.am.orig 2013-12-10 22:01:50.504567189 +0000
|
||||
+++ gst-plugins-bad/tests/check/Makefile.am 2013-12-10 22:02:17.081058500 +0000
|
||||
@@ -181,7 +181,6 @@
|
||||
elements/autovideoconvert \
|
||||
elements/asfmux \
|
||||
elements/baseaudiovisualizer \
|
||||
- elements/camerabin \
|
||||
elements/camerabin2 \
|
||||
elements/dataurisrc \
|
||||
elements/legacyresample \
|
26
gst-plugins-bad010-0.10.23-drop-vpx-compat-defs.patch
Normal file
26
gst-plugins-bad010-0.10.23-drop-vpx-compat-defs.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- gst-plugins-bad.orig/ext/vp8/gstvp8utils.h 2015-04-21 03:31:33.134952881 +0300
|
||||
+++ gst-plugins-bad/ext/vp8/gstvp8utils.h 2015-04-21 03:32:45.553520671 +0300
|
||||
@@ -25,23 +25,6 @@
|
||||
|
||||
G_BEGIN_DECLS
|
||||
|
||||
-/* Some compatibility defines for older libvpx versions */
|
||||
-#ifndef VPX_IMG_FMT_I420
|
||||
-#define VPX_IMG_FMT_I420 IMG_FMT_I420
|
||||
-#endif
|
||||
-
|
||||
-#ifndef VPX_PLANE_Y
|
||||
-#define VPX_PLANE_Y PLANE_Y
|
||||
-#endif
|
||||
-
|
||||
-#ifndef VPX_PLANE_U
|
||||
-#define VPX_PLANE_U PLANE_U
|
||||
-#endif
|
||||
-
|
||||
-#ifndef VPX_PLANE_V
|
||||
-#define VPX_PLANE_V PLANE_V
|
||||
-#endif
|
||||
-
|
||||
const char * gst_vpx_error_name (vpx_codec_err_t status);
|
||||
|
||||
G_END_DECLS
|
35
gst-plugins-bad010-0.10.23-libfaad2-2.10.0.patch
Normal file
35
gst-plugins-bad010-0.10.23-libfaad2-2.10.0.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 1f738ca5b8711ca5532a326cd646312e60484863 Mon Sep 17 00:00:00 2001
|
||||
From: Wim Taymans <wtaymans@redhat.com>
|
||||
Date: Wed, 13 May 2015 16:23:26 +0200
|
||||
Subject: fix faad2 version check
|
||||
|
||||
On fedora 22, the output of cpp inserts extra debug comments, which
|
||||
makes our regexp for the faad2 version check fail. This in turn causes
|
||||
it to compile with the wrong arguments passed which then causes stack
|
||||
corruption and crashes.
|
||||
|
||||
Fix this by only checking for the version (which should be by itself on
|
||||
a single line). This is potentially less safe, it might be possible that
|
||||
a similar string would appear in a later version in the header file.
|
||||
|
||||
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f5ce28c..d295253 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -2008,9 +2008,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
|
||||
AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
|
||||
for minor in 10 9 8 7 6 5 0; do
|
||||
if test x$faad2_minor_version = "x"; then
|
||||
- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
|
||||
+ AC_EGREP_CPP([\"2\.$minor\"$], [
|
||||
#include <$faad_hdr>
|
||||
- GST_CHECK_FAAD_VERSION FAAD2_VERSION
|
||||
+ FAAD2_VERSION
|
||||
], [
|
||||
faad2_minor_version=$minor
|
||||
])
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
12
gst-plugins-bad010-0.10.23-libmodplug-0.8.9.0.patch
Normal file
12
gst-plugins-bad010-0.10.23-libmodplug-0.8.9.0.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uprw gst-plugins-bad.orig/ext/modplug/gstmodplug.cc gst-plugins-bad/ext/modplug/gstmodplug.cc
|
||||
--- gst-plugins-bad.orig/ext/modplug/gstmodplug.cc 2015-04-21 03:15:25.929456272 +0300
|
||||
+++ gst-plugins-bad/ext/modplug/gstmodplug.cc 2015-04-21 03:18:54.624976723 +0300
|
||||
@@ -50,7 +50,7 @@
|
||||
#define WORDS_BIGENDIAN 0
|
||||
#endif
|
||||
|
||||
-#include <stdafx.h>
|
||||
+#include <libmodplug/stdafx.h>
|
||||
#include <libmodplug/sndfile.h>
|
||||
|
||||
#include "gstmodplug.h"
|
52
gst-plugins-bad010-0.10.23-openssl.patch
Normal file
52
gst-plugins-bad010-0.10.23-openssl.patch
Normal file
@ -0,0 +1,52 @@
|
||||
--- gst-plugins-bad-0.10.23/ext/apexsink/gstapexraop.c~ 2018-09-22 17:27:06.000000000 +0200
|
||||
+++ gst-plugins-bad-0.10.23/ext/apexsink/gstapexraop.c 2018-09-22 17:28:24.899555435 +0200
|
||||
@@ -676,7 +676,7 @@ gst_apexraop_write (GstApExRAOP * con, g
|
||||
guchar *buffer, *frame_data;
|
||||
gushort len;
|
||||
gint bit_offset, byte_offset, i, out_len, res;
|
||||
- EVP_CIPHER_CTX aes_ctx;
|
||||
+ EVP_CIPHER_CTX *aes_ctx;
|
||||
_GstApExRAOP *conn = (_GstApExRAOP *) con;
|
||||
const int frame_header_size = conn->generation == GST_APEX_GENERATION_ONE
|
||||
? GST_APEX_RAOP_FRAME_HEADER_SIZE : GST_APEX_RTP_FRAME_HEADER_SIZE;
|
||||
@@ -736,13 +736,13 @@ gst_apexraop_write (GstApExRAOP * con, g
|
||||
&bit_offset, &byte_offset);
|
||||
}
|
||||
|
||||
- EVP_CIPHER_CTX_init (&aes_ctx);
|
||||
- EVP_CipherInit_ex (&aes_ctx, EVP_aes_128_cbc (), NULL, conn->aes_ky,
|
||||
+ aes_ctx = EVP_CIPHER_CTX_new ();
|
||||
+ EVP_CipherInit_ex (aes_ctx, EVP_aes_128_cbc (), NULL, conn->aes_ky,
|
||||
conn->aes_iv, AES_ENCRYPT);
|
||||
- EVP_CipherUpdate (&aes_ctx, frame_data, &out_len, frame_data, /*( */
|
||||
+ EVP_CipherUpdate (aes_ctx, frame_data, &out_len, frame_data, /*( */
|
||||
GST_APEX_RAOP_ALAC_HEADER_SIZE +
|
||||
length /*) / AES_BLOCK_SIZE * AES_BLOCK_SIZE */ );
|
||||
- EVP_CIPHER_CTX_cleanup (&aes_ctx);
|
||||
+ EVP_CIPHER_CTX_free (aes_ctx);
|
||||
|
||||
res =
|
||||
gst_apexraop_send (conn->data_sd, buffer,
|
||||
--- gst-plugins-bad-0.10.23/ext/apexsink/gstapexraop.c~ 2018-09-22 17:32:17.000000000 +0200
|
||||
+++ gst-plugins-bad-0.10.23/ext/apexsink/gstapexraop.c 2018-09-22 17:41:22.253666922 +0200
|
||||
@@ -258,7 +258,7 @@ gst_apexraop_connect (GstApExRAOP * con)
|
||||
} v;
|
||||
guchar buf[4 + 8 + 16];
|
||||
} randbuf;
|
||||
- gsize size;
|
||||
+ gsize size, size2;
|
||||
struct sockaddr_in ioaddr;
|
||||
socklen_t iolen;
|
||||
GstRTSPStatusCode res;
|
||||
@@ -292,9 +292,8 @@ gst_apexraop_connect (GstApExRAOP * con)
|
||||
|
||||
rsa = RSA_new ();
|
||||
mod = g_base64_decode (GST_APEX_RAOP_RSA_PUBLIC_MOD, &size);
|
||||
- rsa->n = BN_bin2bn (mod, size, NULL);
|
||||
- exp = g_base64_decode (GST_APEX_RAOP_RSA_PUBLIC_EXP, &size);
|
||||
- rsa->e = BN_bin2bn (exp, size, NULL);
|
||||
+ exp = g_base64_decode (GST_APEX_RAOP_RSA_PUBLIC_EXP, &size2);
|
||||
+ RSA_set0_key(rsa, BN_bin2bn (mod, size, NULL), BN_bin2bn (exp, size2, NULL), NULL);
|
||||
size =
|
||||
RSA_public_encrypt (AES_BLOCK_SIZE, conn->aes_ky, rsakey, rsa,
|
||||
RSA_PKCS1_OAEP_PADDING);
|
@ -3,16 +3,22 @@
|
||||
|
||||
Name: gst-plugins-bad010
|
||||
Version: 0.10.23
|
||||
Release: 5mamba
|
||||
Release: 6mamba
|
||||
Summary: A set of plug-ins for gstreamer that aren't up to par compared to the rest
|
||||
Group: System/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
|
||||
URL: https://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
|
||||
Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
|
||||
Patch0: gst-plugins-bad-0.10.9-libx264.patch
|
||||
Patch1: gst-plugins-bad010-0.10.23-fix_build_of_directfb_plugin.patch
|
||||
Patch2: gst-plugins-bad010-0.10.23-libmodplug-0.8.9.0.patch
|
||||
Patch3: gst-plugins-bad010-0.10.23-drop-vpx-compat-defs.patch
|
||||
Patch4: gst-plugins-bad010-0.10.23-disable-assrender-test.patch
|
||||
Patch5: gst-plugins-bad010-0.10.23-disable-camerabin-test.patch
|
||||
Patch6: gst-plugins-bad010-0.10.23-libfaad2-2.10.0.patch
|
||||
Patch7: gst-plugins-bad010-0.10.23-openssl.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -20,64 +26,111 @@ BuildRequires: libICE-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libass-devel
|
||||
BuildRequires: libaudio-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcdaudio-devel
|
||||
BuildRequires: libcelt-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdb53-devel
|
||||
BuildRequires: libdc1394-devel
|
||||
BuildRequires: libdca-devel
|
||||
BuildRequires: libdirac-devel
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libdvdnav-devel
|
||||
BuildRequires: libdvdread-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfaac-devel
|
||||
BuildRequires: libfaad2-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libfribidi-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgmp-devel
|
||||
BuildRequires: libgnutls-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgsasl-devel
|
||||
BuildRequires: libgsm-devel
|
||||
BuildRequires: libgss-devel
|
||||
BuildRequires: libgst-plugins-base010-devel
|
||||
BuildRequires: libgstreamer010-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libidn2-devel
|
||||
BuildRequires: libjasper-devel
|
||||
BuildRequires: libkate-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: liblrdf-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libmhash-devel
|
||||
BuildRequires: libmimic-devel
|
||||
BuildRequires: libmjpegtools-devel
|
||||
BuildRequires: libmms-devel
|
||||
BuildRequires: libmodplug-devel
|
||||
BuildRequires: libmpfr-devel
|
||||
BuildRequires: libmusepack-devel
|
||||
BuildRequires: libmusicbrainz2-devel
|
||||
BuildRequires: libnettle-devel
|
||||
BuildRequires: libnghttp2-devel
|
||||
BuildRequires: libntlm-devel
|
||||
BuildRequires: libofa-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libopus-devel
|
||||
BuildRequires: liborc-devel
|
||||
BuildRequires: libp11-kit-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpsl-devel
|
||||
BuildRequires: libraptor2-devel
|
||||
BuildRequires: librasqal-devel
|
||||
BuildRequires: libraw1394-devel
|
||||
BuildRequires: librdf-devel
|
||||
BuildRequires: librsvg-devel
|
||||
BuildRequires: librtmp-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libschroedinger-devel
|
||||
BuildRequires: libslv2-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libsoundtouch-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtasn1-devel
|
||||
BuildRequires: libtiger-devel
|
||||
BuildRequires: libts-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libunistring-devel
|
||||
BuildRequires: libusb-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libvdpau-devel
|
||||
BuildRequires: libvo-aacenc-devel
|
||||
BuildRequires: libvpx-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libxvidcore-devel
|
||||
BuildRequires: libyajl-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
BuildRequires: libzvbi-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libmjpegtools-devel >= 2.2.1
|
||||
BuildRequires: libsoundtouch-devel >= 1.9.2-1mamba
|
||||
#%ifarch %ix86
|
||||
#BuildRequires: divx4linux-devel
|
||||
@ -101,10 +154,8 @@ BuildRequires: libltdl-devel
|
||||
BuildRequires: libmpfr-devel
|
||||
BuildRequires: libgssapi-devel
|
||||
BuildRequires: udev-devel
|
||||
BuildRequires: libmjpegtools-devel >= 2.0.0
|
||||
Provides: gst-plugins-bad0.10
|
||||
Obsoletes: gst-plugins-bad0.10
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: gst-plugins-bad0.10 < 0.10.23-6mamba
|
||||
|
||||
#FIXME:
|
||||
#configure: *** Plug-ins with dependencies that will NOT be built:
|
||||
@ -133,23 +184,37 @@ Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: gst-plugins-bad0.10-devel
|
||||
Obsoletes: gst-plugins-bad0.10-devel
|
||||
Obsoletes: gst-plugins-bad0.10-devel < 0.10.23-6mamba
|
||||
|
||||
%description devel
|
||||
GStreamer Bad Plug-ins is a set of plug-ins that aren't up to par compared to the rest. They might be close to being good quality, but they're missing something - be it a good code review, some documentation, a set of tests, a real live maintainer, or some actual wide use.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n gst-plugins-bad-%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1 -b .libmodplug-0.8.9.0
|
||||
%patch3 -p1 -b .drop-vpx-compat-defs
|
||||
%patch4 -p1 -b .disable-assrender-test
|
||||
%patch5 -p1 -b .disable-camerabin-test
|
||||
%patch6 -p1 -b .libfaad2-2.10.0
|
||||
%patch7 -p1 -b .openssl
|
||||
find . -type f -name '*glib-gen.mak' -print0 | xargs -0 sed -i 's/\\n\\#include/\\n#include/g'
|
||||
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%configure \
|
||||
SCHRO_CFLAGS="-I%{_includedir}/schroedinger-1.0" \
|
||||
--disable-divx \
|
||||
--disable-vp8
|
||||
--disable-vp8 \
|
||||
--disable-decklink
|
||||
|
||||
%make
|
||||
|
||||
@ -225,6 +290,9 @@ This package contains static libraries and header files need for development.
|
||||
%doc ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Sat Jan 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.23-6mamba
|
||||
- rebuilt with libmjpegtools 2.2.1
|
||||
|
||||
* Mon Jun 13 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.23-5mamba
|
||||
- rebuilt by autoport with build requirements: libsoundtouch-devel>=1.9.2-1mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user