rebuilt without divx4linux [release 0.10.23-4mamba;Wed Apr 30 2014]
This commit is contained in:
parent
7d88994030
commit
78f50bd180
@ -1,2 +1,4 @@
|
||||
# gst-plugins-bad010
|
||||
|
||||
GStreamer Bad Plug-ins is a set of plug-ins that aren't up to par compared to the rest. They might be close to being good quality, but they're missing something - be it a good code review, some documentation, a set of tests, a real live maintainer, or some actual wide use.
|
||||
|
||||
|
12
gst-plugins-bad-0.10.9-libx264.patch
Normal file
12
gst-plugins-bad-0.10.9-libx264.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ru gst-plugins-bad-0.10.9.orig/ext/x264/gstx264enc.c gst-plugins-bad-0.10.9/ext/x264/gstx264enc.c
|
||||
--- gst-plugins-bad-0.10.9.orig/ext/x264/gstx264enc.c 2008-10-11 01:13:43.000000000 +0200
|
||||
+++ gst-plugins-bad-0.10.9/ext/x264/gstx264enc.c 2008-11-19 17:21:36.000000000 +0100
|
||||
@@ -541,7 +541,7 @@
|
||||
encoder->x264param.i_frame_reference = encoder->ref;
|
||||
encoder->x264param.i_bframe = encoder->bframes;
|
||||
encoder->x264param.b_bframe_pyramid = encoder->b_pyramid;
|
||||
- encoder->x264param.b_bframe_adaptive = encoder->b_adapt;
|
||||
+ encoder->x264param.i_bframe_adaptive = encoder->b_adapt;
|
||||
encoder->x264param.b_interlaced = encoder->interlaced;
|
||||
encoder->x264param.b_deblocking_filter = 1;
|
||||
encoder->x264param.i_deblocking_filter_alphac0 = 0;
|
@ -0,0 +1,25 @@
|
||||
diff -Nru gst-plugins-bad-0.10.23.orig/ext/directfb/dfb-example.c gst-plugins-bad-0.10.23/ext/directfb/dfb-example.c
|
||||
--- gst-plugins-bad-0.10.23.orig/ext/directfb/dfb-example.c 2011-12-11 19:49:11.000000000 +0100
|
||||
+++ gst-plugins-bad-0.10.23/ext/directfb/dfb-example.c 2014-04-30 00:32:19.318755570 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
|
||||
-#include <directfb.h>
|
||||
#include <stdio.h>
|
||||
#include <gst/gst.h>
|
||||
+#include <directfb.h>
|
||||
|
||||
static IDirectFB *dfb = NULL;
|
||||
static IDirectFBSurface *primary = NULL;
|
||||
--- gst-plugins-bad-0.10.23.orig/tests/examples/directfb/gstdfb.c 2011-12-11 19:49:22.000000000 +0100
|
||||
+++ gst-plugins-bad-0.10.23/tests/examples/directfb/gstdfb.c 2014-04-30 01:10:11.610391084 +0200
|
||||
@@ -35,9 +35,9 @@
|
||||
#include <math.h>
|
||||
#include <time.h>
|
||||
|
||||
-#include <directfb.h>
|
||||
#include <gst/gst.h>
|
||||
#include <string.h>
|
||||
+#include <directfb.h>
|
||||
|
||||
/* macro for a safe call to DirectFB functions */
|
||||
#define DFBCHECK(x...) \
|
311
gst-plugins-bad010.spec
Normal file
311
gst-plugins-bad010.spec
Normal file
@ -0,0 +1,311 @@
|
||||
%define majorminor %(echo %version | cut -d. -f 1-2)
|
||||
%define libname lib%{name}
|
||||
|
||||
Name: gst-plugins-bad010
|
||||
Version: 0.10.23
|
||||
Release: 4mamba
|
||||
Summary: A set of plug-ins for gstreamer that aren't up to par compared to the rest
|
||||
Group: System/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
|
||||
Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
|
||||
Patch0: gst-plugins-bad-0.10.9-libx264.patch
|
||||
Patch1: gst-plugins-bad010-0.10.23-fix_build_of_directfb_plugin.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libass-devel
|
||||
BuildRequires: libaudio-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcdaudio-devel
|
||||
BuildRequires: libcelt-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdc1394-devel
|
||||
BuildRequires: libdca-devel
|
||||
BuildRequires: libdirac-devel
|
||||
BuildRequires: libdirectfb-devel
|
||||
BuildRequires: libdvdnav-devel
|
||||
BuildRequires: libdvdread-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfaac-devel
|
||||
BuildRequires: libfaad2-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgsm-devel
|
||||
BuildRequires: libgst-plugins-base010-devel
|
||||
BuildRequires: libgstreamer010-devel
|
||||
BuildRequires: libjasper-devel
|
||||
BuildRequires: libkate-devel
|
||||
BuildRequires: liblrdf-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libmimic-devel
|
||||
BuildRequires: libmjpegtools-devel
|
||||
BuildRequires: libmms-devel
|
||||
BuildRequires: libmodplug-devel
|
||||
BuildRequires: libmusepack-devel
|
||||
BuildRequires: libmusicbrainz2-devel
|
||||
BuildRequires: libofa-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libopus-devel
|
||||
BuildRequires: liborc-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: librdf-devel
|
||||
BuildRequires: librsvg-devel
|
||||
BuildRequires: librtmp-devel
|
||||
BuildRequires: libschroedinger-devel
|
||||
BuildRequires: libslv2-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libsoundtouch-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtiger-devel
|
||||
BuildRequires: libvdpau-devel
|
||||
BuildRequires: libvo-aacenc-devel
|
||||
BuildRequires: libvpx-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxvidcore-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzvbi-devel
|
||||
## AUTOBUILDREQ-END
|
||||
#%ifarch %ix86
|
||||
#BuildRequires: divx4linux-devel
|
||||
#%endif
|
||||
BuildRequires: libuuid-devel
|
||||
#BuildRequires: libswfdec-devel
|
||||
BuildRequires: libcroco-devel
|
||||
BuildRequires: libquicktime-devel
|
||||
BuildRequires: ladspa-devel
|
||||
BuildRequires: libslv2-devel
|
||||
BuildRequires: liblv2core-devel
|
||||
BuildRequires: mjpegtools
|
||||
BuildRequires: orc
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libsasl-devel
|
||||
BuildRequires: libgss-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: libraptor-devel
|
||||
BuildRequires: librasqal-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: libmpfr-devel
|
||||
BuildRequires: libgssapi-devel
|
||||
BuildRequires: udev-devel
|
||||
BuildRequires: libmjpegtools-devel >= 2.0.0
|
||||
Provides: gst-plugins-bad0.10
|
||||
Obsoletes: gst-plugins-bad0.10
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
#FIXME:
|
||||
#configure: *** Plug-ins with dependencies that will NOT be built:
|
||||
# acm
|
||||
# applemedia
|
||||
# directdrawsink
|
||||
# directsoundsrc
|
||||
# flite
|
||||
# gme
|
||||
# mythtvsrc
|
||||
# opencv
|
||||
# osxvideosrc
|
||||
# qtwrapper
|
||||
# spc
|
||||
# swfdec
|
||||
# timidity
|
||||
# wildmidi
|
||||
# wininet
|
||||
# zbar
|
||||
|
||||
%description
|
||||
GStreamer Bad Plug-ins is a set of plug-ins that aren't up to par compared to the rest. They might be close to being good quality, but they're missing something - be it a good code review, some documentation, a set of tests, a real live maintainer, or some actual wide use.
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: gst-plugins-bad0.10-devel
|
||||
Obsoletes: gst-plugins-bad0.10-devel
|
||||
|
||||
%description devel
|
||||
GStreamer Bad Plug-ins is a set of plug-ins that aren't up to par compared to the rest. They might be close to being good quality, but they're missing something - be it a good code review, some documentation, a set of tests, a real live maintainer, or some actual wide use.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n gst-plugins-bad-%{version}
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
SCHRO_CFLAGS="-I%{_includedir}/schroedinger-1.0" \
|
||||
--disable-divx
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang gst-plugins-bad-%{majorminor}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f gst-plugins-bad-%{majorminor}.lang
|
||||
%defattr(-,root,root)
|
||||
#%{_bindir}/gst-camera
|
||||
#%{_bindir}/gst-camera-perf
|
||||
%{_libdir}/libgstphotography*.so.*
|
||||
%{_libdir}/libgstbasevideo*.so.*
|
||||
%{_libdir}/libgstsignalprocessor-*.so.*
|
||||
%{_libdir}/libgstvdp-0.10.so.*
|
||||
%{_libdir}/libgstbasecamerabinsrc-0.10.so.*
|
||||
%{_libdir}/libgstcodecparsers-0.10.so.*
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgst*.la
|
||||
%{_libdir}/gstreamer-%{majorminor}/libgst*.so
|
||||
%{_libdir}/gstreamer-%{majorminor}/libresindvd.la
|
||||
%{_libdir}/gstreamer-%{majorminor}/libresindvd.so
|
||||
%{_datadir}/glib-2.0/schemas/org.freedesktop.gstreamer-0.10.default-elements.gschema.xml
|
||||
#%{_datadir}/gstreamer-%{majorminor}/camera-apps/gst-camera.ui
|
||||
#%{_datadir}/gstreamer-%{majorminor}/presets/GstAmrwbEnc.prs
|
||||
%doc AUTHORS COPYING COPYING.LIB
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/gstreamer-%{majorminor}
|
||||
%dir %{_includedir}/gstreamer-%{majorminor}/gst
|
||||
%dir %{_includedir}/gstreamer-%{majorminor}/gst/interfaces
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/interfaces/photography*.h
|
||||
%dir %{_includedir}/gstreamer-%{majorminor}/gst/signalprocessor
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/signalprocessor/gstsignalprocessor.h
|
||||
%dir %{_includedir}/gstreamer-%{majorminor}/gst/video
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/video/gstbasevideo*.h
|
||||
%dir %{_includedir}/gstreamer-%{majorminor}/gst/vdpau
|
||||
%{_includedir}/gstreamer-%{majorminor}/gst/vdpau/*.h
|
||||
%dir %{_includedir}/gstreamer-0.10/gst/basecamerabinsrc
|
||||
%{_includedir}/gstreamer-0.10/gst/basecamerabinsrc/*.h
|
||||
%dir %{_includedir}/gstreamer-0.10/gst/codecparsers
|
||||
%{_includedir}/gstreamer-0.10/gst/codecparsers/*.h
|
||||
%dir %{_includedir}/gstreamer-0.10/gst/video
|
||||
%{_includedir}/gstreamer-0.10/gst/video/*.h
|
||||
#%{_libdir}/gstreamer-%{majorminor}/libgst*.a
|
||||
%{_libdir}/libgstphotography*.a
|
||||
%{_libdir}/libgstphotography*.la
|
||||
%{_libdir}/libgstphotography*.so
|
||||
%{_libdir}/libgstbasevideo*.a
|
||||
%{_libdir}/libgstbasevideo*.la
|
||||
%{_libdir}/libgstbasevideo*.so
|
||||
%{_libdir}/libgstsignalprocessor-*.a
|
||||
%{_libdir}/libgstsignalprocessor-*.la
|
||||
%{_libdir}/libgstsignalprocessor-*.so
|
||||
%{_libdir}/libgstvdp-0.10.la
|
||||
%{_libdir}/libgstvdp-0.10.so
|
||||
%{_libdir}/libgstbasecamerabinsrc-0.10.a
|
||||
%{_libdir}/libgstbasecamerabinsrc-0.10.la
|
||||
%{_libdir}/libgstbasecamerabinsrc-0.10.so
|
||||
%{_libdir}/libgstcodecparsers-0.10.a
|
||||
%{_libdir}/libgstcodecparsers-0.10.la
|
||||
%{_libdir}/libgstcodecparsers-0.10.so
|
||||
%{_libdir}/pkgconfig/gstreamer-plugins-bad-%{majorminor}.pc
|
||||
%{_libdir}/pkgconfig/gstreamer-basevideo-%{majorminor}.pc
|
||||
%{_libdir}/pkgconfig/gstreamer-codecparsers-%{majorminor}.pc
|
||||
%dir %{_datadir}/gtk-doc/html/gst-plugins-bad-libs-%{majorminor}/
|
||||
%{_datadir}/gtk-doc/html/gst-plugins-bad-libs-0.10/*
|
||||
%doc ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Wed Apr 30 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.23-4mamba
|
||||
- rebuilt without divx4linux
|
||||
|
||||
* Mon Oct 08 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.23-3mamba
|
||||
- rebuilt as legacy package
|
||||
|
||||
* Wed Sep 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.23-2mamba
|
||||
- rebuilt with libmjpegtools >= 2.0.0
|
||||
|
||||
* Thu Aug 09 2012 Automatic Build System <autodist@mambasoft.it> 0.10.23-1mamba
|
||||
- update to 0.10.23
|
||||
|
||||
* Fri Jan 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.22-7mamba
|
||||
- rebuilt in devel-kde4
|
||||
|
||||
* Fri Jan 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.22-6mamba
|
||||
- added more requirements for more plugins
|
||||
|
||||
* Fri Jan 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.22-5mamba
|
||||
- rebuilt with more build requirements (including mms support for totem)
|
||||
|
||||
* Fri Dec 09 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.22-4mamba
|
||||
- rebuilt with(out) opencv 2.3.1a
|
||||
|
||||
* Sat Oct 29 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.22-3mamba
|
||||
- rebuilt with librasqal 3
|
||||
|
||||
* Sat Jul 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.22-2mamba
|
||||
- rebuilt with libcelt 0.11
|
||||
|
||||
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 0.10.22-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Jan 29 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.21-1mamba
|
||||
- update to 0.10.21
|
||||
|
||||
* Sun Aug 22 2010 Automatic Build System <autodist@mambasoft.it> 0.10.19-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 0.10.19-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 0.10.19-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Feb 20 2010 Automatic Build System <autodist@mambasoft.it> 0.10.17-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Oct 13 2009 Automatic Build System <autodist@mambasoft.it> 0.10.14-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Jul 14 2009 Automatic Build System <autodist@mambasoft.it> 0.10.13-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Jun 29 2009 Automatic Build System <autodist@mambasoft.it> 0.10.13-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 0.10.11-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Tue Apr 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.11-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Mar 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.10-1mamba
|
||||
- update to 0.10.10
|
||||
|
||||
* Fri Jan 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.9-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.9-1mamba
|
||||
- update to 0.10.9
|
||||
|
||||
* Fri Aug 29 2008 gil <puntogil@libero.it> 0.10.8-1mamba
|
||||
- update to 0.10.8
|
||||
|
||||
* Sun Jun 01 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.7-1mamba
|
||||
- update to 0.10.7
|
||||
|
||||
* Fri Apr 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.6-1mamba
|
||||
- update to 0.10.6
|
||||
|
||||
* Tue Nov 13 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.5-1mamba
|
||||
- update to 0.10.5
|
||||
|
||||
* Tue Jul 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.3-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user