automatic version update by autodist [release 1.0.20-1mamba;Sat Jul 16 2022]

This commit is contained in:
Automatic Build System 2024-01-05 23:29:49 +01:00
parent 2de74a88cc
commit ea494573c7
2 changed files with 25 additions and 92 deletions

View File

@ -1,21 +1,15 @@
diff -ru gsm-1.0-pl19.orig/Makefile gsm-1.0-pl19/Makefile
--- gsm-1.0-pl19.orig/Makefile 2020-03-27 22:17:15.000000000 +0100
+++ gsm-1.0-pl19/Makefile 2020-04-20 10:30:52.913000000 +0200
@@ -96,11 +96,11 @@
--- gsm-1.0-pl20.orig/Makefile 2022-07-03 19:49:29.000000000 +0200
+++ gsm-1.0-pl20/Makefile 2022-07-16 13:35:25.819524994 +0200
@@ -99,7 +99,7 @@
# Other tools
SHELL = /bin/sh
-LN = ln
+LN = ln -s -f
+LN = ln -sf
BASENAME = basename
AR = ar
ARFLAGS = cr
-RMFLAGS =
+RMFLAGS = -f
FIND = find
COMPRESS = gzip
COMPRESSFLAGS =
@@ -139,7 +139,7 @@
@@ -142,7 +142,7 @@
# Targets
@ -24,7 +18,7 @@ diff -ru gsm-1.0-pl19.orig/Makefile gsm-1.0-pl19/Makefile
TOAST = $(BIN)/toast
UNTOAST = $(BIN)/untoast
@@ -257,7 +257,7 @@
@@ -260,7 +260,7 @@
# Install targets
GSM_INSTALL_TARGETS = \
@ -33,7 +27,7 @@ diff -ru gsm-1.0-pl19.orig/Makefile gsm-1.0-pl19/Makefile
$(GSM_INSTALL_INC)/gsm.h \
$(GSM_INSTALL_MAN)/gsm.3 \
$(GSM_INSTALL_MAN)/gsm_explode.3 \
@@ -279,7 +279,7 @@
@@ -282,7 +282,7 @@
# Target rules
@ -42,7 +36,7 @@ diff -ru gsm-1.0-pl19.orig/Makefile gsm-1.0-pl19/Makefile
@-echo $(ROOT): Done.
tst: $(TST)/lin2cod $(TST)/cod2lin $(TOAST) $(TST)/test-result
@@ -299,24 +299,23 @@
@@ -302,24 +302,23 @@
# The basic API: libgsm
@ -75,87 +69,16 @@ diff -ru gsm-1.0-pl19.orig/Makefile gsm-1.0-pl19/Makefile
# The local bin and lib directories
@@ -351,53 +350,54 @@
fi
$(TOAST_INSTALL_BIN)/toast: $(TOAST)
- -rm $@
+ -rm $(RMFLAGS) $@
cp $(TOAST) $@
chmod 755 $@
$(TOAST_INSTALL_BIN)/untoast: $(TOAST_INSTALL_BIN)/toast
- -rm $@
- ln $? $@
+ -rm $(RMFLAGS) $@
+ $(LN) toast $@
$(TOAST_INSTALL_BIN)/tcat: $(TOAST_INSTALL_BIN)/toast
- -rm $@
- ln $? $@
+ -rm $(RMFLAGS) $@
+ $(LN) toast $@
$(TOAST_INSTALL_MAN)/toast.1: $(MAN)/toast.1
- -rm $@
+ -rm $(RMFLAGS) $@
cp $? $@
chmod 444 $@
$(GSM_INSTALL_MAN)/gsm.3: $(MAN)/gsm.3
- -rm $@
+ -rm $(RMFLAGS) $@
cp $? $@
chmod 444 $@
$(GSM_INSTALL_MAN)/gsm_option.3: $(MAN)/gsm_option.3
- -rm $@
+ -rm $(RMFLAGS) $@
cp $? $@
chmod 444 $@
$(GSM_INSTALL_MAN)/gsm_explode.3: $(MAN)/gsm_explode.3
- -rm $@
+ -rm $(RMFLAGS) $@
cp $? $@
chmod 444 $@
$(GSM_INSTALL_MAN)/gsm_print.3: $(MAN)/gsm_print.3
- -rm $@
+ -rm $(RMFLAGS) $@
cp $? $@
chmod 444 $@
$(GSM_INSTALL_INC)/gsm.h: $(INC)/gsm.h
- -rm $@
- cp $? $@
- chmod 444 $@
-
-$(GSM_INSTALL_LIB)/libgsm.a: $(LIBGSM)
- -rm $@
+ -rm $(RMFLAGS) $@
cp $? $@
chmod 444 $@
+$(GSM_INSTALL_LIB)/libgsm.so: $(LIBGSMSO)
+ -rm $(RMFLAGS) $@ $@.1 $@.1.0.13
+ cp $?.1.0.13 $@.1.0.13
+ chmod 755 $@.1.0.13
+ $(LN) libgsm.so.1.0.13 $@
+ $(LN) libgsm.so.1.0.13 $@.1
# Distribution
@@ -425,7 +425,7 @@
@@ -428,7 +427,7 @@
-print | xargs rm $(RMFLAGS)
clean: semi-clean
- -rm $(RMFLAGS) $(LIBGSM) $(ADDTST)/add \
+ -rm $(RMFLAGS) $(LIBGSMSO)* $(ADDTST)/add \
$(TOAST) $(TCAT) $(UNTOAST) \
$(ROOT)/gsm-1.0.tar.Z
$(ROOT)/gsm-1.0.tar.gz
@@ -473,22 +473,22 @@
@@ -476,22 +475,22 @@
$(TST)/test-result: $(TST)/lin2cod $(TST)/cod2lin $(TOAST) $(TST)/run
( cd $(TST); ./run )

View File

@ -2,22 +2,21 @@
%define minver %(echo %version | cut -d . -f3)
Name: gsm
Version: 1.0.19
Version: 1.0.20
Release: 1mamba
Summary: GSM 06.10 lossy speech compression library
Group: System/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.quut.com/gsm
URL: http://www.quut.com/gsm/
Source: http://www.quut.com/gsm/gsm-%{version}.tar.gz
Patch0: libgsm-1.0.19-shared.patch
Patch0: gsm-1.0.20-shared.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
## AUTOBUILDREQ-END
Requires: libgsm = %{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
GSM 06.10 lossy speech compression library.
@ -68,6 +67,14 @@ make install \
GSM_INSTALL_INC=%{buildroot}%{_includedir}/gsm \
GSM_INSTALL_MAN=%{buildroot}%{_mandir}/man3
cp -ap lib/libgsm* %{buildroot}%{_libdir}
install -d -m0755 %{buildroot}%{_includedir}/gsm
cp -a inc/*.h %{buildroot}%{_includedir}/gsm/
install -d -m0755 %{buildroot}%{_mandir}/man3
cp -a man/*.3 %{buildroot}%{_mandir}/man3/
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -93,6 +100,9 @@ make install \
%doc ChangeLog README
%changelog
* Sat Jul 16 2022 Automatic Build System <autodist@mambasoft.it> 1.0.20-1mamba
- automatic version update by autodist
* Sat Apr 18 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.19-1mamba
- update to 1.0.19