change build to fix user space arch on x86_64 and added more build options for bios version [release 2.00.bzr20130610-7mamba;Sat Oct 04 2014]
This commit is contained in:
parent
861b89510a
commit
e96f11b4c0
@ -1,13 +1,17 @@
|
|||||||
diff -Nru grub-2.00.orig/util/grub.d/10_linux.in grub-2.00/util/grub.d/10_linux.in
|
diff -Nru grub-2.00/util/grub.d/10_linux.in grub-2.00.patched/util/grub.d/10_linux.in
|
||||||
--- grub-2.00.orig/util/grub.d/10_linux.in 2012-04-18 23:24:38.000000000 +0200
|
--- grub-2.00/util/grub.d/10_linux.in 2013-06-09 23:58:16.000000000 +0200
|
||||||
+++ grub-2.00/util/grub.d/10_linux.in 2013-03-04 22:05:47.004877805 +0100
|
+++ grub-2.00.patched/util/grub.d/10_linux.in 2014-09-13 00:01:34.261330957 +0200
|
||||||
@@ -241,11 +241,33 @@
|
@@ -239,13 +239,35 @@
|
||||||
|
echo "submenu '$(gettext_printf "Advanced options for %s" "${OS}" | grub_quote)' \$menuentry_id_option 'gnulinux-advanced-$boot_device_id' {"
|
||||||
|
fi
|
||||||
|
|
||||||
linux_entry "${OS}" "${version}" advanced \
|
- linux_entry "${OS}" "${version}" advanced \
|
||||||
"${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
- "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
||||||
+
|
+ linux_entry "${OS} (proprietary video driver)" "${version}" nomodeset \
|
||||||
+ linux_entry "${OS} (no modeset video driver)" "${version}" advanced \
|
|
||||||
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT} nomodeset"
|
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT} nomodeset"
|
||||||
|
+
|
||||||
|
+ linux_entry "${OS} (with debug messages)" "${version}" debug \
|
||||||
|
+ "${GRUB_CMDLINE_LINUX} debug"
|
||||||
+
|
+
|
||||||
if [ "x${GRUB_DISABLE_RECOVERY}" != "xtrue" ]; then
|
if [ "x${GRUB_DISABLE_RECOVERY}" != "xtrue" ]; then
|
||||||
linux_entry "${OS}" "${version}" recovery \
|
linux_entry "${OS}" "${version}" recovery \
|
48
grub.spec
48
grub.spec
@ -3,7 +3,7 @@
|
|||||||
Name: grub
|
Name: grub
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.00.bzr20130610
|
Version: 2.00.bzr20130610
|
||||||
Release: 4mamba
|
Release: 7mamba
|
||||||
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -21,7 +21,7 @@ Source3: grub-2.00-openmamba-conf-other
|
|||||||
Source4: %{name}2-sysconfig
|
Source4: %{name}2-sysconfig
|
||||||
Source5: grub-2.00-openmamba-conf-other-linux
|
Source5: grub-2.00-openmamba-conf-other-linux
|
||||||
Source6: %{name}2-conf-failsafe
|
Source6: %{name}2-conf-failsafe
|
||||||
Patch1: grub-2.00-openmamba_boot_choices.patch
|
Patch1: grub-2.00-openmamba_boot_choices-1.patch
|
||||||
Patch2: grub-2.00-stdio.patch
|
Patch2: grub-2.00-stdio.patch
|
||||||
Patch3: %{name}2-1.97-sysconfig.patch
|
Patch3: %{name}2-1.97-sysconfig.patch
|
||||||
Patch9: %{name}2-1.99-fix_saved_entry_default.patch
|
Patch9: %{name}2-1.99-fix_saved_entry_default.patch
|
||||||
@ -33,12 +33,12 @@ BuildRequires: glibc-devel
|
|||||||
BuildRequires: libbzip2-devel
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: libdevmapper-devel
|
BuildRequires: libdevmapper-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
%ifnarch x86_64
|
|
||||||
# TODO: needs 32bit libfuse on x86_64
|
|
||||||
BuildRequires: libfuse-devel
|
BuildRequires: libfuse-devel
|
||||||
%endif
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: liblzma-devel
|
BuildRequires: liblzma-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: libzfs-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: libncurses-devel
|
BuildRequires: libncurses-devel
|
||||||
@ -47,6 +47,7 @@ BuildRequires: bison
|
|||||||
BuildRequires: help2man
|
BuildRequires: help2man
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: dejavu-fonts-ttf
|
BuildRequires: dejavu-fonts-ttf
|
||||||
|
BuildRequires: libzfs-devel
|
||||||
Requires: gettext
|
Requires: gettext
|
||||||
%ifnarch x86_64
|
%ifnarch x86_64
|
||||||
Requires: vbetest
|
Requires: vbetest
|
||||||
@ -105,17 +106,30 @@ ld -v | grep "gold" && {
|
|||||||
%build
|
%build
|
||||||
# WARNING: build requires ld.bfd; ld.gold produces not working binary
|
# WARNING: build requires ld.bfd; ld.gold produces not working binary
|
||||||
%configure \
|
%configure \
|
||||||
|
--with-platform="pc" \
|
||||||
|
--target="i386" \
|
||||||
|
--libdir=%{_prefix}/lib \
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
CFLAGS="-Os -m32" \
|
--enable-efiemu \
|
||||||
%else
|
%else
|
||||||
CFLAGS="%{optflags} -Os" \
|
--disable-efiemu \
|
||||||
%endif
|
%endif
|
||||||
--libdir=%{_prefix}/lib
|
--enable-mm-debug \
|
||||||
|
--enable-nls \
|
||||||
|
--enable-device-mapper \
|
||||||
|
--enable-cache-stats \
|
||||||
|
--enable-boot-time \
|
||||||
|
--enable-grub-mkfont \
|
||||||
|
--enable-grub-mount \
|
||||||
|
--enable-libzfs \
|
||||||
|
--disable-silent-rules \
|
||||||
|
--disable-werror \
|
||||||
|
CFLAGS= \
|
||||||
|
CXXFLAGS= \
|
||||||
|
FFLAGS=
|
||||||
|
|
||||||
%make \
|
# don't use % make because unset *FLAGS are needed
|
||||||
%ifarch x86_64
|
make
|
||||||
CFLAGS="-Os -m32" \
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# Generate Latin-1, Latin Extended A+B, Arrows, Box and Block characters:
|
# Generate Latin-1, Latin Extended A+B, Arrows, Box and Block characters:
|
||||||
./grub-mkfont --output=unifont.pf2 --range=0x0000-0x0241,0x2190-0x21FF,0x2500-0x259f unifont.bdf
|
./grub-mkfont --output=unifont.pf2 --range=0x0000-0x0241,0x2190-0x21FF,0x2500-0x259f unifont.bdf
|
||||||
@ -269,6 +283,7 @@ fi
|
|||||||
%{_bindir}/grub-kbdcomp
|
%{_bindir}/grub-kbdcomp
|
||||||
%{_bindir}/grub-menulst2cfg
|
%{_bindir}/grub-menulst2cfg
|
||||||
%{_bindir}/grub-mklayout
|
%{_bindir}/grub-mklayout
|
||||||
|
%{_bindir}/grub-mount
|
||||||
%{_bindir}/grub-editenv
|
%{_bindir}/grub-editenv
|
||||||
%{_bindir}/grub-fstest
|
%{_bindir}/grub-fstest
|
||||||
%{_bindir}/grub-mkfont
|
%{_bindir}/grub-mkfont
|
||||||
@ -342,6 +357,15 @@ fi
|
|||||||
%{_prefix}/lib/grub/x86_64-efi/*
|
%{_prefix}/lib/grub/x86_64-efi/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 04 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-7mamba
|
||||||
|
- change build to fix user space arch on x86_64 and added more build options for bios version
|
||||||
|
|
||||||
|
* Mon Sep 15 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-6mamba
|
||||||
|
- forgotten re-applying patch1
|
||||||
|
|
||||||
|
* Sat Sep 13 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-5mamba
|
||||||
|
- openmamba boot choices: fix submenu saved entry removing duplicated id and add debug entry
|
||||||
|
|
||||||
* Mon Aug 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-4mamba
|
* Mon Aug 05 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-4mamba
|
||||||
- remove obsoleted 30_other_linux script after fixing os-prober (since 1.62-2mamba)
|
- remove obsoleted 30_other_linux script after fixing os-prober (since 1.62-2mamba)
|
||||||
|
|
||||||
|
@ -1,5 +1,6 @@
|
|||||||
GRUB_DISTRIBUTOR="openmamba"
|
GRUB_DISTRIBUTOR="openmamba"
|
||||||
GRUB_CMDLINE_LINUX="quiet splash"
|
GRUB_CMDLINE_LINUX=""
|
||||||
|
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
|
||||||
#GRUB_DISABLE_LINUX_UUID=true
|
#GRUB_DISABLE_LINUX_UUID=true
|
||||||
GRUB_DISABLE_LINUX_RECOVERY=true
|
GRUB_DISABLE_LINUX_RECOVERY=true
|
||||||
GRUB_DEFAULT=saved
|
GRUB_DEFAULT=saved
|
||||||
|
Loading…
Reference in New Issue
Block a user