added upstream patch for ext2 fix following e2fsprogs 1.47 [release 2.04-7mamba;Sat Mar 04 2023]
This commit is contained in:
parent
72d28eac87
commit
9243e5d4b4
@ -14,7 +14,7 @@
|
||||
printf '%s\n' "${prepare_boot_cache}" | sed "s/^/$submenu_indentation/"
|
||||
fi
|
||||
- message="$(gettext_printf "Loading Linux %s ..." ${version})"
|
||||
+ message="$(gettext_printf "%s starting ..." ${OS})"
|
||||
+ message="$(gettext_printf "%s starting ..." "${OS}")"
|
||||
sed "s/^/$submenu_indentation/" << EOF
|
||||
echo '$(echo "$message" | grub_quote)'
|
||||
linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
|
||||
|
23
grub-2.04-e2fsprogs-1.47.patch
Normal file
23
grub-2.04-e2fsprogs-1.47.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -Nru grub-2.04/grub-core/fs/ext2.c grub-2.04/grub-core/fs/ext2.c
|
||||
--- grub-2.04/grub-core/fs/ext2.c 2019-04-23 10:54:47.000000000 +0200
|
||||
+++ grub-2.04/grub-core/fs/ext2.c 2023-03-04 14:37:37.639563356 +0100
|
||||
@@ -102,6 +102,8 @@
|
||||
#define EXT4_FEATURE_INCOMPAT_64BIT 0x0080
|
||||
#define EXT4_FEATURE_INCOMPAT_MMP 0x0100
|
||||
#define EXT4_FEATURE_INCOMPAT_FLEX_BG 0x0200
|
||||
+#define EXT4_FEATURE_INCOMPAT_CSUM_SEED 0x2000
|
||||
+#define EXT4_FEATURE_INCOMPAT_LARGEDIR 0x4000 /* >2GB or 3 level htree */
|
||||
#define EXT4_FEATURE_INCOMPAT_ENCRYPT 0x10000
|
||||
|
||||
/* The set of back-incompatible features this driver DOES support. Add (OR)
|
||||
@@ -124,7 +126,9 @@
|
||||
* RO driver.
|
||||
*/
|
||||
#define EXT2_DRIVER_IGNORED_INCOMPAT ( EXT3_FEATURE_INCOMPAT_RECOVER \
|
||||
- | EXT4_FEATURE_INCOMPAT_MMP)
|
||||
+ | EXT4_FEATURE_INCOMPAT_MMP \
|
||||
+ | EXT4_FEATURE_INCOMPAT_CSUM_SEED \
|
||||
+ | EXT4_FEATURE_INCOMPAT_LARGEDIR)
|
||||
|
||||
|
||||
#define EXT3_JOURNAL_MAGIC_NUMBER 0xc03b3998U
|
15
grub.spec
15
grub.spec
@ -4,7 +4,7 @@
|
||||
Name: grub
|
||||
Epoch: 2
|
||||
Version: 2.04
|
||||
Release: 5mamba
|
||||
Release: 7mamba
|
||||
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
@ -34,6 +34,7 @@ Patch13: grub-2.02-silent-boot.patch
|
||||
Patch14: grub-2.04-fix-enable-nls-install-locale-dir.patch
|
||||
Patch15: grub-2.04-custom-boot-message.patch
|
||||
Patch16: grub-2.04-binutils-2.36.patch
|
||||
Patch17: grub-2.04-e2fsprogs-1.47.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -59,8 +60,7 @@ Requires(post):%{__install_info}
|
||||
Requires: os-prober >= 1.62-2mamba
|
||||
Provides: bootloader
|
||||
Provides: grub2
|
||||
Obsoletes: grub2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: grub2 < 2:2.04-7mamba
|
||||
|
||||
%description
|
||||
GNU GRUB is a Multiboot boot loader. It was derived from GRUB, GRand Unified Bootloader, which was originally designed and implemented by Erich Stefan Boleyn.
|
||||
@ -81,7 +81,7 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: efibootmgr
|
||||
%endif
|
||||
Provides: grub2-efi
|
||||
Obsoletes: grub2-efi
|
||||
Obsoletes: grub2-efi < 2:2.04-7mamba
|
||||
|
||||
%description efi
|
||||
GNU GRUB is a Multiboot boot loader. It was derived from GRUB, GRand Unified Bootloader, which was originally designed and implemented by Erich Stefan Boleyn.
|
||||
@ -113,6 +113,7 @@ This package contains the efi boot files needed to boot according to EFI standar
|
||||
%patch14 -p1
|
||||
%patch15 -p1 -b .custom-boot-message
|
||||
%patch16 -p1 -b .binutils-2.36
|
||||
%patch17 -p1 -b .e2fsprogs-1.47
|
||||
|
||||
gunzip -c %{SOURCE1} > unifont.bdf
|
||||
|
||||
@ -384,6 +385,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Mar 04 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.04-7mamba
|
||||
- added upstream patch for ext2 fix following e2fsprogs 1.47
|
||||
|
||||
* Mon Aug 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.04-6mamba
|
||||
- add required quotes to fix custom boot message in related patch
|
||||
|
||||
* Sat Jul 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.04-5mamba
|
||||
- updated patch to customize boot message
|
||||
- posttrans: use OS name from /etc/os-release when building EFI loaders
|
||||
|
Loading…
Reference in New Issue
Block a user