update to 2.02
added patch to silent the "Booting" message [release 2.02-1mamba;Mon Oct 30 2017]
This commit is contained in:
parent
a3fa445080
commit
7d6ac2460a
36
grub-2.02-silent-boot.patch
Normal file
36
grub-2.02-silent-boot.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
diff -Nru grub-2.02.orig/grub-core/gfxmenu/view.c grub-2.02/grub-core/gfxmenu/view.c
|
||||||
|
--- grub-2.02.orig/grub-core/gfxmenu/view.c 2015-05-21 17:50:29.000000000 +0200
|
||||||
|
+++ grub-2.02/grub-core/gfxmenu/view.c 2017-10-30 16:53:55.109658971 +0100
|
||||||
|
@@ -598,19 +598,6 @@
|
||||||
|
static void
|
||||||
|
notify_booting (grub_menu_entry_t entry, void *userdata)
|
||||||
|
{
|
||||||
|
- grub_gfxmenu_view_t view = (grub_gfxmenu_view_t) userdata;
|
||||||
|
-
|
||||||
|
- char *s = grub_malloc (100 + grub_strlen (entry->title));
|
||||||
|
- if (!s)
|
||||||
|
- return;
|
||||||
|
-
|
||||||
|
- grub_sprintf (s, "Booting '%s'", entry->title);
|
||||||
|
- set_progress_message (view, s);
|
||||||
|
- grub_free (s);
|
||||||
|
- grub_gfxmenu_view_redraw (view, &view->progress_message_frame);
|
||||||
|
- grub_video_swap_buffers ();
|
||||||
|
- if (view->double_repaint)
|
||||||
|
- grub_gfxmenu_view_redraw (view, &view->progress_message_frame);
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
||||||
|
diff -Nru grub-2.02.orig/grub-core/normal/menu.c grub-2.02/grub-core/normal/menu.c
|
||||||
|
--- grub-2.02.orig/grub-core/normal/menu.c 2015-09-02 22:10:53.000000000 +0200
|
||||||
|
+++ grub-2.02/grub-core/normal/menu.c 2017-10-30 16:52:29.545653772 +0100
|
||||||
|
@@ -810,9 +810,6 @@
|
||||||
|
notify_booting (grub_menu_entry_t entry,
|
||||||
|
void *userdata __attribute__((unused)))
|
||||||
|
{
|
||||||
|
- grub_printf (" ");
|
||||||
|
- grub_printf_ (N_("Booting `%s'"), entry->title);
|
||||||
|
- grub_printf ("\n\n");
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Callback invoked when a default menu entry executed because of a timeout
|
15
grub.spec
15
grub.spec
@ -2,8 +2,8 @@
|
|||||||
%define pkgver %(echo %version | tr _ -)
|
%define pkgver %(echo %version | tr _ -)
|
||||||
#%define betaver %(echo %version| cut -d. -f3)
|
#%define betaver %(echo %version| cut -d. -f3)
|
||||||
Name: grub
|
Name: grub
|
||||||
Epoch: 1
|
Epoch: 2
|
||||||
Version: 2.02_beta3
|
Version: 2.02
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
@ -15,8 +15,8 @@ URL: http://www.gnu.org/software/grub/
|
|||||||
# bzr branch http://bzr.savannah.gnu.org/r/grub/trunk/grub
|
# bzr branch http://bzr.savannah.gnu.org/r/grub/trunk/grub
|
||||||
# cd grub; ./autogen.sh; ./configure; make dist
|
# cd grub; ./autogen.sh; ./configure; make dist
|
||||||
#Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
|
#Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
|
||||||
Source: git://git.savannah.gnu.org/grub.git/grub-%{pkgver}/grub-%{version}.tar.bz2
|
#Source: git://git.savannah.gnu.org/grub.git/grub-%{pkgver}/grub-%{version}.tar.bz2
|
||||||
#Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.gz
|
Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.gz
|
||||||
Source1: http://unifoundry.com/unifont-5.1.20080820.bdf.gz
|
Source1: http://unifoundry.com/unifont-5.1.20080820.bdf.gz
|
||||||
Source2: %{name}2-default
|
Source2: %{name}2-default
|
||||||
Source3: grub-2.00-openmamba-conf-other
|
Source3: grub-2.00-openmamba-conf-other
|
||||||
@ -30,6 +30,7 @@ Patch9: %{name}2-1.99-fix_saved_entry_default.patch
|
|||||||
Patch10: grub-2.00-flex-2.5.37.patch
|
Patch10: grub-2.00-flex-2.5.37.patch
|
||||||
Patch11: grub-2.00-gcc-4.5.patch
|
Patch11: grub-2.00-gcc-4.5.patch
|
||||||
Patch12: grub-2.02_beta3-openmamba-default-nomodeset.patch
|
Patch12: grub-2.02_beta3-openmamba-default-nomodeset.patch
|
||||||
|
Patch13: grub-2.02-silent-boot.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -101,6 +102,8 @@ This package contains the efi boot files needed to boot according to EFI standar
|
|||||||
#%patch10 -p0
|
#%patch10 -p0
|
||||||
#%patch11 -p1
|
#%patch11 -p1
|
||||||
%patch12 -p1
|
%patch12 -p1
|
||||||
|
%patch13 -p1
|
||||||
|
|
||||||
gunzip -c %{SOURCE1} > unifont.bdf
|
gunzip -c %{SOURCE1} > unifont.bdf
|
||||||
|
|
||||||
# ld.gold has problems with -Wl-Ttext=xxx and produces not working binaries
|
# ld.gold has problems with -Wl-Ttext=xxx and produces not working binaries
|
||||||
@ -368,6 +371,10 @@ fi
|
|||||||
%{_prefix}/lib/grub/x86_64-efi/*
|
%{_prefix}/lib/grub/x86_64-efi/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 30 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02-1mamba
|
||||||
|
- update to 2.02
|
||||||
|
- added patch to silent the "Booting" message
|
||||||
|
|
||||||
* Thu Aug 25 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02_beta3-1mamba
|
* Thu Aug 25 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02_beta3-1mamba
|
||||||
- update to 2.02_beta3
|
- update to 2.02_beta3
|
||||||
- patched 10_linux to set openmamba theme colors to submenu
|
- patched 10_linux to set openmamba theme colors to submenu
|
||||||
|
Loading…
Reference in New Issue
Block a user