patched to fix installation of locales in /boot/grub/locale directory [release 2.04-2mamba;Sun Dec 22 2019]
This commit is contained in:
parent
e02b2cfc57
commit
6be92a1248
20
grub-2.04-fix-enable-nls-install-locale-dir.patch
Normal file
20
grub-2.04-fix-enable-nls-install-locale-dir.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- grub-2.04/util/grub-install-common.c.orig 2019-12-22 22:28:32.286000000 +0100
|
||||
+++ grub-2.04/util/grub-install-common.c 2019-12-22 22:25:23.601000000 +0100
|
||||
@@ -598,7 +598,7 @@
|
||||
grub_util_fd_closedir (d);
|
||||
}
|
||||
|
||||
-#if !(defined (GRUB_UTIL) && defined(ENABLE_NLS) && ENABLE_NLS)
|
||||
+#if (defined (GRUB_UTIL) && defined(ENABLE_NLS) && ENABLE_NLS)
|
||||
static const char *
|
||||
get_localedir (void)
|
||||
{
|
||||
@@ -659,7 +659,7 @@
|
||||
grub_install_copy_nls(const char *src __attribute__ ((unused)),
|
||||
const char *dst __attribute__ ((unused)))
|
||||
{
|
||||
-#if !(defined (GRUB_UTIL) && defined(ENABLE_NLS) && ENABLE_NLS)
|
||||
+#if (defined (GRUB_UTIL) && defined(ENABLE_NLS) && ENABLE_NLS)
|
||||
char *dst_locale;
|
||||
|
||||
dst_locale = grub_util_path_concat (2, dst, "locale");
|
50
grub.spec
50
grub.spec
@ -4,7 +4,7 @@
|
||||
Name: grub
|
||||
Epoch: 2
|
||||
Version: 2.04
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
@ -31,6 +31,7 @@ Patch10: grub-2.00-flex-2.5.37.patch
|
||||
Patch11: grub-2.00-gcc-4.5.patch
|
||||
Patch12: grub-2.02_beta3-openmamba-default-nomodeset.patch
|
||||
Patch13: grub-2.02-silent-boot.patch
|
||||
Patch14: grub-2.04-fix-enable-nls-install-locale-dir.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -53,7 +54,7 @@ BuildRequires: flex
|
||||
BuildRequires: dejavu-fonts-ttf
|
||||
BuildRequires: libzfs-devel
|
||||
Requires: gettext
|
||||
%ifnarch x86_64
|
||||
%ifnarch x86_64 aarch64
|
||||
Requires: vbetest
|
||||
%endif
|
||||
Requires(post):%{__install_info}
|
||||
@ -71,7 +72,9 @@ Briefly, boot loader is the first software program that runs when a computer sta
|
||||
Summary: GRUB Multiboot boot loader build for EFI
|
||||
Group: System/Kernel and Hardware
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%ifnarch aarch64
|
||||
Requires: efibootmgr
|
||||
%endif
|
||||
Provides: grub2-efi
|
||||
Obsoletes: grub2-efi
|
||||
|
||||
@ -91,18 +94,18 @@ GNU GRUB is a Multiboot boot loader. It was derived from GRUB, GRand Unified Boo
|
||||
Briefly, boot loader is the first software program that runs when a computer starts. It is responsible for loading and transferring control to the operating system kernel software (such as the Hurd or the Linux). The kernel, in turn, initializes the rest of the operating system (e.g. GNU).
|
||||
This package contains the efi boot files needed to boot according to EFI standard.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n grub-%{majver}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch1 -p1
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch9 -p1
|
||||
#%patch10 -p0
|
||||
#%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
|
||||
gunzip -c %{SOURCE1} > unifont.bdf
|
||||
|
||||
@ -113,14 +116,16 @@ ld -v | grep "gold" && {
|
||||
}
|
||||
|
||||
sh ./linguas.sh
|
||||
./autogen.sh
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
./autogen.sh
|
||||
# WARNING: build requires ld.bfd; ld.gold produces not working binary
|
||||
%configure \
|
||||
%ifarch x86_64 %{ix86}
|
||||
--with-platform="pc" \
|
||||
--target="i386" \
|
||||
%endif
|
||||
--libdir=%{_prefix}/lib \
|
||||
%ifarch x86_64
|
||||
--enable-efiemu \
|
||||
@ -279,7 +284,7 @@ fi
|
||||
|
||||
%files -f grub.lang
|
||||
%defattr(-,root,root)
|
||||
%config %{_sysconfdir}/default/grub
|
||||
%config(noreplace) %{_sysconfdir}/default/grub
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/grub
|
||||
%dir %{_sysconfdir}/grub.d
|
||||
%{_sysconfdir}/grub.d/00_header
|
||||
@ -309,9 +314,6 @@ fi
|
||||
%{_bindir}/grub-mkrescue
|
||||
%{_bindir}/grub-mkstandalone
|
||||
%{_bindir}/grub-render-label
|
||||
%ifnarch x86_64
|
||||
%{_bindir}/grub-mount
|
||||
%endif
|
||||
%{_bindir}/grub-script-check
|
||||
%{_bindir}/grub-syslinux2cfg
|
||||
%{_sbindir}/grub-bios-setup
|
||||
@ -337,20 +339,9 @@ fi
|
||||
%{_datadir}/grub/themes/starfield/*
|
||||
%{_infodir}/grub-dev.info.gz
|
||||
%dir %{_prefix}/lib/grub
|
||||
%ifarch x86_64 %{ix86}
|
||||
%dir %{_prefix}/lib/grub/i386-pc
|
||||
%{_prefix}/lib/grub/i386-pc/config.h
|
||||
%{_prefix}/lib/grub/i386-pc/gdb_grub
|
||||
%{_prefix}/lib/grub/i386-pc/gmodule.pl
|
||||
%{_prefix}/lib/grub/i386-pc/kernel.exec
|
||||
%{_prefix}/lib/grub/i386-pc/modinfo.sh
|
||||
%{_prefix}/lib/grub/i386-pc/*.image
|
||||
%{_prefix}/lib/grub/i386-pc/*.img
|
||||
%{_prefix}/lib/grub/i386-pc/*.lst
|
||||
%{_prefix}/lib/grub/i386-pc/*.mod
|
||||
%{_prefix}/lib/grub/i386-pc/*.module
|
||||
%ifarch x86_64
|
||||
%{_prefix}/lib/grub/i386-pc/efiemu32.o
|
||||
%{_prefix}/lib/grub/i386-pc/efiemu64.o
|
||||
%{_prefix}/lib/grub/i386-pc/*
|
||||
%endif
|
||||
%{_mandir}/man1/grub*.1.gz
|
||||
%{_mandir}/man8/grub*.8.gz
|
||||
@ -358,21 +349,32 @@ fi
|
||||
%doc AUTHORS COPYING
|
||||
#% doc ChangeLog NEWS README THANKS TODO
|
||||
|
||||
%ifarch %{ix86}
|
||||
%ifarch %{ix86} aarch64
|
||||
%files efi
|
||||
%defattr(-,root,root)
|
||||
%dir /boot/efi
|
||||
%ifarch %{ix86}
|
||||
%dir %{_prefix}/lib/grub/i386-efi
|
||||
%{_prefix}/lib/grub/i386-efi/*
|
||||
%endif
|
||||
%ifarch aarch64
|
||||
%dir %{_prefix}/lib/grub/arm64-efi
|
||||
%{_prefix}/lib/grub/arm64-efi/*
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%ifarch x86_64 %{ix86}
|
||||
%files efi-x86_64
|
||||
%defattr(-,root,root)
|
||||
%dir /boot/efi
|
||||
%dir %{_prefix}/lib/grub/x86_64-efi
|
||||
%{_prefix}/lib/grub/x86_64-efi/*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Dec 22 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 2.04-2mamba
|
||||
- patched to fix installation of locales in /boot/grub/locale directory
|
||||
|
||||
* Fri Jul 05 2019 Automatic Build System <autodist@mambasoft.it> 2.04-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user