update to 0.5.3 [release 0.5.3-1mamba;Fri Sep 22 2023]
This commit is contained in:
parent
9f83937f92
commit
e9af1ca6e2
21
grive2-0.5.3-fix-syncer-compilation.patch
Normal file
21
grive2-0.5.3-fix-syncer-compilation.patch
Normal file
@ -0,0 +1,21 @@
|
||||
From 3cf1c058a3e61deb370dde36024a106a213ab2c6 Mon Sep 17 00:00:00 2001
|
||||
From: Christoph Junghans <junghans@gentoo.org>
|
||||
Date: Sat, 21 May 2022 09:36:52 -0600
|
||||
Subject: [PATCH] Syncer.hh: fix build with gcc-12
|
||||
|
||||
---
|
||||
libgrive/src/base/Syncer.hh | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/libgrive/src/base/Syncer.hh b/libgrive/src/base/Syncer.hh
|
||||
index 237b8949..9b6ae4f7 100644
|
||||
--- a/libgrive/src/base/Syncer.hh
|
||||
+++ b/libgrive/src/base/Syncer.hh
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
#include "util/FileSystem.hh"
|
||||
|
||||
+#include <memory>
|
||||
#include <string>
|
||||
#include <vector>
|
||||
#include <iosfwd>
|
23
grive2-0.5.3-grep-3.11.patch
Normal file
23
grive2-0.5.3-grep-3.11.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From 5c8e87ee9a201123bbab30e1a238f7e67fa9ff0a Mon Sep 17 00:00:00 2001
|
||||
From: Jasper Young <jasper.c.young@gmail.com>
|
||||
Date: Tue, 20 Sep 2022 20:10:28 -0400
|
||||
Subject: [PATCH] Fix CMake CMP0004 Error
|
||||
|
||||
---
|
||||
cmake/Modules/FindLibGcrypt.cmake | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/cmake/Modules/FindLibGcrypt.cmake b/cmake/Modules/FindLibGcrypt.cmake
|
||||
index 0e1727f2..1cbc10a0 100644
|
||||
--- a/cmake/Modules/FindLibGcrypt.cmake
|
||||
+++ b/cmake/Modules/FindLibGcrypt.cmake
|
||||
@@ -27,6 +27,9 @@ IF(LIBGCRYPTCONFIG_EXECUTABLE)
|
||||
|
||||
EXEC_PROGRAM(${LIBGCRYPTCONFIG_EXECUTABLE} ARGS --cflags RETURN_VALUE _return_VALUE OUTPUT_VARIABLE LIBGCRYPT_CFLAGS)
|
||||
|
||||
+ string(REPLACE "fgrep: warning: fgrep is obsolescent; using grep -F" "" LIBGCRYPT_LIBRARIES "${LIBGCRYPT_LIBRARIES}")
|
||||
+ string(STRIP "${LIBGCRYPT_LIBRARIES}" LIBGCRYPT_LIBRARIES)
|
||||
+
|
||||
IF(${LIBGCRYPT_CFLAGS} MATCHES "\n")
|
||||
SET(LIBGCRYPT_CFLAGS " ")
|
||||
ENDIF(${LIBGCRYPT_CFLAGS} MATCHES "\n")
|
24
grive2.spec
24
grive2.spec
@ -1,5 +1,5 @@
|
||||
Name: grive2
|
||||
Version: 0.5.1
|
||||
Version: 0.5.3
|
||||
Release: 1mamba
|
||||
Summary: Google Drive client
|
||||
Group: Applications/Networking
|
||||
@ -7,25 +7,27 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/vitalif/grive2
|
||||
## GITSOURCE https://github.com/vitalif/grive2.git v0.5.0
|
||||
Source: https://github.com/vitalif/grive2.git/v%{version}/grive2-%{version}.tar.bz2
|
||||
Patch0: grive2-0.5.1-binutils-2.34.patch
|
||||
Patch1: grive2-0.5.3-grep-3.11.patch
|
||||
Patch2: grive2-0.5.3-fix-syncer-compilation.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libbinutils-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libjson-c-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libyajl-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libbinutils-devel >= 2.34
|
||||
BuildRequires: cmake
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Google Drive client with the support for the new Drive REST API and partial sync.
|
||||
@ -34,10 +36,14 @@ Google Drive client with the support for the new Drive REST API and partial sync
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
#%patch0 -p1
|
||||
%patch 1 -p1 -b .grep-3.11
|
||||
%patch 2 -p1 -b .fix-syncer-compilation
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
%cmake -d build \
|
||||
-DCMAKE_EXE_LINKER_FLAGS="-lzstd -ljson-c -lsframe"
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -50,7 +56,8 @@ Google Drive client with the support for the new Drive REST API and partial sync
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/grive
|
||||
%{_prefix}/lib/grive/grive-sync.sh
|
||||
%{_prefix}/libexec/grive/grive-sync.sh
|
||||
%{_userunitdir}/grive@.service
|
||||
%{_userunitdir}/grive-changes@.service
|
||||
%{_userunitdir}/grive-timer@.service
|
||||
%{_userunitdir}/grive-timer@.timer
|
||||
@ -58,6 +65,9 @@ Google Drive client with the support for the new Drive REST API and partial sync
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Fri Sep 22 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.3-1mamba
|
||||
- update to 0.5.3
|
||||
|
||||
* Sat Feb 29 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
||||
- update to 0.5.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user