update to 0.5.1 [release 0.5.1-1mamba;Sat Feb 29 2020]
This commit is contained in:
parent
00655732d1
commit
9f83937f92
26
grive2-0.5.1-binutils-2.34.patch
Normal file
26
grive2-0.5.1-binutils-2.34.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- grive2-0.5.1/libgrive/src/bfd/SymbolInfo.cc.orig 2020-02-29 15:32:16.688000000 +0100
|
||||
+++ grive2-0.5.1/libgrive/src/bfd/SymbolInfo.cc 2020-02-29 15:35:04.408000000 +0100
|
||||
@@ -34,6 +34,14 @@
|
||||
#include <iomanip>
|
||||
#include <algorithm>
|
||||
|
||||
+#ifndef bfd_get_section_flags
|
||||
+#define bfd_get_section_flags(H, S) bfd_section_flags(S)
|
||||
+#endif /* bfd_get_section_flags */
|
||||
+
|
||||
+#ifndef bfd_get_section_vma
|
||||
+#define bfd_get_section_vma(H, S) bfd_section_vma(S)
|
||||
+#endif /* bfd_get_section_vma */
|
||||
+
|
||||
namespace gr {
|
||||
|
||||
struct SymbolInfo::Impl
|
||||
@@ -124,7 +132,7 @@
|
||||
if ( address < vma )
|
||||
return;
|
||||
|
||||
- bfd_size_type size = bfd_section_size(abfd, section);
|
||||
+ bfd_size_type size = bfd_section_size(section);
|
||||
if ( address > (vma + size))
|
||||
return ;
|
||||
|
20
grive2.spec
20
grive2.spec
@ -1,6 +1,6 @@
|
||||
Name: grive2
|
||||
Version: 0.5.0
|
||||
Release: 7mamba
|
||||
Version: 0.5.1
|
||||
Release: 1mamba
|
||||
Summary: Google Drive client
|
||||
Group: Applications/Networking
|
||||
Vendor: openmamba
|
||||
@ -9,13 +9,13 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/vitalif/grive2
|
||||
## GITSOURCE https://github.com/vitalif/grive2.git v0.5.0
|
||||
Source: https://github.com/vitalif/grive2.git/v%{version}/grive2-%{version}.tar.bz2
|
||||
Patch0: grive2-0.5.1-binutils-2.34.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libbinutils-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
@ -23,7 +23,7 @@ BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libyajl-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libbinutils-devel >= 2.33.1-2mamba
|
||||
BuildRequires: libbinutils-devel >= 2.34
|
||||
BuildRequires: cmake
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -34,6 +34,7 @@ Google Drive client with the support for the new Drive REST API and partial sync
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
@ -49,10 +50,17 @@ Google Drive client with the support for the new Drive REST API and partial sync
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/grive
|
||||
%{_mandir}/man1/grive.1.gz
|
||||
%{_prefix}/lib/grive/grive-sync.sh
|
||||
%{_userunitdir}/grive-changes@.service
|
||||
%{_userunitdir}/grive-timer@.service
|
||||
%{_userunitdir}/grive-timer@.timer
|
||||
%{_mandir}/man1/grive.1*
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Sat Feb 29 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
||||
- update to 0.5.1
|
||||
|
||||
* Sat Nov 23 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.0-7mamba
|
||||
- rebuilt by autoport with build requirements: libbinutils-devel>=2.33.1-2mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user