libgraphviz: obsolete ocaml-graphviz [release 10.0.1-2mamba;Wed Feb 14 2024]
This commit is contained in:
parent
8a1ef8d3c5
commit
9253365e22
@ -1,27 +0,0 @@
|
||||
diff -up graphviz-2.30.1/configure.ac.orig graphviz-2.30.1/configure.ac
|
||||
--- graphviz-2.30.1/configure.ac.orig 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/configure.ac 2013-02-15 11:43:17.794608767 +0100
|
||||
@@ -710,7 +710,7 @@ else
|
||||
GUILE_LIBS=
|
||||
# don't die if PKG_CHECK_MODULES not available - el4, el5
|
||||
PKG_CHECK_MODULES([GUILE],
|
||||
- [guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"],
|
||||
+ [guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"],
|
||||
GUILE_INCLUDES="$GUILE_CFLAGS",
|
||||
[
|
||||
PKG_CHECK_MODULES([GUILE],
|
||||
diff -up graphviz-2.30.1/configure.orig graphviz-2.30.1/configure
|
||||
--- graphviz-2.30.1/configure.orig 2013-02-15 11:44:09.552556536 +0100
|
||||
+++ graphviz-2.30.1/configure 2013-02-14 14:30:22.000000000 +0100
|
||||
@@ -21028,9 +21028,9 @@ else
|
||||
_pkg_short_errors_supported=no
|
||||
fi
|
||||
if test $_pkg_short_errors_supported = yes; then
|
||||
- GUILE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
+ GUILE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
else
|
||||
- GUILE_PKG_ERRORS=`$PKG_CONFIG --print-errors "guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
+ GUILE_PKG_ERRORS=`$PKG_CONFIG --print-errors "guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||
fi
|
||||
# Put the nasty error message in config.log where it belongs
|
||||
echo "$GUILE_PKG_ERRORS" >&5
|
@ -1,11 +0,0 @@
|
||||
diff -up graphviz-2.30.1/lib/gvc/libgvc.pc.in.cgraph graphviz-2.30.1/lib/gvc/libgvc.pc.in
|
||||
--- graphviz-2.30.1/lib/gvc/libgvc.pc.in.cgraph 2013-04-23 16:13:09.034471849 -0400
|
||||
+++ graphviz-2.30.1/lib/gvc/libgvc.pc.in 2013-04-23 16:13:12.209471736 -0400
|
||||
@@ -7,6 +7,6 @@ plugins=@GVPLUGIN_VERSION@
|
||||
Name: libgvc
|
||||
Description: The GraphVizContext library
|
||||
Version: @VERSION@
|
||||
-Libs: -L${libdir} -lgvc -lgraph -lcdt
|
||||
+Libs: -L${libdir} -lgvc -lcgraph -lcdt
|
||||
Cflags: -I${includedir}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- graphviz-2.30.1.orig/configure.ac 2013-02-14 14:27:39.000000000 +0100
|
||||
+++ graphviz-2.30.1/configure.ac 2013-02-27 13:34:31.900615824 +0100
|
||||
@@ -946,7 +946,7 @@
|
||||
fi
|
||||
|
||||
AC_MSG_CHECKING(for Lua compiling and linking)
|
||||
- LUA_TEST=`LT=luatest.c ; echo "#include <lua.h>" > $LT; echo "#include <lualib.h>" >> $LT; echo "int main() { luaopen_base((lua_State *)lua_open()); return 0; }" >> $LT ; $CC -Wall $LT -o $LT.out $LUA_INCLUDES $LUA_LIBS $CFLAGS $LDFLAGS 1>/dev/null 2>&1 ; echo $?; rm -f $LT $LT.out 1>/dev/null 2>&1`
|
||||
+ LUA_TEST=`LT=luatest.c ; echo "#include <lua.h>" > $LT; echo "#include <lualib.h>" >> $LT; echo "int main() { luaopen_base((lua_State *)luaL_newstate()); return 0; }" >> $LT ; $CC -Wall $LT -o $LT.out $LUA_INCLUDES $LUA_LIBS $CFLAGS $LDFLAGS 1>/dev/null 2>&1 ; echo $?; rm -f $LT $LT.out 1>/dev/null 2>&1`
|
||||
if test "x$LUA_TEST" != "x0" ; then
|
||||
AC_MSG_RESULT(no)
|
||||
AC_MSG_WARN([
|
@ -1,17 +0,0 @@
|
||||
diff -ru -x '*o' graphviz-2.30.1.orig/tclpkg/gv/gv_php_init.c graphviz-2.30.1/tclpkg/gv/gv_php_init.c
|
||||
--- graphviz-2.30.1.orig/tclpkg/gv/gv_php_init.c 2013-02-27 12:25:47.939799924 +0100
|
||||
+++ graphviz-2.30.1/tclpkg/gv/gv_php_init.c 2013-02-27 12:26:41.890065699 +0100
|
||||
@@ -19,11 +19,13 @@
|
||||
|
||||
static size_t gv_string_writer (GVJ_t *job, const char *s, size_t len)
|
||||
{
|
||||
+ TSRMLS_FETCH();
|
||||
return PHPWRITE(s, len);
|
||||
}
|
||||
|
||||
static size_t gv_channel_writer (GVJ_t *job, const char *s, size_t len)
|
||||
{
|
||||
+ TSRMLS_FETCH();
|
||||
return PHPWRITE(s, len);
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- graphviz-2.30.1/configure.ac.orig 2013-07-18 00:11:31.511494891 +0200
|
||||
+++ graphviz-2.30.1/configure.ac 2013-07-18 00:11:34.631470248 +0200
|
||||
@@ -1542,7 +1542,7 @@
|
||||
if test `$SWIG -help 2>&1 | $EGREP -c '\-ruby *- Generate'` == 0; then
|
||||
use_ruby="No (swig does not support -ruby option)"
|
||||
else
|
||||
- PKG_CHECK_MODULES([RUBY], [ruby],[
|
||||
+ PKG_CHECK_MODULES([RUBY], [ruby-2.0],[
|
||||
AC_CHECK_PROG(RUBY,ruby,ruby)
|
||||
if test "x$RUBY" == "x"; then
|
||||
use_ruby="No (ruby not available)"
|
@ -1,11 +0,0 @@
|
||||
--- graphviz-2.49.1/configure.ac.orig 2021-10-04 10:51:16.579411906 +0200
|
||||
+++ graphviz-2.49.1/configure.ac 2021-10-04 10:51:26.473594056 +0200
|
||||
@@ -1185,7 +1185,7 @@
|
||||
use_python="No (python is too old)"
|
||||
else
|
||||
PYTHON_PREFIX=`$PYTHON -c "import sys; print(sys.prefix)"`
|
||||
- PYTHON_INCLUDES=-I$PYTHON_PREFIX/include/python$PYTHON_VERSION
|
||||
+ PYTHON_INCLUDES=-I$PYTHON_PREFIX/include/python${PYTHON_VERSION}m
|
||||
PYTHON_LIBS="-undefined dynamic_lookup"
|
||||
PYTHON_INSTALL_DIR="`$PYTHON -c 'from distutils import sysconfig; print(sysconfig.get_python_lib(1,0))'`"
|
||||
save_CPPFLAGS=$CPPFLAGS
|
@ -1,11 +0,0 @@
|
||||
--- graphviz-9.0.0/configure.ac.orig 2023-09-13 17:42:48.657822127 +0200
|
||||
+++ graphviz-9.0.0/configure.ac 2023-09-13 17:43:13.577689435 +0200
|
||||
@@ -800,7 +800,7 @@
|
||||
if test "x$PKG_CONFIG" != "x"; then
|
||||
AC_MSG_CHECKING(for Lua headers and libraries with pkg-config)
|
||||
echo
|
||||
- for l in "$lua_suffix" "" "53" "5.3" "52" "5.2" "51" "5.1" ; do
|
||||
+ for l in "$lua_suffix" "" "54" "5.4" "53" "5.3" "52" "5.2" "51" "5.1" ; do
|
||||
pkgconfig_lua_found=`$PKG_CONFIG --exists lua$l 2>/dev/null`
|
||||
if test "x$?" = "x0" ; then
|
||||
LUA_INCLUDES="$LUA_CFLAGS "`$PKG_CONFIG --cflags lua$l`
|
@ -1,8 +1,8 @@
|
||||
%define libname lib%{name}
|
||||
|
||||
Name: graphviz
|
||||
Version: 9.0.0
|
||||
Release: 1mamba
|
||||
Version: 10.0.1
|
||||
Release: 2mamba
|
||||
Summary: Graph Visualization Tools
|
||||
Group: Applications/Graphics
|
||||
Vendor: openmamba
|
||||
@ -10,14 +10,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.graphviz.org/
|
||||
Source: https://gitlab.com/graphviz/graphviz.git/%{version}/graphviz-%{version}.tar.bz2
|
||||
Patch0: graphviz-2.30.1-php-5.4.11.patch
|
||||
Patch1: graphviz-2.30.1-lua-5.2.patch
|
||||
Patch2: graphviz-2.30.1-gvc.pc-no-libgraph.patch
|
||||
Patch3: graphviz-2.30.1-guile-2.patch
|
||||
Patch4: graphviz-2.30.1-ruby-2.patch
|
||||
Patch5: graphviz-2.38.0-ghostscript-9.19.patch
|
||||
Patch6: graphviz-9.0.0-lua-5.4.patch
|
||||
Patch7: graphviz-2.49.1-python3-3.7.10.patch
|
||||
License: Common Public Attribution License 1.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -32,7 +25,6 @@ BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdevil-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreeglut-devel
|
||||
@ -53,9 +45,6 @@ BuildRequires: libgtkglext-devel
|
||||
BuildRequires: libgts-devel
|
||||
BuildRequires: libguile-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjbig-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: liblua-devel
|
||||
BuildRequires: libnsl-devel
|
||||
@ -63,24 +52,19 @@ BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libperl
|
||||
BuildRequires: libpoppler-glib-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: librsvg-devel
|
||||
BuildRequires: libruby-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtermcap-devel
|
||||
BuildRequires: libtirpc-devel
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libxcrypt-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
BuildRequires: ocaml-runtime
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libgs-devel >= 10.01.2-1mamba
|
||||
BuildRequires: ocaml >= 4.14.1
|
||||
BuildRequires: ocaml-runtime >= 4.11.1
|
||||
BuildRequires: libunistring-devel >= 0.9.6-1mamba
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: lua
|
||||
@ -117,8 +101,9 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
This package provides Guile extension for %{name}.
|
||||
|
||||
%package -n %{libname}
|
||||
Group: Development/Libraries
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
Obsoletes: ocaml-graphviz < 10.0
|
||||
|
||||
%description -n %{libname}
|
||||
This package provides shared library for %{name}.
|
||||
@ -150,14 +135,6 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description -n python-%{name}
|
||||
This package provides Python extension for %{name}.
|
||||
|
||||
%package -n ocaml-%{name}
|
||||
Group: System/Libraries/OCaml
|
||||
Summary: OCaml bindings to %{name}
|
||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n ocaml-%{name}
|
||||
This package provides OCaml bindings to %{name}.
|
||||
|
||||
%package -n %{libname}-java
|
||||
Group: System/Libraries
|
||||
Summary: Java extension for %{name}
|
||||
@ -239,11 +216,7 @@ This package contains the documentation of %{name} in HTML and pdf formats.
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
#%patch4 -p1
|
||||
%patch 5 -p1
|
||||
%patch 6 -p1
|
||||
#%patch7 -p1
|
||||
|
||||
./autogen.sh
|
||||
|
||||
@ -297,7 +270,6 @@ exit 0
|
||||
%{_libdir}/libgvc.so.*
|
||||
%{_libdir}/libgvpr.so.*
|
||||
%{_libdir}/libxdot.so.*
|
||||
%{_libdir}/liblab_gamut.so.*
|
||||
%{_libdir}/libpathplan.so.*
|
||||
%{_libdir}/lua/gv.so
|
||||
%{_libdir}/graphviz/libgvplugin_*.so.*
|
||||
@ -305,11 +277,6 @@ exit 0
|
||||
%{_libdir}/graphviz/lua/gv.so
|
||||
%{_libdir}/graphviz/lua/libgv_lua.so
|
||||
|
||||
%files -n ocaml-%{name}
|
||||
%defattr(-,root,root)
|
||||
%dir %{_libdir}/graphviz/ocaml
|
||||
%{_libdir}/graphviz/ocaml/*
|
||||
|
||||
%files -n perl-%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/graphviz/perl/gv.so
|
||||
@ -344,13 +311,12 @@ exit 0
|
||||
%dir %{_libdir}/graphviz/guile
|
||||
%{_libdir}/graphviz/guile/libgv_guile.so
|
||||
|
||||
#%files -n %{libname}-ruby
|
||||
#%defattr(-,root,root)
|
||||
#%dir %{_libdir}/graphviz/ruby
|
||||
#%{_libdir}/graphviz/ruby/gv.so
|
||||
#%{_libdir}/graphviz/ruby/libgv_ruby.la
|
||||
#%{_libdir}/graphviz/ruby/libgv_ruby.so
|
||||
#%{_libdir}/ruby/vendor_ruby/*/*-linux*/gv.so
|
||||
%files -n %{libname}-ruby
|
||||
%defattr(-,root,root)
|
||||
%dir %{_libdir}/graphviz/ruby
|
||||
%{_libdir}/graphviz/ruby/gv.so
|
||||
%{_libdir}/graphviz/ruby/libgv_ruby.so
|
||||
%{_libdir}/ruby/vendor_ruby/*/*-linux*/gv.so
|
||||
|
||||
#% if "%{stage1}" != "1"
|
||||
#%files -n %{libname}-php
|
||||
@ -387,7 +353,6 @@ exit 0
|
||||
%{_libdir}/libgvpr.so
|
||||
%{_libdir}/libxdot.so
|
||||
%{_libdir}/libpathplan.so
|
||||
%{_libdir}/liblab_gamut.so
|
||||
%{_libdir}/graphviz/libgvplugin_*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_mandir}/man3/*
|
||||
@ -404,12 +369,9 @@ exit 0
|
||||
%files -n %{libname}-tcl
|
||||
%defattr(-,root,root)
|
||||
%dir %{_libdir}/%{name}/tcl
|
||||
#%{_libdir}/%{name}/tcl/libgdtclft.so.*
|
||||
#%{_libdir}/%{name}/tcl/libtcldot.so.*
|
||||
#%{_libdir}/%{name}/tcl/libtcldot_builtin.so.*
|
||||
#%{_libdir}/%{name}/tcl/libtclplan.so.*
|
||||
%ifnarch %{ix86}
|
||||
%{_libdir}/liblab_gamut.so.*
|
||||
#%{_libdir}/%{name}/tcl/libtkspline.so.*
|
||||
%endif
|
||||
%{_libdir}/%{name}/tcl/libgv_tcl.so
|
||||
%{_libdir}/%{name}/tcl/pkgIndex.tcl
|
||||
# symlink
|
||||
@ -421,8 +383,9 @@ exit 0
|
||||
%{_libdir}/%{name}/tcl/libtcldot.so
|
||||
%{_libdir}/%{name}/tcl/libtcldot_builtin.so
|
||||
%{_libdir}/%{name}/tcl/libtclplan.so
|
||||
%ifnarch %{ix86}
|
||||
%{_libdir}/liblab_gamut.so
|
||||
#%{_libdir}/%{name}/tcl/libtkspline.so
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%files doc
|
||||
@ -431,6 +394,12 @@ exit 0
|
||||
%{_docdir}/%{name}/*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 14 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 10.0.1-2mamba
|
||||
- libgraphviz: obsolete ocaml-graphviz
|
||||
|
||||
* Tue Feb 13 2024 Automatic Build System <autodist@openmamba.org> 10.0.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Sep 14 2023 Automatic Build System <autodist@mambasoft.it> 9.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user