automatic version update by autodist [release 9.0.0-1mamba;Thu Sep 14 2023]
This commit is contained in:
parent
cab3781562
commit
8a1ef8d3c5
@ -1,11 +0,0 @@
|
|||||||
--- graphviz-2.38.0/configure.ac.orig 2016-05-15 19:27:52.204176821 +0200
|
|
||||||
+++ graphviz-2.38.0/configure.ac 2016-05-15 19:28:14.198171673 +0200
|
|
||||||
@@ -928,7 +928,7 @@
|
|
||||||
if test "x$ac_found_lua_header" = "xyes" -a "x$ac_found_liblua_header" = "xyes"; then
|
|
||||||
LUA_INCLUDES="$CFLAGS"
|
|
||||||
fi
|
|
||||||
- for l in "$lua_suffix" "" "52" "5.2" "51" "5.1" "50" "5.0" ; do
|
|
||||||
+ for l in "$lua_suffix" "" "54" "5.4" "53" "5.3" "52" "5.2" "51" "5.1" "50" "5.0" ; do
|
|
||||||
AC_CHECK_LIB(lua$l,lua_call,ac_found_lua_lib="yes",ac_found_lua_lib="no")
|
|
||||||
if test "x$ac_found_lua_lib" = "xyes" ; then
|
|
||||||
LUA_VERSION=">=5.1.0"
|
|
11
graphviz-9.0.0-lua-5.4.patch
Normal file
11
graphviz-9.0.0-lua-5.4.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- graphviz-9.0.0/configure.ac.orig 2023-09-13 17:42:48.657822127 +0200
|
||||||
|
+++ graphviz-9.0.0/configure.ac 2023-09-13 17:43:13.577689435 +0200
|
||||||
|
@@ -800,7 +800,7 @@
|
||||||
|
if test "x$PKG_CONFIG" != "x"; then
|
||||||
|
AC_MSG_CHECKING(for Lua headers and libraries with pkg-config)
|
||||||
|
echo
|
||||||
|
- for l in "$lua_suffix" "" "53" "5.3" "52" "5.2" "51" "5.1" ; do
|
||||||
|
+ for l in "$lua_suffix" "" "54" "5.4" "53" "5.3" "52" "5.2" "51" "5.1" ; do
|
||||||
|
pkgconfig_lua_found=`$PKG_CONFIG --exists lua$l 2>/dev/null`
|
||||||
|
if test "x$?" = "x0" ; then
|
||||||
|
LUA_INCLUDES="$LUA_CFLAGS "`$PKG_CONFIG --cflags lua$l`
|
@ -1,8 +1,8 @@
|
|||||||
%define libname lib%{name}
|
%define libname lib%{name}
|
||||||
|
|
||||||
Name: graphviz
|
Name: graphviz
|
||||||
Version: 8.1.0
|
Version: 9.0.0
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: Graph Visualization Tools
|
Summary: Graph Visualization Tools
|
||||||
Group: Applications/Graphics
|
Group: Applications/Graphics
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -16,7 +16,7 @@ Patch2: graphviz-2.30.1-gvc.pc-no-libgraph.patch
|
|||||||
Patch3: graphviz-2.30.1-guile-2.patch
|
Patch3: graphviz-2.30.1-guile-2.patch
|
||||||
Patch4: graphviz-2.30.1-ruby-2.patch
|
Patch4: graphviz-2.30.1-ruby-2.patch
|
||||||
Patch5: graphviz-2.38.0-ghostscript-9.19.patch
|
Patch5: graphviz-2.38.0-ghostscript-9.19.patch
|
||||||
Patch6: graphviz-7.0.6-lua-5.4.patch
|
Patch6: graphviz-9.0.0-lua-5.4.patch
|
||||||
Patch7: graphviz-2.49.1-python3-3.7.10.patch
|
Patch7: graphviz-2.49.1-python3-3.7.10.patch
|
||||||
License: Common Public Attribution License 1.0
|
License: Common Public Attribution License 1.0
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
@ -29,7 +29,6 @@ BuildRequires: libXmu-devel
|
|||||||
BuildRequires: libXrender-devel
|
BuildRequires: libXrender-devel
|
||||||
BuildRequires: libXt-devel
|
BuildRequires: libXt-devel
|
||||||
BuildRequires: libat-spi2-core-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
BuildRequires: libbrotli-devel
|
|
||||||
BuildRequires: libbzip2-devel
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libdevil-devel
|
BuildRequires: libdevil-devel
|
||||||
@ -151,6 +150,14 @@ Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description -n python-%{name}
|
%description -n python-%{name}
|
||||||
This package provides Python extension for %{name}.
|
This package provides Python extension for %{name}.
|
||||||
|
|
||||||
|
%package -n ocaml-%{name}
|
||||||
|
Group: System/Libraries/OCaml
|
||||||
|
Summary: OCaml bindings to %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n ocaml-%{name}
|
||||||
|
This package provides OCaml bindings to %{name}.
|
||||||
|
|
||||||
%package -n %{libname}-java
|
%package -n %{libname}-java
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Summary: Java extension for %{name}
|
Summary: Java extension for %{name}
|
||||||
@ -248,7 +255,7 @@ This package contains the documentation of %{name} in HTML and pdf formats.
|
|||||||
--enable-ruby \
|
--enable-ruby \
|
||||||
--disable-php \
|
--disable-php \
|
||||||
LDFLAGS="-ltermcap" \
|
LDFLAGS="-ltermcap" \
|
||||||
PYTHON=%{__python3}
|
PYTHON=%{__python310}
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -297,6 +304,9 @@ exit 0
|
|||||||
%dir %{_libdir}/graphviz/lua
|
%dir %{_libdir}/graphviz/lua
|
||||||
%{_libdir}/graphviz/lua/gv.so
|
%{_libdir}/graphviz/lua/gv.so
|
||||||
%{_libdir}/graphviz/lua/libgv_lua.so
|
%{_libdir}/graphviz/lua/libgv_lua.so
|
||||||
|
|
||||||
|
%files -n ocaml-%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
%dir %{_libdir}/graphviz/ocaml
|
%dir %{_libdir}/graphviz/ocaml
|
||||||
%{_libdir}/graphviz/ocaml/*
|
%{_libdir}/graphviz/ocaml/*
|
||||||
|
|
||||||
@ -421,6 +431,9 @@ exit 0
|
|||||||
%{_docdir}/%{name}/*
|
%{_docdir}/%{name}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 14 2023 Automatic Build System <autodist@mambasoft.it> 9.0.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Sep 03 2023 Automatic Build System <autodist@mambasoft.it> 8.1.0-2mamba
|
* Sun Sep 03 2023 Automatic Build System <autodist@mambasoft.it> 8.1.0-2mamba
|
||||||
- rebuilt by autoport with build requirements: libgs-devel>=10.01.2-1mamba
|
- rebuilt by autoport with build requirements: libgs-devel>=10.01.2-1mamba
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user