rebuilt with openexr 2.1.0 [release 2.36.0-3mamba;Mon Mar 31 2014]
This commit is contained in:
parent
a3a818e3b2
commit
5ec646ede8
@ -1,2 +1,4 @@
|
|||||||
# graphviz
|
# graphviz
|
||||||
|
|
||||||
|
A collection of tools and tcl packages for the manipulation and layout of graphs (as in nodes and edges, not as in barcharts).
|
||||||
|
|
||||||
|
27
graphviz-2.30.1-guile-2.patch
Normal file
27
graphviz-2.30.1-guile-2.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff -up graphviz-2.30.1/configure.ac.orig graphviz-2.30.1/configure.ac
|
||||||
|
--- graphviz-2.30.1/configure.ac.orig 2013-02-14 14:27:39.000000000 +0100
|
||||||
|
+++ graphviz-2.30.1/configure.ac 2013-02-15 11:43:17.794608767 +0100
|
||||||
|
@@ -710,7 +710,7 @@ else
|
||||||
|
GUILE_LIBS=
|
||||||
|
# don't die if PKG_CHECK_MODULES not available - el4, el5
|
||||||
|
PKG_CHECK_MODULES([GUILE],
|
||||||
|
- [guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"],
|
||||||
|
+ [guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"],
|
||||||
|
GUILE_INCLUDES="$GUILE_CFLAGS",
|
||||||
|
[
|
||||||
|
PKG_CHECK_MODULES([GUILE],
|
||||||
|
diff -up graphviz-2.30.1/configure.orig graphviz-2.30.1/configure
|
||||||
|
--- graphviz-2.30.1/configure.orig 2013-02-15 11:44:09.552556536 +0100
|
||||||
|
+++ graphviz-2.30.1/configure 2013-02-14 14:30:22.000000000 +0100
|
||||||
|
@@ -21028,9 +21028,9 @@ else
|
||||||
|
_pkg_short_errors_supported=no
|
||||||
|
fi
|
||||||
|
if test $_pkg_short_errors_supported = yes; then
|
||||||
|
- GUILE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||||
|
+ GUILE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||||
|
else
|
||||||
|
- GUILE_PKG_ERRORS=`$PKG_CONFIG --print-errors "guile >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||||
|
+ GUILE_PKG_ERRORS=`$PKG_CONFIG --print-errors "guile-2.0 >= "$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR"" 2>&1`
|
||||||
|
fi
|
||||||
|
# Put the nasty error message in config.log where it belongs
|
||||||
|
echo "$GUILE_PKG_ERRORS" >&5
|
11
graphviz-2.30.1-gvc.pc-no-libgraph.patch
Normal file
11
graphviz-2.30.1-gvc.pc-no-libgraph.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up graphviz-2.30.1/lib/gvc/libgvc.pc.in.cgraph graphviz-2.30.1/lib/gvc/libgvc.pc.in
|
||||||
|
--- graphviz-2.30.1/lib/gvc/libgvc.pc.in.cgraph 2013-04-23 16:13:09.034471849 -0400
|
||||||
|
+++ graphviz-2.30.1/lib/gvc/libgvc.pc.in 2013-04-23 16:13:12.209471736 -0400
|
||||||
|
@@ -7,6 +7,6 @@ plugins=@GVPLUGIN_VERSION@
|
||||||
|
Name: libgvc
|
||||||
|
Description: The GraphVizContext library
|
||||||
|
Version: @VERSION@
|
||||||
|
-Libs: -L${libdir} -lgvc -lgraph -lcdt
|
||||||
|
+Libs: -L${libdir} -lgvc -lcgraph -lcdt
|
||||||
|
Cflags: -I${includedir}
|
||||||
|
|
11
graphviz-2.30.1-lua-5.2.patch
Normal file
11
graphviz-2.30.1-lua-5.2.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- graphviz-2.30.1.orig/configure.ac 2013-02-14 14:27:39.000000000 +0100
|
||||||
|
+++ graphviz-2.30.1/configure.ac 2013-02-27 13:34:31.900615824 +0100
|
||||||
|
@@ -946,7 +946,7 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
AC_MSG_CHECKING(for Lua compiling and linking)
|
||||||
|
- LUA_TEST=`LT=luatest.c ; echo "#include <lua.h>" > $LT; echo "#include <lualib.h>" >> $LT; echo "int main() { luaopen_base((lua_State *)lua_open()); return 0; }" >> $LT ; $CC -Wall $LT -o $LT.out $LUA_INCLUDES $LUA_LIBS $CFLAGS $LDFLAGS 1>/dev/null 2>&1 ; echo $?; rm -f $LT $LT.out 1>/dev/null 2>&1`
|
||||||
|
+ LUA_TEST=`LT=luatest.c ; echo "#include <lua.h>" > $LT; echo "#include <lualib.h>" >> $LT; echo "int main() { luaopen_base((lua_State *)luaL_newstate()); return 0; }" >> $LT ; $CC -Wall $LT -o $LT.out $LUA_INCLUDES $LUA_LIBS $CFLAGS $LDFLAGS 1>/dev/null 2>&1 ; echo $?; rm -f $LT $LT.out 1>/dev/null 2>&1`
|
||||||
|
if test "x$LUA_TEST" != "x0" ; then
|
||||||
|
AC_MSG_RESULT(no)
|
||||||
|
AC_MSG_WARN([
|
17
graphviz-2.30.1-php-5.4.11.patch
Normal file
17
graphviz-2.30.1-php-5.4.11.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -ru -x '*o' graphviz-2.30.1.orig/tclpkg/gv/gv_php_init.c graphviz-2.30.1/tclpkg/gv/gv_php_init.c
|
||||||
|
--- graphviz-2.30.1.orig/tclpkg/gv/gv_php_init.c 2013-02-27 12:25:47.939799924 +0100
|
||||||
|
+++ graphviz-2.30.1/tclpkg/gv/gv_php_init.c 2013-02-27 12:26:41.890065699 +0100
|
||||||
|
@@ -19,11 +19,13 @@
|
||||||
|
|
||||||
|
static size_t gv_string_writer (GVJ_t *job, const char *s, size_t len)
|
||||||
|
{
|
||||||
|
+ TSRMLS_FETCH();
|
||||||
|
return PHPWRITE(s, len);
|
||||||
|
}
|
||||||
|
|
||||||
|
static size_t gv_channel_writer (GVJ_t *job, const char *s, size_t len)
|
||||||
|
{
|
||||||
|
+ TSRMLS_FETCH();
|
||||||
|
return PHPWRITE(s, len);
|
||||||
|
}
|
||||||
|
|
11
graphviz-2.30.1-ruby-2.patch
Normal file
11
graphviz-2.30.1-ruby-2.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- graphviz-2.30.1/configure.ac.orig 2013-07-18 00:11:31.511494891 +0200
|
||||||
|
+++ graphviz-2.30.1/configure.ac 2013-07-18 00:11:34.631470248 +0200
|
||||||
|
@@ -1542,7 +1542,7 @@
|
||||||
|
if test `$SWIG -help 2>&1 | $EGREP -c '\-ruby *- Generate'` == 0; then
|
||||||
|
use_ruby="No (swig does not support -ruby option)"
|
||||||
|
else
|
||||||
|
- PKG_CHECK_MODULES([RUBY], [ruby],[
|
||||||
|
+ PKG_CHECK_MODULES([RUBY], [ruby-2.0],[
|
||||||
|
AC_CHECK_PROG(RUBY,ruby,ruby)
|
||||||
|
if test "x$RUBY" == "x"; then
|
||||||
|
use_ruby="No (ruby not available)"
|
509
graphviz.spec
Normal file
509
graphviz.spec
Normal file
@ -0,0 +1,509 @@
|
|||||||
|
%define libname lib%{name}
|
||||||
|
|
||||||
|
Name: graphviz
|
||||||
|
Version: 2.36.0
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: Graph Visualization Tools
|
||||||
|
Group: Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.graphviz.org/
|
||||||
|
Source: http://www.graphviz.org/pub/graphviz/stable/SOURCES/graphviz-%{version}.tar.gz
|
||||||
|
Patch0: graphviz-2.30.1-php-5.4.11.patch
|
||||||
|
Patch1: graphviz-2.30.1-lua-5.2.patch
|
||||||
|
Patch2: graphviz-2.30.1-gvc.pc-no-libgraph.patch
|
||||||
|
Patch3: graphviz-2.30.1-guile-2.patch
|
||||||
|
Patch4: graphviz-2.30.1-ruby-2.patch
|
||||||
|
License: Common Public Attribution License 1.0
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghostscript-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libcroco-devel
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
BuildRequires: libdevil-devel
|
||||||
|
%endif
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libffi-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgc-devel
|
||||||
|
BuildRequires: libgd-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
BuildRequires: libgraphite2-devel
|
||||||
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libgts-devel
|
||||||
|
BuildRequires: libguile-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libicu-devel
|
||||||
|
BuildRequires: libilmbase-devel
|
||||||
|
BuildRequires: libjasper-devel
|
||||||
|
BuildRequires: libjbig-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: liblcms-devel
|
||||||
|
BuildRequires: libltdl-devel
|
||||||
|
BuildRequires: liblua-devel
|
||||||
|
BuildRequires: liblzma-devel
|
||||||
|
BuildRequires: libmng-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpng12-devel
|
||||||
|
BuildRequires: libpng15-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libpthread-stubs-devel
|
||||||
|
BuildRequires: libpython27-devel
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libreadline-devel
|
||||||
|
BuildRequires: librsvg-devel
|
||||||
|
BuildRequires: libselinux-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libtiff-devel
|
||||||
|
BuildRequires: libtk85
|
||||||
|
BuildRequires: libtk-devel
|
||||||
|
BuildRequires: libunistring-devel
|
||||||
|
BuildRequires: libuuid-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXau-devel
|
||||||
|
BuildRequires: libXaw-devel
|
||||||
|
BuildRequires: libxcb-devel
|
||||||
|
BuildRequires: libXdmcp-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: libXmu-devel
|
||||||
|
BuildRequires: libXpm-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
|
BuildRequires: libXt-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
BuildRequires: R
|
||||||
|
BuildRequires: ruby-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: ocaml
|
||||||
|
BuildRequires: lua
|
||||||
|
%ifarch %{ix86}
|
||||||
|
BuildRequires: libming-devel
|
||||||
|
%endif
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
BuildRequires: php-devel
|
||||||
|
BuildRequires: swig
|
||||||
|
%endif
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
# WARNING :
|
||||||
|
# checking for gdlib-config... /usr/bin/gdlib-config
|
||||||
|
# configure: WARNING: GD library version < 2.0.34
|
||||||
|
# configure: WARNING: Using internal libgd source.
|
||||||
|
|
||||||
|
%description
|
||||||
|
A collection of tools and tcl packages for the manipulation and layout of graphs (as in nodes and edges, not as in barcharts).
|
||||||
|
|
||||||
|
%package graphs
|
||||||
|
Group: Applications/Graphics
|
||||||
|
Summary: Demo graphs for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description graphs
|
||||||
|
This package provides some example graphs for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-guile
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Guile extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-guile
|
||||||
|
This package provides Guile extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Shared libraries for %{name}
|
||||||
|
|
||||||
|
%description -n %{libname}
|
||||||
|
This package provides shared library for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Obsoletes: %{name}-devel
|
||||||
|
Provides: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-devel
|
||||||
|
This package contains the files needed for developing programs using %{name} libraries.
|
||||||
|
|
||||||
|
%package -n perl-%{name}
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Perl extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n perl-%{name}
|
||||||
|
This package provides perl extension for %{name}.
|
||||||
|
|
||||||
|
%package -n python-%{name}
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Python extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n python-%{name}
|
||||||
|
This package provides Python extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-java
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Java extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-java
|
||||||
|
This package provides java extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-R
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: R language extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-R
|
||||||
|
This package provides R language extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-sharp
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: C# extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-sharp
|
||||||
|
This package provides C# extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-php
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: PHP extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-php
|
||||||
|
This package provides PHP extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-ruby
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Ruby extension for %{name}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-ruby
|
||||||
|
This package provides Ruby extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-tcl
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Tcl extension for %{name}
|
||||||
|
Obsoletes: %{name}-tcl
|
||||||
|
Provides: %{name}-tcl = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-tcl
|
||||||
|
This package provides tcl extension for %{name}.
|
||||||
|
|
||||||
|
%package -n %{libname}-tcl-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{libname}-tcl
|
||||||
|
Requires: %{libname}-tcl = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: %{libname}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-tcl-devel
|
||||||
|
Static libraries and headers for %{libname}-tcl.
|
||||||
|
|
||||||
|
%package doc
|
||||||
|
Group: Documentation
|
||||||
|
Summary: Documentation for version %{version} of %{name}
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package contains the documentation of %{name} in HTML and pdf formats.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch2 -p1
|
||||||
|
#%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
./autogen.sh
|
||||||
|
%configure \
|
||||||
|
--with-x \
|
||||||
|
--enable-lua \
|
||||||
|
--enable-ruby \
|
||||||
|
PYTHON=%{__python}
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%posttrans
|
||||||
|
dot -c
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%post -n %{libname} -p /sbin/ldconfig
|
||||||
|
%postun -n %{libname} -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%post -n %{libname}-tcl -p /sbin/ldconfig
|
||||||
|
%postun -n %{libname}-tcl -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/*
|
||||||
|
%{_datadir}/%{name}/*
|
||||||
|
%exclude %{_datadir}/%{name}/demo
|
||||||
|
%exclude %{_datadir}/%{name}/graphs
|
||||||
|
%exclude %{_datadir}/%{name}/doc/html
|
||||||
|
%exclude %{_datadir}/%{name}/doc/pdf
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%{_mandir}/man7/graphviz.7.gz
|
||||||
|
|
||||||
|
%files -n %{libname}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_libdir}/%{name}
|
||||||
|
#%{_libdir}/libagraph.so.*
|
||||||
|
%{_libdir}/libcdt.so.*
|
||||||
|
%{_libdir}/libcgraph.so.*
|
||||||
|
#%{_libdir}/libgraph.so.*
|
||||||
|
%{_libdir}/libgvc.so.*
|
||||||
|
%{_libdir}/libgvpr.so.*
|
||||||
|
%{_libdir}/libxdot.so.*
|
||||||
|
#%{_libdir}/libgvc_builtins.so.*
|
||||||
|
%{_libdir}/libpathplan.so.*
|
||||||
|
%{_libdir}/lua/gv.so
|
||||||
|
%{_libdir}/graphviz/libgvplugin_*.so.*
|
||||||
|
%dir %{_libdir}/graphviz/lua
|
||||||
|
%{_libdir}/graphviz/lua/gv.so
|
||||||
|
%{_libdir}/graphviz/lua/libgv_lua.la
|
||||||
|
%{_libdir}/graphviz/lua/libgv_lua.so
|
||||||
|
%dir %{_libdir}/graphviz/ocaml
|
||||||
|
%{_libdir}/graphviz/ocaml/*
|
||||||
|
|
||||||
|
%files -n perl-%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/graphviz/perl/gv.so
|
||||||
|
%{_libdir}/graphviz/perl/gv.pm
|
||||||
|
%{_libdir}/graphviz/perl/libgv_perl.la
|
||||||
|
%{_libdir}/graphviz/perl/libgv_perl.so
|
||||||
|
%{perl_vendorarch}/gv.*
|
||||||
|
|
||||||
|
%files -n python-%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/graphviz/python/_gv.so
|
||||||
|
%{_libdir}/graphviz/python/gv.py
|
||||||
|
%{_libdir}/graphviz/python/libgv_python.la
|
||||||
|
%{_libdir}/graphviz/python/libgv_python.so
|
||||||
|
%{python_sitearch}/*
|
||||||
|
|
||||||
|
%files -n %{libname}-R
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_libdir}/graphviz/R
|
||||||
|
%{_libdir}/graphviz/R/gv.so
|
||||||
|
%{_libdir}/graphviz/R/libgv_R.la
|
||||||
|
%{_libdir}/graphviz/R/libgv_R.so
|
||||||
|
|
||||||
|
%files -n %{libname}-guile
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_libdir}/graphviz/guile
|
||||||
|
%{_libdir}/graphviz/guile/libgv_guile.la
|
||||||
|
%{_libdir}/graphviz/guile/libgv_guile.so
|
||||||
|
|
||||||
|
%files -n %{libname}-ruby
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_libdir}/graphviz/ruby
|
||||||
|
%{_libdir}/graphviz/ruby/gv.so
|
||||||
|
%{_libdir}/graphviz/ruby/libgv_ruby.la
|
||||||
|
%{_libdir}/graphviz/ruby/libgv_ruby.so
|
||||||
|
%{_libdir}/ruby/vendor_ruby/*/*-linux*/gv.so
|
||||||
|
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
%files -n %{libname}-php
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/graphviz/php/gv.php
|
||||||
|
%{_libdir}/graphviz/php/gv.so
|
||||||
|
%{_libdir}/php/modules/gv.so
|
||||||
|
%{_datadir}/php/gv.php
|
||||||
|
%{_libdir}/graphviz/php/libgv_php.la
|
||||||
|
%{_libdir}/graphviz/php/libgv_php.so
|
||||||
|
|
||||||
|
%files -n %{libname}-sharp
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/graphviz/sharp/SWIGTYPE_p_*.cs
|
||||||
|
%{_libdir}/graphviz/sharp/gv.cs
|
||||||
|
%{_libdir}/graphviz/sharp/gvPINVOKE.cs
|
||||||
|
%{_libdir}/graphviz/sharp/libgv_sharp.la
|
||||||
|
%{_libdir}/graphviz/sharp/libgv_sharp.so
|
||||||
|
|
||||||
|
%files -n %{libname}-java
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/graphviz/java/SWIGTYPE_p_*.java
|
||||||
|
%{_libdir}/graphviz/java/gv.java
|
||||||
|
%{_libdir}/graphviz/java/gvJNI.java
|
||||||
|
%{_libdir}/graphviz/java/libgv_java.la
|
||||||
|
%{_libdir}/graphviz/java/libgv_java.so
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files -n %{libname}-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/%{name}
|
||||||
|
%{_includedir}/%{name}/*
|
||||||
|
%{_libdir}/libcdt.la
|
||||||
|
%{_libdir}/libcdt.so
|
||||||
|
%{_libdir}/libcgraph.la
|
||||||
|
%{_libdir}/libcgraph.so
|
||||||
|
%{_libdir}/libgvc.la
|
||||||
|
%{_libdir}/libgvc.so
|
||||||
|
%{_libdir}/libgvpr.la
|
||||||
|
%{_libdir}/libgvpr.so
|
||||||
|
%{_libdir}/libxdot.la
|
||||||
|
%{_libdir}/libxdot.so
|
||||||
|
%{_libdir}/libpathplan.la
|
||||||
|
%{_libdir}/libpathplan.so
|
||||||
|
%{_libdir}/graphviz/libgvplugin_*.la
|
||||||
|
%{_libdir}/graphviz/libgvplugin_*.so
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
|
%files graphs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/%{name}/demo
|
||||||
|
%{_datadir}/%{name}/demo/*
|
||||||
|
%dir %{_datadir}/%{name}/graphs
|
||||||
|
%{_datadir}/%{name}/graphs/*
|
||||||
|
|
||||||
|
%files -n %{libname}-tcl
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_libdir}/%{name}/tcl
|
||||||
|
%{_libdir}/%{name}/tcl/libgdtclft.so.*
|
||||||
|
%{_libdir}/%{name}/tcl/libtcldot.so.*
|
||||||
|
%{_libdir}/%{name}/tcl/libtcldot_builtin.so.*
|
||||||
|
%{_libdir}/%{name}/tcl/libtclplan.so.*
|
||||||
|
%{_libdir}/%{name}/tcl/libtkspline.so.*
|
||||||
|
%{_libdir}/%{name}/tcl/libgv_tcl.la
|
||||||
|
%{_libdir}/%{name}/tcl/libgv_tcl.so
|
||||||
|
%{_libdir}/%{name}/tcl/pkgIndex.tcl
|
||||||
|
# symlink
|
||||||
|
%{_libdir}/tcl*/graphviz
|
||||||
|
|
||||||
|
%files -n %{libname}-tcl-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/%{name}/tcl/libgdtclft.la
|
||||||
|
%{_libdir}/%{name}/tcl/libgdtclft.so
|
||||||
|
%{_libdir}/%{name}/tcl/libtcldot.la
|
||||||
|
%{_libdir}/%{name}/tcl/libtcldot.so
|
||||||
|
%{_libdir}/%{name}/tcl/libtcldot_builtin.la
|
||||||
|
%{_libdir}/%{name}/tcl/libtcldot_builtin.so
|
||||||
|
%{_libdir}/%{name}/tcl/libtclplan.la
|
||||||
|
%{_libdir}/%{name}/tcl/libtclplan.so
|
||||||
|
%{_libdir}/%{name}/tcl/libtkspline.la
|
||||||
|
%{_libdir}/%{name}/tcl/libtkspline.so
|
||||||
|
|
||||||
|
%files doc
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/%{name}/doc/
|
||||||
|
%dir %{_datadir}/%{name}/doc/html
|
||||||
|
%{_datadir}/%{name}/doc/html/*
|
||||||
|
%dir %{_datadir}/%{name}/doc/pdf
|
||||||
|
%{_datadir}/%{name}/doc/pdf/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Mar 31 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.36.0-3mamba
|
||||||
|
- rebuilt with openexr 2.1.0
|
||||||
|
|
||||||
|
* Mon Mar 03 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.36.0-2mamba
|
||||||
|
- rebuilt with libpoppler 0.24.5
|
||||||
|
|
||||||
|
* Tue Feb 04 2014 Automatic Build System <autodist@mambasoft.it> 2.36.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Sep 08 2013 Automatic Build System <autodist@mambasoft.it> 2.34.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 27 2013 Automatic Build System <autodist@mambasoft.it> 2.32.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jul 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.30.1-4mamba
|
||||||
|
- libgraphviz-tcl: fix %{_libdir}/tcl*/graphviz problem due to tcl8.6/graphviz being a symlink to tcl/graphviz
|
||||||
|
|
||||||
|
* Thu Jul 18 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.30.1-3mamba
|
||||||
|
- patched to fix libgvc.pc and for build with recent ruby and guile
|
||||||
|
- added libgts requirement
|
||||||
|
|
||||||
|
* Wed Feb 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.30.1-2mamba
|
||||||
|
- added libgraphviz-R subpackage
|
||||||
|
|
||||||
|
* Wed Feb 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.30.1-1mamba
|
||||||
|
- update to 2.30.1
|
||||||
|
|
||||||
|
* Tue Aug 09 2011 Automatic Build System <autodist@mambasoft.it> 2.28.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Feb 19 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.26.3-6mamba
|
||||||
|
- rebuilt with ghostscript 9.01
|
||||||
|
|
||||||
|
* Fri Nov 12 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.26.3-5mamba
|
||||||
|
- rebuilt with libpng 1.4 (after libdevil fix)
|
||||||
|
|
||||||
|
* Thu Nov 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.26.3-4mamba
|
||||||
|
- rebuilt with libpng 1.4
|
||||||
|
|
||||||
|
* Thu Oct 28 2010 Automatic Build System <autodist@mambasoft.it> 2.26.3-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Jun 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.26.3-2mamba
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Sat Apr 17 2010 Automatic Build System <autodist@mambasoft.it> 2.26.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Jan 18 2010 Automatic Build System <autodist@mambasoft.it> 2.26.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Jun 24 2009 Automatic Build System <autodist@mambasoft.it> 2.24.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue May 19 2009 Automatic Build System <autodist@mambasoft.it> 2.22.2-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 2.22.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Mar 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.20.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.18-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon Dec 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.16-3mamba
|
||||||
|
- execute dot -c in %post script to create plugin configuration
|
||||||
|
|
||||||
|
* Mon Dec 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.16-2mamba
|
||||||
|
- rebuild with libdevil and libming 0.4
|
||||||
|
|
||||||
|
* Mon Dec 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.16-1mamba
|
||||||
|
- update to 2.16
|
||||||
|
|
||||||
|
* Mon Jun 19 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 2.6-2qilnx
|
||||||
|
- added ruby binding
|
||||||
|
|
||||||
|
* Thu Oct 27 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.6-1qilnx
|
||||||
|
- update to version 2.6 by autospec
|
||||||
|
- dotneato-config, demo files moved to graphs package
|
||||||
|
- new package %{libname}
|
||||||
|
|
||||||
|
* Mon Sep 20 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.14-1qilnx
|
||||||
|
- update to version 1.14
|
||||||
|
- added the 'doc' package
|
||||||
|
|
||||||
|
* Fri Feb 27 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.11-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user