automatic rebuild by autodist [release 1.3.2-2mamba;Tue Aug 27 2013]

This commit is contained in:
Automatic Build System 2024-01-05 23:27:09 +01:00
parent 5d8e871d3d
commit df0a95b635
3 changed files with 99 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# graphthing # graphthing
GraphThing is a tool that allows you to create, manipulate and study graphs.

View File

@ -0,0 +1,21 @@
diff -Nru graphthing-1.3.2/src/fancyfileselection.cc graphthing-1.3.2.buono/src/fancyfileselection.cc
--- graphthing-1.3.2/src/fancyfileselection.cc 2006-09-11 03:32:12.000000000 +0200
+++ graphthing-1.3.2.buono/src/fancyfileselection.cc 2008-04-05 16:21:00.000000000 +0200
@@ -2,6 +2,8 @@
// fancyfileselection.cc
//
+#define wxHIDE_READONLY 0x0008
+
#include "wx/filedlg.h"
#include "wx/string.h"
#include "wx/window.h"
@@ -30,7 +32,7 @@
style |= wxHIDE_READONLY;
else if (style & wxSAVE)
style |= wxOVERWRITE_PROMPT;
- SetStyle (style);
+ SetWindowStyle (style);
if (file_types) {
wxString wc = wxT("");

76
graphthing.spec Normal file
View File

@ -0,0 +1,76 @@
Name: graphthing
Version: 1.3.2
Release: 2mamba
Summary: GraphThing is a tool that allows you to create, manipulate and study graphs.
Group: Graphical Desktop/Applications/Educational
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://graph.seul.org
Source: http://graph.seul.org/%{name}-%{version}.tar.bz2
Patch0: %{name}-1.3.2-wxGTK2.8.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
BuildRequires: libwxBase2.8-ansi-devel
BuildRequires: libwxGTK2.8-ansi-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
GraphThing is a tool that allows you to create, manipulate and study graphs.
%prep
%setup -q
%patch0 -p1
%build
%configure \
CXXFLAGS="-fpermissive"
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/bin
install -m 755 src/graphthing %{buildroot}/usr/bin/
# Create the system menu entry
mkdir -p %{buildroot}%{_datadir}/applications
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
[Desktop Entry]
Name=%{name}
Comment=GraphThing is a tool that allows you to create, manipulate and study
Exec=graphthing
Icon=kig
Terminal=0
Type=Application
X-KDE-StartupNotify=false
Categories=Applications;Science;Math;Education
EOF
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/*
%{_datadir}/applications/graphthing.desktop
#%{_mandir}/man1/depend.1.gz
%doc COPYING CREDITS
#README TODO
%changelog
* Tue Aug 27 2013 Automatic Build System <autodist@mambasoft.it> 1.3.2-2mamba
- automatic rebuild by autodist
* Sat Apr 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.2-1mamba
- update to 1.3.2
- changed maintainer
- created patch to build against wxGTK 2.8
* Wed Jul 20 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.0-1qilnx
- package created by autospec