175 lines
5.6 KiB
RPMSpec
175 lines
5.6 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: grantlee-editor
|
|
Version: 21.08.1
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 5 Contact Print Theme Editor
|
|
Group: Graphical Desktop/Look 'n' feel
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://kde.org/
|
|
Source: https://download.kde.org/stable/release-service/%{version}/src/grantlee-editor-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
#libpthread.so.0()(64bit): /usr/lib64/libpthread.so: file not owned by any package
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libQt5WebEngine-devel
|
|
BuildRequires: libakonadi-contacts-devel
|
|
BuildRequires: libakonadi-devel
|
|
BuildRequires: libakonadi-mime-devel
|
|
BuildRequires: libassuan-devel
|
|
BuildRequires: libattica5-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libgpgme-devel
|
|
BuildRequires: libgrantleetheme-devel
|
|
BuildRequires: libkarchive-devel
|
|
BuildRequires: libkauth-devel
|
|
BuildRequires: libkcodecs-devel
|
|
BuildRequires: libkcompletion-devel
|
|
BuildRequires: libkconfig-devel
|
|
BuildRequires: libkconfigwidgets-devel
|
|
BuildRequires: libkcontacts-devel
|
|
BuildRequires: libkcoreaddons-devel
|
|
BuildRequires: libkcrash-devel
|
|
BuildRequires: libkdbusaddons-devel
|
|
BuildRequires: libki18n-devel
|
|
BuildRequires: libkio-devel
|
|
BuildRequires: libkitemmodels-devel
|
|
BuildRequires: libkjobwidgets-devel
|
|
BuildRequires: libkleo-devel
|
|
BuildRequires: libkmime-devel
|
|
BuildRequires: libknewstuff-devel
|
|
BuildRequires: libkpimtextedit-devel
|
|
BuildRequires: libkservice-devel
|
|
BuildRequires: libkwidgetsaddons-devel
|
|
BuildRequires: libkwindowsystem-devel
|
|
BuildRequires: libkxmlgui-devel
|
|
BuildRequires: libpimcommon-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libsolid-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libsyntax-highlighting-devel
|
|
BuildRequires: messagelib-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description
|
|
KDE Frameworks 5 Contact Print Theme Editor.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%find_lang %{name}5_qt --with-qt --with-man --with-html --all-name || touch %{name}5_qt.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%postun -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%files -f %{name}5_qt.lang
|
|
%defattr(-,root,root)
|
|
%{_bindir}/contactprintthemeeditor
|
|
%{_bindir}/contactthemeeditor
|
|
%{_bindir}/headerthemeeditor
|
|
%{_datadir}/applications/org.kde.contactprintthemeeditor.desktop
|
|
%{_datadir}/applications/org.kde.contactthemeeditor.desktop
|
|
%{_datadir}/applications/org.kde.headerthemeeditor.desktop
|
|
%{_datadir}/config.kcfg/grantleethemeeditor.kcfg
|
|
%{_datadir}/qlogging-categories5/grantleeditor.categories
|
|
%{_datadir}/qlogging-categories5/grantleeditor.renamecategories
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libgrantleethemeeditor.so.*
|
|
%doc LICENSES
|
|
|
|
%changelog
|
|
* Sun Sep 05 2021 Automatic Build System <autodist@mambasoft.it> 21.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 20 2021 Automatic Build System <autodist@mambasoft.it> 21.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 09 2021 Automatic Build System <autodist@mambasoft.it> 21.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jun 19 2021 Automatic Build System <autodist@mambasoft.it> 21.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 14 2021 Automatic Build System <autodist@mambasoft.it> 21.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Apr 27 2021 Automatic Build System <autodist@mambasoft.it> 21.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 07 2021 Automatic Build System <autodist@mambasoft.it> 20.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 06 2021 Automatic Build System <autodist@mambasoft.it> 20.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 09 2021 Automatic Build System <autodist@mambasoft.it> 20.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 21 2020 Automatic Build System <autodist@mambasoft.it> 20.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 07 2020 Automatic Build System <autodist@mambasoft.it> 20.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Oct 11 2020 Automatic Build System <autodist@mambasoft.it> 20.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 04 2020 Automatic Build System <autodist@mambasoft.it> 20.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 21 2020 Automatic Build System <autodist@mambasoft.it> 20.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 12 2020 Automatic Build System <autodist@mambasoft.it> 20.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jun 13 2020 Automatic Build System <autodist@mambasoft.it> 20.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 17 2020 Automatic Build System <autodist@mambasoft.it> 20.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 30 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 20.04.0-1mamba
|
|
- package created using the webbuild interface
|