automatic version update by autodist [release 5.2.1-1mamba;Tue Mar 26 2024]
This commit is contained in:
parent
a5b3c3b7a4
commit
babd5473d9
@ -1,55 +0,0 @@
|
|||||||
From 425f414e5b6377425c4c43adb6a9e111f89ce6ca Mon Sep 17 00:00:00 2001
|
|
||||||
From: Benny Malengier <benny.malengier@gramps-project.org>
|
|
||||||
Date: Sun, 30 Jun 2013 15:52:04 +0000
|
|
||||||
Subject: [PATCH] 6807: validatedmaskedentry: no attribute '_block_changed'
|
|
||||||
|
|
||||||
git-svn-id: svn+ssh://svn.code.sf.net/p/gramps/code/trunk@22630 4ae1f11a-8b86-4847-b8af-ab372f36d1fd
|
|
||||||
---
|
|
||||||
gramps/gui/widgets/validatedmaskedentry.py | 7 ++++---
|
|
||||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/gramps/gui/widgets/validatedmaskedentry.py b/gramps/gui/widgets/validatedmaskedentry.py
|
|
||||||
index 36e1fd9..325d0d9 100644
|
|
||||||
--- a/gramps/gui/widgets/validatedmaskedentry.py
|
|
||||||
+++ b/gramps/gui/widgets/validatedmaskedentry.py
|
|
||||||
@@ -235,6 +235,7 @@ class MaskedEntry(UndoableEntry):
|
|
||||||
__gtype_name__ = 'MaskedEntry'
|
|
||||||
|
|
||||||
def __init__(self):
|
|
||||||
+ self._block_changed = False
|
|
||||||
UndoableEntry.__init__(self)
|
|
||||||
|
|
||||||
# connect in UndoableEntry:
|
|
||||||
@@ -253,7 +254,6 @@ def __init__(self):
|
|
||||||
|
|
||||||
self._completion = None
|
|
||||||
self._exact_completion = False
|
|
||||||
- self._block_changed = False
|
|
||||||
self.hasicon = False
|
|
||||||
## self._icon = IconEntry(self)
|
|
||||||
|
|
||||||
@@ -1157,10 +1157,10 @@ def __init__(self, data_type=None, err_color = "#ffd5d5", error_icon=ERROR_ICON)
|
|
||||||
self.data_type = None
|
|
||||||
self.mandatory = False
|
|
||||||
self.error_icon = error_icon
|
|
||||||
+ self._block_changed = False
|
|
||||||
|
|
||||||
MaskedEntry.__init__(self)
|
|
||||||
|
|
||||||
- self._block_changed = False
|
|
||||||
self._valid = True
|
|
||||||
self._def_error_msg = None
|
|
||||||
self._fade = FadeOut(self, err_color)
|
|
||||||
@@ -1171,7 +1171,8 @@ def __init__(self, data_type=None, err_color = "#ffd5d5", error_icon=ERROR_ICON)
|
|
||||||
|
|
||||||
# Virtual methods
|
|
||||||
def do_changed(self):
|
|
||||||
- if self._block_changed:
|
|
||||||
+ block_changed = getattr(self, '_block_changed', True)
|
|
||||||
+ if block_changed:
|
|
||||||
self.emit_stop_by_name('changed')
|
|
||||||
return
|
|
||||||
self.emit('content-changed')
|
|
||||||
--
|
|
||||||
1.8.1.6
|
|
||||||
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: gramps
|
Name: gramps
|
||||||
Version: 5.2.0
|
Version: 5.2.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: An open source genealogy program
|
Summary: An open source genealogy program
|
||||||
Group: Graphical Desktop/Applications/Scientific
|
Group: Graphical Desktop/Applications/Scientific
|
||||||
@ -8,7 +8,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://gramps-project.org/
|
URL: https://gramps-project.org/
|
||||||
Source: http://downloads.sourceforge.net/project/gramps/Stable/%{version}/gramps-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/project/gramps/Stable/%{version}/gramps-%{version}.tar.gz
|
||||||
Patch0: gramps-4.0.1-validatedmaskedentry_no_attribute__block_changed.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: libpython311-devel
|
BuildRequires: libpython311-devel
|
||||||
@ -19,7 +18,6 @@ Gramps, the open source genealogy program.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python3} setup.py build
|
%{__python3} setup.py build
|
||||||
@ -50,7 +48,7 @@ fi
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/gramps
|
%{_bindir}/gramps
|
||||||
%{_datadir}/applications/org.gramps_project.Gramps.desktop
|
%{_datadir}/applications/org.gramps_project.Gramps.desktop
|
||||||
%{_metainfodir}/org.gramps_project.Gramps.appdata.xml
|
%{_metainfodir}/org.gramps_project.Gramps.metainfo.xml
|
||||||
%{_datadir}/mime/packages/org.gramps_project.Gramps.xml
|
%{_datadir}/mime/packages/org.gramps_project.Gramps.xml
|
||||||
%dir %{_datadir}/gramps
|
%dir %{_datadir}/gramps
|
||||||
%{_datadir}/gramps/*
|
%{_datadir}/gramps/*
|
||||||
@ -67,6 +65,9 @@ fi
|
|||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 26 2024 Automatic Build System <autodist@openmamba.org> 5.2.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Wed Feb 28 2024 Automatic Build System <autodist@openmamba.org> 5.2.0-1mamba
|
* Wed Feb 28 2024 Automatic Build System <autodist@openmamba.org> 5.2.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user