automatic version update by autodist [release 4.0.3-1mamba;Wed Feb 05 2014]

This commit is contained in:
Automatic Build System 2024-01-05 23:24:52 +01:00
parent 56909e7127
commit 9dbf72b952
3 changed files with 155 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# gramps
Gramps, the open source genealogy program.

View File

@ -0,0 +1,55 @@
From 425f414e5b6377425c4c43adb6a9e111f89ce6ca Mon Sep 17 00:00:00 2001
From: Benny Malengier <benny.malengier@gramps-project.org>
Date: Sun, 30 Jun 2013 15:52:04 +0000
Subject: [PATCH] 6807: validatedmaskedentry: no attribute '_block_changed'
git-svn-id: svn+ssh://svn.code.sf.net/p/gramps/code/trunk@22630 4ae1f11a-8b86-4847-b8af-ab372f36d1fd
---
gramps/gui/widgets/validatedmaskedentry.py | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/gramps/gui/widgets/validatedmaskedentry.py b/gramps/gui/widgets/validatedmaskedentry.py
index 36e1fd9..325d0d9 100644
--- a/gramps/gui/widgets/validatedmaskedentry.py
+++ b/gramps/gui/widgets/validatedmaskedentry.py
@@ -235,6 +235,7 @@ class MaskedEntry(UndoableEntry):
__gtype_name__ = 'MaskedEntry'
def __init__(self):
+ self._block_changed = False
UndoableEntry.__init__(self)
# connect in UndoableEntry:
@@ -253,7 +254,6 @@ def __init__(self):
self._completion = None
self._exact_completion = False
- self._block_changed = False
self.hasicon = False
## self._icon = IconEntry(self)
@@ -1157,10 +1157,10 @@ def __init__(self, data_type=None, err_color = "#ffd5d5", error_icon=ERROR_ICON)
self.data_type = None
self.mandatory = False
self.error_icon = error_icon
+ self._block_changed = False
MaskedEntry.__init__(self)
- self._block_changed = False
self._valid = True
self._def_error_msg = None
self._fade = FadeOut(self, err_color)
@@ -1171,7 +1171,8 @@ def __init__(self, data_type=None, err_color = "#ffd5d5", error_icon=ERROR_ICON)
# Virtual methods
def do_changed(self):
- if self._block_changed:
+ block_changed = getattr(self, '_block_changed', True)
+ if block_changed:
self.emit_stop_by_name('changed')
return
self.emit('content-changed')
--
1.8.1.6

98
gramps.spec Normal file
View File

@ -0,0 +1,98 @@
Name: gramps
Version: 4.0.3
Release: 1mamba
Summary: An open source genealogy program
Group: Graphical Desktop/Applications/Scientific
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://gramps-project.org/
Source: http://downloads.sourceforge.net/project/gramps/Stable/%{version}/gramps-%{version}.tar.gz
Patch0: gramps-4.0.1-validatedmaskedentry_no_attribute__block_changed.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: libpython-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Gramps, the open source genealogy program.
%debug_package
%prep
%setup -q
#%patch0 -p1
%build
%{__python} setup.py build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%{__python} setup.py install \
--root=%{buildroot}
%find_lang %{name} || touch %{name}.lang
sed -i "s|%{buildroot}||" %{buildroot}%{python_sitearch}/gramps/gen/utils/resource-path
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post
%{_bindir}/update-mime-database %{_datadir}/mime 2>&1 > /dev/null
:
%postun
if [ $1 -eq 0 ]; then
%{_bindir}/update-mime-database %{_datadir}/mime 2>&1 > /dev/null
fi
:
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/gramps
%{_datadir}/appdata/gramps.appdata.xml
%{_datadir}/applications/gramps.desktop
%dir %{_datadir}/gramps
%{_datadir}/gramps/*
%{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-gedcom.png
%{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-geneweb.png
%{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-gramps-package.png
%{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-gramps-xml.png
%{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-gramps.png
%{_datadir}/icons/gnome/scalable/mimetypes/gnome-mime-application-x-gedcom.svg
%{_datadir}/icons/gnome/scalable/mimetypes/gnome-mime-application-x-geneweb.svg
%{_datadir}/icons/gnome/scalable/mimetypes/gnome-mime-application-x-gramps-package.svg
%{_datadir}/icons/gnome/scalable/mimetypes/gnome-mime-application-x-gramps-xml.svg
%{_datadir}/icons/gnome/scalable/mimetypes/gnome-mime-application-x-gramps.svg
%{_datadir}/mime-info/gramps.keys
%{_datadir}/mime-info/gramps.mime
%{_datadir}/mime/packages/gramps.xml
%{_mandir}/cs/man1/gramps.1.gz
%{_mandir}/fr/man1/gramps.1.gz
%{_mandir}/man1/gramps.1.gz
%{_mandir}/nl/man1/gramps.1.gz
%{_mandir}/pl/man1/gramps.1.gz
%{_mandir}/pt_BR/man1/gramps.1.gz
%{_mandir}/sv/man1/gramps.1.gz
%dir %{python_sitearch}/gramps
%{python_sitearch}/gramps/*
%{python_sitearch}/gramps-%{version}-py%{python_version}.egg-info
%{_datadir}/icons/gramps.png
%dir %{_docdir}/gramps
%{_docdir}/gramps/*
%doc AUTHORS COPYING
%changelog
* Wed Feb 05 2014 Automatic Build System <autodist@mambasoft.it> 4.0.3-1mamba
- automatic version update by autodist
* Wed Jul 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.0.1-2mamba
- upstream patch to fix a 'no attribute' error
* Tue Jul 16 2013 Automatic Build System <autodist@mambasoft.it> 4.0.1-1mamba
- automatic update by autodist
* Mon May 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.5-1mamba
- package created by silvan using the webbuild interface