184 lines
5.9 KiB
RPMSpec
184 lines
5.9 KiB
RPMSpec
Name: gradle
|
|
Version: 8.8
|
|
Release: 1mamba
|
|
Summary: Powerful build system for the JVM
|
|
Group: Applications/Development
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://gradle.org/
|
|
Source: https://services.gradle.org/distributions/gradle-%{version}-src.zip
|
|
Source1: gradle.sh
|
|
Source2: https://services.gradle.org/distributions/gradle-%{version}-bin.zip
|
|
Patch0: gradle-7.1.1-replace_gradle_plugin_repository.patch
|
|
License: Apache License 2.0
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: javapackages
|
|
BuildRequires: java-environment
|
|
BuildRequires: kotlin
|
|
|
|
%description
|
|
Powerful build system for the JVM.
|
|
|
|
%package docs
|
|
Summary: Gradle documentation
|
|
Group: Documentation
|
|
|
|
%description docs
|
|
This package contains the apache server documentation in HTML format.
|
|
|
|
%package src
|
|
Summary: Gradle sources
|
|
Group: Development/Libraries
|
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description src
|
|
This package contains the apache server documentation in HTML format.
|
|
|
|
# Don't clean build at the end
|
|
%global __spec_rmbuild_cmd /bin/true
|
|
|
|
%prep
|
|
%setup -q
|
|
#-D -T
|
|
#:<< _EOF
|
|
#%patch0 -p1
|
|
# remove ADOPTIUM contraint from all build related files
|
|
sed -i '/JvmVendorSpec.ADOPTIUM/d' \
|
|
build-logic-commons/module-identity/build.gradle.kts \
|
|
build-logic-commons/gradle-plugin/build.gradle.kts \
|
|
build-logic/jvm/src/main/kotlin/gradlebuild.unittest-and-compile.gradle.kts \
|
|
build-logic-commons/gradle-plugin/src/main/kotlin/gradlebuild/commons/JavaPluginExtensions.kt \
|
|
build-logic-commons/code-quality-rules/build.gradle.kts \
|
|
build-logic-commons/basics/build.gradle.kts \
|
|
platforms/jvm/language-java/src/integTest/groovy/org/gradle/jvm/toolchain/JavaToolchainDownloadIntegrationTest.groovy
|
|
|
|
%ifarch %{ix86}
|
|
unzip %{SOURCE2}
|
|
mv gradle-%{version} dist
|
|
%endif
|
|
|
|
%build
|
|
#:<< _EOF
|
|
export JAVA_HOME="%{_jvmdir}/java-11-openjdk"
|
|
export PATH="%{_jvmdir}/java-11-openjdk/bin:${PATH}"
|
|
%ifnarch %{ix86}
|
|
./gradlew installAll \
|
|
-Porg.gradle.java.installations.auto-download=false \
|
|
-PfinalRelease=true \
|
|
-Pgradle_installPath="$(pwd)/dist" \
|
|
--no-configuration-cache
|
|
%endif
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
install -d -m0755 %{buildroot}%{_bindir}
|
|
install -d -m0755 %{buildroot}%{_javadir}/gradle/{lib/{plugins,agents},init.d}
|
|
install -D -m0644 dist/lib/*.jar %{buildroot}%{_javadir}/gradle/lib/
|
|
install -D -m0644 dist/lib/plugins/*.jar %{buildroot}%{_javadir}/gradle/lib/plugins
|
|
install -D -m 644 dist/lib/agents/*.jar %{buildroot}%{_javadir}/gradle/lib/agents
|
|
|
|
install -D -m0755 dist/bin/gradle %{buildroot}%{_javadir}/gradle/bin/gradle
|
|
install -m0644 dist/init.d/*.* %{buildroot}%{_javadir}/gradle/init.d/
|
|
|
|
# install profile.d
|
|
install -D -m 755 %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d/gradle.sh
|
|
|
|
# link to gradle binary
|
|
ln -s ../share/java/gradle/bin/gradle %{buildroot}%{_bindir}/gradle
|
|
|
|
%ifnarch %{ix86}
|
|
# docs
|
|
install -d %{buildroot}%{_javadir}/gradle/docs
|
|
cp -r dist/docs/* %{buildroot}%{_javadir}/gradle/docs/
|
|
|
|
# src
|
|
install -d %{buildroot}%{_javadir}/gradle/src
|
|
cp -r dist/src/* %{buildroot}%{_javadir}/gradle/src/
|
|
%endif
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_sysconfdir}/profile.d/gradle.sh
|
|
%{_bindir}/gradle
|
|
%dir %{_datadir}/java/gradle
|
|
%dir %{_datadir}/java/gradle/bin
|
|
%{_datadir}/java/gradle/bin/gradle
|
|
%dir %{_datadir}/java/gradle/init.d
|
|
%{_datadir}/java/gradle/init.d/readme.txt
|
|
%dir %{_datadir}/java/gradle/lib
|
|
%{_datadir}/java/gradle/lib/*.jar
|
|
%dir %{_datadir}/java/gradle/lib/agents
|
|
%{_datadir}/java/gradle/lib/agents/*.jar
|
|
%dir %{_datadir}/java/gradle/lib/plugins
|
|
%{_datadir}/java/gradle/lib/plugins/*.jar
|
|
|
|
%ifnarch %{ix86}
|
|
%files docs
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/java/gradle/docs
|
|
%{_datadir}/java/gradle/docs/*
|
|
|
|
%files src
|
|
%defattr(-,root,root)
|
|
%dir %{_datadir}/java/gradle/src
|
|
%{_datadir}/java/gradle/src/*
|
|
%endif
|
|
|
|
%changelog
|
|
* Sat Jun 01 2024 Automatic Build System <autodist@openmamba.org> 8.8-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 23 2024 Automatic Build System <autodist@openmamba.org> 8.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 03 2024 Automatic Build System <autodist@openmamba.org> 8.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 31 2024 Automatic Build System <autodist@openmamba.org> 8.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 17 2023 Automatic Build System <autodist@mambasoft.it> 8.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 04 2023 Automatic Build System <autodist@mambasoft.it> 8.0.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 18 2023 Automatic Build System <autodist@mambasoft.it> 8.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Feb 14 2023 Automatic Build System <autodist@mambasoft.it> 8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 25 2022 Automatic Build System <autodist@mambasoft.it> 7.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 06 2022 Automatic Build System <autodist@mambasoft.it> 7.5.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 14 2022 Automatic Build System <autodist@mambasoft.it> 7.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 23 2021 Automatic Build System <autodist@mambasoft.it> 7.3.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 17 2021 Automatic Build System <autodist@mambasoft.it> 7.3.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 01 2021 Automatic Build System <autodist@mambasoft.it> 7.3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 10 2021 Automatic Build System <autodist@mambasoft.it> 7.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Sep 13 2021 Automatic Build System <autodist@mambasoft.it> 7.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jul 25 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 7.1.1-1mamba
|
|
- package created using the webbuild interface
|