gpsd/gpsd.spec

272 lines
13 KiB
RPMSpec

Name: gpsd
Version: 3.25
Release: 3mamba
Summary: A service daemon that monitors one or more GPSes attached to a host computer
Group: Graphical Desktop/Applications/Utilities
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.berlios.de/software/gpsd/
Source: http://download-mirror.savannah.gnu.org/releases/gpsd/gpsd-%{version}.tar.gz
Source1: gpsd.conf
Patch0: gpsd-3.7-rpath.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libbluetooth-devel
BuildRequires: libdbus-devel
BuildRequires: libgcc
BuildRequires: libncurses-devel
BuildRequires: libnsl-devel
BuildRequires: libpython311-devel
BuildRequires: libstdc++6-devel
BuildRequires: libusb-devel
BuildRequires: qt5-qtbase-devel
## AUTOBUILDREQ-END
BuildRequires: libpython3-devel
Requires: libgps = %{?epoch:%epoch:}%{version}-%{release}
%description
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
Besides gpsd itself, the project provides auxiliary tools for diagnostic monitoring and profiling of GPSes and feeding GPS-aware applications specified track data for diagnostic purposes.
The goal of the gpsd project is to create a solid layer of open-source infrastructure for programs running under Linux and other open-source Unixes that want to be location-sensitive. We aim for simple, robust interfaces, unfussy operation, and an easy learning curve for application developers. Applications that presently use gpsd include pyGPS, Kismet, GPSdrive, gpeGPS, position, roadmap, roadnav, navit, viking, and gaia.
%package -n xgps
Summary: X11 GPS UI application provided with %{name}
Group: Graphical Desktop/Applications/Utilities
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n xgps
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
This package provides the X11 GPS UI application provided with %{name},
%package -n libgps
Summary: GPS libraries provided by %{name}
Group: System/Libraries
%description -n libgps
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
This package contains the QT binding library for libgps.
%package -n libgps-devel
Summary: Devel package for libgps
Group: Development/Libraries
Requires: libgps = %{?epoch:%epoch:}%{version}-%{release}
Provides: %{name}-devel
Obsoletes: %{name}-devel < 3.25
%description -n libgps-devel
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
This package contains static libraries and header files need for development.
%package -n libgps-qt
Summary: QT binding for libgps
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n libgps-qt
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
This package contains the QT binding library for libgps.
%package -n libgps-qt-devel
Summary: Development package for libgps-qt
Group: Development/Libraries
Requires: libgps-devel = %{?epoch:%epoch:}%{version}-%{release}
Requires: libgps-qt = %{?epoch:%epoch:}%{version}-%{release}
%description -n libgps-qt-devel
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
This package contains the QT binding library for libgps.
%debug_package
%prep
%setup -q
#%patch0 -p1
find -name "*.py" | while read line; do sed -i "s|env python$|env python3|" $line; done
%build
scons \
prefix=%{_prefix} \
libdir=%{_lib} \
systemd=yes \
gpsd_group=uucp \
target_python=%{__python3} \
python_shebang="/usr/bin/env python3" \
python_libdir=%{python3_sitelib} \
qt_versioned=5 \
nostrip=True
scons build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
export DESTDIR=%{buildroot}
scons install prefix=%{_prefix} libdir=%{_lib}
install -D -m0755 gpsinit %{buildroot}%{_bindir}/gpsinit
install -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/default/gpsd
install -D -m0644 gpsd-%{version}/gpsd.rules %{buildroot}%{_udevrulesdir}/25-gpsd-usb.rules
install -D -m0755 gpsd.hotplug %{buildroot}%{_prefix}/lib/udev/gpsd.hotplug
sed -e 's|/local||' -i packaging/X11/*.desktop
install -D -m0644 packaging/X11/*.desktop -t %{buildroot}%{_datadir}/applications/
install -D -m0644 gpsd-%{version}/systemd/{gpsd.service,gpsd.socket,gpsdctl@.service} -t %{buildroot}%{_unitdir}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%preun
%systemd_preun gpsd.socket
:
%post
%systemd_post gpsd.socket
:
%postun
%systemd_postun gpsd.socket
:
%files
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/default/gpsd
%{_bindir}/cgps
%{_bindir}/gegps
%{_bindir}/gps*
%{_bindir}/gpxlogger
%{_bindir}/lcdgps
%{_bindir}/ntpshmmon
%{_bindir}/ppscheck
%{_bindir}/ubxtool
%{_bindir}/zerk
%{_sbindir}/gpsd
%{_sbindir}/gpsdctl
%{_unitdir}/gpsd.socket
%{_unitdir}/gpsd.service
%{_unitdir}/gpsdctl@.service
%{_prefix}/lib/udev/gpsd.hotplug
%{_udevrulesdir}/25-gpsd-usb.rules
%dir %{_datadir}/gpsd
%dir %{_datadir}/gpsd/icons
%{_datadir}/gpsd/icons/gpsd-logo.png
%dir %{_datadir}/gpsd/doc
%{_datadir}/gpsd/doc/*
%{_datadir}/snmp/mibs/gpsd/GPSD-MIB
%{_mandir}/man1/*
%{_mandir}/man8/*
%doc LICENSE COPYING
%files -n xgps
%defattr(-,root,root)
%{_bindir}/xgps
%{_bindir}/xgpsspeed
%{_datadir}/applications/xgps.desktop
%{_datadir}/applications/xgpsspeed.desktop
%files -n libgps
%defattr(-,root,root)
%{_libdir}/libgps.so.*
%{_libdir}/libgpsdpacket.so.*
%{python3_sitelib}/gps-*.egg-info
%dir %{python3_sitelib}/gps*
%{python3_sitelib}/gps/*
%files -n libgps-devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_libdir}/libgps.so
%{_libdir}/libgpsdpacket.so
%{_libdir}/pkgconfig/libgps.pc
%{_mandir}/man3/*
%{_mandir}/man5/*
%files -n libgps-qt
%defattr(-,root,root)
%{_libdir}/libQgpsmm.so.*
%files -n libgps-qt-devel
%defattr(-,root,root)
%{_libdir}/libQgpsmm.so
%{_libdir}/libQgpsmm.prl
%{_libdir}/pkgconfig/Qgpsmm.pc
%changelog
* Mon Oct 16 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.25-3mamba
- rebuilt with python3 == 3.11
* Sat Feb 25 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.25-2mamba
- install systemd and udev files; added xgps and -debug packages
* Tue Jan 17 2023 Automatic Build System <autodist@mambasoft.it> 3.25-1mamba
- automatic version update by autodist
* Thu Apr 28 2022 Automatic Build System <autodist@mambasoft.it> 3.24-1mamba
- automatic version update by autodist
* Wed Sep 22 2021 Automatic Build System <autodist@mambasoft.it> 3.23.1-1mamba
- automatic version update by autodist
* Sat Aug 07 2021 Automatic Build System <autodist@mambasoft.it> 3.23-1mamba
- automatic version update by autodist
* Sat Jan 09 2021 Automatic Build System <autodist@mambasoft.it> 3.22-1mamba
- automatic version update by autodist
* Fri Aug 14 2020 Automatic Build System <autodist@mambasoft.it> 3.21-1mamba
- automatic version update by autodist
* Sat Jan 04 2020 Automatic Build System <autodist@mambasoft.it> 3.20-1mamba
- automatic version update by autodist
* Sat Jul 20 2019 Automatic Build System <autodist@mambasoft.it> 3.19-1mamba
- automatic version update by autodist
* Sun Nov 04 2018 Automatic Build System <autodist@mambasoft.it> 3.18.1-1mamba
- automatic version update by autodist
* Mon Jan 11 2016 Automatic Build System <autodist@mambasoft.it> 3.16-1mamba
- automatic version update by autodist
* Fri Aug 21 2015 Automatic Build System <autodist@mambasoft.it> 3.15-1mamba
- automatic version update by autodist
* Thu Oct 02 2014 Automatic Build System <autodist@mambasoft.it> 3.11-1mamba
- automatic version update by autodist
* Wed May 08 2013 Automatic Build System <autodist@mambasoft.it> 3.9-1mamba
- automatic version update by autodist
* Tue Apr 30 2013 Automatic Build System <autodist@mambasoft.it> 3.8-1mamba
- automatic version update by autodist
* Fri Aug 10 2012 Automatic Build System <autodist@mambasoft.it> 3.7-1mamba
- update to 3.7
* Fri Aug 10 2012 Automatic Build System <autodist@mambasoft.it> 3.4-1mamba
- automatic version update by autodist
* Sun Mar 27 2011 Automatic Build System <autodist@mambasoft.it> 2.96-1mamba
- automatic update by autodist
* Mon Oct 11 2010 Automatic Build System <autodist@mambasoft.it> 2.95-1mamba
- automatic update by autodist
* Fri Apr 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.94-1mamba
- update to 2.94
* Wed Jan 13 2010 Automatic Build System <autodist@mambasoft.it> 2.90-1mamba
- automatic update by autodist
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 2.39-2mamba
- automatic rebuild by autodist
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.39-1mamba
- automatic update by autodist
* Thu Mar 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.38-1mamba
- automatic update by autodist
* Wed Jan 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.37-1mamba
- package created by autospec